Subject: RE: mboned: Country level Admin scope

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 6 May 2004 10:15:07 -0400

One possible approach is to limit the scope of the "broadcast" to the Belgian ISPs' networks? In  other words, for any given station, you don't necessarily have to use the same Class D address for the entire country. Just have each ISP assign a Class D address that is appropriately scoped for that ISP's own network.

This would fit in the scheme of RFC 2365 and 3171.

Bert

> -----Original Message-----
> From: Pieter Liefooghe [mailto:[email-masked]]
> 
> Hi,
> 
> Since we are talking here about Admin Scopes I have the 
> following issue. 
> We are planning on multicasting some Belgian Radio channels. 
> One of the 
> requirements of the Broadcaster is that the content be limited to 
> Belgium (Because they only pay the royalties for distribution in 
> Belgium). I looked for some admin scoping mechanism at the 
> level of the 
> country, but I couldn't find anything in any of the RFCs.
> 
> Did I miss some thing or do we need to "update" RFC 2365 with a new 
> admin scope range which can be limited to a given country? 
> (Maybe encode 
> in the address range the telephone country code ?).
> 
> Pieter
> 
> --
> dr. ir. Pieter Liefooghe
> 
> Doctor Assistant
> Vrije Universiteit Brussel (VUB) INFO/TW
> Tele.Com Group
> Pleinlaan 2
> 1050 Brussel
> Phone: +32-2-6292977
> Fax: +32-2-6292870
> [email-masked]

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 6 May 2004 12:10:56 -0400

> From: Beau Williamson [mailto:[email-masked]]
 
> At 09:38 AM 5/6/2004, Manfredi, Albert E wrote:

> >Yes, I think this is the best approach. If you go this way, 
> then each ISP 
> >can assign a 239/8 address independent of the others, and everything 
> >should work as intended.
> 
> In general this is a bad idea because 239/8 is private 
> address space.  A 
> SP/Content Provider can not assume that they can transmit 
> content in this 
> space.

Agreed. The content providers would use a different multicast address, or individual unicast addresses, to reach the "head end" of each ISP. Presumably, the number of ISPs is limited.

> The Enterprise networks that wish to receive this 
> content will be 
> blocking all 239/8 multicast at their borders.  I'm assuming 
> here that this 
> content would be desired by Enterprise networks connect to 
> the SP.  If not 
> initially, I would bet good money that it would be down the 
> road and then 
> the Content Provider/SP would have to readdress the streams 
> to allow it to 
> cross the boundary.  Now we are back to where we started, 
> GLOP. So why not 
> use this space in the first place?

Of course, *if* what you postulate is the case, if you indeed want to increase the scope of each multicast beyond the boundaries of individual admin domains, then you'd use the GLOP block and *not* the 239/8 block.

I would certainly be opposed to any scheme that wants to take away 239/8 address space and turn it into a GLOP add-on.

Bert