Subject: RE: mboned: Interest in working on multicast address rendezvous?

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 28 Jan 2005 15:16:06 -0500

Beau Williamson [mailto:[email-masked]] wrote:

> Manual IANA allocations for these "smaller-than-global" 
> scopes is, IMHO, 
> not an option.  This is because we are talking about scopes that fall 
> inside of private PIM-SM domains, i.e. Enterprise networks, 
> most of which 
> have adopted the 239/8 address range as Private space.
> 
> These Enterprise networks have built (or are planning on 
> building) their 
> own custom admin. scoping plans within the Enterprise 
> network.  Therefore 
> IANA should NEVER manually assign addresses within this scope 
> beyond Scope 
> Relative addresses.  To do so would mean the 239/8 address 
> space is no 
> longer "private".

Good deal. Some of us need this 239/8 space to work with minimal use of servers or other such points of failure.

[Enterpise nets using the global scope multicast address space]

> Most 
> of which have NO desire to send or receive multicast to/from the 
> Internet.  Their maximum scope of interest is the boundaries of the 
> Enterprise network.
> 
> This is the problem I'd like us to address.  If we can find a way to 
> address it within the framework of a larger global address 
> allocation and 
> scoping problem, then I'm happy with that.  However, I really 
> don't think 
> we have scoping problems outside of the Enterprise boundary.

To me, this is really an open question. I agree that with the limited global scope address space, this is true. But with a much faster Internet, and a much larger global scope multicast address space, I can see this might not be a good assumption.

For example, there are some trade journal scribes who make amazing claims about how the Internet, or IPTV, will "revolutionize" distribution of television around the world. It's easy to dismiss such talk out of hand, but it's even more fun to figure out ways to make this work.

Bert

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Beau Williamson <[email-masked]>
Date: Fri, 28 Jan 2005 14:52:44 -0600

At 1/28/2005 02:16 PM, Manfredi, Albert E wrote:
>To me, this is really an open question. I agree that with the limited 
>global scope address space, this is true. But with a much faster Internet, 
>and a much larger global scope multicast address space, I can see this 
>might not be a good assumption.
>
>For example, there are some trade journal scribes who make amazing claims 
>about how the Internet, or IPTV, will "revolutionize" distribution of 
>television around the world. It's easy to dismiss such talk out of hand, 
>but it's even more fun to figure out ways to make this work.

Bert,

True, I'll agree that other limited scopes of sizes between Enterprise and 
the entire Internet may someday be useful.  However, I think right now we 
have a much more pressing need to solve the Enterprise scope problem.  It's 
real and pervasive in our networks today and getting worse with each 
slap-dash application that comes out with hard coded, AE assigned addresses.

Having said that, I don't mind looking ahead at the bigger (scope-wise) 
problem.  I just don't want it to to delay us finding a solution the 
problem I described.

Beau