Subject: RE: automatic enterprise-scale rendezvous [Re: mboned: Interest in working on multicast address rendezvous?]

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 9 Feb 2005 16:23:09 -0500

But I must be missing something.

If you take this approach, then the multicast group won't be differentiated for these different applications. So how do the multicast routers in the enterprise create the proper multicast trees? And how does IGMP manage to join the necessary group only?

Thanks.

Bert

> -----Original Message-----
> From: Beau Williamson [mailto:[email-masked]]
> Sent: Wednesday, February 09, 2005 12:52 PM
> To: Stig Venaas; Marshall Eubanks
> Cc: Leonard Giuliano; Dave Price; Pekka Savola; John Kristoff;
> [email-masked]; [email-masked]
> Subject: Re: automatic enterprise-scale rendezvous [Re: 
> mboned: Interest
> in working on multicast address rendezvous?]
> 
> 
> At 2/9/2005 11:40 AM, Stig Venaas wrote:
> >Hard to explain this. But it's sort of like instead of requiring
> >different applications (products) to have different multicast
> >addresses today, you instead use a common multicast group, and
> >then you need these applications (products) to have some sort of
> >unique id on the application level instead.
> >
> >Maybe this isn't a problem. The identifier might actually be
> >something like "Acme Inc, Lightsensor 678P". They can then find
> >eachother based on that name, and it's pretty well guaranteed
> >that no one else uses the same"...
> 
> Right.  The goal is to keep it dirt simple.  I think unique names of 
> sufficient length should be more than adequate.
> 
> Beau
> 
> _______________________________________________________________
> user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
> web archive:  http://darkwing.uoregon.edu/~llynch/mboned/
> 

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Beau Williamson <[email-masked]>
Date: Wed, 09 Feb 2005 15:36:10 -0600

At 2/9/2005 03:23 PM, Manfredi, Albert E wrote:
>If you take this approach, then the multicast group won't be 
>differentiated for these different applications.

Sure it will.  The Scope Relative address is ONLY used to find the server 
and REQUEST the information as to what multicast address has been 
configured (by the network admin) for the application to use.  Assuming the 
network admin doesn't assign all applications the same multicast address, 
there isn't a problem.

Beau