Subject: RE: mboned: draft-lehtonen-mboned-dynssm-req

From: <[email-masked]>
Date: Mon, 13 Jun 2005 09:40:42 +0300

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Marshall Eubanks
> Sent: 10. kesäkuuta 2005 23:22
> To: Manfredi, Albert E; Hoerdt Mickael
> Cc: [email-masked]
> Subject: Re: mboned: draft-lehtonen-mboned-dynssm-req
> 
> On Fri, 10 Jun 2005 15:52:57 -0400
>  "Manfredi, Albert E" <[email-masked]> wrote:
> > Okay, I'm not disputing whether another protocol might be useful or 
> > not for this purpose. I'm just having trouble with 
> understanding why use SSM in a case where ASM seems the 
> obvious choice.
> > 
> > >From what you describe, the huge dynamic multicast environment, it 
> > >seems to me that the natural
> > solution would be ASM and either SDP or some mirrored web 
> sites to get the group's specifics out.
> > In this case, the SDP or web sites would not have to change in real 
> > time, because the group membership doesn't matter, so the 
> only scaling issue is how fast the multicast tree will adapt.
> > 
> > Where SSM must be used, that's where I don't see this 
> approach scaling 
> > well. Not for this enormous example of sources coming and 
> going. (For 
> > static sources, no problem.) Seems to me that millions of sources 
> > joining and leaving, where this will impact millions more 
> in how they 
> > formulate their IGMPv3/MLDv3 "reports" in real time, and 
> routers reacting to these to build or tear down multicast 
> trees, is what will be a scaling challenge. No?
> > 
> 
> My feeling is that the IPv6 situation fits about right (SSM 
> for broadcasts, embedded RP's for highly dynamic ASM 
> scenarios, with trees going to the ERP). That suggests that 
> serious thought be given to ERP for IPv4, which Dave Thaler 
> suggested, with a less than resounding response.

I think both IPv6 and IPv4 inter-domain multicast models have some serious problems, IPv6 with deployment (requires support in every router between DR and RP) and IPv4 with scalability and security (MSDP). So let's take the source discovery finally out from the network and introduce application layer solution for that. HTTP might be enough for some cases but dynamic groups require a standardised way to inform receivers about new sources arriving during the session.

- Rami

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: "Marshall Eubanks" <[email-masked]>
Date: Mon, 13 Jun 2005 15:33:26 -0400

> > Subject: Re: mboned: draft-lehtonen-mboned-dynssm-req
<snip>
> I think both IPv6 and IPv4 inter-domain multicast models have some serious problems, IPv6 with
> deployment (requires support in every router between DR and RP) and IPv4 with scalability and
> security (MSDP). So let's take the source discovery finally out from the network and introduce
> application layer solution for that. HTTP might be enough for some cases but dynamic groups
> require a standardised way to inform receivers about new sources arriving during the session.
> 

I fully agree with the separation of source discovery and the network, and also with the need
for a new standardized way to propagate new source information.

I am not sure that I would agree with IPv6 having deployment problems. Multicast always has
to have (well, until AMT comes on line) deployment between source and receiver. Adding in a global
RP doesn't change that much.

> - Rami

Marshall