Subject: Re: mboned: Re: [m6bone] Toward an interdomain IP multicast routing deployment

From: Hoerdt Mickael <[email-masked]>
Date: Tue, 05 Jul 2005 15:50:35 +0200

Well, maybe something is not clear for me but a solution that can work
over several administrative domains is an inter-domain solution. If you are
talking about PIM domains, yes, PIM-SSM and PIM-SM+Rp-embedded produce
one flat PIM domain over the Internet.

Hoerdt Mickaël

Jerome Durand wrote:

>> For me, two technical  solutions emerged : PIM-SSM + MLDv2/IGMP3 and
>> PIM-RP-embedded+MLDv1/IGMPv2. The first one is the implementation of the
>> SSM model the second one implements the ASM model (which is an overset
>> of SSM).
>
>
> Except SSM is not an interdomain solution... it's just another model,
> that can work over several administrative domain (not talking PIM
> domain here)
>
>> So here is the thing that I would like that we fill up together, I
>> already started as you
>> can see:
>>
>> PIM-SSM, MLDv2/IGMPv3 :
>>
>> Pro :
>> . Works with IPv4/IPv6
>> . A source can enforce its channel.
>> . Don't need modifications to PIM, only edges routers have to be
>> modified.
>> . Control plane and data plane are totally disjoint
>> ....
>>
>> Con:
>> . All the hosts need to implements MLDv2/IGMPv3
>
>
> And apps need to have appropriate interface!
>
>> . Need to maintain a (S,G) per sources in the group.
>> . To to discover new sources can takes a long time
>
>
> ??? I would remove last point as it's clearly for me a missing point!
>
>> Missing:
>> . How to efficiently do dynamic source discovery.
>> . S from (S,G) is a central point of failure.
>>
>> PIM-RP-embedded, MLDv1/IGMPv2:
>
>
> Remove IGMPv2 here as only IPv6 solution
>
>> Pro:
>> . Very simple way to do inter-domain ASM, by elegantly coupling
>> adressing and routing.
>> . You don't have to modify the hosts.
>> . In-band multicast source discovery per group.
>> . Could maintains one (*,G) per group no matter how many sources you
>> have.
>>
>> Con:
>> . Only works with IPv6.
>> . Need alls the routers to be modified.
>> . PIM-SM Register encapsulation is ugly.
>
>
> :) You could say instead that data and control plane are not disjoint
> to be coherent with what you say before.
>
>> . Could maintains one (*,G) per group and one (S,G) per source in the
>> group is the DRs switched to the SPT.
>
>
> ?? In which sense is that pro or cons?
>
>>
>> Missing:
>> . How do I manage my RP ?
>
>
> We should detail this point.
>
>> . where to put the RP ?
>
>
> on the DR?
> draft-jdurand-all-drs-are-rps-00.txt :))))
>
>> . How do I control the access to my RP ?
>
>
> Let's say instead: "how can I allow people to use my RP only when
> local users are interested?"
>
>> . How to have well known multicast addresses for inter-domain ?
>
>
> PIM register rate-limiting on the RP!!! Now it's on the DR :)
> With this new model you can't put it on the DR anymore as you don't
> know if the DR is in your administrative domain
>
> Jerome
> _______________________________________________________________
> user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
> web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Hoerdt Mickael <[email-masked]>
Date: Tue, 05 Jul 2005 14:39:59 +0200

Hello,

The last 5 years in the multicast routing community have seen a lots of
change in the way that we can interpret how we can have multicasting as
a standard service for the Internet users : much more bandwidth is
available,
much more processing power, new multicast services models, new addressing
and routing solutions and new implementations.

What I would try do here is to now sum up the progress accomplished with
you,
to have an idea where we stand today with layer 3 multicasting to have a
nice view of
the tradeoffs given by each solutions.

PIM-SSM, MLDv2/IGMPv3 :

Pro :
. Works with IPv4/IPv6
. A source can enforce its channel.
. Don't need modifications to PIM, only edges routers have to be modified.
. Control plane and data plane are totally disjoint
....

Con:

Missing:

Pro:
. Very simple way to do inter-domain ASM, by elegantly coupling
adressing and
   routing.
. You don't have to modify the hosts.
. In-band multicast source discovery per group.
. Could maintains one (*,G) per group no matter how many sources you have.
....

Con:
. Only works with IPv6.
group is the
  DRs switched to the SPT.
....

Missing:

Hoerdt Mickaël

---

From: Jerome Durand <[email-masked]>
Date: Tue, 05 Jul 2005 15:17:33 +0200

Except SSM is not an interdomain solution... it's just another model, 
that can work over several administrative domain (not talking PIM domain 
here)

> . PIM-SM Register encapsulation is ugly.

:) You could say instead that data and control plane are not disjoint to 
be coherent with what you say before.

on the DR?

> . How do I control the access to my RP ?

Let's say instead: "how can I allow people to use my RP only when local 
users are interested?"

PIM register rate-limiting on the RP!!! Now it's on the DR :)
With this new model you can't put it on the DR anymore as you don't know 
if the DR is in your administrative domain

Jerome