Subject: mboned: Re: [nesg] Multicast Detective

From: "Mike O'Connor" <[email-masked]>
Date: Mon, 31 Oct 2005 10:37:55 -0500

Hi Kevin,

I've downloaded and run the Multicast detective with mixed results.
The Windows XP system I used to run the application is connected to a 
Juniper router that has been configured for multicast support, PIM-SM, 
RP, IGMP V3. I use this network when I assist DOE Labs with multicast 
problems, this network is multicast enabled.

The detective produces some confusing output.
It looks like the two multicast groups in the first two lines are 
swapped. The group address used in test one is in the SSM range and the 
address in line 2 is the old beacon address, the new one is 233,4.200.18.

I don't see how test 3 can fail if test one succeeds, if 32 beacons 
respond my first hop has to be multicast capable in some sense at least. 
If this is somehow correct you need to be more specific.

Test 6 fails the IGMP V3 test but the summary claims the router is IGMP 
V3 capable, which it is.

I'd be happy to run this again after you've checked it over.

-Mike O'Connor
[email-masked]

*****************************************
*     Multicast Detective Beta          *
*****************************************

Running 8 Tests :
        1.  Joining NLAR Multicast Beacon Group 232.64.133.120, port 10002
Test succeeded:   received response from 32 members
        2.  Joining SSM Video Group 233.4.200.19, 63.105.122.29 port 8020
Test failed:  did not get reponse from any member
        3.  Checking if first-hop router is multicast capabile
Test failed:  no router responded to ping
        4.  Checking if first-hop router is SSM capable
Test failed:  no router responded to ping
        5.  Detecting if there is IGMPv2 capability to first-hop router
Test succeeded:  received IGMPv2 response from the first-hop router
        6.  Detecting if there is IGMPv3 capability to first-hop router
Test failed:  no IGMPv3 response received from the router
        7.  Detecting if first-hop router supports PIM-SM
Test failed:  no router responded to PIM ping
        8.  Detecting if first-hop router knows about an RP
Test failed:  no router responded to PIM-SM Hello

*****************************************
*     Multicast Detective Report        *
*****************************************
=> Host is capable of Any Source Multicast (IGMP v2)
=> Host is capable of Source Specific Multicast (IGMP v3)
=> Path to first hop router is working for ASM, router responds to  
IGMPv2 reque
sts.
=> ASM is working for the 'Beacon Group', RTP packets from members were 
received
.

 +> To exit enter 'q' , to re run the test enter 'y'

>
> ------------------------------------------------------------------------
>
> Subject:
> mboned: Multicast Detective
> From:
> "Kevin C. Almeroth" <[email-masked]>
> Date:
> Tue, 25 Oct 2005 13:19:29 -0700 (PDT)
> To:
> [email-masked]
>
> To:
> [email-masked]
> CC:
> Kamil Sarac <[email-masked]>, <[email-masked]>
>
>
>Okay, this is a pre-release of some code we put together to
>test local multicast capability...  basically it runs 8 tests:
>
>   1. Joins the NLAR Multicast Beacon Group 232.64.133.120, port 10002
>   2. Joins the SSM Video Group 233.4.200.19, 63.105.122.29 port 8020
>   3. Checks if the first-hop router is multicast capabile
>   4. Checks if the first-hop router is SSM capable
>   5. Detects if there is IGMPv2 capability to the first-hop router
>   6. Detects if there is IGMPv3 capability to the first-hop router
>   7. Detects if the first-hop router supports PIM-SM
>   8. Detects if the first-hop router knows about an RP
>
>And let's you know the results.
>
>We've got source code on the web page, and an executable for Win32.
>Working on an executable for linux...
>
>Web page is at:  http://www.nmsl.cs.ucsb.edu/mcast_detective/
>
>Right now, we're looking for feedback...
>
>-Kevin
>
>
>_______________________________________________________________
>user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
>web archive:  http://darkwing.uoregon.edu/~llynch/mboned/
>
>  
>

-- 
Mike O'Connor,                  E-mail: [email-masked]
Network Engineer                Energy Sciences Network (ESnet)
Phone: +1 631 344-7410     
Ernest O. Lawrence Berkeley National Laboratory (Berkeley Lab) 

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: "Kevin C. Almeroth" <[email-masked]>
Date: Mon, 31 Oct 2005 13:39:11 -0800 (PST)

Mike, the first problem is a typo...  that will be fixed.

We've discovered that juniper routers don't respond to pings...
we need to fix that in the code.  We should say that we are
pinging a number of multicast groups which routers should
respond to.  If there is no answer, it doesn't necessarily
mean multicast isn't working.

The test really checks two things...  we need to fix the
part under the "report" that the Host "OS" is capable of
supporting IGMPv3/SSM...  we know this because it has the
right socket options.

I'll make sure Avijit gets this feedback.

-Kevin

On Mon, 31 Oct 2005, Mike O'Connor wrote:

>>*******************From [email-masked] Mon Oct 31 17:10:58 2005
Date: Mon, 31 Oct 2005 13:39:11 -0800 (PST)
From: "Kevin C. Almeroth" <[email-masked]>
To: "Mike O'Connor" <[email-masked]>
cc: [email-masked], <[email-masked]>, <[email-masked]>
Subject: Re: mboned: Re: [nesg] Multicast Detective
Sender: [email-masked]

Mike, the first problem is a typo...  that will be fixed.

We've discovered that juniper routers don't respond to pings...
we need to fix that in the code.  We should say that we are
pinging a number of multicast groups which routers should
respond to.  If there is no answer, it doesn't necessarily
mean multicast isn't working.

The test really checks two things...  we need to fix the
part under the "report" that the Host "OS" is capable of
supporting IGMPv3/SSM...  we know this because it has the
right socket options.

I'll make sure Avijit gets this feedback.

-Kevin