Subject: RE: mboned: draft-ietf-mboned-ipv6-multicast-issues-02.txt

From: "Molina, Angel (Angel)" <[email-masked]>
Date: Thu, 13 Oct 2005 09:03:24 +0200

Pekka,

thank you for the response, I see what is meant by the description now. 

Rephrasing it in terms of Ethernet addresses, it would mean that an Ethernet switch that 

- discarded frames with DA in 0x0100.5Exx.xxxx (the result of mapping IPv4 multicast onto Ethernet), except as learnt by IGMP snooping (*), and

- flooded all other Ethernet multicast DA (including 0x3333.xxxx.xxxx for IPv6 multicast) 

would be fine. Problematic would be an IGMP snooping switch that discarded *all* ethernet multicast except what has been learned by IGMP snooping, because it would discard IPv6 as well (for some reason I did not consider this implementation option when trying to understand the problem description). 

Thanks again and best regards,
Angel 

PS: (*) I know that there must be some exceptions to this behavior for IPv4 DA 224.0.0.x, as per draft-ietf-magma-snoop-12.txt.

> -----Original Message-----
> From: Pekka Savola [mailto:[email-masked]]
> Sent: Donnerstag, 13. Oktober 2005 14:15
> To: Molina, Angel (Angel)
> Cc: [email-masked]
> Subject: Re: mboned: draft-ietf-mboned-ipv6-multicast-issues-02.txt
> 
> 
> Hi,
> 
> On Thu, 13 Oct 2005, Molina, Angel (Angel) wrote:
> > while reading draft-ietf-mboned-ipv6-multicast-issues-02.txt I came 
> > across the passage quoted below (section "4.2 Neighbor Discovery 
> > Using Multicast"). It's quite likely I'm missing something trivial, 
> > but I'm having trouble figuring out how the problem hinted 
> at in the 
> > passage can come about.
> >
> > - Why would such an IGMP-snooping switch fail to forward 
> IPv6 frames?
> 
> If the snooping switch were to do IP-based snooping, just by looking 
> at the IGMP reports, and discarding other multicast (including v6 
> multicast), obviously there would be a problem, right?
> 
> Also obviously, if the switch were to do look for IGMP reports, 
> discarding other *IPv4* multicast, but flooding v6 multicast on all 
> ports, v6 multicast would work (though v4 multicast might be hampered 
> if IGMPv3 would not be supported).
> 
> Does this clarify the (potential) problem?
> 
> NB: the document has been discontinued, and should be reworked into 
> something a bit different.  I haven't wanted to do that as 
> folks don't 
> seem too interested in doing the work.  Anyone can feel free to pick 
> up the ball.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Pekka Savola <[email-masked]>
Date: Thu, 13 Oct 2005 10:27:24 +0300 (EEST)

On Thu, 13 Oct 2005, Molina, Angel (Angel) wrote:
> would be fine. Problematic would be an IGMP snooping switch that 
> discarded *all* ethernet multicast except what has been learned by 
> IGMP snooping, because it would discard IPv6 as well (for some 
> reason I did not consider this implementation option when trying to 
> understand the problem description).

Exactly, the principle should be, "do not discard what you cannot 
reliably snoop."

---

From: John Zwiebel <[email-masked]>
Date: Thu, 13 Oct 2005 10:44:19 -0700

On Oct 13, 2005, at 12:03 AM, Molina, Angel (Angel) wrote:

>
> PS: (*) I know that there must be some exceptions to this behavior  
> for IPv4 DA 224.0.0.x, as per draft-ietf-magma-snoop-12.txt.
>
>

FWIW: there had long been a debate whether or not an IP system should
send IGMP host reports for link-local groups.  Considering that
at L2 one can't tell if the MAC address is for 224.0.0.x or 224.1.0.x
(etc.) most IP systems now ensure that an IGMP host report is
sent for link-local IPv4 groups to ensure snooping picks up the
right forwarding information.
_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: John Zwiebel <[email-masked]>
Date: Thu, 13 Oct 2005 11:24:35 -0700

Sorry, I meant 224.0.0.x and 224.128.0.x are the same MAC address.