Subject: mboned: FYI ([ppml] Proposed Policy: 4-Byte AS Number Policy Proposal)

From: David Meyer <[email-masked]>
Date: Tue, 13 Dec 2005 08:19:42 -0800

David,

> While I have heard of folk indicating that the private IPv4 address space 
> is too small, I have not heard of anyone saying that the 1023 AS numbers 
> reserved for private use is too small. If there is a broad perception that 
> the space is too small then we'd either need to go down the path of a 
> global policy to reserve additional space or possibly head down the IETF 
> Standards track document path. Both represent significantly greater 
> thresholds than this relatively simple policy proposal. I'd suggest that 
> expansion of the private AS number space be considered as a separate topic 
> and the merits or otherwise of such a proposal be considered without tying 
> it up with this transition policy.

	I don't know if you're following these developments, but
	they could effect our ability to deploy eGLOP space (RFC
	3138), as it is mapped from the IPv4 private AS space.
	While we haven't been successful to date, I do know that
	Marshall is working with Mirjam (or she's pointing him at
	the right people at RIPE, or something) to try and launch
	the use of some of this space, so the MBONED WG (or
	whatever it becomes) will want to be watching this.    

	Dave

> ----- Forwarded message from Geoff Huston <[email-masked]> -----
> 
> > From: Geoff Huston <[email-masked]>
> > To: Rich Emmings <[email-masked]>, [email-masked]
> > Subject: Re: [ppml] Proposed Policy: 4-Byte AS Number Policy Proposal
> > Date: Tue, 13 Dec 2005 09:57:13 +1100
> > 
> > At 09:36 AM 13/12/2005, Rich Emmings wrote:
> > >A possible addition is for space to be left aside in the proposal for 
> > >private 4 byte AS numbers, perhaps:
> > >
> >   1) in the same range as the 2 byte range, i.e. 64512 - 65534:x or
> >   2) in each range (x:64512 - 65534)
> > 
> > 
> > While I have heard of folk indicating that the private IPv4 address space 
> > is too small, I have not heard of anyone saying that the 1023 AS numbers 
> > reserved for private use is too small. If there is a broad perception that 
> > the space is too small then we'd either need to go down the path of a 
> > global policy to reserve additional space or possibly head down the IETF 
> > Standards track document path. Both represent significantly greater 
> > thresholds than this relatively simple policy proposal. I'd suggest that 
> > expansion of the private AS number space be considered as a separate topic 
> > and the merits or otherwise of such a proposal be considered without tying 
> > it up with this transition policy.
> > 
> > 
> > 
> > >Notes: a) not sure the status of AS23456 with regard to this, if any.
> > 
> > 
> > as23456 is reserved for use as a transition AS in 
> > draft-ietf-idr-as4bytes-12.txt - no further RIR action is required 
> > regarding this particular AS number.
> > 
> > 
> >         b) administrative ease is addressed here by using the same range, 
> > at the possible expense of "c"
> >         c) efficiency of allocation is not -- could be with a small range 
> > at the top, at the expense of "b"
> > 
> > 
> > it is unclear to me what your point is here.
> > 
> > 
> > 
> > >In addition, documention-only ASN's may be of use, ala the IPv4 addresses in
> > >RFC3330.  While the private range can be used, in BGP documentation, as with
> > >others, it's harder to determine 'public' from 'private' when only private
> > >space is used.
> > 
> > Again, this may well benefit from being a distinct policy proposal.
> > 
> > regards,
> > 
> >     Geoff
> > 
> > 
> > 
> > 
> > _______________________________________________
> > PPML mailing list
> > [email-masked]
> > http://lists.arin.net/mailman/listinfo/ppml
> 
> ----- End forwarded message -----

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 13 Dec 2005 11:39:12 -0500

Hello;

I am on the PPML list and have been following this.

There does not seem to be much support for extending the private ASN  
space.

I am not sure that GLOP will extend easily or any other way to 4byte  
ASN's - there
obviously isn't enough multicast IPV4 space to even give a /32 to  
every one of 4 billion ASNs.
And there is talk about giving 2 byte blocks of ASN space to RIR's,  
so even another /8 won't suffice without hashing or something.

> 	whatever it becomes) will want to be watching this.

After talking  to Mirjam, I am taking this up with IANA. If anyone is  
interested in this, please
let me know.

Marshall

>> ----- End forwarded message -----

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: David Meyer <[email-masked]>
Date: Tue, 13 Dec 2005 08:42:23 -0800

> There does not seem to be much support for extending the private ASN  

	Yes, this was just a heads up.

> ASN's 

	Yep. From 3180:

7. Large AS Numbers

   It is important to note that this approach will work only for two
   octet AS numbers. In particular, it does not work for any AS number
   extension scheme.

	Dave

---

From: David Kessens <[email-masked]>
Date: Tue, 13 Dec 2005 15:22:52 -0800

Dave,

Yes, I am also following the discussions on the ppml list.

I don't think there is a lot that I can say about this in my capacity
as an AD.

Speaking as a working group participant, 4 byte AS numbers feel a lot
like 'the final nail in the coffin of eGLOP'. Perhaps I formulate this
a bit too strong, but I believe that it might be time to consider to
come up with an alternative and retire eGLOP.

David Kessens
---

---

From: David Meyer <[email-masked]>
Date: Tue, 13 Dec 2005 15:38:02 -0800

> come up with an alternative and retire eGLOP.

	Sure, and the same could be said for GLOP.

	Dave