Subject: Re: AMT and Checksums (was Re: mboned: draft minutes of the last mboned session)

From: Tom Pusateri <[email-masked]>
Date: Thu, 22 Jun 2006 22:16:13 -0400

In message <[email-masked]> you write:
>On Mon, 1 May 2006, Tom Pusateri wrote:
>>> *Dave -- Added text to say the UDP checksum SHOULD BE calculated on control
> me
>>> ssages but MAY be 0 on the multicast data messages.
>>> *Dino - Checksum: should be zero on data messages
>>> discussion on MAY vs SHOULD, Dave and Dino agree
>>
>> So what was the outcome of this? The minutes aren't clear.
>> Dave, Dino?
>
>Note that RFC2460 states:
>
>       o  Unlike IPv4, when UDP packets are originated by an IPv6 node,
>          the UDP checksum is not optional.  That is, whenever
>          originating a UDP packet, an IPv6 node must compute a UDP
>          checksum over the packet and the pseudo-header, and, if that
>          computation yields a result of zero, it must be changed to hex
>          FFFF for placement in the UDP header.  IPv6 receivers must
>          discard UDP packets containing a zero checksum, and should log
>          the error.
>
>draft-heffner-frag-harmful-01.txt also discusses why fragmentation is 
>harmful, especially for IPv4.  This is underlined when checksums are 
>disabled.
>
>So, it's a bit questionable whether we should allow (or even 
>recommend) zero checksum.  Certainly we can't do that for IPv6 at 
>least.

I forgot about this in the latest AMT draft.
I'll address it in the next version.

Thanks,
Tom

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Dino Farinacci <[email-masked]>
Date: Sat, 24 Jun 2006 14:59:34 -0700

>> I'll address it in the next version.

    How will you address it? 

    There is no point in including a UDP checksum in the outer UDP header if
    the checksum is computed by the multicast host and set in the inner UDP 
    header.

    And I don't think it is compelling to provide the very little incremental
    reliability if an AMT Data Message turns out to be fragmented on it's
    way to/from a AMT Relay/Gateway.

Dino