Subject: RE: mboned: RE: [magma] suggestion for simplifying IGMPV3/MLDV2 to discard EXCLUDEmode

From: "David McWalter" <[email-masked]>
Date: Thu, 8 Jun 2006 16:39:37 +0100

As I read the holbrook draft, the restriction applies only to SSM addresses.  We still have exclude mode (and therefore source filtering) for ASM.

DMcW.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Manfredi, Albert E
Sent: 08 June 2006 16:20
To: David McWalter; Hui Liu; [email-masked]
Cc: [email-masked]
Subject: RE: mboned: RE: [magma] suggestion for simplifying IGMPV3/MLDV2
to discard EXCLUDEmode

When operating with IGMPv3/MLDv2, is there no value in allowing for any
source multicast filtering behavior? Are we saying that whenever ASM is
needed, the host must revert to IGMPv1/IGMPv2/MLDv1?

I figured the EXCLUDE mode was useful if IGMPv3/MLDv2 was to be used in
an ASM situation, although I suppose that this isn't a big deal. Because
the version can be different for any given multicast group supported by
a multicast router.

Bert

> -----Original Message-----
> From: David McWalter [mailto:[email-masked]] 
> Sent: Thursday, June 08, 2006 7:29 AM
> To: Hui Liu; [email-masked]
> Cc: [email-masked]
> Subject: mboned: RE: [magma] suggestion for simplifying 
> IGMPV3/MLDV2 to discard EXCLUDEmode
> 
> Hi Hui.
> 
> Yes, I think that's already been agreed.
> 
> (See section 2.2.2 in 
> http://www.ietf.org/internet-drafts/draft-holbrook-idmr-igmpv3
-ssm-08.txt
> currently in RFC Ed queue).
> 
> 'An SSM-aware host SHOULD NOT send any of the following 
> record types for
> an SSM address.
> 
>     - MODE_IS_EXCLUDE as part of a Current-State Record
> 
>     - CHANGE_TO_EXCLUDE_MODE as part of a Filter-Mode-Change Record
> 
> This is a MODIFICATION to [IGMPv3,MLDv2], imposing a 
> restriction on its
> use for SSM destination addresses.  The rationale is that EXCLUDE mode
> does not apply to SSM addresses ... '
> 
> 
> I don't think you're proposing anything in addition to this?
> DMcW.
> 
> -----Original Message-----
> From: Hui Liu [mailto:[email-masked]]
> Sent: 08 June 2006 10:59
> To: [email-masked]
> Cc: [email-masked]
> Subject: [magma] suggestion for simplifying IGMPV3/MLDV2 to discard
> EXCLUDEmode
> 
> 
> Hello, all
> 
> I'd like to suggest here the simplification of IGMPv3/MLDv2;
> 
> In IGMPV3/MLDv2, protocol filter-mode is defined to support SSM. In
> practice, it seems EXCLUDE mode is not so useful, for there is little
> requirement for excluding specific sources. Further, EXCLUDE can not
> guarantee host not receiving unexpected traffic.
> 
> The realization of the EXCLUDE mode and corresponding 
> mode-switch operation
> are relatively complicated, especially when implementing 
> L2/L3 LAN switch
> with snooping. So it is suggested here to simplify 
> IGMPV3/MLD2 to eliminate
> the EXCLUDE mode. Then the process of router and host will be greatly
> simplified. And the important thing is: For SSM, INCLUDE mode 
> is enough to
> express join for specific sources.
> 
> Glad to hear your opinions
> 
> Regards,
> 
> Hui   Liu

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

_______________________________________________________________
user interface: http://darkwing.uoregon.edu/~llynch/mboned.html
web archive:  http://darkwing.uoregon.edu/~llynch/mboned/

---

From: Hui Liu <[email-masked]>
Date: Mon, 26 Jun 2006 09:33:37 +0800

Sorry ,  I forgot to attach the draft in the previous mail.

Regard,

Hui liu