Subject: [MBONED] Fwd: [pim] IPv6 Inter-domain Multicasting and Address Assignments

From: Marshall Eubanks <[email-masked]>
Date: Thu, 22 Feb 2007 21:36:32 -0500

For the group's information.

Marshall

Begin forwarded message:

> From: "Marshall Eubanks" <[email-masked]>
> Date: February 22, 2007 8:36:39 PM EST
> To: "Tim Chown" <[email-masked]>
> Cc: "Gibbons, James" <[email-masked]>, [email-masked],   
> [email-masked]
> Subject: Re: [pim] IPv6 Inter-domain Multicasting and Address  
> Assignments
>
> Hello;
>
> In my opinion, this should be done on Mboned, and certainly not on
> PIM. However, here is my take in this.
>
>
> On 2/22/07, Tim Chown <[email-masked]> wrote:
>> On Tue, Feb 20, 2007 at 03:41:33PM -0500, Gibbons, James wrote:
>> >
>> >    Hello,
>> >
>> >
>> >    SI   International  represents  and  contracts  with  DITO   
>> (DoD  IPv6
>> >    Transition  Office)  on  a number of IPv6 issues.  In this  
>> case we are
>> >    providing  DITO  with  a  white  paper  on IPv6 Inter-domain  
>> multicast
>> >    address   assignments   and  issues/problems  (expected  or   
>> realized)
>> >    regarding IPv6 multicast implementations.
>> >
>> >    To begin, I have gone over a number of RFCs (including RFC  
>> 3306, 3956,
>> >    3307,  2375,  4607,  ID draft-ietf-mboned-ipv6-multicast- 
>> issues-02.txt
>> >    among  others)  but they are vague as to actual working  
>> implementation
>> >    of  inter-domain  multicast  address  assignments and how  
>> they will or
>> >    might work proceed.
>>
>> RFC3306 lets you create for yourself a globally unique multicast  
>> group
>> address where your unicast prefix (which is unique by allocation)  
>> contributes
>> towards the first 96 bits of the group address.
>>
>> The missing bit is how you manage the last 32 bits, but that could be
>> application determined if for example you used a /64 per application.
>> Or you can choose your own manually.
>>
>> >    In IPv4 GLOP was developed but not widely used, where an  
>> organizations
>
> I disagree with this. Except for going to IANA - or making it up -  
> this is the
> only thing that is used in IPv4.
>
> Also, you might be interested that we are working on instantiating  
> eGLOP - see
>
> http://www.apnic.net/docs/policy/proposals/prop-047-v001.html  -
>
> similar proposals have been sent to RIPE and ARIN.
>
>> >    ASN  is embedded in the 223.0.0.0 / 8 multicast range.  In  
>> IPv6 I have
>> >    seen  V6UPBM  (RFC  3306)  and  "Embedded  RP"  (RFC  3956)  
>> as similar
>> >    proposals for IPv6.
>>
>> Yep.
>>
>> >    However,  I  am  still  not  clear  of the "reality" of IPv6  
>> multicast
>> >    address  assignments  especially  with  regards to globally  
>> unique (by
>> >    organization, domain, site, etc.) inter-domain multicast.
>>
>> We're using RFC3306 and Embedded-RP group addresses for international
>> IPv6 multicast applications.
>
> This has been used since at least early 2003; it was first presented
> at the Summer 2003
> IETF in Vienna - see
>
> http://www.6net.org/events/workshop-2004/durand.pdf
>
>>
>> >    That is, how far have actual address assignments proceeded?
>>
>> For 3306 you don't need an authority to hand it out, it's just  
>> there for
>> you to use implicitly by the format.
>>
>> >    What is just proposed versus being implemented or to be  
>> implemented?
>> >
>> >    Are there actual standards being followed?
>>
>> A growing base of routers support Embedded RP... we've run that  
>> between
>> the UK and US academic networks; all router son path (mainly Cisco  
>> and
>> Juniper) support it.   No RP required :)
>>
>> >    Are   there  known/expected  issues/problems  with  IPv6   
>> inter-domain
>> >    multicast and address assignments?
>> >
>> >    Maybe a quote from my actual assignment will further clarify  
>> what I am
>> >    looking for:
>> >
>> >    "DITO  is  having  some concerns with IPv6 multicast address  
>> space and
>> >    how  it  should  or  should  not be provisioned.  You should  
>> start the
>> >    study  with  regards  to  how  IPv4 multicast addressing  
>> worked in the
>> >    past.   If  you  ever  worked  with  it you would know there  
>> was never
>> >    official  group  reservations  made  with  regards  to  
>> address blocks.
>> >    However,  this  was  never a real issue since its popularity  
>> died.  So
>> >    except  for  what  was deemed to be the well-known addresses  
>> there was
>> >    never  any  reservations, unlike how unicast is reserved.   
>> One thought
>> >    might be the Army gets a block of addresses, Navy, and so on."
>>
>> A big win for v6 is that you dont need an ASN for GLOP like v4,  
>> you can
>> just form multicast groups from your unicast allocated prefix(es).
>>
>
> Note that there has been a big discussion about assignment of IPv6
> addresses - see
>
> http://www.arin.net/policy/proposals/2005_1.html
>
>> And with a lot of /64's in an IPv6 site, you can (as we have)  
>> assign an
>
> Most assignments are /48s
>
>> RFC3306 group range per application if you chose to do so.
>>
>> The other nice thing about v6 multicast is the explicit scoping  
>> bits, which
>> make it easier to control where your traffic flows.
>>
>
> Yes. I expect more in the future here.
>
>> --
>> Tim
>
> Regards
> Marshall
>
>>
>> _______________________________________________
>> pim mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/pim
>>

_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 22 Feb 2007 21:36:32 -0500

Marshall