Subject: [MBONED] Draft Revised Mboned Charter

From: Marshall Eubanks <[email-masked]>
Date: Wed, 21 Mar 2007 09:10:39 -0400

Here is a draft revised charter to simulate discussion tomorrow.

Regards
Marshall & Hiroshi

-------------
Description of Working Group:

The MBONE Deployment Working Group is a forum for coordinating
the deployment, engineering, and operation of multicast routing
protocols and procedures in the global Internet as well as other  
applications. This activity will
include, but not be limited to:

- Documenting deployment of multicast routing in IP based networks  
including the global Internet.  Develop overview documents and best  
current practice documents on multicast technologies.

- Solicit and receive regular reports on the current state of the  
deployment of
   multicast technology. Create "practice and experience" documents that
   capture the experience of those who have deployed and are deploying
   various multicast technologies.

- Based on reports and other information, provide feedback to other
   relevant working groups.

- Develop mechanisms and procedures for sharing operational
   information to aid in operation of the multicast backbones and
   interconnects.

- Update RFC 3171/BCP 51 based on experience.

- Develop a roadmap informational RFC that describes the current
   IPv4 and IPv6 IETF multicast architectures, including
   references to the relevant IETF documents and guidance for
   implementers and network operators.

  - Regularize IPv4 Multicast Address Practice
-        IANA or RIR address assignments
-        IPv4 Prefix Assignments

- Multicast management
- have a standard RFC for mtrace for IPv4 and IPv6
- update the very old troubleshooting guidelines for ASM and SSM  
multicast services
- SSMPING
- Accounting, Authentication and Authorization (AAA)
- IPTV/CDS issues
- Document necessary management capabilities (related to multicast  
management)
- Document IPTV standards and operational scenario
- Document CDS standards and operational scenario
- Publish Operator Survey
- Best Current Practices for Multicast VPNs
- IPv4 / IPv6 multicast interaction
- Automatic IP Multicast Without Explicit Tunnels (AMT)
- SSM issues
- Multicast Number Registry issues
- Port Registry
- Address Registry
- Lightweight IGMPv3/MLDv2 issues

Goals and Milestones:

April 2007   Update I-D describing IPv4 Multicast Unusable Group And  
Source Addresses
May 2007   Update IP v4 Multicast Best Current Practice
Jun 2007   Create IP v6 Multicast Best Current Practice Draft
Jun 2007    Submit Unicast-Prefix-based IPv4 Multicast Addresses Draft
Jun 2007   Submit AMT Draft for Proposed Standard
Jul 2007    Submit Moving MCAST.NET into the ARPA infrastructure top  
level domain as Informational
Aug 2007   Submit IP v4 Multicast Best Current Practice for BDP
Aug 2007   Submit IP v6 Multicast Best Current Practice Draft for BCP
Aug 2007    Submit IPv4 multicast address allocation procedures IESG  
for BCP
Sep 2007    Create multicast roadmap/reference architecture document
Aug 2007    Create I-D on IPv4/IPv6 multicast co-existence issues and  
strategies for IPv4 multicast and IPv6 multicast
Nov 2007     Update IANA Guidelines for IPv4 Multicast Address  
Assignments (RFC 3171/BCP 51)
Dec 2007    Create IPv4/v6 co-existence strategies as Draft
Apr 2008 Submit multicast roadmap/reference architecture document to  
IESG for Informational
Apr 2008 Submit I-D on IPv4/IPv6 multicast co-existence issues and  
strategies for IPv4 multicast and IPv6 multicast
Apr 2008 Submit IPv4/v6 co-existence strategies Draft to IESG for  
Informational

_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 22 Mar 2007 05:51:45 -0700

On Thu, Mar 22, 2007 at 04:36:15AM -0700, Yakov Rekhter wrote:
> With respect to the "- Best Current Practices for Multicast VPNs"
> item on the proposed revised MBONED WG charter, I think we
> need to be very clear about the *real* motivations for this item.
> 
> These motivations have been spelled out by folks from cisco
> during the discussion on this topic about a month ago.
> 
> >From MikeMcBride (Cisco) e-mail to mboned on 2/20:
> 
>    What can/should we do in MBONED to prevent the L3VPN WG from
>    further delaying documentation of a well known and accepted
>    solution while it works on incomplete options?
> 
> >From John Meylor (Cisco) e-mail to mboned on 2/21:
> 
>    So really the focus and concern of the MBONED and IETF should
>    be how to move L3VPN wg forward toward standardization of the
>    mVPN GRE solution.
> 
> The above makes it quite clear that such things as (a) expanding
> MBONED charter to include MVPN experiece,

First:

It is YOUR personal reading reading of the MBoned charter to specifically
exclude operational experience with this most important IP multicast
functionality for service providers from MBoned. I would argue that
this ype of experience documentation if if anything the most
fundamental role of MBoned as an operational group for IP multicast services.

Second:

Could you please stop to inappropriately stop to insinuate ulterior motives ?
I think it is clear to anybody that people who have collected
positive experience with actually deployed products are not only
interested to publish that to an operational group, but are also
of course interested to leverage that positive experience in a
standardization process. Whether it's MVPN or any other technology.

> or (b) accepting
> draft-ycai-mboned-mvpn-deploy as an MBONED WG document are just
> means - the real goal is to use the MBONED WG to push the L3VPN WG
> to standardize draft-rosen as soon as possible.

If there is any ulterior form of collusion then it is a strategy of
trying to leverage the vendor allegiance of one WG chair to suppress such
experience from another operational group in an attempt to exclude
such experience from consideration in his working groups standardization
process. Such tactics are highly unnecessary.

Cheers
    Toerless

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 22 Mar 2007 05:51:45 -0700

First:

Second:

Cheers
    Toerless