Subject: [MBONED] RE: MBONED Digest, Vol 14, Issue 35

From: Su Haiyang <[email-masked]>
Date: Fri, 14 Dec 2007 11:33:10 +0800

Dear All,
  I agree with the following opinions. Mbone needs to focus on 
the research how to deploy multicast in IP based networks, specially
including IPTV networks. MVPN solution may be the suitable IPTV deployments
for IPTV carrier networks. What's more, MOGI(multicast over global internet)
become losing interest from providers and gradually replace with P2P
session(such as BT,emule),  or shared video service.
Su Haiyang

 I agree, the new charter looks good, and adding "in IP based networks"
may better describe the historical scope under which we've always
operated.  

 I also agree that arbitrarily restricting this scope and WG discussions
now (under old or new charter) doesn't reflect the reality of how ip
multicast deployments work.

 Further, MBONED as chartered from day-one (ie "coordinating the
deployment") has always provided deployment review and input to all
other WGs throughout the IETF regarding any protocol work which might be
associated with ip multicast deployments.   This role has always been
seen as a positive contribution to other working groups since they don't
have the ip multicast deployment expertise of MBONED, and because they
end up with proposals which are more likely to work within the context
of real end-end ip multicast deployments.

 I'm not sure why we would restrict this scope or role now for any
arbitrary subset of the problem space.

 john

> -----Original Message-----
> From: PAPADIMITRIOU Dimitri 
> [mailto:[email-masked]] 
> Sent: Wednesday, December 12, 2007 7:29 PM
> To: Leonard Giuliano
> Cc: [email-masked]
> Subject: RE: [MBONED] Draft revised charter description
> 
> then, i suggest one does a reality check. mcast routing 
> protocols are also being deployed in MVPNs (in part. PIM with 
> GRE tunnels). this is a fact.
> 
> from that perspective, the newly proposed charter looks very 
> good to me.
> 
> -d.
> 
> > -----Original Message-----
> > From: Leonard Giuliano [mailto:[email-masked]]
> > Sent: Wednesday, December 12, 2007 9:30 PM
> > To: PAPADIMITRIOU Dimitri
> > Cc: [email-masked]
> > Subject: RE: [MBONED] Draft revised charter description
> > 
> > 
> > Good point, and to clarify I suggest keeping the current wording of 
> > the
> > charter:
> > 
> > "The MBONE Deployment Working Group is a forum for coordinating the 
> > deployment, engineering, and operation of multicast routing 
> protocols 
> > and procedures in the global Internet."
> > 
> > 
> > On Wed, 12 Dec 2007, PAPADIMITRIOU Dimitri wrote:
> > 
> > -) even if some of the concerns expressed are valid (in 
> part. BGP for
> > -) exchanging mcast state), they are independent of the MBONED work.
> > -) indeed, deltas in protocols are/should have been be 
> > discussed in the
> > -) protocol/VPN working groups themselves where they have 
> > been defined.
> > -) MBONED from this perspective can provide for 
> > experience/lessons learned
> > -) from implementing and deploying multicast routing protocols   
> > -) 
> > -) now, when reading the first line of the charter, it states:
> > -) 
> > -) "The MBONE Deployment Working Group is a forum for 
> coordinating the
> > -) deployment, engineering, and operation of multicast 
> > routing protocols
> > -) and procedures in IP based networks including the global 
> > Internet." 
> > -) 
> > -) you seem to infer that such statement is only valid if the 
> > protocol set
> > -) is unique and exclusively applicable in the global 
> > Internet          
> > -) 
> > -) but this sentence explicitly says -- including -- and not 
> > exclusively
> > -) for the global Internet. in addition, it does not refer to 
> > a specific
> > -) set of protocols and/or procedures.
> > -) 
> > -) in brief, the charter itself does not prevent including topics on
> > -) multicast in VPN context. in particular, it is a 
> suitable place to
> > -) discuss MVPN using PIM with GRE tunnels deployments.  
> > -) 
> > -) -d.
> > -) 
> > -) 
> > -) 
> > -) 
> > -) > -----Original Message-----
> > -) > From: Leonard Giuliano [mailto:[email-masked]] 
> > -) > Sent: Wednesday, December 12, 2007 6:27 PM
> > -) > To: [email-masked]
> > -) > Subject: Re: [MBONED] Draft revised charter description
> > -) > 
> > -) > 
> > -) > I do not think that MVPNs should be added to the charter 
> > of this WG.  
> > -) > MBONED has always been focused on the deployment issues of 
> > -) > multicast on 
> > -) > the global Internet, not a general all-purpose multicast 
> > -) > operational forum 
> > -) > (hence, the name MBONED as opposed to something like 
> MCAST-OPS).
> > -) > 
> > -) > The difference in this case is more than just semantic- the 
> > -) > issues that 
> > -) > face MVPNs have little to nothing in common with the issues 
> > -) > of Mcast over 
> > -) > the Global Internet (MOGI) that this WG has always focused 
> > -) > on.  MOGI is 
> > -) > concerned with building and maintaining state between 
> > sourcing and 
> > -) > receiving hosts over the global Internet.  In the case of 
> > -) > MVPNs, this is 
> > -) > the easy part and can be taken for granted- MVPNs add no new 
> > -) > considerations here.  The primary issues regarding MVPNs 
> > -) > concern building 
> > -) > tunnels between provider edge routers to transport 
> > customer VPN mcast 
> > -) > traffic across a provider VPN network.  These router-router 
> > -) > tunnels (P2MP 
> > -) > GRE, P2MP MPLS, etc) have little to no applicability to MOGI. 
> > -) >  Much of the 
> > -) > control-plane protocol extensions used to build and utilize 
> > -) > these tunnels 
> > -) > (BGP, RSVP, etc) have little to no applicability to MOGI.  
> > -) > Where there is 
> > -) > overlap (eg, PIM used to create PTMP GRE tunnels for MDTs), 
> > -) > MVPNs add no 
> > -) > new considerations.  But where the considerable 
> > differences lay, the 
> > -) > control plane and data plane mechanisms of MVPNs bear 
> > little to no 
> > -) > resemblance to what weve always done in MOGI.  In the case of 
> > -) > the Next-Gen 
> > -) > MVPN solution that the L3VPN WG has consensus, the mechanisms 
> > -) > look far 
> > -) > more like VPNs than mcast as we know it (decoupled data 
> > and control 
> > -) > planes, BGP for exchanging mcast state and maintaining 
> > -) > neighbors, label 
> > -) > stacking, etc).  For this reason, I believe L3VPN WG should 
> > -) > continue to 
> > -) > handle MVPNs, and we should continue to focus on MOGI.
> > -) > 
> > -) > There is plenty of precedent here.  When issues of multicast 
> > -) > in mobile 
> > -) > environments have arisen, they have generally been more 
> > germane to 
> > -) > mobility than multicast.  When our input and expertise has 
> > -) > been sought, 
> > -) > the issues and concerns have been introduced into MBONED.  
> > -) > However, the 
> > -) > work has been done in the relevant mobility working groups.  
> > -) > I think we 
> > -) > should take this same approach with MVPNs.  Let the relevant 
> > -) > WGs that have 
> > -) > the expertise in VPN environments continue to work on this, 
> > -) > and where our 
> > -) > input is desired, or when updates as to what solutions have 
> > -) > been agreed 
> > -) > upon are necessary, they can be presented to MBONED.  
> > -) > Otherwise, why stop 
> > -) > at MVPNs?  Why not just take on all operational issues 
> > related to 
> > -) > multicast, be they Mobile, L2VPNs, PWs, MPLS, etc?
> > -) > 
> > -) > The main reason it seems to be adding MVPNs to our 
> > charter and going 
> > -) > beyond the focus of MOGI that MBONED has always had is that a 
> > -) > handful of 
> > -) > people simply do not like some of the solutions that the 
> > L3VPN WG has 
> > -) > agreed upon.  This is not an assertion, but rather has 
> > been stated 
> > -) > explicitly and openly on this mailing list in the past.  In 
> > -) > any event, 
> > -) > this is not a good reason to add MVPNs to our charter.  We 
> > -) > should also 
> > -) > keep in mind that we are not talking about 1 draft here.  
> > -) > Adding MVPNs to 
> > -) > the charter would open the floodgates for a bunch of 
> > MVPN drafts that 
> > -) > could create competing standards with WGs better focused on 
> > -) > issues related 
> > -) > to VPNs.  Getting mcast deployed on the global Internet is 
> > -) > tough enough- I 
> > -) > see no reason to unnecessarily take on the headaches of 
> > other WGs.
> > -) > 
> > -) > 
> > -) > Thanks,
> > -) > Lenny
> > -) > 
> > -) > 
> > -) > On Fri, 7 Dec 2007, Hiroshi Ohta wrote:
> > -) > 
> > -) > -) Working Group:
> > -) > -) 
> > -) > -) I uploaded a draft revised charter description to
> > -) > -) 
> > -) > -) http://www3.ietf.org/proceedings/07dec/slides/mboned-5.pdf
> > -) > -) 
> > -) > -) Please have a look and post your comments if you have 
> > any.  We 
> > -) > -) will ask for approval after reflecting ML discussion.
> > -) > -) 
> > -) > -) Best regards,
> > -) > -) Hiroshi and Marshall
> > -) > -) 
> > -) > -) 
> > -) > -) 
> > -) > -) 
> > -) > -) _______________________________________________
> > -) > -) MBONED mailing list
> > -) > -) [email-masked]
> > -) > -) https://www1.ietf.org/mailman/listinfo/mboned
> > -) > -) 
> > -) > 
> > -) > 
> > -) > _______________________________________________
> > -) > MBONED mailing list
> > -) > [email-masked]
> > -) > https://www1.ietf.org/mailman/listinfo/mboned
> > -) > 
> > -) 
> > 
> 
> 
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mboned
> 

------------------------------

_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

End of MBONED Digest, Vol 14, Issue 35
**************************************

_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: Su Haiyang <[email-masked]>
Date: Fri, 14 Dec 2007 11:33:10 +0800

Dear All,

 john