Subject: Re: [MBONED] Re: Comments on mtrace version 2 draft

From: ycai <[email-masked]>
Date: Wed, 02 Jan 2008 17:35:56 -0800

On 12/23/07 7:26 AM, "Bharat Joshi" <[email-masked]> wrote:

>>> * Why are we having 8 bytes for packet counts while the objects
>>> referred here are of 4 bytes?
>> 
>> Having 8 bytes is correct.
>> 
> 
> But this will never exceed a 4 byte value. This is because the MIB object this
> variable refers to is of 4 bytes only.

It is pretty common for today's core routers to support 64 bit counters.  So
the information is there.  SNMP just gets the lower 32 bits during each
query.

-- 
Yiqun

_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: ycai <[email-masked]>
Date: Wed, 02 Jan 2008 17:35:56 -0800

-- 
Yiqun

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 09:16:49 +0530

Hi,

> the information is there.  SNMP just gets the lower 32 bits during each

If thats the case, I would suggest to remove the reference to MIB Object
from the text here. Let a router put this as 64 bit value irrespective
of whatever way it maintains this internally.

Thanks,
Bharat

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 09:16:49 +0530

Hi,

Thanks,
Bharat

---

From: ycai <[email-masked]>
Date: Wed, 02 Jan 2008 22:19:55 -0800

> of whatever way it maintains this internally.

That is fine.  Thanks.

-- 
Yiqun

---

From: ycai <[email-masked]>
Date: Wed, 02 Jan 2008 22:19:55 -0800

That is fine.  Thanks.

-- 
Yiqun

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 19:56:42 +0530

Hi Hitoshi,

>(Bharat, if my mail is still filtered out, please forward this mail to
> the ML. Thanks.)

I forwarded your reply to MBONED list.

> Or, mtrace2 should adopt new "high capacity" groups?
> RFC2863 adopts expanded, 64 bit, counters that are provided in new
> high capacity groups, while it does not deprecate old 32-bit
> counters.
> In other words, should mtrace2 draft explicitly mention whether
> mtrace2 *SHOULD* or *MAY* use ifHCInMulticastPkts instead of
> ifInMulticastPkts?
>
> For instance,
>
> 5.6.  Input packet count on incoming interface
>
>    This field contains the number of multicast packets received for all
>    groups and sources on the incoming interface, or all 1 if no count
>    can be reported.  This counter should have the same value as
>    ifHCInMulticastPkts from the IF-MIB [9] for this interface.  If the
>    multicast router does not support new high capacity groups, it
>    may fill the same value as ifInMulticastPkts instead.
>
> Or ifInMulticastPkts should not be mentioned here and recommend to use
> the different 64-bits counter values maintained by the router
> internally?
>
> What is your comment?
>

   I think its better not to refer to any MIB objects here. I think its enough to say:

   This field contains the number of multicast packets received for all groups and sources on the incoming interface, or all 1 if no count can be reported.

Thanks & Regards,
Bharat

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 19:56:42 +0530

Hi Hitoshi,

Thanks & Regards,
Bharat