Subject: [Fwd: Re: [MBONED] Re: Comments on mtrace version 2 draft]

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 16:45:31 +0530

As suspected by Hitoshi, this mail did not make it to mboned mailing
list. So forwarding it.

Thanks,
Bharat

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely for the use of the addressee(s). If you are not the intended recipient, please notify the sender by e-mail and delete the original message. Further, you are not to copy, disclose, or distribute this e-mail or its contents to any other person and any such actions are unlawful. This e-mail may contain viruses. Infosys has taken every reasonable precaution to minimize this risk, but is not liable for any damage you may sustain as a result of any virus in this e-mail. You should carry out your own virus checks before opening the e-mail or attachment. Infosys reserves the right to monitor and review the content of all messages sent to or from this e-mail address. Messages sent to or from this e-mail address may be stored on the Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***

Subject: Re: [MBONED] Re: Comments on mtrace version 2 draft
From: Hitoshi Asaeda <[email-masked]>
To: Bharat Joshi <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Date: Thu, 3 Jan 2008 12:43:51 +0530

(Bharat, if my mail is still filtered out, please forward this mail to
the ML. Thanks.)

> > >>> * Why are we having 8 bytes for packet counts while the objects
> > >>> referred here are of 4 bytes?
> > >>
> > >> Having 8 bytes is correct.
> > >
> > > But this will never exceed a 4 byte value. This is because the
> > > MIB object this
> > > variable refers to is of 4 bytes only.
> >
> > It is pretty common for today's core routers to support 64 bit counters.  So
> > the information is there.  SNMP just gets the lower 32 bits during each
> > query.
>
> If thats the case, I would suggest to remove the reference to MIB Object
> from the text here. Let a router put this as 64 bit value irrespective
> of whatever way it maintains this internally.

Or, mtrace2 should adopt new "high capacity" groups?
RFC2863 adopts expanded, 64 bit, counters that are provided in new
high capacity groups, while it does not deprecate old 32-bit
counters.
In other words, should mtrace2 draft explicitly mention whether
mtrace2 *SHOULD* or *MAY* use ifHCInMulticastPkts instead of
ifInMulticastPkts?

For instance,

5.6.  Input packet count on incoming interface

   This field contains the number of multicast packets received for all
   groups and sources on the incoming interface, or all 1 if no count
   can be reported.  This counter should have the same value as
   ifHCInMulticastPkts from the IF-MIB [9] for this interface.  If the
   multicast router does not support new high capacity groups, it
   may fill the same value as ifInMulticastPkts instead.

Or ifInMulticastPkts should not be mentioned here and recommend to use
the different 64-bits counter values maintained by the router
internally?

What is your comment?
--
Hitoshi Asaeda
_______________________________________________
MBONED mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mboned

---

From: Bharat Joshi <[email-masked]>
Date: Thu, 3 Jan 2008 16:45:31 +0530

Thanks,
Bharat

For instance,

What is your comment?