Subject: Re: [MBONED] UDP Header draft for IPv6 AMT

From: Magnus Westerlund <[email-masked]>
Date: Wed, 14 Jan 2009 10:55:01 +0100

Thomas Narten skrev:
> FWIW, my take is that the IPv6 WG will resist attempts to allow UDP
> packets with no checksums. We've had this discussion more than once in
> the past.
> 
> Why not use UDPLite instead? Yes, there is still a minimal checksum,
> but it *is* minimal enough that the cost of processing it should be
> acceptable.
> 

There is also this little problem called NAT traversal that doesn't work
particular well if one has UDP-Lite. That was to me much more a good
argument why UDP-lite is a bad choice.

I think instead of complaining that the issue has been beaten to its
death, you actually do somethFrom [email-masked]  Wed Jan 14 01:55:20 2009
Date: Wed, 14 Jan 2009 10:55:01 +0100
From: Magnus Westerlund <[email-masked]>
To: Thomas Narten <[email-masked]>
Cc: [email-masked], "Chimento, Philip F." <[email-masked]>
Subject: Re: [MBONED] UDP Header draft for IPv6 AMT
Sender: [email-masked]

Thomas Narten skrev:
> FWIW, my take is that the IPv6 WG will resist attempts to allow UDP
> packets with no checksums. We've had this discussion more than once in
> the past.
> 
> Why not use UDPLite instead? Yes, there is still a minimal checksum,
> but it *is* minimal enough that the cost of processing it should be
> acceptable.
> 

There is also this little problem called NAT traversal that doesn't work
particular well if one has UDP-Lite. That was to me much more a good
argument why UDP-lite is a bad choice.

I think instead of complaining that the issue has been beaten to its
death, you actually do somethining. The mboned WG is the main beneficiary
of the proposed update to the IPv6 spec, so it is you that should drive
the work. So write up the motivation and the proposed wording change and
head over to 6MAN WG.

AMT will be stuck until this update has happened to IPv6 spec.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
MBONED mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mboned

g. The mboned WG is the main beneficiary
of the proposed update to the IPv6 spec, so it is you that should drive
the work. So write up the motivation and the proposed wording change and
head over to 6MAN WG.

AMT will be stuck until this update has happened to IPv6 spec.

Cheers

Magnus Westerlund

IETF Transport Area Director & TSVWG Chair
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------
_______________________________________________
MBONED mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mboned

---

From: "Chimento, Philip F." <[email-masked]>
Date: Wed, 14 Jan 2009 08:01:57 -0500

We (Marshall Eubanks and I, with advice from Brian Haberman) are pulling together a draft addressing the change. Should appear by the -00 deadline before the next IETF.

Regards,
Phil Chimento

JHU/APL
240-228-1743
443-778-1743
[email-masked]
--

On 1/14/09 4:55 AM, "Magnus Westerlund" <[email-masked]> wrote:

Thomas Narten skrev:
> but it *is* minimaFrom [email-masked]  Wed Jan 14 06:33:56 2009
From: "Chimento, Philip F." <[email-masked]>
To: Magnus Westerlund <[email-masked]>, Thomas Narten
	<[email-masked]>
Date: Wed, 14 Jan 2009 08:01:57 -0500
Accept-Language: en-US
acceptlanguage: en-US
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [MBONED] UDP Header draft for IPv6 AMT
Sender: [email-masked]
We (Marshall Eubanks and I, with advice from Brian Haberman) are pulling together a draft addressing the change. Should appear by the -00 deadline before the next IETF.

Regards,
Phil Chimento

JHU/APL
240-228-1743
443-778-1743
[email-masked]
--

On 1/14/09 4:55 AM, "Magnus Westerlund" <[email-masked]> wrote:

Thomas Narten skrev:
> but it *is* minimal l enough that the cost of processing it should be
> acceptable.
>

I think instead of complaining that the issue has been beaten to its
death, you actually do something. The mboned WG is the main beneficiary
of the proposed update to the IPv6 spec, so it is you that should drive
the work. So write up the motivation and the proposed wording change and
head over to 6MAN WG.

Cheers

Magnus Westerlund

Content-Tenough that the cost of processing it should be

I think instead of complaining that the issue has been beaten to its
death, you actually do something. The mboned WG is the main beneficiary
of the proposed update to the IPv6 spec, so it is you that should drive
the work. So write up the motivation and the proposed wording change and
head over to 6MAN WG.

Cheers

Magnus Westerlund

F=E4r=F6gatan 6                | Mobile +46 73 0949079

--_000_C5934C75F29DPhilipChimentojhuapledu_
Content-Type: text/html; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<HTML>
<HEAD>
<TITLE>Re: [MBONED] UDP Header draft for IPv6 AMT</TITLE>
</HEAD>
<BODY>
<FONT FACE=3D"Lucida Bright"><SPAN STYLE=3D'font-size:9pt'>We (Marshall Eub=
anks and I, with advice from Brian Haberman) are pulling together a draft a=
ddressing the change. Should appear by the &#8211;00 deadline before the ne=
xt IETF. <BR>
<BR>
Regards, <BR>
Phil Chimento<BR>
<BR>
JHU/APL<BR>
240-228-1743<BR>
443-778-1743<BR>
<a href=3D"[email-masked]">[email-masked]</a><BR>
-- <BR>
<BR>
<BR>
On 1/14/09 4:55 AM, &quot;Magnus Westerlund&quot; &lt;<a href=3D"magnus.wes=
[email-masked]">[email-masked]</a>&gt; wrote:<BR>
<BR>
</SPAN></FONT><BLOCKQUOTE><FONT FACE=3D"Lucida Bright"><SPAN STYLE=3D'font-=
size:9pt'>Thomas Narten skrev:<BR>
&gt; FWIW, my take is that the IPv6 WG will resist attempts to allow UDP<BR=
&gt; packets with no checksums. We've had this discussion more than once in=
<BR>
&gt; the past.<BR>
&gt;<BR>
&gt; Why not use UDPLite instead? Yes, there is still a minimal checksum,<B=
R>
&gt; but it *is* minimal enough that the cost of processing it should be<BR=
&gt; acceptable.<BR>
&gt;<BR>
<BR>
There is also this little problem called NAT traversal that doesn't work<BR=
particular well if one has UDP-Lite. That was to me much more a good<BR>
argument why UDP-lite is a bad choice.<BR>
<BR>
I think instead of complaining that the issue has been beaten to its<BR>
death, you actually do something. The mboned WG is the main beneficiary<BR>
of the proposed update to the IPv6 spec, so it is you that should drive<BR>
the work. So write up the motivation and the proposed wording change and<BR=
head over to 6MAN WG.<BR>
<BR>
AMT will be stuck until this update has happened to IPv6 spec.<BR>
<BR>
Cheers<BR>
<BR>
Magnus Westerlund<BR>
<BR>
IETF Transport Area Director &amp; TSVWG Chair<BR>
----------------------------------------------------------------------<BR>
Multimedia Technologies, Ericsson Research EAB/TVM<BR>
----------------------------------------------------------------------<BR>
Ericsson AB &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nb=
sp;&nbsp;&nbsp;&nbsp;&nbsp;| Phone &nbsp;+46 10 7148287<BR>
F&auml;r&ouml;gatan 6 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp=
;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;| Mobile +46 73 0949079<BR>
SE-164 80 Stockholm, Sweden| mailto: <a href=3D"magnus.westerlund@ericsson.=
com">[email-masked]</a><BR>
----------------------------------------------------------------------<BR>
<BR>
</SPAN></FONT></BLOCKQUOTE><FONT FACE=3D"Lucida Bright"><SPAN STYLE=3D'font=
-size:9pt'><BR>
<BR>
</SPAN></FONT>
</BODY>
</HTML>

--_000_C5934C75F29DPhilipChimentojhuapledu_--
_______________________________________________
MBONED mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mboned