Subject: Re: [MBONED] Input for 3171bis

From: Marshall Eubanks <[email-masked]>
Date: Tue, 3 Mar 2009 12:45:37 -0500

On Mar 3, 2009, at 12:39 PM, Michelle Cotton wrote:

> Marshall,
>
> I didn’t see any responses on the list.  Any suggestions on how to  
> get these remaining issues resolved.
>
> Thanks!
>
> Michelle
> IANA
>
>
> On 2/24/09 10:49 AM, "Michelle Cotton" <[email-masked]>  
> wrote:
>
> Marshall,
>
> I see that the Working Group Last Call message you sent out  
> indicated the Last Call would end February 20th.
> I sent the following message out on that day but have not seen any  
> responses on the list.  Can you assist us in resolving the remaining  
> issues?
>
> Thanks in advance.
>
> Michelle
> IANA
>
> ------ Forwarded Message
> From: Michelle Cotton <[email-masked]>
> Date: Fri, 20 Feb 2009 11:09:30 -0800
> To: <[email-masked]>
> Subject: [MBONED] Input for 3171bis
>
> Attention MBONED Working Group:
>
> During 2008 there were some comments on the mailing list from Pekka  
> and
> Prashant.  Some of the points they bring up would need decisions  
> made by the
> working group and not IANA.
>
> These include:
>
> Comments by Prashant Jhingran (2/20/2008):
>
> 1)  As per my understanding, the "225.0.0.0   - 231.255.255.255
> 7 /8s RESERVED" addresses are the ones which are going to be
> widely used for ASM multicast by various multicast content
> providers (channels/data-sources).
> Who (whether IANA or someone else) is going to
> monitor/provide these addresses to the multicast content
> providers because content providers must use unique
> addresses for each channel globally.
>
> Shouldn't this be clarified?

These addresses are reserved. If they are needed, a bis for 3171bis  
can be written. I don't
see a problem here.

>
>
> 2) Section 8.1.  Assignment Guidelines
>
> "Because the SSM model essentially makes the entire
> multicast address space local to the host, no IANA
> assignment policy is required."
>
> Once again, SSM addresses should also be globally unique and
> thus someone should monitor these as well. Shouldn't this be
> clarified?
>
>

I do not see why there is any need for globally unique SSM addresses.  
The channel
address (the S,G tuple) needs to be unique, but that can be done by  
the holder of "S".

Regards
Marshall

> Comments by Pekka Savola (03/09/2008)
>
> We have gone through the comments made by Pekka. Some of them will be
> addressed in an updated version of this document.  Others will be  
> addressed
> in a future policy document.  This document it meant to cover more  
> of the
> procedures for IANA to follow regarding assignments.  We will begin  
> working
> on the policy document after this document has been published.  We  
> would
> like to re-start policy related discussions when we begin working on  
> that
> document.
>
>
> Please see version 05 of this document that is being Last Called and  
> submit
> all comments so that we can review and address them.
> Marshall can assist with answering questions as he is currently the  
> IESG
> designated multicast expert.
>
> Thank you for your time and efforts.
>
> Michelle Cotton
> Leo Vegoda
> IANA
>
>
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>
>
> ------ End of Forwarded Message

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 3 Mar 2009 12:50:09 -0500

On Mar 3, 2009, at 12:45 PM, Marshall Eubanks wrote:

>> responses on the list.  Can you assist us in resolving the  
>> remaining issues?
>>
>> Thanks in advance.
>>
>> Michelle
>> IANA
>>
>> ------ Forwarded Message

And, of course, if anyone has other ideas for these blocks, the  
deadline for new Internet-Drafts has not closed !

Marshall

> I do not see why there is any need for globally unique SSM  
> addresses. The channel
>> like to re-start policy related discussions when we begin working  
>> on that
>> document.
>>
>>
>> Please see version 05 of this document that is being Last Called  
>> and submit

---

From: Michelle Cotton <[email-masked]>
Date: Tue, 3 Mar 2009 10:48:31 -0800

Thanks for the response Marshall.

So based on your responses, and if there is no additional feedback are we ready to submit this to the IESG for approval?

Are there any other changes that need to be made to this version? (I guess this means WG speak up now!)

Thanks!

Michelle
IANA

On 3/3/09 9:45 AM, "Marshall Eubanks" <[email-masked]> wrote:

On Mar 3, 2009, at 12:39 PM, Michelle Cotton wrote:

> Marshall,
>
> I didn't see any responses on the list.  Any suggestions on how to

Regards
Marshall

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 3 Mar 2009 13:53:18 -0500

Putting on my co-chair hat, I will give people until Close of Business  
Friday to comment on this
issue. I don't see any other remaining issues, but if anyone else  
disagrees, please speak up about that
by COB Friday as well.

Regards
Marshall

On Mar 3, 2009, at 1:48 PM, Michelle Cotton wrote:

> So based on your responses, and if there is no additional feedback  
> are we ready to submit this to the IESG for approval?
>

---

From: Stig Venaas <[email-masked]>
Date: Wed, 04 Mar 2009 09:59:02 +0100

Marshall Eubanks wrote:
> address (the S,G tuple) needs to be unique, but that can be done by the 
> holder of "S".

The only possible issue is at layer 2. It's not good if everyone uses
G's that result in the same layer 2 addresses. Randomness might be
better than uniqueness for this.

I wouldn't completely rule out that some application may want to get
a well-known SSM group. We do have this for IPv6.

Stig

>> in a future policy document.  This document it meant to cover more of the
>> on the policy document after this document has been published.  We would
>> like to re-start policy related discussions when we begin working on that
>> document.
>>
>>
>> Marshall can assist with answering questions as he is currently the IESG

---

From: "Prashant Jhingran (pjhingra)" <[email-masked]>
Date: Wed, 4 Mar 2009 15:06:49 +0530

And who would assign a unique SSM G in such scenarios (viz. where an
application or content provider wants a unique SSM G) ? 

Regards,
Prashant Jhingran
www.cisco.com 
Phone:   +91-80-442 61800
 
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Stig Venaas
Sent: Wednesday, March 04, 2009 2:29 PM
To: Marshall Eubanks
Cc: [email-masked]
Subject: Re: [MBONED] Input for 3171bis

Marshall Eubanks wrote:
>> Once again, SSM addresses should also be globally unique and thus 
>> someone should monitor these as well. Shouldn't this be clarified?
>>
>>
> 

I wouldn't completely rule out that some application may want to get a
well-known SSM group. We do have this for IPv6.

Stig

>> addressed in a future policy document.  This document it meant to 
>> cover more of the procedures for IANA to follow regarding 
>> assignments.  We will begin working on the policy document after this

>> document has been published.  We would like to re-start policy 
>> related discussions when we begin working on that document.
>>
>>
>> submit all comments so that we can review and address them.
>> IESG designated multicast expert.
>>

---

From: Pekka Savola <[email-masked]>
Date: Wed, 4 Mar 2009 14:13:08 +0200 (EET)

On Tue, 3 Mar 2009, Marshall Eubanks wrote:
> Putting on my co-chair hat, I will give people until Close of Business Friday 
> to comment on this
> issue. I don't see any other remaining issues, but if anyone else disagrees, 
> please speak up about that
> by COB Friday as well.

Quoting what Michelle/Leo wrote:

>submit all comments so that we can review and address them. Marshall 
>can assist with answering questions as he is currently the IESG 

The intent seems to be to produce a new version of this document.

I believe that should happen prior to the WG having to say "we're 
done, let's ship this off to the IESG".  Or at the least, intended 
edits/diffs to the existing version should be posted.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 4 Mar 2009 07:46:46 -0500

What Pekka says sounds reasonable.

Michelle, can we see a last rev of the document before we declare this  
finished ?

Regards
Marshall

On Mar 4, 2009, at 7:13 AM, Pekka Savola wrote:

>> Putting on my co-chair hat, I will give people until Close of  
>> Business Friday to comment on this
>> We have gone through the comments made by Pekka. Some of them will  
>> be addressed in an updated version of this document.  Others will  
>> be addressed in a future policy document.  This document it meant  
>> to cover more of the procedures for IANA to follow regarding  
>> assignments.  We will begin working on the policy document after  
>> this document has been published.  We would like to re-start policy  
>> and submit all comments so that we can review and address them.

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 4 Mar 2009 08:27:47 -0500

> application or content provider wants a unique SSM G) ?

Why would you want it ? What do you gain from having it ?

You do not gain uniqueness - that comes from S being unique. That  
assignment is done
already by the unicast assignment.

Regards
Marshall

>>> be
>>> this

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 4 Mar 2009 08:32:09 -0500

Dear Stig;

> better than uniqueness for this.

Yes, because of multicast group to MAC collisions. I don't think that  
the solution
to this is by assignment.

> a well-known SSM group. We do have this for IPv6.

To date, none have. However, if someone did, and could make a case for  
it, I don't see
why they couldn't just apply for it in IANA or put it in an RFC.

Regards
Marshall

>>> procedures for IANA to follow regarding assignments.  We will  
>>> begin working

---

From: Michelle Cotton <[email-masked]>
Date: Wed, 4 Mar 2009 08:09:10 -0800

Marshall/WG

We can produce a new version after we wait for all comments to be sorted out by Friday.
I'll touch base with you on what exact changes should be made after the discussion is finished.

Thanks for the feedback.

Michelle
IANA

On 3/4/09 4:46 AM, "Marshall Eubanks" <[email-masked]> wrote:

Regards
Marshall

---

From: Leo Vegoda <[email-masked]>
Date: Thu, 12 Mar 2009 13:59:14 -0700

Hi Marshall,

> Michelle, can we see a last rev of the document before we declare this

Michelle and I have prepared a -06 version, which we believe incorporates
all the changes agreed on the list. We've missed the cut-off for revisions
to existing I-Ds and so we'll post it when submissions open again.

Thanks,

Leo