Subject: [MBONED] 224.0.0.12

From: Marshall Eubanks <[email-masked]>
Date: Sat, 23 May 2009 15:14:10 -0400

In the IANA list

http://www.iana.org/assignments/multicast-addresses/

224.0.0.12 is listed as

224.0.0.12 DHCP Server / Relay Agent [RFC1884]

This address is manifestly not assigned in RFC 1884 (which deals with  
IPv6), and a search on my part reveals only
that DHCP-AGENTS.MCAST.NET resolves to 224.0.0.12

Does anyone know what, if anything, this address is really used for,  
and on what authority ?

My suspicion at present is that this may be a lame delegation.

Regards
Marshall

P.S. Bob Hinden says

> After doing some searches, it looks like the 224.0.0.12 multicast  
> was defined in a draft "Extensions to DHCP for Roaming Users" <draft- 
> mukherjee-dhc-dhcproam-00.txt>.  This appears to be where the  
> incorrect reference is.
>
> The next version of that draft -01 does not have the definition.

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 26 May 2009 18:30:59 -0400

Unless someone speaks up by June 6th this will be removed from the  
IANA list and would probably eventually be reassigned.

Regards
Marshall

On May 23, 2009, at 3:14 PM, Marshall Eubanks wrote:

> This address is manifestly not assigned in RFC 1884 (which deals  
> with IPv6), and a search on my part reveals only
>> was defined in a draft "Extensions to DHCP for Roaming Users"  
>> <draft-mukherjee-dhc-dhcproam-00.txt>.  This appears to be where  
>> the incorrect reference is.
>>
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>

---

From: Dave Thaler <[email-masked]>
Date: Wed, 27 May 2009 18:34:36 +0000

I couldn't find anything either, although it appears to have
been mentioned in
http://tools.ietf.org/html/draft-mukherjee-dhc-dhcproam-00
but then removed from version -01.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Marshall Eubanks
> Sent: Tuesday, May 26, 2009 3:31 PM
> To: Marshall Eubanks
> Cc: [email-masked]
> Subject: Re: [MBONED] 224.0.0.12
>

---

From: Brian Haberman <[email-masked]>
Date: Wed, 27 May 2009 21:48:10 -0400

I also have not been able to find anything on this address.

Regards,
Brian

---

From: Lucy Lynch <[email-masked]>
Date: Thu, 28 May 2009 07:43:51 -0700 (PDT)

> but then removed from version -01.

ah, but either 00 or 01 is worth a quick look *just* for the ascii art:

http://tools.ietf.org/html/draft-mukherjee-dhc-dhcproam-01

see fig. 2

FWIW, there is also a mention in:

http://tools.ietf.org/html/draft-sandiick-flip-00

7.1 All-FLIP-Peers

The All-FLIP-Peers multicast address has the following possible values:

            o  IPv4 _ 224.0.0.12
            o  IPv6 _ FF02:0:0:0:0:0:0:C

individual submission, c.2000

- Lucy

---

From: Dave Thaler <[email-masked]>
Date: Thu, 28 May 2009 15:35:50 +0000

Perhaps Brian Haberman can comment on FLIP?

> From: Lucy Lynch [mailto:[email-masked]]
> Sent: Thursday, May 28, 2009 7:44 AM
> To: Dave Thaler
> Cc: Marshall Eubanks; [email-masked]

---

From: Brian Haberman <[email-masked]>
Date: Thu, 28 May 2009 13:01:19 -0400

I suppose I can even though I had blocked the FLIP experience out of my 
consciousness. :)

When FLIP was proposed and discussed (Adelaide IETF, if I recall), it 
was the target of a rather vicious attack.  The authors decided to forgo 
any further standardization efforts and the I-D died without ever 
advancing.  I don't recall how the multicast addresses were chosen for 
that document.  I would venture to guess that one of the primary editors 
picked the next available link-local address from the IANA registry.

For those of you interested... The initial implementation was never 
shipped in a product that I am aware of.  And I am pretty sure that the 
implementation didn't actually use the 224.0.0.12 address.

In addition, you may notice the resemblance of Bi-Directional Forwarding 
Detection (BFD) to FLIP. :)

Regards,
Brian