Subject: [MBONED] Progressing the AMT draft

From: Tom Pusateri <[email-masked]>
Date: Wed, 25 Nov 2009 15:16:27 -0500

I have a suggestion for progressing the AMT draft and wanted to see what people thought about it.

Currently, the draft is stuck because of wanting to optionally calculate the UDP checksum over IPv6 which is forbidden.

There is an effort underway to allow exceptions to this but its not clear how long this will take or if it will even get approved.

Now, if in a few more months we are able to get an exception, we will submit the AMT draft and there are bound to be some suggestions from the IESG on more changes needed in the draft and this will hold it up even longer.

So my suggestion is to work the process in parallel in the following way.

1. Change the current AMT draft to require the UDP checksum to be calculated and submit it to the IESG.
2. Get their feedback on other changes that need to be made in order to proceed the draft to a proposed standard.
3. Make all the necessary changes needed and go back and forth with the IESG getting the draft exactly like it needs to be.

If by then, the checksum issue is worked out, we can make the change to the draft. If not, we can decide at that time how to proceed.

Sound reasonable?

Thanks,
Tom

---

From: Dave Thaler <[email-masked]>
Date: Wed, 25 Nov 2009 20:44:47 +0000

[...]
> 2. Get their feedback on other changes that need to be made in order to
> proceed the draft to a proposed standard.
> 3. Make all the necessary changes needed and go back and forth with the
> IESG getting the draft exactly like it needs to be.
> 
> If by then, the checksum issue is worked out, we can make the change to
> the draft. If not, we can decide at that time how to proceed.
> 
> Sound reasonable?

Sounds reasonable to me.

-Dave

---

From: Marshall Eubanks <[email-masked]>
Date: Wed, 25 Nov 2009 15:58:20 -0500

>> the draft. If not, we can decide at that time how to proceed.

And to me.

I would estimate that getting zero UDP checksums through is still a  
few IETFs away.

Marshall

>
> -Dave
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 25 Nov 2009 19:30:16 -0800

Sorry, but this issue has really frustrated me. We (NGTRANS) had
already decided on this issue when we (MBONED) brought it to their
attention for AMT. Then, before we could get it shipped LISP came
along with the same requirement and an all new group of worms came out
of the wood to reject the zero-checksum proposal - with fairly
transparent motives. There have yet to be any rational arguments
against zero-checksum yet for some reason there still seems to be an
audience for the crowing.

I'm not ready to roll-over. Let's try to help NGTRANS to the right
thing - again - so we can move forward as we had decided years ago.

Greg

---

From: Tom Pusateri <[email-masked]>
Date: Wed, 25 Nov 2009 22:46:54 -0500

I'm concerned that AMT is going to rejected by the security guys (they've rejected everything we've sent them) so I want to find out what is the cause of rejection and being working on it.

Thanks,
Tom

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 25 Nov 2009 21:11:36 -0800

Shep, I support your position and don't think we should roll over  
either.

Let me just say if the specs don't reflect what vendors have brought  
to issue, the specs will become irrelevant. Now we don't want that to  
happen, do we.

Dino

On Nov 25, 2009, at 7:30 PM, Greg Shepherd wrote:

>> Currently, the draft is stuck because of wanting to optionally  
>> calculate the UDP checksum over IPv6 which is forbidden.
>>
>> There is an effort underway to allow exceptions to this but its not  
>> clear how long this will take or if it will even get approved.
>>
>> Now, if in a few more months we are able to get an exception, we  
>> will submit the AMT draft and there are bound to be some  
>> suggestions from the IESG on more changes needed in the draft and  
>> this will hold it up even longer.
>>
>> 2. Get their feedback on other changes that need to be made in  
>> order to proceed the draft to a proposed standard.
>> 3. Make all the necessary changes needed and go back and forth with  
>> the IESG getting the draft exactly like it needs to be.
>>
>> If by then, the checksum issue is worked out, we can make the  
>> change to the draft. If not, we can decide at that time how to  
>> proceed.
>>
>> Sound reasonable?
>>
>> Thanks,
>> Tom

---

From: Pekka Savola <[email-masked]>
Date: Thu, 26 Nov 2009 08:49:11 +0200 (EET)

On Wed, 25 Nov 2009, Tom Pusateri wrote:
> I'm concerned that AMT is going to rejected by the security guys 
> (they've rejected everything we've sent them) so I want to find out 
> what is the cause of rejection and being working on it.

FWIW, I support Tom's original suggestion, and I could also support 
Toerless's alternative version b).

IETF and IESG review _could_ (and in all likelyhood, will) find issues 
in the rest of the spec and it would be useful to root those out now.

Even if the spec doesn't end up changing and we go forward with the 
checksum as mandatory, vendors could just very earily not implement 
IPv6 version of AMT if they don't want/can't do that.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: John Zwiebel <[email-masked]>
Date: Wed, 25 Nov 2009 21:02:17 -1000

> thing - again - so we can move forward as we had decided years ago.

I'm with shep.

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 25 Nov 2009 23:10:06 -0800

> IETF and IESG review _could_ (and in all likelyhood, will) find  
> issues in the rest of the spec and it would be useful to root those  
> out now.

What we did with LISP is put a MAY in the spec. Maybe that is a  
compromise position.

> IPv6 version of AMT if they don't want/can't do that.

That message sends a precedent that IPv6 is not important enough as  
IPv4.

Dino