Subject: Re: [MBONED] I-D Action:draft-ietf-mboned-multiaaa-framework-10.txt

From: "ALTOM, MARK W (ATTLABS)" <[email-masked]>
Date: Sun, 7 Mar 2010 09:59:02 -0500

Hiroaki,

Please see below:

>
> Hiroaki,
> Here a few notes that we had on AAA and Admission Control Framework
for
> Multicasting (draft-ietf-mboned-multiaaa-framework-10).
>
> 1.  Is there a mechanism to prevent the sharing of authorization
(e.g.,
> sharing an S,G among end users)?
>

-> Our assumption is that the NSP identifies the user on L2 (such as 
-> VLAN or PPP) And it would be
-> problematic for NSP if more than two receivers for the same user 
-> accessed the same channel and one
-> is accepted but the other is rejected on L2 or L3.   Prevention of 
-> unauthorized content sharing could be
-> handled on the application layer by the CP: e.g. could distinguish
among 
-> receivers and distribute encryption
-> keys so that non-authorized receivers can not make use of the
content.
->
-> Do you have any ideas related to preventing the sharing of 
-> authorization?  Do you have any proposals of
-> how the NSP might effectively distinguish among receivers on the same

-> line (is it necessary)?

In investigating this issue, we uncovered some AT&T intellectual
property that addresses preventing the sharing of authorization 
among end-users.  We are working with AT&T legal to determine 
the licensing conditions for this intellectual property.  
We will be filling an intellectual property disclosure as 
soon as possible with the IETF.

Mark Altom
Andy Huang
Tom Imburgia
Pat McCrink
Han Nguyen
Doug Nortz
AT&T Labs
(Contact Mark Altom: [email-masked]; +1 732 420 9073)

---

From: Hiroaki Sato <[email-masked]>
Date: Mon, 08 Mar 2010 16:42:35 +0900

Mark,

Thank you for your information.
I'm looking forward to hearing such information in the IETF.

It's difficult for NSP (L3 provider) to identify receivers.
NSP has receiver information only about source addresses of IGMP/MLD 
reports.
When a user has a home router, it looks like a receiver from NSP and NSP 
don't know actual receivers.
I think the NSP can only control of consuming NSP's network resources by 
a user.

Thank you,
Hiroaki

-- 
************************************
NTT Network Service Systems Lab.
Hiroaki Sato
TEL:0422-59-3141 (+81-422-59-3141)
FAX:0422-59-3167 (+81-422-59-3167)
************************************