Subject: [MBONED] Existing 234/8 filtering recommendations

From: Tim Chown <[email-masked]>
Date: Wed, 30 Mar 2011 13:37:53 +0200

Hi,

Just a quick followup to a mic comment I made.

Here's the addresses under 234/8 that I have seen in multiple existing multicast guides (for filtering), this specific example coming from an I2 text (http://globalnoc.iu.edu/i2network/multicast-cookbook.html):
   route-filter 234.42.42.40/30 orlonger;     ! IMAGECAST
   route-filter 234.142.142.42/31 orlonger;     ! IMAGECAST
   route-filter 234.142.142.44/30 orlonger;     ! IMAGECAST
   route-filter 234.142.142.48/28 orlonger;     ! IMAGECAST
   route-filter 234.142.142.64/26 orlonger;     ! IMAGECAST
   route-filter 234.142.142.128/29 orlonger;    ! IMAGECAST
   route-filter 234.142.142.136/30 orlonger;    ! IMAGECAST
   route-filter 234.142.142.140/31 orlonger;    ! IMAGECAST
   route-filter 234.142.142.142/32 exact;     ! IMAGECAST
I wasn't aware of such existing use of 234 space.   So I wonder who uses 42.42.0.0/16 or 142.142.0.0/16? 

The more serious problem though is ISPs who still filter 234/8.

Tim

---

From: "William F. Maton Sotomayor" <[email-masked]>
Date: Wed, 30 Mar 2011 07:58:41 -0400 (EDT)

> I wasn't aware of such existing use of 234 space.   So I wonder who uses 42.42.0.0/16 or 142.142.0.0/16?

I remember thinking the same thing.  when I looked at this from Internet2 
last year I had not updated my operational filters since 2005.  This seems 
to have been a recent discovery.

> The more serious problem though is ISPs who still filter 234/8.

I think this might be in part a lack of info at the operator level beyond 
the R+E networks.  spreading the word via pressos to folks like NANOG may 
make a difference or at least make them more aware of multicast.

wfms

---

From: Leo Vegoda <[email-masked]>
Date: Wed, 30 Mar 2011 15:52:06 -0700

Hi,

On 30 Mar 2011, at 4:37, Tim Chown wrote:

[...]

> The more serious problem though is ISPs who still filter 234/8.

I wasn't in the room and may have missed some context but I know that it is common for new unicast allocations to the RIRs to take some time to be 'debogonised'. I suspect the same need applies with multicast space. Looking at the graphs here, it can take at least a couple of months:

http://www.ris.ripe.net/debogon/index.shtml

As I understand it, once the RIRs have done some 'running in' they try to make the first allocation from a new /8 to a large ISP as the larger the ISP the more pester power available to get fire-and-forget filters changed. Obviously, 234/8 is different because it is algorithmically assigned but pester power may still be necessary.

Regards,

Leo