Subject: [MBONED] Mutrans AF Requirement

From: Ronald Bonica <[email-masked]>
Date: Tue, 6 Dec 2011 14:56:03 -0500

Folks,

As I was thinking about the MULTRANS interim agenda, a nasty question occurred to me. Must information identifying the actually source of a multicast stream be preserved across an IPv4/IPv6 boundary. Is this information ever required to prevent duplicate injection of a multicast stream into a network?

--------------------------
Ron Bonica
vcard:       www.bonica.org/ron/ronbonica.vcf

---

From: Brian Haberman <[email-masked]>
Date: Tue, 06 Dec 2011 15:44:25 -0500

Hi Ron,

On 12/6/11 2:56 PM, Ronald Bonica wrote:
> Folks,
> 
> As I was thinking about the MULTRANS interim agenda, a nasty question
> occurred to me. Must information identifying the actually source of a
> multicast stream be preserved across an IPv4/IPv6 boundary. Is this
> information ever required to prevent duplicate injection of a
> multicast stream into a network?

Without knowing more of the context, I would say that you may have
issues with loops if RPF cannot function properly.  It would seem that
the conversion between address families (especially IPv6 to IPv4) could
be problematic if information about the true source is not available.

Regards,
Brian

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 6 Dec 2011 16:21:57 -0500

> be problematic if information about the true source is not available.

I think that in the intended IPTV use case the actual data
flow will be almost exclusively unidirectional and with known
mappings. That, to me, means that it may not be necessary to carry
along the actual source IP address, even for SSM IPv6 -> IPv4.

Regards
Marshall

> Regards,
> Brian
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 6 Dec 2011 16:27:08 -0500

Does that mean that the scope is constrained to SSM?

                              Ron

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]]
> Sent: Tuesday, December 06, 2011 4:22 PM
> To: Brian Haberman
> Cc: Ronald Bonica; MBONED WG
> Subject: Re: [MBONED] Mutrans AF Requirement
>

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 6 Dec 2011 15:56:54 -0500

That too!

> From: Brian Haberman [mailto:[email-masked]]
> Sent: Tuesday, December 06, 2011 3:44 PM
> To: Ronald Bonica
> Cc: MBONED WG

---

From: Stig Venaas <[email-masked]>
Date: Tue, 06 Dec 2011 13:44:47 -0800

> Does that mean that the scope is constrained to SSM?

No IMO.

I believe you may get loops if you do translation multiple
times with arbitrary mappings. E.g. if you translate

S -> AF1 -> AF2 -> AF1
          T1     T2

and T2(T1(S)) != S

This assuming that there is an RPF check on S, which is not
always true.

At least for 4 -> 6 -> 4 one could use a mapping such that
one end up with the original source address.

I'm wondering if the BOF needs to consider double translation
versus tunneling? Or if that should be out of scope. From
the use-cases provided last time, it seems that we may have
double translation scenarios where tunneling would not work.

Stig

---

From: Ronald Bonica <[email-masked]>
Date: Tue, 6 Dec 2011 17:41:21 -0500

Stig,

That leads us to two rules for our address mapping function. Given the following network:

IPvX -> IPvY -> IPvX
     T1      T2

T2(T1(S)) == S
    -and-
T2(T1(G)) == G

                   Ron

P.S. I think that the first part of this rule means that the answer to my initial question is "yes".

> From: Stig Venaas [mailto:[email-masked]]
> Sent: Tuesday, December 06, 2011 4:45 PM
> To: Ronald Bonica
> Cc: Marshall Eubanks; Brian Haberman; MBONED WG
> >>>> occurred to me. Must information identifying the actually source
> of
> >> a