Subject: [MBONED] draft-boucadair-64-multicast-address-format

From: Ronald Bonica <[email-masked]>
Date: Wed, 1 Feb 2012 11:00:49 -0500

Guys,

It appears that we have consensus to adopt draft-boucadair-64-multicast-address-format as a WG item. Since it is such a short document, do you think that it would be appropriate to have a WG last call before IETF 83?

--------------------------
Ron Bonica
vcard:       www.bonica.org/ron/ronbonica.vcf

---

From: <[email-masked]>
Date: Fri, 3 Feb 2012 09:46:47 +0100

Dear Ron, all,

IMHO, the document is stable. I vote for issuing a WG LC just after publishing the -00 of the WG adopted version.

Cheers,
Med 

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] 
> De la part de Ronald Bonica
> Envoyé : mercredi 1 février 2012 17:01
> À : MBONED WG
> Objet : [MBONED] draft-boucadair-64-multicast-address-format
> 
> Guys,
> 
> It appears that we have consensus to adopt 
> draft-boucadair-64-multicast-address-format as a WG item. 
> Since it is such a short document, do you think that it would 
> be appropriate to have a WG last call before IETF 83?
> 
> 
> 
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>

---

From: <[email-masked]>
Date: Fri, 3 Feb 2012 09:47:55 +0100

Hi*,

I agree with Med.

Cheers,

Christian. 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 3 février 2012 09:47
À : Ronald Bonica; MBONED WG
Objet : Re: [MBONED] draft-boucadair-64-multicast-address-format

Dear Ron, all,

Cheers,
Med 

> De : [email-masked] [mailto:[email-masked]] De la 
> part de Ronald Bonica Envoyé : mercredi 1 février 2012 17:01 À : 
> MBONED WG Objet : [MBONED] draft-boucadair-64-multicast-address-format
> 
> Guys,
> 
> Since it is such a short document, do you think that it would be 
> appropriate to have a WG last call before IETF 83?
> 
> 
> 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 3 Feb 2012 16:50:05 +0800

+1.

Cheers,
Xiaohong

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, February 03, 2012 4:48 PM
To: BOUCADAIR Mohamed OLNC-NAD-TIP; RonaldBonica; MBONED WG
Subject: Re: [MBONED] draft-boucadair-64-multicast-address-format

Hi*,

I agree with Med.

Cheers,

Christian. 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 3 février 2012 09:47
À : Ronald Bonica; MBONED WG
Objet : Re: [MBONED] draft-boucadair-64-multicast-address-format

Dear Ron, all,

Cheers,
Med

---

From: Ronald Bonica <[email-masked]>
Date: Fri, 3 Feb 2012 10:51:28 -0500

Med,

This is a call for the chairs to make. What say you, chairs?

                                     Ron

> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Friday, February 03, 2012 3:47 AM
> To: Ronald Bonica; MBONED WG
> Subject: RE: draft-boucadair-64-multicast-address-format
> 
> Dear Ron, all,
> 
> IMHO, the document is stable. I vote for issuing a WG LC just after
> publishing the -00 of the WG adopted version.
> 
> Cheers,
> Med
>

---

From: Stig Venaas <[email-masked]>
Date: Fri, 03 Feb 2012 10:14:57 -0800

> IMHO, the document is stable. I vote for issuing a WG LC just after publishing the -00 of the WG adopted version.

In the document we state:

    The format of the MPREFIX64 should be compatible with what is
    specified in [RFC3306] and [RFC3956] if corresponding mechanisms are
    used.

I wonder if it is worth explaining this in a little more detail?
Both of those mechanisms have some reserved bits after the scope,
which now will be redefined. Basically the first of the reserved
bits will now have a meaning, while the rest according to this
document MUST be 0, which is inline with their previous reserved
status.

Should there be an example in the document?

Stig

---

From: Stig Venaas <[email-masked]>
Date: Fri, 03 Feb 2012 11:17:25 -0800

Hi

I guess it is time to decide when to do the interim. Have this
been discussed already?

Perhaps about 2-3 weeks from now? That would give us more time
to prepare, but also leave room for working on documents
between the meeting and the IETF submission-deadline.

Stig

---

From: Ronald Bonica <[email-masked]>
Date: Fri, 3 Feb 2012 14:40:33 -0500

Hi Stig,

The purpose of the interim meeting  is to discuss the overview document. I would like to see some revisions to that document, but neither Tina nor I will be available to work on it until the week of the 12th. So we can assume that a new version will be available around the 19th.

The WG chair, armed with that information, can schedule the interim accordingly.

BTW, since this meeting is to be held in cyberspace, we will be looking for somebody to donate webex/gotomeeting/whatever facilities.

                                           Ron

> From: Stig Venaas [mailto:[email-masked]]
> Sent: Friday, February 03, 2012 2:17 PM
> To: [email-masked]; Ronald Bonica
> Subject: When to do the mboned interim?
> 
> Hi
>

---

From: Stig Venaas <[email-masked]>
Date: Fri, 03 Feb 2012 11:55:19 -0800

> BTW, since this meeting is to be held in cyberspace, we will be looking for somebody to donate webex/gotomeeting/whatever facilities.

I should be able to set up webex for the meeting if there is interest.

Stig

---

From: Tina TSOU <[email-masked]>
Date: Fri, 03 Feb 2012 21:02:15 +0000

Tina

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Stig Venaas
> Sent: Friday, February 03, 2012 11:55 AM
> To: Ronald Bonica
> Cc: [email-masked]
> Subject: Re: [MBONED] When to do the mboned interim?
> 
> > The purpose of the interim meeting is to discuss the overview document.
Will other documents be discussed along the overview document, as Ron wrote to the mailing list earlier about the agenda discussion?
> I would like to see some revisions to that document, but neither Tina nor
> I will be available to work on it until the week of the 12th. So we can
> assume that a new version will be available around the 19th.
> >
> > BTW, since this meeting is to be held in cyberspace, we will be looking
> for somebody to donate webex/gotomeeting/whatever facilities.
> 
The interest for the meeting was shown in Taipei meeting and also in the mailing list after Taipei.
Thank you for your donation of Webex.
Can the WG chairs announce the date and time?

---

From: Leonard Giuliano <[email-masked]>
Date: Fri, 3 Feb 2012 14:33:39 -0800

Sounds like there is solid consensus and there has been pretty good review 
so far.  So, first the authors may rename and reissue as an MBONED 
document.  Second, we can initiate WGLC since this is very short, 
straightforward and seems fairly non-controversial.

WGLC will run through Feb 24.  Please review this very short draft and 
provide comments- that you support/oppose advancing this doc, as well as 
anything you think should be added/deleted/changed in the doc.

Thanks,
Lenny and Greg

On Fri, 3 Feb 2012, Ronald Bonica wrote:

-) Med,
-) 
-) This is a call for the chairs to make. What say you, chairs?
-) 
-)                                      Ron
-) 
-) 
-) > -----Original Message-----
-) > From: [email-masked]
-) > [mailto:[email-masked]]
-) > Sent: Friday, February 03, 2012 3:47 AM
-) > To: Ronald Bonica; MBONED WG
-) > Subject: RE: draft-boucadair-64-multicast-address-format
-) > 
-) > Dear Ron, all,
-) > 
-) > IMHO, the document is stable. I vote for issuing a WG LC just after
-) > publishing the -00 of the WG adopted version.
-) > 
-) > Cheers,
-) > Med
-) > 
-) > > -----Message d'origine-----
-) > > De : [email-masked] [mailto:[email-masked]]
-) > > De la part de Ronald Bonica
-) > > Envoyé : mercredi 1 février 2012 17:01
-) > > À : MBONED WG
-) > > Objet : [MBONED] draft-boucadair-64-multicast-address-format
-) > >
-) > > Guys,
-) > >
-) > > It appears that we have consensus to adopt
-) > > draft-boucadair-64-multicast-address-format as a WG item.
-) > > Since it is such a short document, do you think that it would
-) > > be appropriate to have a WG last call before IETF 83?
-) > >
-) > >
-) > >
-) > > --------------------------
-) > > Ron Bonica
-) > > vcard:       www.bonica.org/ron/ronbonica.vcf
-) > >
-) > >
-) > > _______________________________________________
-) > > MBONED mailing list
-) > > [email-masked]
-) > > https://www.ietf.org/mailman/listinfo/mboned
-) > >
-) _______________________________________________
-) MBONED mailing list
-) [email-masked]
-) https://www.ietf.org/mailman/listinfo/mboned
-)

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Fri, 3 Feb 2012 17:05:26 -0600

Looks good to me. We needed something like this, for sure. Nice to see it being standardized.

Quibbles:

On page 5,

"When "M-bit" is set to 1, it indicates that *a* multicast ..."

And I believe that the Section 7 header should be

"Source IPv4 Address in the IPv6 Realm" (vs. Ream)

Bert

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Leonard Giuliano
Sent: Friday, February 03, 2012 5:34 PM
To: Ronald Bonica
Cc: MBONED WG
Subject: Re: [MBONED] draft-boucadair-64-multicast-address-format

Thanks,
Lenny and Greg

-) Med,
-)

---

From: "Lee, Yiu" <[email-masked]>
Date: Mon, 6 Feb 2012 02:35:18 +0000

I agree with Stig, we may want to explain the detail and give some
examples.

---

From: <[email-masked]>
Date: Mon, 6 Feb 2012 14:23:27 +0100

Dear Albert,

Thank you for catching this. 
This is fixed in my local copy.

Cheers,
Med

> De la part de Manfredi, Albert E
> Envoyé : samedi 4 février 2012 00:05
> À : Leonard Giuliano
> Cc : MBONED WG
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Leonard Giuliano

---

From: <[email-masked]>
Date: Mon, 6 Feb 2012 14:52:22 +0100

Hi Stig,

I added a section listing some examples.

As for the sentence you mentioned, I updated to:

   The format of the MPREFIX64 should follow what is specified in
   [RFC3306] and [RFC3956] if corresponding mechanisms are used.

      Note: the format specified in Section 3 uses some reserved bits
      defined in [RFC3306] and [RFC3956]: the first bit of the reserved
      bits have now a meaning, while the remaining bits MUST be set to
      0.

Do we need to say more?

Cheers,
Med 

> De : Stig Venaas [mailto:[email-masked]] 
> Envoyé : vendredi 3 février 2012 19:15
> À : BOUCADAIR Mohamed OLNC/NAD/TIP
> Cc : Ronald Bonica; MBONED WG
> > IMHO, the document is stable. I vote for issuing a WG LC 
> just after publishing the -00 of the WG adopted version.
>

---

From: Stig Venaas <[email-masked]>
Date: Mon, 06 Feb 2012 13:24:37 -0800

>        bits have now a meaning, while the remaining bits MUST be set to

Great! A few typos though, see below.

Above I think you should write "The first of the reserved bits now has a
meaning, while....".

In section 8 you wrote:

    Figure 4 provides an example of ASM IPv4-Embedded IPv6 Address while
    Figure 4 provides an example of SSM IPv4-Embedded IPv6 Address.
          ^^^

Also for this example:

       +---------------------+--------------+----------------------------+
        |      MPREFIX64      | IPv4 address | IPv4-embedded IPv6 address |
        +---------------------+--------------+----------------------------+
        |   ff3x:0:8000::/96  |  232.1.2.3   |   ffxx:0:8000::232.1.2.3   |
        +---------------------+--------------+----------------------------+

It should say "ff3x:0:8000::232.1.2.3".

Sorry for the bad line wrapping.

Stig

---

From: <[email-masked]>
Date: Tue, 7 Feb 2012 08:00:50 +0100

Hi Stig,

Fixed. Thanks.

Cheers,
Med 

> Envoyé : lundi 6 février 2012 22:25