Subject: Re: [MBONED] Proposed interim date and agenda

From: Ronald Bonica <[email-masked]>
Date: Mon, 20 Feb 2012 21:27:51 -0500

Jacni,

Good question! I have seen pretty good progress on both the multrans overview and addressing drafts. The interim may not be needed. 

However, I will let the proponents of this meeting speak for themselves. If they still want to hold this meeting, they can tell us what topics remain open for discussion. If however, they no longer want to hold this meeting, they always have the option to cancel it.

                                    Ron

> Message: 1
> Date: Tue, 21 Feb 2012 09:51:26 +0800
> From: Jacni Qin <[email-masked]>
> To: Marc Blanchet <[email-masked]>
> Cc: MBONED WG <[email-masked]>
> Subject: Re: [MBONED] Proposed interim date and agenda
> Message-ID:
> 	<CAHmj1Weabs9=P-
> [email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Re-,
> 
> Sorry, may I ask why we need this interim meeting?
> 
> 
> Cheers,
> Jacni
> 
> 
****************

---

From: Tina TSOU <[email-masked]>
Date: Tue, 21 Feb 2012 02:56:57 +0000

We have at least for topics to discuss.
1. The degree to which the AF is stateless.
2. Which strategy looks more promising in the Address Acquisition draft?
3. Routing crosses address boundaries, loop avoidance.
4. What does the AF do when it lives on a machine that speaks IGMP or MLD out one side and PIM out the other? Does it translate between IGMP and MLD, or does it maintain all of the state that it needs to interface between IGMP or MLD and PIM?

That's actually a discussion that requires relatively high bandwidth. It is better suited to a conference call than an email exchange.

Tina

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ronald Bonica
> Sent: Monday, February 20, 2012 6:28 PM
> To: [email-masked]
> Good question! I have seen pretty good progress on both the multrans
> overview and addressing drafts. The interim may not be needed.
> 
> However, I will let the proponents of this meeting speak for themselves.
> If they still want to hold this meeting, they can tell us what topics
> remain open for discussion. If however, they no longer want to hold this
> meeting, they always have the option to cancel it.
> 
>                                     Ron
> 
> 
> > Message: 1
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

---

From: Jacni Qin <[email-masked]>
Date: Fri, 24 Feb 2012 16:19:48 +0800

Re-,

> overview and addressing drafts. The interim may not be needed.

Thanks Ron, for your clarification.

Cheers,
Jacni

---

From: Jacni Qin <[email-masked]>
Date: Fri, 24 Feb 2012 16:26:15 +0800

Re-,

On Tue, Feb 21, 2012 at 10:56 AM, Tina TSOU <[email-masked]>wrote:

> 4. What does the AF do when it lives on a machine that speaks IGMP or MLD
> out one side and PIM out the other? Does it translate between IGMP and MLD,
> or does it maintain all of the state that it needs to interface between
> IGMP or MLD and PIM?
>

Sorry, I don't understand what you mean by the 1.
Not sure yet about the 2., still reading the draft.
About the 3 &4, please refer to Christian's message earler, or you can read
the http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03,
not all cases are covered, but you can get the clue to the answer.

Cheers,
Jacni

> That's actually a discussion that requires relatively high bandwidth. It
> is better suited to a conference call than an email exchange.
>
> Tina
>
>

---

From: Stig Venaas <[email-masked]>
Date: Fri, 24 Feb 2012 11:03:39 -0800

On 2/24/2012 12:26 AM, Jacni Qin wrote:
> Re-,
>
>
> On Tue, Feb 21, 2012 at 10:56 AM, Tina TSOU
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     4. What does the AF do when it lives on a machine that speaks IGMP
>     or MLD out one side and PIM out the other? Does it translate between
>     IGMP and MLD, or does it maintain all of the state that it needs to
>     interface between IGMP or MLD and PIM?
>
>

Hi Jacni. Regarding number 1. In my opinion, the question is whether
stateful or stateless, similar to what has been discussed for unicast.

I believe you can easily do stateless translation from IPv4 to IPv6
by embedding IPv4 address into IPv6. But in the other direction, it
is likely that you need state.

Basically you can map a set of IPv6 addresses to IPv4, but that
mapping either needs to be a statically configured mapping, or
somehow learned dynamically.

Stig

> About the 3 &4, please refer to Christian's message earler, or you can
> read the http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03,
>     That's actually a discussion that requires relatively high
>     bandwidth. It is better suited to a conference call than an email
>     exchange.
>
>     Tina
>
>
>      > From: [email-masked] <mailto:[email-masked]>
>     [mailto:[email-masked] <mailto:[email-masked]>] On
>     Behalf
>      > Of Ronald Bonica
>      > To: [email-masked] <mailto:[email-masked]>
>      > > From: Jacni Qin <[email-masked] <mailto:[email-masked]>>
>      > > To: Marc Blanchet <[email-masked]
>     <mailto:[email-masked]>>
>      > > Cc: MBONED WG <[email-masked] <mailto:[email-masked]>>
>      > > [email-masked]
>     <mailto:[email-masked]>>
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Mike McBride <[email-masked]>
Date: Fri, 24 Feb 2012 12:35:53 -0800

Is it still undecided where this work will occur? mboned? behave? new
wg? Seems like this would be better discussed in behave (mcast
translation is in the charter) or new wg. There are no minutes posted
from the last meeting so don't recall what was discussed. Sorry if I
missed that decision somewhere on the list.

thanks,
mike

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 24 Feb 2012 20:57:58 +0000

Hi Stig,

I agree with you. However, is there any request to work on the v6->v4
mcast case? Is it worth to take the time to work on it now? Or should we
wait for real requirements coming out first?

Regards,
Yiu

---

From: Stig Venaas <[email-masked]>
Date: Fri, 24 Feb 2012 13:30:22 -0800

> wait for real requirements coming out first?

I think we should stick to the v6->v4 case for now, and I would like us
work on stateless solutions.

For stateless, we need some minimal configuration specifying which
prefixes to use for embedding IPv4 into IPv6. I think this would
typically be one prefix for ASM, and one for SSM. Despite this state,
I think it is correct to call it stateless...

Trying to generalize, we can perhaps say that a mapping algorithm must
be configured, and it may need some parameters (like prefixes). But
there is no per group/translation state needed.

Stig

>
> Regards,
> Yiu
>
>
> On 2/24/12 2:03 PM, "Stig Venaas"<[email-masked]>  wrote:
>

---

From: Greg Shepherd <[email-masked]>
Date: Tue, 28 Feb 2012 09:35:01 -0800

*,

I'm happy to see so much progress has been made on the list already. I
think it's best if we cancel the interim meeting and concentrate most
of the MBONED agenda time in Paris to Multrans issues. If there is no
serious objection the chairs will officially cancel the interim with
the secretariat tomorrow.

Thanks,
Greg

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 28 Feb 2012 12:50:01 -0500

I'm pretty confused on the process here.
- during last ietf, the consensus I understood was to:
 + have an interim meeting to make progress
 + have an overview document being written

why are we again changing our direction?

Marc.

---

From: Tina TSOU <[email-masked]>
Date: Tue, 28 Feb 2012 17:56:04 +0000

We are having the meeting because we have things to discuss. 
If we can settle what the necessary work items are, our meeting in Paris would be more productive.

Tina

> Of Greg Shepherd
> Sent: Tuesday, February 28, 2012 9:35 AM
> To: [email-masked]; Ron Bonica

---

From: Tina TSOU <[email-masked]>
Date: Tue, 28 Feb 2012 18:38:04 +0000

1. Welcome introduction and agenda bashing (mboned chairs) 

2. What work items to be completed (all)

3. Discuss what should be the baseline overview? (all)
http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03
or
http://datatracker.ietf.org/doc/draft-eubanks-mboned-transition-overview/

4. Outstanding issues discussion (all)
a. The degree to which the AF is stateless.
b. Which strategy looks more promising in the Address Acquisition draft?
c. Routing crosses address boundaries, loop avoidance.
d. What does the AF do when it lives on a machine that speaks IGMP or MLD out one side and PIM out the other? Does it translate between IGMP and MLD, or does it maintain all of the state that it needs to interface between IGMP or MLD and PIM?

5. Wrap-up: action items, next steps, AOB. (all)

Tina

---

From: Stig Venaas <[email-masked]>
Date: Tue, 28 Feb 2012 11:15:05 -0800

> why are we again changing our direction?

I don't understand either. Why would we want to cancel?

Stig

>> On Mon, Feb 20, 2012 at 6:27 PM, Ronald Bonica<[email-masked]>  wrote:
>>> Jacni,
>>>
>>>> From: Jacni Qin<[email-masked]>
>>>> To: Marc Blanchet<[email-masked]>
>>>> Cc: MBONED WG<[email-masked]>

---

From: Tom Taylor <[email-masked]>
Date: Tue, 28 Feb 2012 14:22:16 -0500

Just to be formal, I object. Please hold the meeting as scheduled.

---

From: Greg Shepherd <[email-masked]>
Date: Wed, 29 Feb 2012 11:43:49 -0800

Clearly from the feedback there is still much support for the interim
meeting scheduled for tomorrow. So I'm happy to say it is a 'go'.
Please find the access details below:

http://www.ietf.org/mail-archive/web/mboned/current/msg01361.html

Hear you all tomorrow.

Greg

---

From: Stig Venaas <[email-masked]>
Date: Wed, 29 Feb 2012 13:41:32 -0800

> http://www.ietf.org/mail-archive/web/mboned/current/msg01361.html

Good, but what is the final agenda? Which drafts to read, and who is
presenting what? Are slides available ahead of the meeting?

Stig

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 29 Feb 2012 14:22:22 -0800

Tina- this agenda looks pretty good, so we'll go with it.  For the 
draft-eubanks-mboned-transition-overview discussion, Stig will be 
presenting.

On Tue, 28 Feb 2012, Tina TSOU wrote:

-) 1. Welcome introduction and agenda bashing (mboned chairs) 
-) 
-) 2. What work items to be completed (all)
-) 
-) 3. Discuss what should be the baseline overview? (all)
-) http://tools.ietf.org/html/draft-jaclee-behave-v4v6-mcast-ps-03
-) or
-) http://datatracker.ietf.org/doc/draft-eubanks-mboned-transition-overview/
-) 
-) 4. Outstanding issues discussion (all)
-) a. The degree to which the AF is stateless.
-) b. Which strategy looks more promising in the Address Acquisition draft?
-) c. Routing crosses address boundaries, loop avoidance.
-) d. What does the AF do when it lives on a machine that speaks IGMP or MLD out one side and PIM out the other? Does it translate between IGMP and MLD, or does it maintain all of the state that it needs to interface between IGMP or MLD and PIM?
-) 
-) 5. Wrap-up: action items, next steps, AOB. (all)
-) 
-) 
-) Tina
-)

---

From: Tina TSOU <[email-masked]>
Date: Wed, 29 Feb 2012 22:35:24 +0000

The charts Stig will present are intended to animate the work item discussion.

Tina

> From: Leonard Giuliano [mailto:[email-masked]]
> Sent: Wednesday, February 29, 2012 2:22 PM
> To: Tina TSOU
> Cc: [email-masked]; [email-masked]; Ron Bonica
> Subject: Re: Proposed interim agenda
> 
> 
> -) d. What does the AF do when it lives on a machine that speaks IGMP or
> MLD out one side and PIM out the other? Does it translate between IGMP and
> MLD, or does it maintain all of the state that it needs to interface
> between IGMP or MLD and PIM?
> -)

---

From: Stig Venaas <[email-masked]>
Date: Wed, 29 Feb 2012 15:23:19 -0800

> The charts Stig will present are intended to animate the work item discussion.

Those are the slides I got from you Tina? They are for bullet 2 in the
agenda, right? I can present those.

Do we have any slides for the rest of the agenda? E.g. for the drafts
mentioned in bullet 3?

Stig