Subject: Re: [MBONED] Interdomain/AS Multicast for CDN

From: Greg Shepherd <[email-masked]>
Date: Mon, 21 May 2012 13:18:51 -0700

Inline:

On Wed, Apr 4, 2012 at 5:52 AM, SAYKO, ROBERT J <[email-masked]> wrote:
>
> All,
>
>
> As we didn't have time to complete our agenda on last Thursday I didn't have the opportunity to raise this topic.
>
> (As I am very new to IETF please excuse me if I am not following correct protocol or process in the following)
>
> I would like to propose that mboned initiate work on a draft for Inter-domain/AS CDN Multicast.  I have already spoken
> with one of our chairs,  Greg Shepherd, on this and he indicated that he would support the WG taking it on.

And I still think this is appropriate work for MBONED.

> I am aware that CDNi is doing a lot of interdomain CDN work,  but they are not addressing multicast and per their
> chairs do not want to take on multicast at this time (or from what I gather in the near future).    I have recently
> completed work on the ATIS interdomain MC specification and would like to take that work as a starting point to go
> even further by creating a RFC through IETF.

This seems to be the typical response in the IETF and why MBONED has
become the mcast safety net. Additionally, this isn't protocol work so
it fits right into our charter.

> If mboned takes on this challenge I think our scope will be slightly different then if CDNi were to do it,  but that is fine
> and it would not be demonstratively different I think.   Since I think interdomain CDN MC is almost a niche I think it
> would actually be easier to do then the caching based approach CDNi seems to be concentrating on.

Agreed.

> Interdomain CDNi is also likely to be more quickly and incorporated by some large operators then cache based.  There
> are a number of reasons for this:  many operators have MC ready or operating backbones,  it is a quick starter,  MC
> ready content is rapidly growing,  less investment then cache,  best solution for flash crowds.  Also,  large operators
> have within their ownership several AS's with separate CDNs in some cases and see MC as an extremely significant
> cost saving technology.

>From the WGs perspective, you've done the hard bit already in ATIS. We
just need to advance this work in the IETF, possibly as a BCP draft.

> Hopefully,  the WG will favorably consider taking this on.  I would be happy to be lead author,  but would of course like
> as much help as possible.  Please give me your comments and questions.

Again, I'm all for it. Anyone on the list interested in helping Bob
author the draft?

Thanks!,
Greg

> Regards,
> Bob Sayko
>
>
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

---

From: Tina TSOU <[email-masked]>
Date: Mon, 21 May 2012 20:59:45 +0000

Is it related to CDNi WG as well?

Tina

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Greg Shepherd
> Sent: Monday, May 21, 2012 1:19 PM
> To: SAYKO, ROBERT J
> Cc: [email-masked]
> Subject: Re: [MBONED] Interdomain/AS Multicast for CDN
> 
> Inline:
> 
> > As we didn't have time to complete our agenda on last Thursday I didn't
> have the opportunity to raise this topic.
> >
> > I would like to propose that mboned initiate work on a draft for Inter-
> domain/AS CDN Multicast.  I have already spoken
> > I am aware that CDNi is doing a lot of interdomain CDN work,  but they
> are not addressing multicast and per their
> > chairs do not want to take on multicast at this time (or from what I
> gather in the near future).    I have recently
> > completed work on the ATIS interdomain MC specification and would like
> to take that work as a starting point to go
> > If mboned takes on this challenge I think our scope will be slightly
> different then if CDNi were to do it,  but that is fine
> > and it would not be demonstratively different I think.   Since I think
> interdomain CDN MC is almost a niche I think it
> > Interdomain CDNi is also likely to be more quickly and incorporated by
> some large operators then cache based.  There
> > are a number of reasons for this:  many operators have MC ready or
> operating backbones,  it is a quick starter,  MC
> > ready content is rapidly growing,  less investment then cache,  best
> solution for flash crowds.  Also,  large operators
> > have within their ownership several AS's with separate CDNs in some
> cases and see MC as an extremely significant
> > cost saving technology.
> 
> > Hopefully,  the WG will favorably consider taking this on.  I would be
> happy to be lead author,  but would of course like

---

From: "SAYKO, ROBERT J" <[email-masked]>
Date: Mon, 21 May 2012 21:32:43 +0000

It is related in that it will identify the type of underlying/basic procedures and components for interdomain MC be it native or AMT.  So in a way it is similar what CDNi is doing with caching in that respect. Like Greg said I don't think this will entail protocol work,  unless perhaps utilizing existing protocol parameters (e.g. or perhaps adding new value to a parameter) implies protocol work.     

-----Original Message-----
From: Tina TSOU [mailto:[email-masked]] 
Sent: Monday, May 21, 2012 5:00 PM
To: [email-masked]; SAYKO, ROBERT J
Cc: [email-masked]
Subject: RE: [MBONED] Interdomain/AS Multicast for CDN

Tina

---

From: "SAYKO, ROBERT J" <[email-masked]>
Date: Mon, 21 May 2012 21:34:11 +0000

Oh,  I forgot to mention.  Myself and others are putting together an outline for a draft.  We will socialize it in the next few weeks with mboned. 

-----Original Message-----
From: Tina TSOU [mailto:[email-masked]] 
Sent: Monday, May 21, 2012 5:00 PM
To: [email-masked]; SAYKO, ROBERT J
Cc: [email-masked]
Subject: RE: [MBONED] Interdomain/AS Multicast for CDN

Tina