Subject: Re: [MBONED] multicast over wifi and and IEEE-IETF coordination

From: Toerless Eckert <[email-masked]>
Date: Tue, 3 Nov 2015 16:45:58 -0800

[sorry, resending with correct email aliases]

Mikael: 

Any reason to choose INTAREA ? 

There is already a draft in mboned:

draft-mcbride-mboned-wifi-mcast-problem-statement-00.txt

and... mboned runs in parallel to intarea this time *sigh*
and... i am sure mboned participants would love to hear your preso about IEEE.

Cheers
    Toerless

On Wed, Nov 04, 2015 at 01:31:52AM +0100, Mikael Abrahamsson wrote:
> 
> Hi,
> 
> I have been involved with the coordination group between IEEE and IETF to 
> discuss multicast over 802.11 issues that have been brought up in different 
> forums, both regarding reliability and power usage on battery powered 
> devices.
> 
> There will be a presentation in INTAREA regarding this and initial 
> discussion on the issue will be had there. In case there is enough interest 
> in the issue, there might be a non-working group mailing list created for 
> further discussion, or something else.
> 
> There will also be presentation in the IEEE meeting next week on this 
> issue, so there is awareness in both forums that the issue has been raised 
> to try to gather all interested parties to work on this problem.
> 
> The presentation tomorrow will be to present what IEEE already has done in 
> this area (for instance GCR), and then there is a need to figure out what 
> part of the problem to be solved where (IETF/IEEE).
> 
> -- 
> Mikael Abrahamsson    email: [email-masked]
> 
> --------------------------------------------------------------------
> IETF IPv6 working group mailing list
> [email-masked]
> Administrative Requests: https://www.ietf.org/mailman/listinfo/ipv6
> --------------------------------------------------------------------

-- 
---
Toerless Eckert, [email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 4 Nov 2015 01:56:54 +0100 (CET)

> Any reason to choose INTAREA ?

I didn't choose anything, INTAREA was chosen by the people in the 
coordination group that includes several ADs. The multicast over wifi 
issue has been raised in multiple working groups.

> and... i am sure mboned participants would love to hear your preso about IEEE.

So thanks for including mboned so that people there are aware that this is 
discussed in INTAREA. MBONED is not alone in having conflicts with 
INTAREA, there are other low-power wireless technology people who also 
have conflicts. Please discuss this issue on the INTAREA mailing list, and 
you can watch the presentation (it's not mine) after the fact on for 
instance Meetecho. I don't believe there is much time for discussion in 
the INTAREA meeting, they have a packed agenda already if I understood 
correctly.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 4 Nov 2015 03:22:03 +0000

Hello Dan,

I'd see it useful to give this a lot of visibility and accessibility. A BoF-type meeting outside of meeting hours at this or the next IETF would probably improve that piece. INTAREA has collisions that people did not necessarily get a chance to manage in advance so interested people may miss the presentation.
I would like to be sure that most interested parties have a chance to know that this is happening at all.

Some of these discussion will relate to work happening at various WGs. Out of my hat and not copied above I see at least 6lo and MANET which deal with radios networks and need efficient network and service discovery. Cc ing 6lo because this is where RFC 6775 originated, and new work is taking place.

There will be serious discussions, and probably documents produced in the form of best practices. This work may deserve a short-termed WG on its own. A non-Wg forming BoF would help figure all that out.

Cheers,

Pascal

> -----Original Message-----
> From: ipv6 [mailto:[email-masked]] On Behalf Of Romascanu, Dan
> (Dan)
> Sent: mercredi 4 novembre 2015 10:52
> To: Mikael Abrahamsson <[email-masked]>; Toerless Eckert (eckert)
> <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: multicast over wifi and and IEEE-IETF coordination
> 
> Does anybody believe there is a better/other place to go with this
> information?
> 
> Thanks and Regards,
> 
> Dan
> 
> 
> > -----Original Message-----
> > From: ipv6 [mailto:[email-masked]] On Behalf Of Mikael
> > Abrahamsson
> > Sent: Wednesday, November 04, 2015 2:57 AM
> > To: Toerless Eckert
> > Cc: [email-masked]; [email-masked]; [email-masked]
> > Subject: Re: multicast over wifi and and IEEE-IETF coordination
> >
> > > and... mboned runs in parallel to intarea this time *sigh* and... i
> > > am sure mboned participants would love to hear your preso about IEEE.
> >
> > So thanks for including mboned so that people there are aware that
> > this is discussed in INTAREA. MBONED is not alone in having conflicts
> > with INTAREA, there are other low-power wireless technology people who
> > also have conflicts. Please discuss this issue on the INTAREA mailing
> > list, and you can watch the presentation (it's not mine) after the
> > fact on for instance Meetecho. I don't believe there is much time for
> > discussion in the INTAREA meeting, they have a packed agenda already if I
> understood correctly.
> >
> > --
> > Administrative Requests:
> > https://urldefense.proofpoint.com/v2/url?u=https-
> >
> 3A__www.ietf.org_mailman_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl
> 1
> >
> SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=aVouzp
> b
> > CzgpDGMb8eabFNhiZ61AnoK06iltaK1NwjdE&s=cleQzxju-
> > 9RBGYIarDCVTKq1uzL_2XAW0kgXpVNreiw&e=

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Wed, 4 Nov 2015 10:20:53 +0000

I also support the idea of a BoF during an IETF meeting. The issues need
to be known to as many people as possible until there is 'a fix' within
IEEE 

-éric

On 4/11/15 04:22, "ipv6 on behalf of Pascal Thubert (pthubert)"
<[email-masked] on behalf of [email-masked]> wrote:

>Hello Dan,
>
>I'd see it useful to give this a lot of visibility and accessibility. A
>BoF-type meeting outside of meeting hours at this or the next IETF would
>probably improve that piece. INTAREA has collisions that people did not
>necessarily get a chance to manage in advance so interested people may
>miss the presentation.
>Some of these discussion will relate to work happening at various WGs.
>Out of my hat and not copied above I see at least 6lo and MANET which
>deal with radios networks and need efficient network and service
>discovery. Cc ing 6lo because this is where RFC 6775 originated, and new
>work is taking place.
>
>There will be serious discussions, and probably documents produced in the
>form of best practices. This work may deserve a short-termed WG on its
>own. A non-Wg forming BoF would help figure all that out.
>
>Cheers,
>
>Pascal
>
>

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 4 Nov 2015 01:52:11 +0000

Does anybody believe there is a better/other place to go with this information?

Thanks and Regards,

Dan

> coordination group that includes several ADs. The multicast over wifi issue
> has been raised in multiple working groups.
> 
> > and... mboned runs in parallel to intarea this time *sigh* and... i am
> > sure mboned participants would love to hear your preso about IEEE.
> 
> discussed in INTAREA. MBONED is not alone in having conflicts with INTAREA,
> there are other low-power wireless technology people who also have
> conflicts. Please discuss this issue on the INTAREA mailing list, and you can
> watch the presentation (it's not mine) after the fact on for instance
> Meetecho. I don't believe there is much time for discussion in the INTAREA
> meeting, they have a packed agenda already if I understood correctly.
> 
> --
> 3A__www.ietf.org_mailman_listinfo_ipv6&d=BQICAg&c=BFpWQw8bsuKpl1
> SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=aVouzpb

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 4 Nov 2015 04:59:01 +0000

Hi Pascal,

  I think the multicast-over-wifi discussion will be interesting for folks  in 6lo (regarding RFC6775) .

The goal is to reduce the  unnecessary signaling in the protocols and especially in efficient-nd (discussed in 6man) we had many rounds of discussions on wifi multicast behavior. 

Fixing 802.11 behavior for multicast will be helpful in many usecases to properly handle multicast messages.  However, I believe in general the protocols should reduce multicast signaling in  constrained node networks as well as in environments with virtual networks and VMs.

-Samita

-----Original Message-----
From: ipv6 [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Tuesday, November 03, 2015 7:22 PM
To: Romascanu, Dan (Dan); Mikael Abrahamsson; Toerless Eckert (eckert)
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: RE: multicast over wifi and and IEEE-IETF coordination

Hello Dan,

Cheers,

Pascal

> > coordination group that includes several ADs. The multicast over 
> > wifi issue has been raised in multiple working groups.
> >
> > > and... mboned runs in parallel to intarea this time *sigh* and... 
> > > i am sure mboned participants would love to hear your preso about IEEE.
> >
> > this is discussed in INTAREA. MBONED is not alone in having 
> > conflicts with INTAREA, there are other low-power wireless 
> > technology people who also have conflicts. Please discuss this issue 
> > on the INTAREA mailing list, and you can watch the presentation 
> > (it's not mine) after the fact on for instance Meetecho. I don't 
> > believe there is much time for discussion in the INTAREA meeting, 
> > they have a packed agenda already if I
> understood correctly.
> >
> > --
> > IETF IPv6 working group mailing list [email-masked] Administrative 
> > Requests: