Subject: [MBONED] Summary of Recent Changes to draft-ietf-mboned-mtrace-v2

From: "Kerry Meyer (kerrymey)" <[email-masked]>
Date: Wed, 12 Jul 2017 04:14:01 +0000

At this point, all last call comments have been incorporated for draft-ietf-mboned-mtrace-v2. No further comments have been submitted since publication of the current version of the draft.  I would like to summarize the changes made to satisfy the previously open issues and recommend that we proceed with adoption of this document as a standard.

The changes made in versions 16 (the previous version) and 17 (the current version) were:

  *   Revised the introduction to clarify the criteria for directing the mtrace v2 query to either a last hop router or a rendezvous point; carried this dual endpoint concept through in all sections of the document.
  *   Scanned for and corrected deviations from conventions (e.g. capitalization of “MUST” and “SHOULD” keywords), description of field ranges, etc.)
  *   Clarified the difference between an mtrace v2 query and an mtrace v2 request
  *   Broadened the description of circumstances in which a reply may be sent before the mtrace reaches the FHR
  *   Expanded on the criteria described in section 3 (Packet Formats) for validating TLVs within the message and for handling invalid TLVs.
  *   Corrected the minimum length requirement in section 3.
  *   In the “forwarding code” item in section 3, added an explicit definition of the reserved error code range.
  *   Section 4.2: Defined the term “outgoing interface” before using it in the subsequent paragraphs.
  *   Corrected/clarified the steps specified for section 4.2.2 “Request Normal Processing”; These changes included clarification of the handling for the “ADMIN_PROHIB” forwarding code.
  *   Section 4.5: Corrected the description for the “number of hops” field adjustment made when proxying an mtrace v2 query.
  *   Added more specific details and wording corrections to the descriptions of the mtrace2 forwarding codes registry and TLV types registry in section 8.1 and 8.2.
  *   Corrected the formula in section 3.2.4 for converting a UNIX timestamp to the form used in the mtrace “query arrival time” field in the mtrace2 standard response block.
  *
Please respond with any additional comments on changes required in the document, if any.

            Kerry Meyer

---

From: Leonard Giuliano <[email-masked]>
Date: Wed, 12 Jul 2017 09:40:50 -0700

Thanks for the update, Kerry.

Given these changes, and since there was only one reply during the last 
WGLC (thanks Stig), we will run another brief WGLC for comments.

Please speak up with support for/against advancing this doc by Aug 2- we'd 
like to get more feedback from the WG in support of this draft for 
publication.

And, of course, comments are welcome.

https://datatracker.ietf.org/doc/draft-ietf-mboned-mtrace-v2/

On Wed, 12 Jul 2017, Kerry Meyer (kerrymey) wrote:

| 
| At this point, all last call comments have been incorporated for draft-ietf-mboned-mtrace-v2. No further comments have been submitted since publication of the current version of the draft.  I would like
| to summarize the changes made to satisfy the previously open issues and recommend that we proceed with adoption of this document as a standard.
| 
|  
| 
| The changes made in versions 16 (the previous version) and 17 (the current version) were:
| 
|  
| 
|  *  Revised the introduction to clarify the criteria for directing the mtrace v2 query to either a last hop router or a rendezvous point; carried this dual endpoint concept through in all sections of the
|     document.
|  *  Scanned for and corrected deviations from conventions (e.g. capitalization of “MUST” and “SHOULD” keywords), description of field ranges, etc.)
|  *  Clarified the difference between an mtrace v2 query and an mtrace v2 request
|  *  Broadened the description of circumstances in which a reply may be sent before the mtrace reaches the FHR
|  *  Expanded on the criteria described in section 3 (Packet Formats) for validating TLVs within the message and for handling invalid TLVs.
|  *  Corrected the minimum length requirement in section 3.
|  *  In the “forwarding code” item in section 3, added an explicit definition of the reserved error code range.
|  *  Section 4.2: Defined the term “outgoing interface” before using it in the subsequent paragraphs.
|  *  Corrected/clarified the steps specified for section 4.2.2 “Request Normal Processing”; These changes included clarification of the handling for the “ADMIN_PROHIB” forwarding code.
|  *  Section 4.5: Corrected the description for the “number of hops” field adjustment made when proxying an mtrace v2 query.
|  *  Added more specific details and wording corrections to the descriptions of the mtrace2 forwarding codes registry and TLV types registry in section 8.1 and 8.2.
|  *  Corrected the formula in section 3.2.4 for converting a UNIX timestamp to the form used in the mtrace “query arrival time” field in the mtrace2 standard response block.
|  *   
| 
| Please respond with any additional comments on changes required in the document, if any.
| 
|  
| 
|             Kerry Meyer
| 
| 
|