Subject: [MBONED] draft-ietf-tsvwg-rfc6040update-shim-05 - implications for AMT.

From: joel jaeggli <[email-masked]>
Date: Wed, 15 Nov 2017 14:53:30 +0800

Hi,

I would call the attention of the working group to AMT tunnel
negotiation changes proposed in:

https://tools.ietf.org/html/draft-ietf-tsvwg-rfc6040update-shim-05

in particular

https://tools.ietf.org/html/draft-ietf-tsvwg-rfc6040update-shim-05#section-5.1.4

this might be something that you want to comment on.

joel

---

From: "Holland, Jake" <[email-masked]>
Date: Thu, 16 Nov 2017 16:57:43 +0000

Hi Joel,

I suggested to Bob including AMT in the 6040 update.

I’m not using it yet, but I think ECN would be a useful signal, and it would additionally be useful to be able to propagate it through AMT tunnels.

The new proposed ECN-capability advertisement for AMT is a 1-way advertisement, since the data packets are a 1-way flow, and it goes in the Request message so the relay will get it. Bob had originally suggested the Relay Discovery message, but I asked to move it to the Request message because the Relay Discovery won’t always go to the relay that forwards the data.

The relay will ignore the bit if it doesn’t understand it, which (correctly) results in using non-ECT on the outer IP and leaving the inner IP unmodified, but when the gateway advertises support with the new E-bit and the relay understands it, the 6040-bis behavior is used instead, which will propagate the ECT from the inner IP to the outer wrapper at the Relay and propagate new CE signals from the outer IP to the forwarded data packets in the Gateway.

I hope within a few years to use those CE signals to help with making ABR decisions.

The question of how to safely include ECT in the 1-way multicast data flows in the first place is not necessarily obvious—I’m thinking most likely when I try this I’ll run 2 different channels, one marked with ECT(0) and one without (and possibly another one for ECT(1) eventually, depending how the L4S experiments go), and the expected marking for the channel will be known by the client as part of the application-layer flow discovery, and only the receivers that know how to respond to CE will join the ECT flows.

Thanks for sending to mboned, that’s a good idea that probably should have occurred to me.

Regards,
Jake

On 11/14/17, 10:54 PM, "joel jaeggli" <[email-masked]> wrote:

Hi,

in particular

joel

_______________________________________________
MBONED mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mboned