Subject: Re: [MBONED] MBONED Digest, Vol 134, Issue 10

From: Tim Chown <[email-masked]>
Date: Sun, 1 Apr 2018 10:05:14 +0000

Hi Jim,

> On 31 Mar 2018, at 04:19, James A. (Jim) Stevens <[email-masked]> wrote:
> 
> On Thu, 29 Mar 2018 21:21:34 +0000​ , Tim Chown <[email-masked]>  wrote:
> Hi,
> 
> We've just posted a new -01 version of the draft on deprecating interdomain ASM. Toerless is now also an author.
> 
> We'll be working on a further new version in the coming weeks, so all comments and suggestions for improvement are very welcome.
> 
> The WG session agreed WG adoption, but I've posted the -01 as an individual draft as the adoption hasn't - I think - been confirmed on the list.
> 
> Best wishes,
> Tim
> 
> > On 29 Mar 2018, at 22:17, [email-masked] wrote:
> >
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts directories.
> >
> >
> >        Title           : Deprecating ASM for Interdomain Multicast
> >        Authors         : Mikael Abrahamsson
> >                          Tim Chown
> >                          Lenny Giuliano
> >                          Toerless Eckert
> >       Filename        : draft-acg-mboned-deprecate-interdomain-asm-01.txt
> >       Pages           : 15
> >       Date            : 2018-03-29
> >
> > Abstract:
> >   This document recommends deprecation of the use of Any-Source
> >   Multicast (ASM) for interdomain multicast.  It recommends the use of
> >   Source-Specific Multicast (SSM) for interdomain multicast
> >   applications, and that hosts and routers that are expected to handle
> >   such applications fully support SSM.  The recommendations in this
> >   document do not preclude the continued use of ASM within a single
> >   organisation or domain, and are especially easy to adopt when already
> >   using the preferred ASM protocol options there (PIM-SM).
> 
>  
> ​I think that this is an appropriate document.  One picky comment with respect to the following paragraph from the introduction:
> "   This document does not make any statement on the use of ASM within a
>    single domain or organisation, and therefore does not preclude its
>    use.  Indeed, there may be a number of application contexts for which
>    ASM is currently still considered well-suited within a single domain.
> 
> "​
> ​As per the earlier emails, there are some applications contexts for which ASM is still the best suited approach.​ For example, in an earlier email, I mentioned a multicast scenario with many dynamic bidirectional sources and receivers, where we use ASM rather than SSM model to reduce management overhead and simplify source discovery by not having to track which nodes have joined which groups in order to do an SSM join to all the members of the group. 
> 
> Thus, I recommend rewording the last sentence in that paragraph to something like 
> "    Indeed, there are application contexts for which
>    ASM is still considered well-suited within a single domain."

Perhaps "Indeed, there are application contexts for which ASM is currently still widely considered well-suited within a single domain."

Tim

---

From: Toerless Eckert <[email-masked]>
Date: Sun, 1 Apr 2018 15:03:43 +0200

Thanks, James, Tim

Agreed. That additional text in the abstract didn't add good value *sigh*

Can i ask whether you are using PIM-SM or Bidir-PIM for these type of apps ?
Always particularily curious about how well PIM-SM with bursty sources
does work well (or not) in different scenarios. E.g: Do you think that
RFC 8364 would work equally well for your app environment ?

Cheers
    Toerless

On Fri, Mar 30, 2018 at 10:19:14PM -0500, James A. (Jim) Stevens wrote:
> On Thu, 29 Mar 2018 21:21:34 +0000
> ???
> , Tim Chown <[email-masked]>  wrote:
> 
> > Hi,
> >
> > We've just posted a new -01 version of the draft on deprecating
> > interdomain ASM. Toerless is now also an author.
> >
> > We'll be working on a further new version in the coming weeks, so all
> > comments and suggestions for improvement are very welcome.
> >
> > The WG session agreed WG adoption, but I've posted the -01 as an
> > individual draft as the adoption hasn't - I think - been confirmed on the
> > list.
> >
> > Best wishes,
> > Tim
> >
> ???I think that this is an appropriate document.  One picky comment with
> respect to the following paragraph from the introduction:
> "???
> ???As per the earlier emails, there are some applications contexts for which
> ASM is still the best suited approach.??? For example, in an earlier email, I
> mentioned a multicast scenario with many dynamic bidirectional sources and
> receivers, where we use ASM rather than SSM model to reduce management
> overhead and simplify source discovery by not having to track which nodes
> have joined which groups in order to do an SSM join to all the members of
> the group.
> 
> Regards,
> Jim Stevens

> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned

-- 
---
[email-masked]

---

From: "James A. (Jim) Stevens" <[email-masked]>
Date: Sun, 1 Apr 2018 23:31:12 -0500

Toerless, we are using Bidir-PIM.

I haven't been tracking
​
RFC 8364, but from just glancing at it, I think Bidir-PIM is probably
better for these bursty source/destination multicast applications as well
as being an existing standard available in some routers and host operating
systems. Doesn't mean I couldn't change my opinion as I learn more and it
becomes widely available, however.

Cheers,
Jim

On Sun, Apr 1, 2018 at 8:03 AM, Toerless Eckert <[email-masked]> wrote:

> ​​

---

From: Tim Chown <[email-masked]>
Date: Mon, 2 Apr 2018 06:59:03 +0000

Hi,

> On 2 Apr 2018, at 05:31, James A. (Jim) Stevens <[email-masked]> wrote:
> 
> I haven't been tracking ​RFC 8364, but from just glancing at it, I think Bidir-PIM is probably better for these bursty source/destination multicast applications as well as being an existing standard available in some routers and host operating systems. Doesn't mean I couldn't change my opinion as I learn more and it becomes widely available, however.

Certainly BIDIR and PFM have their use cases intradomain. The question is how much we talk about these in the draft. The thrust of the document is on removing ASM components from interdomain scenarios.

Tim

> ​​RFC 8364 would work equally well for your app environment ?
> 
> Cheers
>     Toerless
>

---

From: Toerless Eckert <[email-masked]>
Date: Mon, 2 Apr 2018 21:20:38 +0200

Agreed. My answer to the question is that we shouldn't discuss any
use of ASM we don't suggest to change. That would be a whole other BCP.
Fun BCP, but lets serialize.

Subsections of 4. discuss how going SSM interdomain can impact and
be sarted also with intradomain SSM capable apps. Thats i think the correct
extend.

My abstract text change especially mentioning PIM-SM wasnt helpful (with James 
even better example of intradomain ASM wit Bidir-PIM). But explaining
exactly when/why to use intradomain ASM Bidir vs. ASM is exactly
not in scope of this draft.

Cheers
    Toerless

On Mon, Apr 02, 2018 at 06:59:03AM +0000, Tim Chown wrote:
> > I haven't been tracking ???RFC 8364, but from just glancing at it, I think Bidir-PIM is probably better for these bursty source/destination multicast applications as well as being an existing standard available in some routers and host operating systems. Doesn't mean I couldn't change my opinion as I learn more and it becomes widely available, however.
> 
> > ??????RFC 8364 would work equally well for your app environment ?
> > 
> > Cheers
> >     Toerless
> > 

-- 
---
[email-masked]