Subject: [MBONED] I-D Action: draft-ietf-mboned-ieee802-mcast-problems-05.txt

From: [email-masked]
Date: Mon, 15 Apr 2019 08:12:47 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the MBONE Deployment WG of the IETF.

        Title           : Multicast Considerations over IEEE 802 Wireless Media
        Authors         : Charles E. Perkins
                          Mike McBride
                          Dorothy Stanley
                          Warren Kumari
                          Juan Carlos Zuniga
	Filename        : draft-ietf-mboned-ieee802-mcast-problems-05.txt
	Pages           : 24
	Date            : 2019-04-15

Abstract:
   Well-known issues with multicast have prevented the deployment of
   multicast in 802.11 and other local-area wireless environments.  This
   document offers guidance on known limitations and problems with
   wireless multicast.  Also described are certain multicast enhancement
   features that have been specified by the IETF and by IEEE 802 for
   wireless media, as well as some operational choices that can be taken
   to improve the performace of the network.  Finally, some
   recommendations are provided about the usage and combination of these
   features and operational choices.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mboned-ieee802-mcast-problems/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-mboned-ieee802-mcast-problems-05
https://datatracker.ietf.org/doc/html/draft-ietf-mboned-ieee802-mcast-problems-05

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mboned-ieee802-mcast-problems-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 29 Apr 2019 19:55:11 +0000

Hi,

I came across this https://superuser.com/questions/730288/why-do-some-wifi-routers-block-multicast-packets-going-from-wired-to-wireless. It listed some issues, at least one (about encryption) of which is not discussed in this draft.

That topic is a bit old (from 2014), not sure if the list issues not discussed in this draft are no longer present, or if they are worthy discussion in this draft?

I am also curious, in a home environment, if only one receiver joins a particular multicast flow (e.g. one viewer for a multicast TV channel), how much trouble would a typical consumer router run into if we turn on multicast?

Thanks.
Jeffrey

Juniper Internal

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 29 Apr 2019 19:57:39 +0000

[Resend w/o the id-announce list - please do not reply to the earlier thread]

Hi,

Thanks.
Jeffrey

Juniper Public

---

From: Mikael Abrahamsson <[email-masked]>
Date: Mon, 29 Apr 2019 22:17:23 +0200 (CEST)

On Mon, 29 Apr 2019, Jeffrey (Zhaohui) Zhang wrote:

> I am also curious, in a home environment, if only one receiver joins a 
> particular multicast flow (e.g. one viewer for a multicast TV channel), 
> how much trouble would a typical consumer router run into if we turn on 
> multicast?

>From my understanding most customer routers do not have the 
multicast->wifi-unicast conversion mechanism, so it'd start to transmit 
the multicast stream at low speeds without any retransmit mechanism, 
giving that receiver lots of packet loss for this multicast plus chewing 
up most of the airtime.

So that's a bad idea...

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: "Jeffrey (Zhaohui) Zhang" <[email-masked]>
Date: Mon, 29 Apr 2019 20:22:26 +0000

I was hoping to hear that, even w/o the unicast conversion, since the router does not have to use a low speed to reach many receivers (of different signaling levels), it would not be problem.

Guess I was too naïve 😊

Thanks.

Jeffrey

Juniper Internal

> -----Original Message-----
> From: Mikael Abrahamsson <[email-masked]>
> Sent: Monday, April 29, 2019 4:17 PM
> To: Jeffrey (Zhaohui) Zhang <[email-masked]>
> Cc: [email-masked]; [email-masked]
> Subject: Re: [MBONED] I-D Action: draft-ietf-mboned-ieee802-mcast-
> problems-05.txt
>