Subject: [MBONED] [Technical Errata Reported] RFC8777 (6218)

From: RFC Errata System <[email-masked]>
Date: Wed, 1 Jul 2020 16:09:03 -0700 (PDT)

The following errata report has been submitted for RFC8777,
"DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6218

--------------------------------------
Type: Technical
Reported by: Brian Wellington <[email-masked]>

Section: 4.3.2

Original Text
-------------
10   IN TYPE260  \# (
       18 ; length
       0a ; precedence=10
       02 ; D=0, relay type=2, an IPv6 address
       20010db800000000000000000000000f ) ; 2001:db8::15
10   IN TYPE260  \# (
       24 ; length
       80 ; precedence=128
       83 ; D=1, relay type=3, a wire-encoded domain name
       09616d7472656c617973076578616d706c6503636f6d ) ; domain name

Corrected Text
--------------
10   IN TYPE260  \# (
       18 ; length
       0a ; precedence=10
       02 ; D=0, relay type=2, an IPv6 address
       20010db8000000000000000000000015 ) ; 2001:db8::15
10   IN TYPE260  \# (
       25 ; length
       80 ; precedence=128
       83 ; D=1, relay type=3, a wire-encoded domain name
       09616d7472656c617973076578616d706c6503636f6d00 ) ; domain name

Notes
-----
In the first example, the IPv6 address is incorrectly encoded.

In the second example, the trailing root label of the domain name was not included, and should be.  This also increases the length by 1 byte.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8777 (draft-ietf-mboned-driad-amt-discovery-13)
--------------------------------------
Title               : DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery
Publication Date    : April 2020
Author(s)           : J. Holland
Category            : PROPOSED STANDARD
Source              : MBONE Deployment
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Warren Kumari <[email-masked]>
Date: Fri, 10 Jul 2020 13:48:00 -0400

[ - RFC Ed (for clutter) ]

Dear MBONED / Authors,

I *think* that this erratum is correct, and should be marked at Verified.
If you disagree, please let me know by Friday July 17th...

Thanks!
W

P.S: I had thought that I had sent this on July 1st, but apparently not...

On Wed, Jul 1, 2020 at 7:09 PM RFC Errata System <[email-masked]>
wrote:

> In the second example, the trailing root label of the domain name was not
> included, and should be.  This also increases the length by 1 byte.
>
> Instructions:
> -------------

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Holland, Jake" <[email-masked]>
Date: Fri, 10 Jul 2020 22:39:55 +0000

I agree, I think these are correct.  Thanks Brian for catching and reporting them.

Best,
Jake

From: Warren Kumari <[email-masked]>
Date: Friday, July 10, 2020 at 10:49 AM
Cc: "Wellington, Brian" <[email-masked]>, MBONED WG <[email-masked]>, Jake Holland <[email-masked]>
Subject: Re: [MBONED] [Technical Errata Reported] RFC8777 (6218)

Dear MBONED / Authors,

I *think* that this erratum is correct, and should be marked at Verified.
If you disagree, please let me know by Friday July 17th....

Thanks!
W

On Wed, Jul 1, 2020 at 7:09 PM RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:
The following errata report has been submitted for RFC8777,
"DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6218<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-2Deditor.org_errata_eid6218&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=2YiJjA3C74QomL0Bkygr4dYvuzaip8lKTZ3FeelO_Ik&s=SkZMyU-vLmIFP-4WJAirYojmJ-Ohv9BzkuLbD6CBw1w&e=>

--------------------------------------
Type: Technical
Reported by: Brian Wellington <[email-masked]<mailto:[email-masked]>>

Section: 4.3.2

Original Text
-------------
10   IN TYPE260  \# (
       18 ; length
       0a ; precedence=10

Corrected Text
--------------
10   IN TYPE260  \# (
       18 ; length
       0a ; precedence=10

Notes
-----

Instructions:
-------------

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

---

From: Warren Kumari <[email-masked]>
Date: Mon, 13 Jul 2020 17:48:43 -0400

On Fri, Jul 10, 2020 at 6:40 PM Holland, Jake <[email-masked]> wrote:

> I agree, I think these are correct.
>

Thanks -- I had said that I'll wait till the 17th for people to object, so,
well, I'll wait till the 17th..... <twiddles thumbs...>

> Thanks Brian for catching and reporting them.
>

Indeed.
W

>
>
> Best,
>
> Jake
>
>
>
> *From: *Warren Kumari <[email-masked]>
> *Date: *Friday, July 10, 2020 at 10:49 AM
> *Cc: *"Wellington, Brian" <[email-masked]>, MBONED WG <
> [email-masked]>, Jake Holland <[email-masked]>
> *Subject: *Re: [MBONED] [Technical Errata Reported] RFC8777 (6218)
>
>
>
> On Wed, Jul 1, 2020 at 7:09 PM RFC Errata System <
> [email-masked]> wrote:
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.rfc-2Deditor.org_errata_eid6218&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=bqnFROivDo_4iF8Z3R4DyNWKbbMeXr0LOgLnElT1Ook&m=2YiJjA3C74QomL0Bkygr4dYvuzaip8lKTZ3FeelO_Ik&s=SkZMyU-vLmIFP-4WJAirYojmJ-Ohv9BzkuLbD6CBw1w&e=>
>