Subject: [MBONED] [Technical Errata Reported] RFC8777 (6688)

From: RFC Errata System <[email-masked]>
Date: Sun, 19 Sep 2021 10:03:36 -0700 (PDT)

The following errata report has been submitted for RFC8777,
"DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6688

--------------------------------------
Type: Technical
Reported by: Dick Franks <[email-masked]>

Section: 5

Original Text
-------------
   +-------+---------------------------------------+
   | 3     | A wire-encoded domain name is present |
   +-------+---------------------------------------+
   | 4-255 | Unassigned                            |
   +-------+---------------------------------------+

      Table 2: Initial Contents of the "Relay Type
                    Field" Registry

   Values 0, 1, 2, and 3 are further explained in Sections 4.2.3 and
   4.2.4.  Relay type numbers 4 through 255 can be assigned with a
   policy of Specification Required (as described in [RFC8126]).

Corrected Text
--------------
   +-------+---------------------------------------+
   | 3     | A wire-encoded domain name is present |
   +-------+---------------------------------------+
   | 4-127 | Unassigned                            |
   +-------+---------------------------------------+

      Table 2: Initial Contents of the "Relay Type
                    Field" Registry

   Values 0, 1, 2, and 3 are further explained in Sections 4.2.3 and
   4.2.4.  Relay type numbers 4 through 127 can be assigned with a
   policy of Specification Required (as described in [RFC8126]).

Notes
-----
Relay Type is a 7 bit field, the MS bit of the wire-format  octet contains the D-bit.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8777 (draft-ietf-mboned-driad-amt-discovery-13)
--------------------------------------
Title               : DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery
Publication Date    : April 2020
Author(s)           : J. Holland
Category            : PROPOSED STANDARD
Source              : MBONE Deployment
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Warren Kumari <[email-masked]>
Date: Thu, 23 Sep 2021 19:24:24 -0400

Hi all,

I'd appreciate some feedback here - I think that this Errata should be
marked Verified, but I might be missing something.

>From what I can see,
https://datatracker.ietf.org/doc/html/rfc8777#section-4.2 speaketh thusly:
The AMTRELAY RData consists of an 8-bit precedence field, a 1-bit
   "Discovery Optional" field, a 7-bit type field, and a variable length
   relay field."

There are some more discussions around what various type codes mean, but
nothing else about the field size.

The IANA Considerations section then says: "Relay type numbers 4 through
255 can be assigned with a policy of Specification Required"

You can’t put 10 pounds of manure into a five-pound bag, and you can't fit
255 values in a 7 bit field.

I'm planning on marking this verified on Monday the 4th of October[0]
unless someone tells me otherwise.

W
[0]: I'm going to be at a conference for much of next week, and will have a
hard time keeping up with mail.

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra

---

From: "Holland, Jake" <[email-masked]>
Date: Fri, 24 Sep 2021 06:31:29 +0000

Hi Warren,

This looks like a correct errata to me, yes.  Thanks Dick, much appreciated.

Best,
Jake

From: Warren Kumari <[email-masked]>
Date: Thu,2021-09-23 at 4:25 PM
To: RFC Errata System <[email-masked]>
Cc: Dick Franks <[email-masked]>, MBONED WG <[email-masked]>, Jake Holland <[email-masked]>
Subject: Re: [MBONED] [Technical Errata Reported] RFC8777 (6688)

Hi all,

I'd appreciate some feedback here - I think that this Errata should be marked Verified, but I might be missing something.

From what I can see, https://datatracker.ietf.org/doc/html/rfc8777#section-4.2<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc8777*section-4.2__;Iw!!GjvTz_vk!EqoawHI4PIfRXpUTy-SNRNXNbCPsyO7r9uZok_jm241CJ2F9IG04eYTBCSuHPfk$> speaketh thusly:
The AMTRELAY RData consists of an 8-bit precedence field, a 1-bit
   "Discovery Optional" field, a 7-bit type field, and a variable length
   relay field."

There are some more discussions around what various type codes mean, but nothing else about the field size.

The IANA Considerations section then says: "Relay type numbers 4 through 255 can be assigned with a policy of Specification Required"

You can’t put 10 pounds of manure into a five-pound bag, and you can't fit 255 values in a 7 bit field.

I'm planning on marking this verified on Monday the 4th of October[0] unless someone tells me otherwise.

W
[0]: I'm going to be at a conference for much of next week, and will have a hard time keeping up with mail.

On Sun, Sep 19, 2021 at 1:03 PM RFC Errata System <[email-masked]<mailto:[email-masked]>> wrote:
The following errata report has been submitted for RFC8777,
"DNS Reverse IP Automatic Multicast Tunneling (AMT) Discovery".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6688<https://urldefense.com/v3/__https:/www.rfc-editor.org/errata/eid6688__;!!GjvTz_vk!EqoawHI4PIfRXpUTy-SNRNXNbCPsyO7r9uZok_jm241CJ2F9IG04eYTBxsrltKo$>

--------------------------------------
Type: Technical
Reported by: Dick Franks <[email-masked]<mailto:[email-masked]>>

Section: 5

Original Text
-------------

Corrected Text
--------------

Notes
-----

Instructions:
-------------