Subject: [MBONED] FW: [Secdispatch] Requesting agenda time for draft-krose-multicast-security"

From: "Holland, Jake" <[email-masked]>
Date: Fri, 1 Apr 2022 23:40:16 +0000

Hi mboned,

Lenny just pointed out to me that DAZN’s contribution on the secdispatch list last October expressing their interest in standardizing mabr multicast would also be of interest in the mboned wg, so please enjoy their forwarded comments below, and consider their call to action to continue work to standardize things that will help make multicast adaptive bitrate streaming possible.

-Jake

From: Alasdair Kennedy <[email-masked]>
Date: Fri,2021-10-29 at 1:27 AM
To: "[email-masked]" <[email-masked]>
Cc: "Taylor, James" <[email-masked]>, "Holland, Jake" <[email-masked]>
Subject: Re: [Secdispatch] Requesting agenda time for draft-krose-multicast-security"

We have recently rolled out Multicast ABR in conjunction with an ISP.
The results have shown a revolutionary step change for us, both in terms of QoE, specifically rebuffering rate / CIRR, and cost of delivery.
As such Multicast ABR (mABR) is something we are actively pushing forward with, with other ISPs globally.

As users change TV watching habits from traditional TV to OTT Streaming, the volume of video traffic can only go up.
ISPs can either continue to build out to handle peak unicast traffic, which is providing difficult & expensive, or they will embrace mABR, as we are finding from a lot of ISPs globally.

However, we are acutely aware that this is likely to involve multiple vendors with different proprietary standards, creating the usual problems.

So any initiatives to standardise mABR we would like to see move forward.

Regards,

Alasdair Kennedy (he/him)
Head of Video Architecture
[email-masked]<mailto:[email-masked]>
+44 (0)7769 700 910
12 Hammersmith Grove, London, W6 7AP

CONFIDENTIALITY: This email and any files transmitted with it are confidential, may be legally privileged and are intended solely for the use of the individual or entity to whom they are addressed. If this has come to you in error, you must not copy, distribute, disclose or use any of the information it contains. Please notify the sender immediately and delete them from your system. PRIVACY: DAZN Media Services Limited (a member of the DAZN Group, with Companies House registration number 3426471) may monitor email traffic data and also the content of email for the purposes of security and staff training. For information on how the DAZN Group processes your information, please refer to https://media.dazn.com/en/privacy-notice-gdpr/. SECURITY: Please be aware that emails are not secure and may contain viruses. AUTHORITY: Any views or opinions expressed in this email are solely those of the sender and do not necessarily represent those of the DAZN Group. COPYRIGHT: Copyright of this email and any attachments belongs to DAZN Group Limited, Companies House registration number 6324278. Further information about DAZN Group is available at https://media.dazn.com/en/.

---

From: Gyan Mishra <[email-masked]>
Date: Sun, 3 Apr 2022 14:24:34 -0400

Hi Jake

I agree that Multicast ABR standardization is valuable for operators as
customers start shifting to OTT streaming services which we are seeing
already from the pandemic.

Does MBONE have MABR drafts already in progress?

I did a google search on MABR as far a standardization across SDOs and ITU
came up.

https://www.itu.int/md/T17-SG09-C-0197/en

DVB has a presentation on MABR

https://thebroadcastknowledge.com/2020/10/27/video-making-a-case-for-dvb-mabr/

Another link about OTT and MABR

https://www.tvtechnology.com/news/smpte2020-finding-the-middle-ground-for-live-content-over-ott

Thanks

Gyan

On Fri, Apr 1, 2022 at 7:40 PM Holland, Jake <jholland=
[email-masked]> wrote:

> Hi mboned,
>
>
>
> Lenny just pointed out to me that DAZN’s contribution on the secdispatch
> list last October expressing their interest in standardizing mabr multicast
> would also be of interest in the mboned wg, so please enjoy their forwarded
> comments below, and consider their call to action to continue work to
> standardize things that will help make multicast adaptive bitrate streaming
> possible.
>
>
>
> -Jake
>
>
>
> *From: *Alasdair Kennedy <[email-masked]>
> *Date: *Fri,2021-10-29 at 1:27 AM
> *To: *"[email-masked]" <[email-masked]>
> *Cc: *"Taylor, James" <[email-masked]>, "Holland, Jake" <
> [email-masked]>
> *Subject: *Re: [Secdispatch] Requesting agenda time for
> draft-krose-multicast-security"
>
>
>
> The results have shown a revolutionary step change for us, both in terms
> of QoE, specifically rebuffering rate / CIRR, and cost of delivery.
>
> As users change TV watching habits from traditional TV to OTT Streaming,
> the volume of video traffic can only go up.
>
> ISPs can either continue to build out to handle peak unicast traffic,
> which is providing difficult & expensive, or they will embrace mABR, as we
> are finding from a lot of ISPs globally.
>
>
>
> However, we are acutely aware that this is likely to involve multiple
> vendors with different proprietary standards, creating the usual problems.
>
>
>
> *Alasdair Kennedy (he/him)*
>
> [email-masked]
>
> +44 (0)7769 700 910
>
> CONFIDENTIALITY: This email and any files transmitted with it are
> confidential, may be legally privileged and are intended solely for the use
> of the individual or entity to whom they are addressed. If this has come to
> you in error, you must not copy, distribute, disclose or use any of the
> information it contains. Please notify the sender immediately and delete
> them from your system. PRIVACY: DAZN Media Services Limited (a member of
> the DAZN Group, with Companies House registration number 3426471) may
> monitor email traffic data and also the content of email for the purposes
> of security and staff training. For information on how the DAZN Group
> processes your information, please refer to
> https://media.dazn.com/en/privacy-notice-gdpr/. SECURITY: Please be aware
> that emails are not secure and may contain viruses. AUTHORITY: Any views or
> opinions expressed in this email are solely those of the sender and do not
> necessarily represent those of the DAZN Group. COPYRIGHT: Copyright of this
> email and any attachments belongs to DAZN Group Limited, Companies House
> registration number 6324278. Further information about DAZN Group is
> available at https://media.dazn.com/en/.
> _______________________________________________
> MBONED mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mboned
>
-- 

<http://www.verizon.com/>

*Gyan Mishra*

*Network Solutions A**rchitect *

*Email [email-masked] <[email-masked]>*

*M 301 502-1347*

---

From: "Holland, Jake" <[email-masked]>
Date: Wed, 6 Apr 2022 00:49:09 +0000

Hi Gyan,

From: Gyan Mishra <[email-masked]>
> Date: Sun,2022-04-03 at 11:25 AM
> Hi Jake 
>
> I agree that Multicast ABR standardization is valuable for operators as customers start shifting to OTT streaming services which we are seeing already from the pandemic.
>

I don't think so.  The active doc list is in the datatracker:
https://datatracker.ietf.org/wg/mboned/documents/

Although I would love to see more forward progress specifically on
MABR, I think work on MABR-specific protocols would probably be out
of scope for mboned.  The main reasons I wanted to point the note
out to MBONED were:

1. it might wind up leading to a report about deployment status of
   multicast, which is one of the things mentioned in the mboned charter
2. the reported improvements that were observed in practice by enabling
   the use of multicast are also especially noteworthy

Anyway, if MABR work happens at IETF, I'd expect that to fall under
the ART area (and possibly somewhere in TSV if it's trying to use a
new transport protocol), with hopefully some updates given to MBONED
especially about deployment status.

But I wouldn't expect to see such work adopted here, and I didn't intend
to suggest we do so (though I would be interested to know if there's any
work I'm not aware of yet, and I think some kind of list to track that
might perhaps be in scope here as well as mops?)  Anyway, sorry if that
caused any confusion.

> I did a google search on MABR as far a standardization across SDOs and ITU came up.

I would add at least a few more items to your list, namely a few of
CableLabs' technical reports, as well as the MABR spec developed at
DVB and the ROUTE/DASH work for ATSC 3.0:

- IP Multicast Adaptive Bit Rate Architecture Technical Report
(CableLabs OC-TR-IP-MULTI-ARCH-V01-141112)
https://community.cablelabs.com/wiki/plugins/servlet/cablelabs/alfresco/download?id=51b3c11a-3ba4-40ab-b234-42700e0d4669

- IP Multicast Controller-Server Interface Specification
(CableLabs OC-TR-IP-MULTI-ARCH-C01-161026)
https://community.cablelabs.com/wiki/plugins/servlet/cablelabs/alfresco/download?id=7102f5ad-f08e-42dc-8603-b4c2477e334e

- IP Multicast Controller-Client Interface Specification
(CableLabs OC-SP-MC-EMCI-I02-160923)
https://community.cablelabs.com/wiki/plugins/servlet/cablelabs/alfresco/download?id=77eb9e28-c7ed-491a-98ba-f20507eb223e

- Digital Video Broadcasting (DVB);
Adaptive media streaming over IP multicast
(ETSI TS 103 769 V1.1.1 (2020-11))
https://www.etsi.org/deliver/etsi_ts/103700_103799/103769/01.01.01_60/ts_103769v010101p.pdf

- Signaling, Delivery, Synchronization, and Error Protection
(ATSC A/331:2022-03)
https://muygs2x2vhb2pjk6g160f1s8-wpengine.netdna-ssl.com/wp-content/uploads/2022/04/A331-2022-03-Signaling-Delivery-Sync-FEC.pdf
(Defines use of "Real-time Object delivery over Unidirectional Transport" for digital TV)

HTH.

-Jake

---

From: Gyan Mishra <[email-masked]>
Date: Wed, 6 Apr 2022 00:01:33 -0400

Thanks Jake for the clarification and additional MABR links.

Kind Regards

Gyan

*Gyan Mishra*

*M 301 502-1347*