Subject: [mdnsext] mDNSext features/requirements rollup

From: RJ Atkinson <[email-masked]>
Date: Mon, 28 Jan 2013 11:39:48 -0500

Earlier, Alf Watt wrote:
> - multicast on wireless links is expensive, 
>   move as much traffic as possible to unicast 

This reportedly is true for IEEE 802.11 links
as of today.  Reports also indicate that some
folks active in IEEE 802.11 are looking into this issue, 
with a goal being to eliminate this issue in
future revisions of IEEE 802.11.

However, the quote at top is (emphatically) NOT TRUE 
for a wide range of other wireless links.  For MANY
wireless link types, multicast is MUCH more
efficient and cheaper than unicast.

While it is sensible to note this limitation of
IEEE 802.11 wireless link technology, it is 
NOT sensible to impair the applicability of mDNS
to the wide range of other links (wired or wireless)
where multicast is cheap and efficient.

Yours,

Ran

---

From: David Farmer <[email-masked]>
Date: Mon, 28 Jan 2013 18:23:37 -0600

> efficient and cheaper than unicast.

I agree that we should not assume multicast or unicast is more or less 
efficient, that should be left up to the network operator.  We need to 
provide a tool that work with either multicast or unicast allowing a 
network operator to control that where appropriate.  Multicast as an 
assumption for an unmanaged network, is fine, but allowing this to be 
managed or controlled by the network operator in the case of a managed 
network is what some of us are looking for.  This could be with a DHCP 
option or many other possible solutions.

Besides 802.11, another example where multicast could be problematic; 
there are metro Ethernet providers that disable multicast or rate limit 
multicast packets, when an Enterprise network operator uses these 
services, this is just something you have to deal with.

> where multicast is cheap and efficient.

Yes, when appropriate, available, and efficient multicast is great, its 
just not universally available, efficient, or always appropriate.

As in most things one-size-fits-all is a myth, multicast is not 
universally good or bad, some of us just want/need other options.

-- 
================================================
David Farmer               Email: [email-masked]
Office of Information Technology
University of Minnesota
2218 University Ave SE     Phone: 1-612-626-0815
Minneapolis, MN 55414-3029  Cell: 1-612-812-9952
================================================

---

From: RJ Atkinson <[email-masked]>
Date: Tue, 29 Jan 2013 06:10:33 -0500

On 28  Jan 2013, at 19:23 , David Farmer wrote:
> I agree that we should not assume multicast or unicast
> is more or less efficient, that should be left up to the
> network operator.  
> 
> We need to provide a tool that work with either multicast or
> unicast allowing a network operator to control that where
> appropriate.  Multicast as an assumption for an unmanaged
> network, is fine, but allowing this to be managed or
> controlled by the network operator in the case of a managed
> network is what some of us are looking for.  

The above sounds about right to me.  

Thanks,

Ran Atkinson