Subject: [mdnsext] mdnsproxy and hybrid proxy loop detection

From: Alf Watt <[email-masked]>
Date: Fri, 1 Feb 2013 17:34:26 +0000

My initial though is that loop detection is most important for multicast to multicast proxy scenarios, which is the current state of the art in bonjour bridges. Can anyone think of a case where the proposed hybrid proxy can get into a loop?

One solution I've been considering is to have the proxy advertise itself as a service, _mdnsproxy._udp. for e.g., if they include some basic configuration information in the txt record then a second proxy can detect the presence of another proxy with similar configuration and disable any conflicting proxy directives until such time as the first proxy removes itself from the subnet.

Best,
Alf

On Jan 29, 2013, at 12:00 PM, [email-masked]<mailto:[email-masked]> wrote:

From: David Farmer <[email-masked]<mailto:[email-masked]>>
Subject: Re: [mdnsext] mDNSext features/requirements rollup
Date: January 29, 2013 10:59:51 AM PST
To: "Stephen Orr (sorr)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dan Harkins <[email-masked]<mailto:[email-masked]>>

As a first step I'm ok with this, in fact I'm already doing it, but I view this as mostly a work around or hack.

1. What happens if you get a proxy loop?  This seems really bad! Right now I have nothing to prevent this.

2. Maybe loop detection can be defined as part o a proxies behavior.

---

From: David Farmer <[email-masked]>
Date: Mon, 4 Feb 2013 12:16:37 -0600

> My initial though is that loop detection is most important for multicast to multicast proxy scenarios, which is the current state of the art in bonjour bridges. Can anyone think of a case where the…

Not a forwarding loop, but maybe a registration loop, or a registration race condition.  If two hybrid proxies were registering to the same DNS zone and connected to the same link network they would need some kind of coordination to prevent them both registering the same services. Or to detect that the second place gateway is attempting to reregister the same service and not return a registration conflict back to the device on the link.

So, while they are probably different kinds of loops and they may need different solutions, maybe we can find a common solution or at least parts in common to separate solutions.

> One solution I've been considering is to have the proxy advertise itself as a service, _mdnsproxy._udp. for e.g., if they include some basic configuration information in the txt record then a secon…

This seems like a logical approach.  They could advertise the link networks they connect to and for a hybrid proxy the DNS zone they connect to as part of the txt records.  We would need a link network identifier that the proxies can agree on, this may be difficult in the presence of dual stack, partitioning and joining of link networks.

> Best,
> Alf
> 
> On Jan 29, 2013, at 12:00 PM, [email-masked] wrote:
> 
>> From: David Farmer <[email-masked]>
>> To: "Stephen Orr (sorr)" <[email-masked]>
>> Cc: "[email-masked]" <[email-masked]>, Dan Harkins <[email-masked]>
>> 
>>