Subject: Re: [media-types] Review request for application/geo+json media type registration

From: Sean Gillies <[email-masked]>
Date: Tue, 2 Feb 2016 22:04:44 -0700

Mark,

On Thu, Jan 14, 2016 at 10:04 AM, Erik Wilde <[email-masked]> wrote:

> hello mark.
>
> thanks for the feedback.
>
> On 2016-01-14 06:39, Mark Baker wrote:
>
>> I think the WG has also made enough changes
>>> to the format (deprecation of coordinate reference systems and coordinate
>>> position items beyond x, y, and z, for examples) to warrant a new media
>>> type.
>>>
>> Well that could certainly change the balance in favour of a new type.
>> Could you elaborate on the compatibility between the old and new
>> formats?
>>
>
> that sounds like a good idea, and
> https://github.com/geojson/draft-geojson/issues/125 is proposing to add a
> section explaining the changes (and that might be useful to have regardless
> of whether there's a new media type or not). so we'll get back to you
> shortly with a first stab of the difference between the media types.
>
> cheers,
>
> dret.
>

I'm looking for clarification on the process of deprecating
application/vnd.geo+json (as Mike Amundsen suggested). My understanding of
http://tools.ietf.org/html/rfc6838#section-5.5 is that I should fill out
the http://www.iana.org/form/media-types form again, selecting Intended
Usage: Obsolete and noting the new recommended media type for GeoJSON in
the usage notes field, correct?

Would it be desirable for draft-ietf-geojson to mention in its IANA
Considerations that the (proposed) application/geo+json media type is to
replace application/vnd.geo+json?

Thanks for the comments above, we've incorporated them into the GeoJSON
draft.

-- 
Sean Gillies

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Wed, 3 Feb 2016 13:25:42 +0000

Sean,

I like the idea of documenting the differences from application/vnd.geo+json and using an IANA note saying that application/vnd.geo+json should be considered obsolete.

This should be sufficient to make the change occur in the applicatino/vnd.geo+json. Words along these lines should be fine:

IANA Considerations

The registration entry for applciation/vnd.geo+json in <http://www.iana.org/assignments/media-types/> should have its status changed to be Obsolete with a pointer to the media type application/geo+json and a reference added to this RFC.

IANA would then change the entry there to say
application/vnd.geo+json – OBSOLETED in favor of application/geo+json

If IANA wants the wording of this changed, they’ll let you know when they review your document prior to publication as an RFC.

As the change owner of record for application/vnd.geo+json, you certainly may also fill in the form at <http://www.iana.org/form/media-types> and provide the updated status as you suggested, but it shouldn’t be necessary. (Note that if you had NOT been writing an RFC about the replacement media type, then using the online form would definitely have been the proper course of action.)

Tony Hansen

From: media-types <[email-masked]<mailto:[email-masked]>> on behalf of Sean Gillies <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, February 3, 2016 at 12:04 AM
To: Mark Baker <[email-masked]<mailto:[email-masked]>>
Cc: Michael Amundsen <[email-masked]<mailto:[email-masked]>>, Martin Thomson <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Erik Wilde <[email-masked]<mailto:[email-masked]>>
Subject: Re: [media-types] Review request for application/geo+json media type registration

Mark,

On Thu, Jan 14, 2016 at 10:04 AM, Erik Wilde <[email-masked]<mailto:[email-masked]>> wrote:
hello mark.

thanks for the feedback.

that sounds like a good idea, and https://github.com/geojson/draft-geojson/issues/125 is proposing to add a section explaining the changes (and that might be useful to have regardless of whether there's a new media type or not). so we'll get back to you shortly with a first stab of the difference between the media types.

cheers,

dret.

I'm looking for clarification on the process of deprecating application/vnd.geo+json (as Mike Amundsen suggested). My understanding of http://tools.ietf.org/html/rfc6838#section-5.5 is that I should fill out the http://www.iana.org/form/media-types form again, selecting Intended Usage: Obsolete and noting the new recommended media type for GeoJSON in the usage notes field, correct?

Would it be desirable for draft-ietf-geojson to mention in its IANA Considerations that the (proposed) application/geo+json media type is to replace application/vnd.geo+json?

Thanks for the comments above, we've incorporated them into the GeoJSON draft.

--
Sean Gillies

---

From: "Martin J. Dürst" <[email-masked]>
Date: Wed, 3 Feb 2016 15:41:44 +0900

Hello Sean,

Just put want you want IANA to do into the "IANA Considerations" 
section. IANA checks all RFCs-to-be to make sure they do what's needed, 
and will come back to us if it's not clear enough.

As far as I know, there's no need to send requests separately to IANA. 
This also has the advantage that all the changes are executed in sync.

Regards,   Martin.

On 2016/02/03 14:04, Sean Gillies wrote:
> _______________________________________________
> media-types mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types
>