Subject: [media-types] Macintosh file type codes

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 27 Mar 2019 16:03:14 +0100

RFC6838 refers to http://www.info.apple.com/kbnum/n55381 for discussion of
Mac file type codes, but that URL no longer works.  Does anyone know of a
more current reference?

-MSK

---

From: Guy Harris <[email-masked]>
Date: Wed, 27 Mar 2019 10:03:06 -0700

On Mar 27, 2019, at 8:03 AM, Murray S. Kucherawy <[email-masked]> wrote:

> RFC6838 refers to http://www.info.apple.com/kbnum/n55381 for discussion of Mac file type codes, but that URL no longer works.  Does anyone know of a more current reference?

A Web search of apple.com didn't find anything about type and creator codes other than discussions on support forums and mailing lists.

The Wayback Machine's most recent version of that page is at

	https://web.archive.org/web/20080329133645/http://docs.info.apple.com/article.html?artnum=55381

This may be Apple's way of telling the universe that type and creator codes aren't particularly relevant any more; I think somebody's asked on this list, in the past, whether we should still bother with them - Apple uses Uniform Type Identifiers, these days:

	https://developer.apple.com/library/archive/qa/qa1796/_index.html

(yes, they say that's no longer being updated - Apple's documentation on anything other than "how to write shiny new apps" seems to be neglected these days).