Subject: Re: [media-types] Media subtypes containing "+"

From: Manu Sporny <[email-masked]>
Date: Wed, 26 May 2021 13:07:41 -0400

Francesca and Murray, there is a question directed toward each of you in your
capacities as IETF Area Directors for ART from the W3C DID Working Group:

On 2/4/21 8:03 PM, Mark Nottingham wrote:
>> So I truly believe this is a zero-cost convention for those who don’t 
>> care about it.
> 
> And I strongly suspect that as soon as this is allowed, people are going to
> start to build a processing model around the suffixes, and make other 
> assumptions that extend media types in ways that aren't a good idea.
> 
> Anyway, the question was asked and I've said my piece.

Bumping this thread up because the W3C Decentralized Identifiers WG is
finishing up it's Candidate Recommendation phase in the next few weeks and we
still don't have an answer for what Media Type we're allowed to register for
DID Documents expressed in JSON-LD.

Background here:

https://mailarchive.ietf.org/arch/msg/media-types/L0YVPU1zUIlECS8_4ScB5H62GNI/

The W3C DID WG, after consideration of the past year or so of discussion on
the topic in [email-masked] and in the DID WG, would like to register:

application/did+ld+json

Referenced here:

https://www.w3.org/TR/did-core/#application-did-ld-json

The W3C DID WG believes that it has done everything that was requested of it
including 1) create a specification on how to process media types with
multiple suffixes and seek feedback, 2) have a discussion that has now
occurred with no strong objections for the general strategy (trepidations were
registered), and 3) wait for the discussion to settle before moving forward.

We formally request that:

1. The registration of application/did+ld+json is allowed
   to proceed.

2. The "Media Types with Multiple Suffixes" document is
   progressed along the IETF standards track. We have no
   strong opinion on the IETF mechanism used to do so.

Can the Area Directors please weigh in on this item as we are going to be
blocked from proceeding to W3C Proposed Recommendation very soon due to this
long-standing issue.

-- manu

-- 
Manu Sporny - https://www.linkedin.com/in/manusporny/
Founder/CEO - Digital Bazaar, Inc.
blog: Veres One Decentralized Identifier Blockchain Launches
https://tinyurl.com/veres-one-launches

---

From: Phil Archer <[email-masked]>
Date: Wed, 26 May 2021 21:01:38 +0000

Hi all,

I did raise this issue a while back in the HTTP API WG in the context of the Linkset I-D (just before it was adopted by that WG). See https://github.com/dret/I-D/issues/151#event-4257544820. I cited Amy's work in this area.

Sadly from my POV the proposal for a "two +" media type was quickly turned down. I was told that's what the profile header is for.

Phil

Phil Archer
Director, Web Solutions, GS1
https://www.gs1.org

Meet GS1 Digital Link Developers at
https://groups.google.com/forum/#!forum/gs1-digital-link-developers

https://philarcher.org
+44 (0)7887 767755
@philarcher1
Skype: philarcher

On 26 May 2021 18:08, Manu Sporny wrote:
Francesca and Murray, there is a question directed toward each of you in your capacities as IETF Area Directors for ART from the W3C DID Working Group:

On 2/4/21 8:03 PM, Mark Nottingham wrote:
> And I strongly suspect that as soon as this is allowed, people are
> going to start to build a processing model around the suffixes, and
> make other assumptions that extend media types in ways that aren't a good idea.
>

Bumping this thread up because the W3C Decentralized Identifiers WG is finishing up it's Candidate Recommendation phase in the next few weeks and we still don't have an answer for what Media Type we're allowed to register for DID Documents expressed in JSON-LD.

Background here:

The W3C DID WG, after consideration of the past year or so of discussion on the topic in [email-masked] and in the DID WG, would like to register:

application/did+ld+json

Referenced here:

The W3C DID WG believes that it has done everything that was requested of it including 1) create a specification on how to process media types with multiple suffixes and seek feedback, 2) have a discussion that has now occurred with no strong objections for the general strategy (trepidations were registered), and 3) wait for the discussion to settle before moving forward.

Can the Area Directors please weigh in on this item as we are going to be blocked from proceeding to W3C Proposed Recommendation very soon due to this long-standing issue.

-- manu

--
Manu Sporny - https://www.linkedin.com/in/manusporny/
Founder/CEO - Digital Bazaar, Inc.
blog: Veres One Decentralized Identifier Blockchain Launches https://tinyurl.com/veres-one-launches

CONFIDENTIALITY / DISCLAIMER: The contents of this e-mail are  confidential and are not to be regarded as a contractual offer or acceptance from GS1 (registered in Belgium). 
If you are not the addressee, or if this has been copied or sent to you in error, you must not use data herein for any purpose, you must delete it, and should inform the sender. 
GS1 disclaims liability for accuracy or completeness, and opinions expressed are those of the author alone. 
GS1 may monitor communications. 
Third party rights acknowledged. 
(c) 2020.