Subject: [media-types] I-D Action: draft-ietf-mediaman-suffixes-01.txt

From: [email-masked]
Date: Mon, 21 Feb 2022 07:04:39 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Media Type Maintenance WG of the IETF.

        Title           : Media Types with Multiple Suffixes
        Authors         : Manu Sporny
                          Amy Guy
	Filename        : draft-ietf-mediaman-suffixes-01.txt
	Pages           : 5
	Date            : 2022-02-21

Abstract:
   This document updates RFC 6838 "Media Type Specifications and
   Registration Procedures" to describe how to interpret subtypes with
   multiple suffixes.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mediaman-suffixes/

There is also an htmlized version available at:
https://datatracker.ietf.org/doc/html/draft-ietf-mediaman-suffixes-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mediaman-suffixes-01

Internet-Drafts are also available by rsync at rsync.ietf.org::internet-drafts

---

From: Manu Sporny <[email-masked]>
Date: Mon, 21 Feb 2022 10:15:39 -0500

> This draft is a work item of the Media Type Maintenance WG of the IETF.

https://www.ietf.org/archive/id/draft-ietf-mediaman-suffixes-01.html

I went ahead and updated the draft since the old mental model was wrong. The
new draft:

* Attempts to establish a new mental model that addresses
  the issue that MSK raised. I'm not happy with the
  prose, it feels Rube Goldbergian, but wanted to get
  some approximation of the new mental model out there for
  review and refinement.

* Attempts to align with the way image/svg+xml+gzip
  is expected to work.

* Recognizes the existence of, and leverages, the
  Structured Syntax Suffixes Registry[1], which I had no
  idea existed.

* Adds a Security Considerations section with Harald's
  concern (albeit, at the wrong level in the table of
  contents, I'll fix that in the next revision).

Feedback and thoughts on the new sections are welcome:

https://www.ietf.org/archive/id/draft-ietf-mediaman-suffixes-01.html#name-processing-multiple-suffixe

https://www.ietf.org/archive/id/draft-ietf-mediaman-suffixes-01.html#name-media-type-fibbing

-- manu

[1]https://www.iana.org/assignments/media-type-structured-suffix/media-type-structured-suffix.xhtml

-- 
Manu Sporny - https://www.linkedin.com/in/manusporny/
Founder/CEO - Digital Bazaar, Inc.
News: Digital Bazaar Announces New Case Studies (2021)
https://www.digitalbazaar.com/