Subject: Re: [media-types] WG: Still need an editor....

From: Yeshwant Muthusamy <[email-masked]>
Date: Mon, 14 Feb 2022 23:40:28 +0000

Folks,

Since Harald's last message calling for volunteer editors for the "process for creating a new top level type", the silence has been quite deafening. Is it a lack of interest or bandwidth or both?

A review of the mediaman charter (https://datatracker.ietf.org/wg/mediaman/about/) reveals a dependency relationship between the first two items on the charter, but it is not to the point where Item #2 is killed off if no progress is made on Item #1 (at least that's the way I understand it from the wording):

  1.  Determine whether any specific criteria or guidance are warranted to handle registration of future top-level media types, and publish any such guidance.
  2.  Develop and process the pending 'haptics' top-level media type request, based on draft-muthusamy-dispatch-haptics, and the outcome of the previous work item.

Are members OK with proceeding with Item #2 and punting on Item #1 until a later point in time? After all, 'font' went through the process just fine (and was approved as an RFC) without Item #1.

Since I have a vested interest in moving Item #2 forward, I am more than happy to serve as editor for Item #1, with the proviso that IETF members more well-versed in top-level media type registrations are willing to contribute to the draft and help me along.

Any takers?

Thanks,

Yeshwant

Yeshwant Muthusamy, Ph.D. | Vice President, Standards

[email-masked] | +1 469-583-2171

www.immersion.com

330 Townsend St, Suite 234

San Francisco, California 94107

-----Original Message-----
From: media-types <[email-masked]> On Behalf Of Harald Alvestrand
Sent: Wednesday, December 1, 2021 4:32 PM
To: [email-masked]
Subject: [media-types] WG: Still need an editor....

At the moment, the -haptics draft has been republished as draft-ietf-mediaman-haptics-00.

We're still waiting for the -suffixes draft to be republished under the new name.

But more importantly, we're still hoping for someone to volunteer as editor for the "process for creating a new top level type".

Any takers?

Harald

_______________________________________________

media-types mailing list

[email-masked]<mailto:[email-masked]>

https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmedia-types&amp;data=04%7C01%7C%7Cdc2ce5bafdc74ed10ef408d9b51a6443%7C4f05e41a59b8413aae19d5df3dfd0fb5%7C0%7C1%7C637739947249316953%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=G5Q1md6jXDrUiiPM%2Fpgt4AiqX2UdGzlMajQAv0736gU%3D&amp;reserved=0

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 15 Feb 2022 09:21:09 +0900

[see below]

> Are members OK with proceeding with Item #2 and punting on Item #1 until a later point in time? After all, 'font' went through the process just fine (and was approved as an RFC) without Item #1.

I for one would be happy with this. I think the main guidance I have so 
far distilled from the haptics draft is "don't go out and assume new top 
level types will be approved just because you start using them". But 
sadly, writing that up probably won't help.

Other than that, I agree that registrations for top-level types are so 
sparse (and should continue to be sparse) and each one comes with its 
own considerations that it's difficult to write up something that's 
general enough to hold up for the next instance (if an when that would 
happen).

Regards,   Martin.

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 15 Feb 2022 10:17:35 +0100

Martin, I would be happy with having a draft that says what you say 
below ("New top level types are rare enough and different enough that 
each application needs to be evaluated separately").

The draft probably needs to say that the document specifying the new top 
level type has to be a standards-track RFC approved by the IESG, I think 
that's no change from previous practice.

If there are other considerations that we agree upon after discussion, 
we can add them. But a draft shouldn't need to be much more than one 
page of real content (+ the usual 4 pages of boilerplate).

Would you be willing to author such a draft?

Harald

On 2/15/22 01:21, Martin J. Dürst wrote:
>> Since Harald's last message calling for volunteer editors for the 
>> "process for creating a new top level type", the silence has been 
>> quite deafening. Is it a lack of interest or bandwidth or both?
>>
>>
>>
>> A review of the mediaman charter 
>> (https://datatracker.ietf.org/wg/mediaman/about/) reveals a 
>> dependency relationship between the first two items on the charter, 
>> but it is not to the point where Item #2 is killed off if no progress 
>> is made on Item #1 (at least that's the way I understand it from the 
>> wording):
>>
>>    1.  Determine whether any specific criteria or guidance are 
>> warranted to handle registration of future top-level media types, and 
>> publish any such guidance.
>>    2.  Develop and process the pending 'haptics' top-level media type 
>> request, based on draft-muthusamy-dispatch-haptics, and the outcome 
>> of the previous work item.
>>
>>
>>
>> Are members OK with proceeding with Item #2 and punting on Item #1 
>> until a later point in time? After all, 'font' went through the 
>> process just fine (and was approved as an RFC) without Item #1.
>
> I for one would be happy with this. I think the main guidance I have 
> so far distilled from the haptics draft is "don't go out and assume 
> new top level types will be approved just because you start using 
> them". But sadly, writing that up probably won't help.
>
>> Since I have a vested interest in moving Item #2 forward, I am more 
>> than happy to serve as editor for Item #1, with the proviso that IETF 
>> members more well-versed in top-level media type registrations are 
>> willing to contribute to the draft and help me along.
>>
>>
>>
>> Any takers?
>>
>>
>>
>> Thanks,
>>
>> Yeshwant
>>
>>
>>
>> But more importantly, we're still hoping for someone to volunteer as 
>> editor for the "process for creating a new top level type".
>>
>>
>>
>> Any takers?
>>
>>
>>
>> Harald
>>

---

From: Martin J. Dürst <[email-masked]>
Date: Tue, 15 Feb 2022 18:51:33 +0900

Hello Harald, others,

> Would you be willing to author such a draft?

If the draft is really going to be that short, I guess I'd be willing. 
I'll give it a try at the start of March, please ping me if you don't 
see anything from me by that time.

Regards,   Martin.

P.S.: Everybody, please be aware that Harald is very good a twisting 
arms :-).

---

From: Alexey Melnikov <[email-masked]>
Date: Tue, 15 Feb 2022 12:29:45 +0000

Hi Yeshwant,

On 14/02/2022 23:40, Yeshwant Muthusamy wrote:
> (https://datatracker.ietf.org/wg/mediaman/about/) reveals a dependency 
> relationship between the first two items on the charter, but it is not 
> to the point where Item #2 is killed off if no progress is made on 
> Item #1 (at least that’s the way I understand it from the wording):
>
>  1. Determine whether any specific criteria or guidance are warranted
>     to handle registration of future top-level media types, and
>  2. Develop and process the pending ‘haptics’ top-level media type
>     request, based on draft-muthusamy-dispatch-haptics, and the
>     outcome of the previous work item.
>
> until a later point in time?
>
Yes, this would be fine with me.
>
> After all, ‘font’ went through the process just fine (and was approved 
> as an RFC) without Item #1.
>
"font" was done in another WG, so the comparison is not quite exact.
> [email-masked] <mailto:[email-masked]>
>
> <https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmedia-types&amp;data=04%7C01%7C%7Cdc2ce5bafdc74ed10ef408d9b51a6443%7C4f05e41a59b8413aae19d5df3dfd0fb5%7C0%7C1%7C637739947249316953%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&amp;sdata=G5Q1md6jXDrUiiPM%2Fpgt4AiqX2UdGzlMajQAv0736gU%3D&amp;reserved=0>
>
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/media-types

---

From: Martin J. Dürst <[email-masked]>
Date: Thu, 24 Feb 2022 11:19:48 +0900

Hello Harald, others,

[This mail is in response to a private nudge by Harald.]

> Would you be willing to author such a draft?

I have started working on such a draft, mostly on getting up to speed 
with the newest version of xml2rfc and related tooling.

When I started looking for status, update relationships, and references 
that I might have to include, I found 
https://datatracker.ietf.org/doc/html/rfc6838#section-4.2.7, which says:

4.2.7.  Additional Top-Level Types

    In some cases, a new media type may not "fit" under any currently
    defined top-level type names.  Such cases are expected to be quite
    rare.  However, if such a case does arise, a new type name can be
    defined to accommodate it.  Definition of a new top-level type name
    MUST be done via a Standards Track RFC; no other mechanism can be
    used to define additional type names.

If you compare this text with what Harald and I wrote above and below, 
there's really not much (if indeed anything) that isn't already said.

So before I continue working on this draft (which I can do this 
weekend), I really want to make sure that we need such a draft.

Regards,   Martin.

> .

-- 
Prof. Dr.sc. Martin J. Dürst
Department of Intelligent Information Technology
College of Science and Engineering
Aoyama Gakuin University
Fuchinobe 5-1-10, Chuo-ku, Sagamihara
252-5258 Japan

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 24 Feb 2022 12:24:35 +0100

We were asked to create one, i think the new text is "no objective criteria have been identified". I would also add that "machines do not care, so it only matters to humans who argue aesthetics". 

Every time we argue a new one, we seem to spend lots of time trying to find other things that matter and fail, so it would be nice to write down that we have stopped looking.

-- 
Sent from my Android device with K-9 Mail. Please excuse my brevity.