Subject: Re: [MEDIACTRL] QOS control: what is in scope?

From: Sukanta ganguly <[email-masked]>
Date: Tue, 31 Jul 2007 06:42:48 -0700 (PDT)

Martin,
   I am confused. QoS needs to be dependent on the AS consumption. Applications need to determine the QoS but at the same time Network needs to comply with the needs of the application. So dependencies will always exist. So I don't understand how it can be out of scope. It may need seperate set of documents and a different working group, but dependencies will exist.

SG

----- Original Message ----
From: "DOLLY, MARTIN C, ATTLABS" <[email-masked]>
To: RahulSrivastava 71616 <[email-masked]>; Tom Taylor <[email-masked]>
Cc: [email-masked]
Sent: Monday, July 30, 2007 9:33:36 AM
Subject: RE: [MEDIACTRL] QOS control: what is in scope?

NO

QoS is out of scope for this WG. In any network deployment you address
QoS as a separate topic. You invoke QoS long before you hit the AS.

Cheers,

Martin 

-----Original Message-----
From: RahulSrivastava 71616 [mailto:[email-masked]] 
Sent: Monday, July 30, 2007 12:06 PM
To: Tom Taylor
Cc: [email-masked]
Subject: Re: [MEDIACTRL] QOS control: what is in scope?

Qos should be in domain of Application.
If AS wants to have the capbility for QOS it can very well parse the SDP
and send that to media server.
All this depends on Application.
If application is just meant for few features why to overload it with
heavy SDP parsing.(Basic voice call)
On the other hand if features are required let the application do it.
It looks like it should be in Aapplcation design specification.

Can you suggest one use case where the QOS for a UE is different from a
QOS of media server? I don't know Diameter at all :)
If its really required we can discuss this but as for now I don't see
any use of it.

Rahul 

************************************************************************
******************
This email and its attachments contain confidential information from
HUAWEI, which is intended only for the person or entity whose address is
listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure,
reproduction, or dissemination) by persons other than the intended
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by phone or email immediately and delete it!

************************************************************************
*****************

----- Original Message -----
From: Tom Taylor <[email-masked]>
Date: Friday, July 27, 2007 11:59 pm
Subject: [MEDIACTRL] QOS control: what is in scope?

> The question arises, whether QOS control is at all in scope, and 
> what components 
> of the architecture it would affect.
> 
> This question arises out of one I posed to the meeting. The 
> architecture defined 
> by the MultiService Forum (MSF, http://www.msforum.org) is 
> primarily IMS-based, 
> has a strong resemblance to the MediaCtrl framework architecture 
> in the relevant 
> parts, but has an open issue regarding which component was 
> responsible for 
> reserving QOS resources for media streams originating at the Media 
> Server. We 
> are talking concretely about a Diameter interface to a Bandwidth 
> Manager.
> It is clear from list discussion about AS understanding of SDP 
> that it would not 
> be a popular suggestion that the AS have this responsibility. On 
> the other hand, 
> Media Server vendors plead that their boxes have no service 
> understanding, and 
> should not be the responsible components either.
> 
> It was clear from meeting discussion that if there is per-session 
> QoS control at 
> all, it should be done close to the UA rather than at any of the 
> AS, MS, or MRB.
> 
> There are a couple of points that came out in discussion, however, 
> that the list 
> should consider. One is that the framework (section 7.1) allocates 
> responsibility for assembling media resources to the Media Server. 
> This may need 
> clarification. The other point is that at a protocol level the MS 
> may have to 
> understand something like SIP preconditions, which may be used to 
> coordinate the 
> setting up of QoS. At the very least, the Media Server has to be 
> prepared to be 
> responsive to offers that initially make a stream inactive, 
> changing it to 
> active in a re-INVITE when QoS resources have been arranged.
> 
> Comments on how if at all this affects the framework or other 
> documents?
> Tom Taylor
> 
> 
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
> 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

____________________________________________________________________________________
Building a website is a piece of cake. Yahoo! Small Business gives you all the tools to get online.
http://smallbusiness.yahoo.com/webhosting 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Chris Boulton" <[email-masked]>
Date: Tue, 31 Jul 2007 15:42:23 +0100

Martin,

   I am confused. QoS needs to be dependent on the AS consumption.
Applications need to determine the QoS but at the same time Network
needs to comply with the needs of the application. So dependencies will
always exist. So I don't understand how it can be out of scope. It may
need seperate set of documents and a different working group, but
dependencies will exist.

[Chris Boulton] I did mention this in the meeting and I don't think we
can have any meaningful discussions or make bold statement on a topic
like this until we define what is meant by QOS in this context.

Information contained in this e-mail and any attachments are intended for the use of the addressee only, and may contain confidential information of Ubiquity Software Corporation. All unauthorized use, disclosure or distribution is strictly prohibited.  If you are not the addressee, please notify the sender immediately and destroy all copies of this email. Ubiquity Software Corporation plc, a company registered under the laws of England and Wales, Registration 2719723, registered offices at Eastern Business Park, Building 3, Wern Fawr Lane, St. Mellons, Cardiff CF3 5EA, Wales, United Kingdom.