Subject: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-framework-00.txt

From: RahulSrivastava 71616 <[email-masked]>
Date: Wed, 04 Jul 2007 23:20:33 +0800

I have reviewed only first few portions of the drafts. I have some basic questions on that.
I'll review further and give my comments soon. 
I am putting this on list so that we can start discussing these points.
>From first half I can say its a good start but lot needs to be done still.

1. "AS is able to discover capabilities." That means are we going towards a direction of dynamic
exchange of packages and their versions? 

2. The control channel of one media connection should be for each media connection or it can carry information of multiple media connection?

3.    "commands from an AS to an MS to request the application or
      configuration of a function.  The request may apply to a single
      media stream, multiple media streams associated with multiple SIP
      dialogs, or to properties of a conference mix"

      Does it mean than an AS using a control channel of one media session can modify some charecterstics of control sessions of some other media sessions?

4. "Dedicated control channels provide reliable peer to peer transport for media server control interactions."

This statement looks like we are going for a TCP connection. From network perspective both control channel and media
session has equal probability of going down.
So from what perspective its reliable than some other SIP Connection?(Assuming its not TCP)

5. Even inside MS control channel (if used with SIP as defined by draft) what messages will be used by AS to send messages to MS. Draft can give some 
direction to discussion I believe. In fact this issue must be decided ASAP 
Something of the likes of PUBLISH,MESSAGE etc.

6. How the MS can synchronize the events between MS control channel and control dialog? E.g a reInvite is rcvd with changed media characterstics based on that it might need to send some notifcation to AS?

7. I assume AS starts MS control channel? What actions MS when AS doesn't starts the control channel? How MS knows it has been started?
A clear control and exit points of control channel must be put.
Does MS terminates the media session? How will it be decided?

8.
MS Control Dialog:  A SIP dialog that is used for establishing a
control channel between the UA and the MS.

It may not be required to have a SipDialog, only Non Dialog SipMessages could possibly be used.

Rahul

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained herein in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Tim Melanchuk" <[email-masked]>
Date: Wed, 4 Jul 2007 10:05:01 -0700

hi rahul,

thanks for your comments! answers inline.

> exchange of packages and their versions?

[timm] the specific mechanism(s) are still tbd. but could include the
package/version
exchange you mention, SIP OPTIONS, and the use if rfc3840 capabilities.

2. The control channel of one media connection should be for each media
> connection or it can carry information of multiple media connection?

[timm] the control channel is independent of media connections and can carry
control
information for any MS function, whether that function applies to a single
or multiple
media streams.

>       Does it mean than an AS using a control channel of one media session
> can modify some charecterstics of control sessions of some other media
> sessions?

 [timm] as stated above - a control channel is not bound to a media session.
a control
channel is essentially the "media session" described by the SDP used by the
SIP
control dialog to establish it. in other words, it is simply a SIP
established TCP
connection that can be used to carry the MS control protocol.

4. "Dedicated control channels provide reliable peer to peer transport for
> media server control interactions."
>
> This statement looks like we are going for a TCP connection. From network
> perspective both control channel and media

[timm] TCP yes. SIP is used to establish the TCP connection. TCP provides
guaranteed
in-order delivery of for MS protocol PDUs. SIP itself is not a transport
protocol for
the MS control protocol and this TCP connection, is *not* used to transport
SIP.
we should provides guidelines in the draft for the SIP transport protocol
but that
is not currently in the draft.

5. Even inside MS control channel (if used with SIP as defined by draft)
> what messages will be used by AS to send messages to MS. Draft can give some

[timm] the draft is intended to define the basic architecture, not the
protocol syntax.
the control channel does not use SIP methods.

see: draft-boulton-sip-control-framework-05, for details on establishing and
using a control channel and the basic message types that are defined.

6. How the MS can synchronize the events between MS control channel and
> control dialog? E.g a reInvite is rcvd with changed media characterstics
> based on that it might need to send some notifcation to AS?

[timm] this would be a MS control protocol requirement and outside the scope
of this architecture draft. if this is a requirement, it needs to be
captured in:
draft-dolly-mediactrl-requirements-00

generally, since the AS is responsible for establishing all media streams to
the
MS, it could be expected to know the contents of all re-INVITES.

7. I assume AS starts MS control channel? What actions MS when AS doesn't
> starts the control channel? How MS knows it has been started?

i  think there is some behaviour here that may need to be defined in the
draft.  i'd like to hear what other people think about recommending which
side initiates the control channel.

8.
> It may not be required to have a SipDialog, only Non Dialog SipMessages

sip is used to establish the control channel so that we can reap all of the
rendezvous, location, and security properties as discussed in section 5
of the draft.

cheers,
timm

Rahul
> This email and its attachments contain confidential information from
> HUAWEI, which is intended only for the person or entity whose address is
> listed above. Any use of the information contained herein in any way
> (including, but not limited to, total or partial disclosure, reproduction,
> or dissemination) by persons other than the intended recipient(s) is
> prohibited. If you receive this e-mail in error, please notify the sender by
> phone or email immediately and delete it!
>

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Wed, 18 Jul 2007 00:44:49 +0800

Some more comments:

1. Draft doesn't mention about how will IVR be done on whole conference? 
Since there is no UA how AS is suppose to pass this message to MS.
(There are ways to do that but it will be better to standardized it).

2.  "Each conference will be referred to by a specific
   identifier" can be replaced as "globally unique identifier".
Also the architecture should also allow AS and MS both to generate this identifier.
MS can also generate this identifier and give it to AS if AS doesn't provide it under certain conditions.
The architecture should give scope for this.
And in general it can be generated for IVR dialogs as well which gives AS pretty concrete way of changing dialog properties.

3.  "When a SIP UA places an INVITE to a URI associated with
   an existing conference, the Application Server forwards it to the MS
   associated with the conference."

   This is correct but this is not the only mechanism used by AS to join to conference.
An AS can at any point decide conevert a two party call to conference. This entirely depends on AS logic and draft should leave scope for that.

4. A doubt comes to my mind when I see the example for unmuting conference.
Suppose the UA wants to unmute from its end. It sends reInvite and AS forwards it. In this case suppose AS doesn't parse the SDP and just sends it MS should inform AS that characterstics of the party has changed.
(AS will not parse SDP except changing version and sessionid) untill some special logic.
Whether this is in the scope of this draft?
The idea is when the conference charecterstics change due to an operation which is not done by AS explicity(i.e request not passed in control channel) how
will the AS know about it? 

Rahul

----- Original Message -----
From: Tim Melanchuk <[email-masked]>
Date: Thursday, July 5, 2007 1:05 am
Subject: Re: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-framework-00.txt

> > I have reviewed only first few portions of the drafts. I have 
> some basic
> > questions on that.
> > I am putting this on list so that we can start discussing these 
> points.> >From first half I can say its a good start but lot needs 
> to be done
> > still.
> >
> > 1. "AS is able to discover capabilities." That means are we 
> going towards
> > a direction of dynamic
> 2. The control channel of one media connection should be for each 
> media> connection or it can carry information of multiple media 
> connection?
> 
> >       configuration of a function.  The request may apply to a 
> single>       media stream, multiple media streams associated with 
> multiple SIP
> > can modify some charecterstics of control sessions of some other 
> media> sessions?
> 
> 
> [timm] TCP yes. SIP is used to establish the TCP connection. TCP 
> providesguaranteed
> in-order delivery of for MS protocol PDUs. SIP itself is not a 
> transportprotocol for
> the MS control protocol and this TCP connection, is *not* used to 
> transportSIP.
> we should provides guidelines in the draft for the SIP transport 
> protocolbut that
> 5. Even inside MS control channel (if used with SIP as defined by 
> draft)> what messages will be used by AS to send messages to MS. 
> Draft can give some
> > control dialog? E.g a reInvite is rcvd with changed media 
> characterstics> based on that it might need to send some 
> notifcation to AS?
> 
> 
> 7. I assume AS starts MS control channel? What actions MS when AS 
> doesn't> starts the control channel? How MS knows it has been started?
> > It may not be required to have a SipDialog, only Non Dialog 
> SipMessages> could possibly be used.
> 
> 
> ******************************************************************************************> This email and its attachments contain confidential information from
> > (including, but not limited to, total or partial disclosure, 
> reproduction,> or dissemination) by persons other than the 
> intended recipient(s) is
> *****************************************************************************************>
> >

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 17 Jul 2007 20:00:02 +0300

Rahul

1.    In "Since there is no UA how AS is suppose to pass this message to
MS." I am not sure I understand the issue. The IVR in the conference is
to the participants. The MS does the IVR session through the media
channel.

2.    "An AS can at any point decide convert a two party call to
conference." Are you suggesting that point to point calls are going
through a conference AS. What is the scenario here

Roni Even

> -----Original Message-----

> From: RahulSrivastava 71616 [mailto:[email-masked]]

> Sent: Tuesday, July 17, 2007 7:45 PM

> To: Tim Melanchuk

> Cc: [email-masked]

> Subject: Re: [MEDIACTRL] Comments on
draft-melanchuk-mediactrl-framework-

> 00.txt

> Also the architecture should also allow AS and MS both to generate
this

> identifier.

> MS can also generate this identifier and give it to AS if AS doesn't

> provide it under certain conditions.

> And in general it can be generated for IVR dialogs as well which gives
AS

> pretty concrete way of changing dialog properties.

>    This is correct but this is not the only mechanism used by AS to
join

> to conference.

> An AS can at any point decide conevert a two party call to conference.

> This entirely depends on AS logic and draft should leave scope for
that.

> 4. A doubt comes to my mind when I see the example for unmuting

> conference.

> Suppose the UA wants to unmute from its end. It sends reInvite and AS

> forwards it. In this case suppose AS doesn't parse the SDP and just
sends

> it MS should inform AS that characterstics of the party has changed.

> (AS will not parse SDP except changing version and sessionid) untill
some

> special logic.

> The idea is when the conference charecterstics change due to an
operation

> which is not done by AS explicity(i.e request not passed in control

> channel) how

************************************************************************
**

> ****************

> (including, but not limited to, total or partial disclosure,
reproduction,

> prohibited. If you receive this e-mail in error, please notify the
sender

> by phone or email immediately and delete it!

************************************************************************
**

> ***************

> Subject: Re: [MEDIACTRL] Comments on
draft-melanchuk-mediactrl-framework-

> 00.txt

> > exchange you mention, SIP OPTIONS, and the use if rfc3840

> > capabilities.

> > [timm] the control channel is independent of media connections and

> > can carry

> > information for any MS function, whether that function applies to

> > a single

> > >       Does it mean than an AS using a control channel of one

> > media session

> > [timm] as stated above - a control channel is not bound to a

> > media session.

> > channel is essentially the "media session" described by the SDP

> > used by the

> > 4. "Dedicated control channels provide reliable peer to peer

> > transport for

> > > This statement looks like we are going for a TCP connection.

> > From network

> > > So from what perspective its reliable than some other SIP

> > > Connection?(Assuming its not TCP)

> > > direction to discussion I believe. In fact this issue must be

> > decided ASAP

> > see: draft-boulton-sip-control-framework-05, for details on

> > establishing and

> > 6. How the MS can synchronize the events between MS control

> > channel and

> > [timm] this would be a MS control protocol requirement and outside

> > the scope

> > generally, since the AS is responsible for establishing all media

> > streams to

> > i  think there is some behaviour here that may need to be defined

> > in the

> > draft.  i'd like to hear what other people think about

> > recommending which

> > sip is used to establish the control channel so that we can reap

> > all of the

> > rendezvous, location, and security properties as discussed in

> > section 5

************************************************************************
**

> ****************> This email and its attachments contain confidential

> information from

> > > HUAWEI, which is intended only for the person or entity whose

> > address is

> > > prohibited. If you receive this e-mail in error, please notify

> > the sender by

************************************************************************
**

> ***************>

---

From: "Adnan Saleem" <[email-masked]>
Date: Tue, 17 Jul 2007 10:34:47 -0700

Hi Rahul,
 
1. I think by IVR to conference, you mean services like play or record
to a conference.
    This is in scope of the architecture, and if not clearly specified,
it can be added.
    The message passing to the MS (from AS) would be the same mechanism
used
    to create the conference. Details of this will be defined in
subsequent docs which
    define the IVR and conference packages.
 
2. Conference Identifier: I agree that we need to allow either MS or AS
to define this identifier.
    (perhaps this is a detailed enough issue which should be specified
in the conference
     control package, yet to be defined)
 
3. Agreed, but I should clarify that a conference mix can be created
using the URI
    or via conference control package (yet to be defined). Either way,
there is no
    inherent restriction in being able to start with two party
'conference' and extending
    it to include several participants.
 
4. I think you are assuming that muting (or unmuting) a participant in a
conference
    is initiated by the UA via a reINV with SDP sent to AS. This is one
way of 
    accomplishing this, but certainly not the only way. Using this
approach,
    the reINV with SDP is forwarded to MS, which in turn changes the
media
    connection to the given UA (in effect muting or unmuting), but the
conference
    characteristics are not modfied. (ie: media stream to/from send/recv
is
    changed as a result of processing of SDP by the MS).
 
    An alternate approach, is that UA mutes/unmutes by pressing DTMF,
which
    is detected by MS and reported to AS. The AS logic in turn sends
conference
    control command to MS to mute/unmute a particular connection from
conference
    to the UA, without needing a reINV/SDP exchange.

Adnan Saleem

________________________________

From: Even, Roni [mailto:[email-masked]] 
Sent: July 17, 2007 10:00 AM
To: RahulSrivastava 71616; Tim Melanchuk
Cc: [email-masked]
Subject: RE: [MEDIACTRL] Comments on
draft-melanchuk-mediactrl-framework-00.txt

Rahul

 

Roni Even

this

AS

join

that.

sends

some

operation

reproduction,

sender

---

From: "Even, Roni" <[email-masked]>
Date: Tue, 17 Jul 2007 20:47:00 +0300

Adnan,

3.  There is a difference between having a conference with two
participants (have a conference uri) like you described and having the
AS convert a point to point call to multipoint. That is why I asked for
the call scenario. A point to point call does not necessarily flow
through an AS.

4. The UA to AS flow is not the scope of the work. This is XCON or
similar work

Roni Even

From: Adnan Saleem [mailto:[email-masked]] 
Sent: Tuesday, July 17, 2007 8:35 PM
To: Even, Roni; RahulSrivastava 71616; Tim Melanchuk
Cc: [email-masked]
Subject: RE: [MEDIACTRL] Comments on
draft-melanchuk-mediactrl-framework-00.txt

Hi Rahul,

 

Adnan Saleem

Rahul

 

Roni Even

this

AS

join

that.

sends

some

operation

reproduction,

sender

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Thu, 19 Jul 2007 00:37:57 +0800

1. This is my understanding of how from the draft says that IVRs are played on a UE :Setting up of media channel and performing control commands on control channel.
Now since there is no media channel for a conference (since there is no single UE).
I think sending of control commands on the control channel addressing the conference  should be ok.
Or settig up of a media channel with hold SDP is also required.?

2. Yes Conference is not created at startup it can be started at any point of time by AS.
 Suppose A and B are happily talking. Now AS wants to play annoucement to both the parties. 
This can be achieved by a normal 3pcc call flow involving rengotiation(converting this call to conference) and then asking MS to do the annc part.
Above is a just a way of using conference for media control and it entirely depends on internal logic of AS and certainly we can leave scope for that in our draft.

Rahul

----- Original Message -----
From: "Even, Roni" <[email-masked]>
Date: Wednesday, July 18, 2007 1:00 am
Subject: RE: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-framework-00.txt

> > And in general it can be generated for IVR dialogs as well which 
> givesAS
> 
> addressis

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Thu, 19 Jul 2007 00:58:59 +0800

Yes agreed .

For the last point as mentioned we can also start putting some use cases as we move on.

Rahul

----- Original Message -----
From: Adnan Saleem <[email-masked]>
Date: Wednesday, July 18, 2007 1:34 am
Subject: RE: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-framework-00.txt

>    This is in scope of the architecture, and if not clearly 
> specified,it can be added.
>    The message passing to the MS (from AS) would be the same 
> mechanismused
>    characteristics are not modfied. (ie: media stream to/from 
> send/recvis

---

From: "Even, Roni" <[email-masked]>
Date: Wed, 18 Jul 2007 20:12:05 +0300

inline
Roni
> Sent: Wednesday, July 18, 2007 7:38 PM
> To: Even, Roni
> Cc: Tim Melanchuk; [email-masked]
> Subject: Re: RE: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-
> framework-00.txt
> 
> 
> 1. This is my understanding of how from the draft says that IVRs are
> played on a UE :Setting up of media channel and performing control
> commands on control channel.
> Now since there is no media channel for a conference (since there is
no
> single UE).
> I think sending of control commands on the control channel addressing
the
> conference  should be ok.
[RE:] The IVR session media to UE and input back is to the MS. The AS
gets the response from the MS.
Are you trying to have an IVR session with all participants at the same
time by using one IVR script on the conference level.

> 
> 2. Yes Conference is not created at startup it can be started at any
point
> of time by AS.
>  Suppose A and B are happily talking. Now AS wants to play annoucement
to
> both the parties.
> This can be achieved by a normal 3pcc call flow involving
> rengotiation(converting this call to conference) and then asking MS to
do
> the annc part.
> Above is a just a way of using conference for media control and it
> entirely depends on internal logic of AS and certainly we can leave
scope
> for that in our draft.
[RE:] This is not a specific scope, this is an application using
conference and announcement functionality combined. The AS gets a
request to send an announcement to a call. It can do it by conference or
by putting both on hold and connect them to the announcement server
sending announcement to both and them connecting them again. This is
simpler than using a three way conference.
reproduction,
sender
> > >    an existing conference, the Application Server forwards it to
the
> > MS
> > > > [timm] the specific mechanism(s) are still tbd. but could
include
> > > > [timm] the draft is intended to define the basic architecture,
not
> > > > > listed above. Any use of the information contained herein in
any
> > way

---

From: "Tim Melanchuk" <[email-masked]>
Date: Wed, 18 Jul 2007 10:16:42 -0700

inline...

On 7/18/07, RahulSrivastava 71616 <[email-masked]> wrote:
> played on a UE :Setting up of media channel and performing control commands
> on control channel.

[timm] first, a bit about terminology. media streams have an associated
SIP "media dialog" since SIP is how  the streams are established.
conferences have no associated SIP dialog since they are established
using a media control protocol. conferences and media streams *do*
have an association with an AS for authorization/security functions
(i.e. if AS(a) controls conf-foo and the streams from UA(1) and UA(2),
we don't want some other AS to be able to manipulate conf-foo or the
streams associated with UA(1) and UA(2).

all media server control comands will be part of the media server
control protocol(s), running over the control channel. those commands
may identify either a media stream or a conference as the target of
function that is requested. things like playing announcements and
making recordings make sense on a conference basis, this requiring
user input make more sense on a stream basis. both reflect more
the protocol than the model being presented in the framework.

cheers,
timm

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Thu, 19 Jul 2007 02:03:54 +0800

For second point both use cases hold good.
For a simple conference what you suggested is better option.
When a annc is desired quite often on a two party call may be other is better option.

What I want to emphasize here is since these issues are not standardized and each can use this to provide services in its own way.
There is an  ardent need for standardizing the use cases. (or at least collect and discuss)
I agree this is a bit difficult.

For first point I didn't get your question completely. 
Are you talking from implementation perspective. 
All I want to achieve below:

A,B and C are in conf. AS wants to play annc and record respectively "for the total conference".
How AS instructs the MS?
1. Option A:
            Send a control message to the conf using control channel and bingo annc is played.
(From Timm's previous this is what I understood that conf will have no separate Sip "Media" Session" Right Timm?)
2. Option B:
             (This is for MS using INFO to tunnel commands). Send on any one of media dialogs to play an annc to whole conf.
3. Option C:
             This is also same as above just a minor diff. A separate SipSession is created with no media and annc is played on that.
Usuallly called control connection of conf.

B & C are the pre media control draft solutions and option A is what draft recommends. (Though this was not clear to me from the first look)

Rahul

----- Original Message -----
From: "Even, Roni" <[email-masked]>
Date: Thursday, July 19, 2007 1:12 am
Subject: RE: RE: [MEDIACTRL] Comments on draft-melanchuk-mediactrl-framework-00.txt

> > I think sending of control commands on the control channel 
> addressingthe
> > conference  should be ok.
> Are you trying to have an IVR session with all participants at the 
> sametime by using one IVR script on the conference level.
> 
> > 
> >  Suppose A and B are happily talking. Now AS wants to play 
> annoucementto
> > both the parties.
> >  This email and its attachments contain confidential information 
> from> HUAWEI, which is intended only for the person or entity 
> whose address
> is
> > > conference." Are you suggesting that point to point calls are 
> going> > through a conference AS. What is the scenario here
> > >
> > >
> > >
> > >
> > >
> > > Roni Even
> > >
> > >
> > >
> > >
> > >
> > >
> > >
> > > > Also the architecture should also allow AS and MS both to 
> generate> > this
> > >
> > > > identifier.
> > >
> > > >    This is correct but this is not the only mechanism used 
> by AS
> to
> > > join
> > >
> > > > to conference.
> > >
> > > > > > I have reviewed only first few portions of the drafts. I 
> have> >
> > > > > some basic
> > >
> > > > > > questions on that.
> > >
> > > > > media> connection or it can carry information of multiple 
> media> >
> > > > > connection?
> > >
> > > > >
> > >
> > > > > control dialog to establish it. in other words, it is 
> simply a
> SIP
> > >
> > > > > established TCP
> > >
> > > > > we should provides guidelines in the draft for the SIP 
> transport> >
> > > > > protocolbut that
> > >
> > > > > MS, it could be expected to know the contents of all re-
> INVITES.> >
> > > > >
> > >
> > > > > > Does MS terminates the media session? How will it be 
> decided?> >
> > > > >
> > >
> > > > >
> > >
> > > > > > HUAWEI, which is intended only for the person or entity 
> whose> >
> > > > > address is
> > >
> > > > > > prohibited. If you receive this e-mail in error, please 
> notify> >
> > > > > the sender by
> > >

---

From: "Tim Melanchuk" <[email-masked]>
Date: Wed, 18 Jul 2007 11:27:18 -0700

things are a little difficult. there have been many previous proposals
and this draft is speaking from a framework perspective making it
harder to sort through how specific services and functiona are intended
to work. hopefuly, with feedback like this, the next draft will be clearer.
your "option a" below is the intended model.

cheers,
timm

On 7/18/07, RahulSrivastava 71616 <[email-masked]> wrote:
> What I want to emphasize here is since these issues are not standardized
> and each can use this to provide services in its own way.
> (From Timm's previous this is what I understood that conf will have no
> separate Sip "Media" Session" Right Timm?)
> 2. Option B:
>              (This is for MS using INFO to tunnel commands). Send on any
> one of media dialogs to play an annc to whole conf.
> 3. Option C:
>              This is also same as above just a minor diff. A separate
> SipSession is created with no media and annc is played on that.
> B & C are the pre media control draft solutions and option A is what draft
> recommends. (Though this was not clear to me from the first look)
>
> Rahul
>
>
>
> Subject: RE: RE: [MEDIACTRL] Comments on
> > > > from
> > notify the

---

From: "Even, Roni" <[email-masked]>
Date: Thu, 19 Jul 2007 08:40:47 +0300

Rahul,
I think that you need to differentiate between call scenarios and
standardization. In your example of sending an announcement to all
participants, this is just adding a new participant which is the
announcement MS and make it the speaker. You can argue if this needs to
be an atomic request or done using the announcement server and
conference server.
My view is that we are decomposing the functionalities. 

As for how you do it, definitely not by using INFO. The framework
describe using a control channel between the AS and MS and send the
requests using this channel or by using the SIP dialog depending on the
objective.

Roni

> Sent: Wednesday, July 18, 2007 9:04 PM
> To: Even, Roni
> Subject: Re: RE: RE: [MEDIACTRL] Comments on
draft-melanchuk-mediactrl-
> A,B and C are in conf. AS wants to play annc and record respectively
"for
> the total conference".
> How AS instructs the MS?
> 1. Option A:
>             Send a control message to the conf using control channel
and
> bingo annc is played.
reproduction,
sender
> > > > > (There are ways to do that but it will be better to
standardized
> > > > it).
any
> > > > > > [timm] the control channel is independent of media
connections
> > and
> > > >
> > > > > > can carry
> > > >
> > > > > > control
> > > >
> > > > > > information for any MS function, whether that function
applies
> > to
> > > >
> > > > > > a single
> > > >
> > > > > > or multiple
> > > >
> > > > > > media streams.
> > > >
> > > > > >
> > > >
> > > > > > 3.    "commands from an AS to an MS to request the
application
> > or
> > > > > > single>       media stream, multiple media streams
associated
> > with
> > > > > > the MS control protocol and this TCP connection, is *not*
used
> > > > > > 5. Even inside MS control channel (if used with SIP as
defined
> > by
> > > > > > of this architecture draft. if this is a requirement, it
needs
> > > > to be
> > > > > > 7. I assume AS starts MS control channel? What actions MS
when
> > AS
> > > >
> > > > > > doesn't> starts the control channel? How MS knows it has
been
> > > > started?