Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-ivr-control-package-00.txt

From: [email-masked]
Date: Tue, 10 Jun 2008 09:30:02 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Media Server Control Working Group of the IETF.

	Title           : An Interactive Voice Response (IVR) Control Package for the Media Control Channel Framework
	Author(s)       : S. McGlashan, et al.
	Filename        : draft-ietf-mediactrl-ivr-control-package-00.txt
	Pages           : 105
	Date            : 2008-06-10

This document defines a Media Control Channel Framework Package for
Interactive Voice Response (IVR) dialog interaction on media
connections and conferences.  The package defines dialog management
elements for preparing, starting and terminating dialog interactions,
as well as associated responses and notifications.  While other
dialog types can be used, this package defines a specific IVR dialog
type supporting prompt playback, runtime controls, DTMF collect and
media recording.  The package also defines elements for auditing
package capabilities and dialogs.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-mediactrl-ivr-control-package-00.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Tue, 10 Jun 2008 20:02:21 +0000

As requested by the chairs, we've updated the IVR control package as a WG item ID.

This version addresses issues raised at the last meeting as well as on the list - apologies if we've missed any.

The changes are summarized in detail in section 9. The major functional changes are:

1. Audit capability for package capability and dialogs (Section 4.4)

2. Subscribe/notify for DTMF keypress events (Sections 4.2.2.1 and 4.2.5.2).

3. Moving VCR controls from <collect> to a separate <control> element (Section 4.3.1.2).

The document has also been re-stuctured for clarity. The XML schema has been re-vamped - still extensible but much simpler.

Please read and let us know if there are remaining errors, inclarities or typos. We'd like to move on to RAI review with this spec.

Expect an update of mixer package later this month.

Thanks

Scott

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, June 10, 2008 18:30
To: [email-masked]
Cc: [email-masked]
Subject: [MEDIACTRL] I-D Action:draft-ietf-mediactrl-ivr-control-package-00.txt

This document defines a Media Control Channel Framework Package for Interactive Voice Response (IVR) dialog interaction on media connections and conferences.  The package defines dialog management elements for preparing, starting and terminating dialog interactions, as well as associated responses and notifications.  While other dialog types can be used, this package defines a specific IVR dialog type supporting prompt playback, runtime controls, DTMF collect and media recording.  The package also defines elements for auditing package capabilities and dialogs.

Below is the data which will enable a MIME compliant mail reader implementation to automatically retrieve the ASCII version of the Internet-Draft.
_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl