Subject: [MEDIACTRL] msc-ivr.xsd validation failure with xerces-c 3.0

From: Jean-François Bertrand <[email-masked]>
Date: Thu, 11 Dec 2008 16:33:11 -0500

The formal syntax proposed in
draft-ietf-mediactrl-ivr-control-package-03 appears to be invalid due to
an error in the extensible core type.  Xerces-c 3.0 is unable to use the
proposed schema to validate msc-ivr/1.0 messages.  Xerces-c fails with
the following error: 

   "complex type 'parType' violates the unique particle attribution rule
in its components '##other' and '##other'"

As a workaround, I ended up commenting up part of the Tcore complexType
definition as follow:

<xsd:complexType name="Tcore">
  <xsd:annotation>
   <xsd:documentation>
    This type is extended by other component types to
    allow elements and attributes from other namespaces
    to be added.
   </xsd:documentation>
  </xsd:annotation>
  <xsd:sequence>
<!--     
     <xsd:any namespace="##other" minOccurs="0"
         maxOccurs="unbounded" processContents="lax" />
-->
  </xsd:sequence>
  <xsd:anyAttribute namespace="##other" processContents="lax" />
</xsd:complexType>

Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc. 
Montreal, Qc, Canada

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Fri, 19 Dec 2008 11:43:52 +0000

Sorry for the delay in replying.

I'm a bit puzzled about this one - the extensible core type is used in almost every element definition so why the xml processor only complains about parType is a bit strange (it should have encountered the same problem with <mscivr>, <dialog> and <prompt>).

The schema was developed and tested with Xerces 2.8 (Java) and I don't get any errors like this. If anyone else is able to test the schema with another validator, we'd be interested in hearing the results. I'll try to test it with another schema validator to see if this is a schema error or just xerces-c 3.0.

thanks

Scott

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Jean-François Bertrand [[email-masked]]
Sent: Thursday, December 11, 2008 22:33
To: [email-masked]
Subject: [MEDIACTRL] msc-ivr.xsd validation failure with xerces-c 3.0

The formal syntax proposed in draft-ietf-mediactrl-ivr-control-package-03 appears to be invalid due to an error in the extensible core type.  Xerces-c 3.0 is unable to use the proposed schema to validate msc-ivr/1.0 messages.  Xerces-c fails with the following error:

   "complex type 'parType' violates the unique particle attribution rule in its components '##other' and '##other'"

As a workaround, I ended up commenting up part of the Tcore complexType definition as follow: