Subject: [MEDIACTRL] Comments on Appendix A of draft-ietf-mediactrl-ivr-control-package-03

From: "Stephane Bastien" <[email-masked]>
Date: Mon, 1 Dec 2008 10:03:36 -0500

Hi,

Thank you for introducing Appendix A into the ivr-control-package draft - it will make interoperability with VoiceXML scripts a lot easier. I have a few comments:

Section 12.2.1 Session protocol information: when using <dialogstart> with a conferenceid, what are the recommended values for session.connection.* ?

Section 12.5 Call Transfer: The MS should throw to the VoiceXML script error.unsupported.transfer.blind or error.unsupported.transfer.bridge, as defined in VoiceXML 2.0, instead of terminating the dialog. This would be in-line with existing VoiceXML error handling.

Thanks,

Stéphane

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "McGlashan, Scott" <[email-masked]>
Date: Wed, 3 Dec 2008 16:07:54 +0000

Hi Stephane,

Good points, I'll fix the transfer section as suggested.

For starting a vxml dialog on a conference, I'm open to suggestions for the values of session.connection properties.  The spec currently says

If a conferenceid attribute is specified and the MS supports using a VoiceXML dialog on a conference, then the MS populates the VoiceXML session protocol variables using an implementation specific mechanism. Otherwise, the MS sends an 439 error response (Section 4.5 (Response Status Codes)<file:///C:/smcglashan/standards/ietf/mediactrlDocs/msc-ivr/draft-ietf-mediactrl-ivr-control-package-03.html#defn.statuscodes>).

where 'mechanism' should be clarified as 'values', i.e. this spec doesn't state the values if the vxml dialog is played on a conference.  However, media stream information is specified under session.connection.protocol.sip.media for both connection and conference (following mediactrl-vxml). So here are some options:

[1]  We could simply treat a conference like a SIP connection and require that the following vxml parameters are filled:

session.connection.local.uri
Evaluates to the value of the conferenceid value
session.connection.remote.uri
Evaluates to the value of the conferenceid value
session.connection.protocol.name
Evaluates to "sip". Note that this is intended to reflect the use of SIP in general, and does not distinguish between whether the connection accesses the MS via SIP or SIPS procedures.
session.connection.protocol.version
Evaluates to "2.0".

where the same values for local.uri and remote.uri would indicate a conference. Simple, but not necessarily true that the conference is a connection entity.

[2] Create an explicit conference object and require that following parameters are set:

session.conference.name
Evaluates to the value of the conferenceid value

and then conference media information would go under session.conference.media.

[3] As option [2], but put media stream information in session.media. This is more aligned with the mediactrl <dialogstart> structure but no longer aligned with mediactrl-vxml for the connection's media stream information.

Let me know what you prefer - I'm leaning towards the [2] since it is explicit and compatible with mediactrl-vxml.

One other issue is that based on VoiceXML3.0 discussions yesterday, I will change our spec's session.connection.params to session.values (and return it to an associative array) for (potential at least)
alignment. It also makes these parameter values independent of whether the dialog is attached to a connection or conference.

thanks

Scott

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stephane Bastien
Sent: Monday, December 01, 2008 16:04
To: [email-masked]
Subject: [MEDIACTRL] Comments on Appendix A of draft-ietf-mediactrl-ivr-control-package-03

Hi,

Thanks,

Stéphane

---

From: "Stephane Bastien" <[email-masked]>
Date: Thu, 4 Dec 2008 10:12:00 -0500

These are all good proposals. Option #2 looks a little cleaner, but this is just a preference.

From: McGlashan, Scott [mailto:[email-masked]] 
Sent: 3 décembre 2008 11:08
To: Stephane Bastien; [email-masked]
Subject: RE: Comments on Appendix A ofdraft-ietf-mediactrl-ivr-control-package-03

(...)

Evaluates to "2.0". 

 

session.conference.name