Subject: [MEDIACTRL] Call for country-specific tones expert

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 19 Nov 2009 19:08:18 -0600

Dear Mediactrl,

During our discussion in Hiroshima, we identified two things

- we needed expert help with how to specify country-specific 
<Supported-tones>, and

- no one in the room had a clue (or would admit to having a clue) about this 
topic.

Eric and I had the action to ask on-list, so I'm asking - any guidance 
towards an expert in this space?

Thanks,

Spencer

---

From: "Adnan Saleem" <[email-masked]>
Date: Thu, 19 Nov 2009 19:26:46 -0800

I'm certainly not an expert in this area, but we could use 
the following references:

ITU-T (E.180/Q.35)  - Tones in National Signaling Systems
ITU-T (H.248.1)     - Tone Identifiers and Call Progress Tone Gen/Det
ITU-T (H.248.27)    - Defines Conferencing Tone Gen

E.164 or ISO 3166-1 - Country Code Identifiers

To indicate country codes E.164 definitions or ISO 3166-1 could 
be used and specific MS implementations would internally map 
country codes to the tone types they need to generate or detect.

Ie: we should allow specification of country code and tone 
identifier wherever applicable in MediaCtrl packages.

Country codes could be based on E.164 or ISO identifiers,
And tone identifiers could be based on h.248.1 (eg dial tone
identifier is "dt", special information tone identifier is 
"sit"), see h.248.1v3.

Adnan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Spencer Dawkins
Sent: November 19, 2009 5:08 PM
To: [email-masked]
Subject: [MEDIACTRL] Call for country-specific tones expert

Dear Mediactrl,

- no one in the room had a clue (or would admit to having a clue) about
this 
topic.

Thanks,

Spencer 

_______________________________________________
MEDIACTRL mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mediactrl
Supplemental Web Site:
http://www.standardstrack.com/ietf/mediactrl

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 20 Nov 2009 04:21:16 -0600

Hi, Adnan,

Excellent start - do other people have opinions about these suggestions?

Thanks,

Spencer

----- Original Message ----- 
From: "Adnan Saleem" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>; <[email-masked]>
Sent: Thursday, November 19, 2009 9:26 PM
Subject: RE: [MEDIACTRL] Call for country-specific tones expert

Adnan

-----Original Message-----

Dear Mediactrl,

Thanks,

Spencer

---

From: Christian Groves <[email-masked]>
Date: Mon, 23 Nov 2009 16:53:44 +1100

Hello Spencer,

I'm not exactly sure of the scope of the tones that are required to be 
supported by media control. I wasn't at Hiroshima so I'm not sure what 
is required.

At least in H.248 there are packages defined for alerting, line test, 
calling progress, conferencing, business tones etc. So there's a wide range.
 
In general re-using H.248 defined tones would certainly make 
interworking between SIP and H.248 easier. A Media Controller could 
re-use H.248 codes rather than having to maintain some sort of mapping 
table.

H.248 defines a basic tone sending/reception capabilities in the H.248.1 
Annex E "Tone Generator" and "Tone Detection" Packages. Tones are 
typically defined as extensions to these packages. Similar Tones are 
typically grouped into packages. The packageID and SignalID uniquely 
identify the tones. These packages are defined in several 
Recommendations such as the ones specified by the previous email. 
Additionally ITU-T Q.1950  (http://www.itu.int/rec/T-REC-Q.1950/en) 
contains packages on:
- Basic call progress tones generator with directionality
- Expanded call progress tones generator package
- Basic services tones generation package
- Expanded services tones generation package
- Intrusion Tones Generation Package
- Business tones generation package

Another benefit of using H.248 is that the supported sets of tones can 
be specified using wildcarding. For example: if a media server wanted to 
indicate the supported of all the tones in the business tones generation 
package rather than listing each of the four tones (biztn/ofque, 
biztn/erwt, biztn/ddt, biztn/idt) it could simply specify (biztn/*).

A further benefit is that if people come up with additional tones the 
mechanism to define and register these with IANA already exists. This 
reduces the need to define a process in mediacntrl.

Regards, Christian

Spencer Dawkins wrote:
> ----- Original Message ----- From: "Adnan Saleem" 
> <[email-masked]>
> I'm certainly not an expert in this area, but we could use the 
> following references:
>
> To indicate country codes E.164 definitions or ISO 3166-1 could be 
> used and specific MS implementations would internally map country 
> codes to the tone types they need to generate or detect.
>
> Ie: we should allow specification of country code and tone identifier 
> wherever applicable in MediaCtrl packages.
>
> identifier is "dt", special information tone identifier is "sit"), see 
> h.248.1v3.
>
>
> Adnan
>
> this topic.