Subject: [MEDIACTRL] Fw: Fw: Draft Shepherd Write-Up: A Mixer Control Package forthe Media Control Channel Framework

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 17 Dec 2009 14:13:02 -0600

Scott is traveling, but says he needs to ask the working group two questions 
based on my shepherd write-up of MIXER:

> 1. Validating the schema: I've validated the mixer schema with Xerces
> (Java). Have other implementors validated it and if so with which tool?

I need to know this for the shepherd write-up - obviously, more validation 
is better :D

> 2. Expanding the reserved error codes. If expand the set up to 419, up to
> say 440, then we'll to move existing codes 420-435. This will affect
> existing implementations. Is gain worth the pain?

I asked about expanding the reserved error codes in my shepherd write-up, 
based more on a sense that only allowing six additional error codes in this 
range, in the initial version of this package, seemed too small, rather than 
any evidence that this was true. If people think I'm overreacting, that 
would be a fine thing to say now!

Thanks,

Spencer

---

From: Jean-Francois Bertrand <[email-masked]>
Date: Thu, 17 Dec 2009 13:19:40 -0800

_______________________________________
From: [email-masked] [[email-masked]] On Behalf Of Spencer Dawkins [[email-masked]]
(...)
> (Java). Have other implementors validated it and if so with which tool?

We have validated the msc-ivr and msc-mixer schemas using xerces-c 3.0 when implementing these protocols for our media server.

Jean-François Bertrand, ing.
Sr. Software Designer
BroadSoft, Inc.
Montreal, Qc, Canada

(...)

---

From: "Spencer Dawkins" <[email-masked]>
Date: Thu, 17 Dec 2009 15:36:15 -0600

Hi, Jean-Francois,

Got it - and thanks.

Has anyone validated against a different validator?

Spencer

----- Original Message ----- 
From: "Jean-Francois Bertrand" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>; <[email-masked]>
Sent: Thursday, December 17, 2009 3:19 PM
Subject: RE: [MEDIACTRL] Fw: Fw: Draft Shepherd Write-Up: A Mixer 
ControlPackage forthe Media Control Channel Framework

_______________________________________
From: [email-masked] [[email-masked]] On Behalf Of 
Spencer Dawkins [[email-masked]]
(...)
> (Java). Have other implementors validated it and if so with which tool?

We have validated the msc-ivr and msc-mixer schemas using xerces-c 3.0 when 
implementing these protocols for our media server.

(...)=

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 18 Dec 2009 10:22:48 +0100

Hi Spencer,

I validated both the ivr and mixer schema using XMLSpy and they were ok.

Lorenzo

On Thu, 17 Dec 2009 15:36:15 -0600
"Spencer Dawkins" <[email-masked]> wrote:

> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
> 

-- 
Lorenzo Miniero <[email-masked]>

---

From: "Spencer Dawkins" <[email-masked]>
Date: Fri, 18 Dec 2009 06:45:54 -0600

Lorenzo,

Thank you! I'll update the shepherd writeup.

To all:

I'd be delighted to hear about experiences with other validators, but think 
that listing two validators addresses our first question.

It would be great to hear opinions about expanding the range of error values 
(beyond 419) really soon, because that's the last question before I can 
forward the shepherd report to Robert, and I would really like to do that, 
before December 24th.

Thanks,

Spencer

----- Original Message ----- 
From: "Lorenzo Miniero" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>
Cc: "Jean-Francois Bertrand" <[email-masked]>; <[email-masked]>
Sent: Friday, December 18, 2009 3:22 AM
Subject: Re: [MEDIACTRL] Fw: Fw: Draft Shepherd Write-Up: A Mixer 

Hi Spencer,

Lorenzo