Subject: [MEDIACTRL] draft-ietf-mediactrl-mixer-control-package-11 error in examples in section 4.2.3

From: Stéphane Bastien <[email-masked]>
Date: Fri, 4 Jun 2010 10:04:03 -0700

Hi,

In draft-ietf-mediactrl-mixer-control-package-11, there are errors in the examples in section 4.2.3 <response>.

The examples are:

<response code="200">
    <reason>Success</reason>
   </response>

<response code="403">

    <reason>Conf already exists</reason>

   </response>

But I believe they should show:

<response status="200" reason="conference created" />

<response status="405" reason="Conference already exists" />

Regards,

Stéphane

---

From: "McGlashan, Scott" <[email-masked]>
Date: Thu, 10 Jun 2010 15:29:16 +0000

thanks - I'll fix them.

Scott

On 4 Jun 2010, at 19:04, Stéphane Bastien wrote:

Hi,

The examples are:

<response code="200">
    <reason>Success</reason>
   </response>

<response code="403">

   </response>

Regards,

Stéphane

<ATT00001..txt>

---

From: Eric Burger <[email-masked]>
Date: Tue, 15 Jun 2010 01:11:25 -0400

More fundamental question: Why do we have reason text at all?

One of the DISCUSSes from the ADs is that if we have human-readable text, it has to have a language indicator.

If the Reason Comment is not human readable, then we do not need it.

What would be the opinion of the WG to drop reason / comment text everywhere? Or, to keep with HTTP, to have fixed reason strings? Or, to keep with XML, we just say that the string gets interpreted in whatever locale the XML gets interpreted?

On Jun 10, 2010, at 11:29 AM, McGlashan, Scott wrote:

> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Tue, 15 Jun 2010 14:34:14 +0500

Mostly this is required for writing logs and debugging.
Required for checking call failures and proving to somebody why it failed after days of usgae :-)

Regards,
Rahul

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

----- Original Message -----
From: Eric Burger <[email-masked]>
Date: Tuesday, June 15, 2010 10:42 am
Subject: Re: [MEDIACTRL] draft-ietf-mediactrl-mixer-control-package-11 error	in examples in section 4.2.3
To: [email-masked]

> One of the DISCUSSes from the ADs is that if we have human-
> readable text, it has to have a language indicator.
> 
> What would be the opinion of the WG to drop reason / comment text 
> everywhere? Or, to keep with HTTP, to have fixed reason strings? 
> Or, to keep with XML, we just say that the string gets interpreted 
> in whatever locale the XML gets interpreted?
> 
> > In draft-ietf-mediactrl-mixer-control-package-11, there are 
> errors in the examples in section 4.2.3 <response>.
> > 
> > The examples are:
> > 
> > <response code="200">
> >    <reason>Success</reason>
> >   </response>
> > 
> > 
> > <response code="403">
> >

---

From: Eric Burger <[email-masked]>
Date: Tue, 15 Jun 2010 07:26:28 -0400

Does it need to be in local language? Does it need to always be readable? Does it need to be interpreted by a human? Does it need to be interpreted by a machine?

I would offer the answers are "No, No, Probably, Never", which means the comment should be opaque, 7-bit ASCII text.

Anyone think otherwise?