Subject: Re: [MEDIACTRL] Issue with mixer package <codec> element

From: "McGlashan, Scott" <[email-masked]>
Date: Thu, 7 Oct 2010 08:49:09 +0000

Hi Jonathan,

Thanks for the comment and apologies for the delay.

Reviewing the XCON's definition, I see that they have a name attribute
which we have mistakenly not put in our definition of <codec>.

Unless anyone on the mailing list objects, I'll add a mandatory name
attribute to the <codec> element which specifies the top-level media type
of the codec. I'll also fix up the definitions of name and <subtype> to
map to the type-name and subtype-name of RFC 4288 as well as the examples.

Thanks 

Scott

On 25/03/2010 21:58, "Jonathan Lennox" <[email-masked]> wrote:

>I'm sorry this is being raised so late, but I was looking over the mixer
>package's definition of <codec> (to recommend that MRB copy its
>definition for its <rtp-codec>), and realized there was a problem.
>
>The problem is that mixer package's definition of <codec> includes only
>the media subtype (e.g. pcmu or h264), not its top-level media type
>(audio or video).  In most cases subtypes are unique, but there are a few
>"container" subtypes (e.g. rtx, fec, or red) that are registered as
>multiple top-level types.  I believe this is only by convention and good
>practice, however; RFC 4288 requires only that the type/subtype pair be
>unique. 
>    
>My recommendation would be to add a <type> element under <codec>, whose
>definition is the top-level content type, leaving <subtype> as the
>subtype.  (An alternative would be to change to only using <type> as
>type/subtype, e.g. audio/pcmu, which would probably be equally good, but
>this might make life unnecessarily harder for implementations that want
>to try to maintain backward compatibility with the draft as-is.)
>
>It is probably also worth pointing out that both type and subtype names
>are not case-sensitive.
>
>The other (minor) problem is that I'm not sure the defining the values of
><subtype> by reference to a column IANA's RTP Payload Format media types
>table is the best choice, among other reasons being that that table is
>very incomplete, missing, for instance, video/h264.  (This has been
>raised with IANA.)  I would instead define the value simply as "the name
>of the subtype of the codec's media format".  The reference to RFC 4855
>can remain.
>
>-- 
>Jonathan Lennox
>Vidyo, Inc
>[email-masked]
>
>
>_______________________________________________
>MEDIACTRL mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mediactrl
>Supplemental Web Site:
>http://www.standardstrack.com/ietf/mediactrl

---

From: Eric Burger <[email-masked]>
Date: Thu, 7 Oct 2010 18:37:10 -0400

Works for me. Anyone else?

---

From: Victor Paulsamy <[email-masked]>
Date: Fri, 8 Oct 2010 10:47:43 +0700

Likewise -- works for me too.

--victor

---

From: Chris Boulton <[email-masked]>
Date: Fri, 08 Oct 2010 11:14:39 +0100

+1.

On 08/10/2010 04:47, Victor Paulsamy wrote:
> On Fri, Oct 8, 2010 at 5:37 AM, Eric Burger 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     > On 25/03/2010 21:58, "Jonathan Lennox" <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     >> [email-masked] <mailto:[email-masked]>
>     >>
>     >>
>     >> [email-masked] <mailto:[email-masked]>
>     > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

-- 
Chris Boulton
CTO & Co-founder
NS-Technologies <http://www.ns-technologies.com>
m: +44.7876.476681

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 8 Oct 2010 13:06:28 +0200

It's ok for me as well.

L.

On Fri, 08 Oct 2010 11:14:39 +0100

-- 
Lorenzo Miniero
Meetecho s.r.l.
http://www.meetecho.com