Subject: [MEDIACTRL] ISSUE 3 - IVR Package - <variable>/<variabletype> interoperability

From: "McGlashan, Scott" <[email-masked]>
Date: Thu, 7 Oct 2010 09:31:38 +0000

Hi All,

As part of our IESG review of the IVR package the following issues have been identified:

(a) 4.3.1.1.1.  <variable>

   A <variable> element has the following attributes:

   value:  specifies the string to be rendered.  A valid value is a
      string (see Section 4.6.6).  The attribute is mandatory.

   type:  specifies the type to use for rendering.  A valid value is a
      string (see Section 4.6.6).  The attribute is mandatory.

   format:  specifies format information to use in conjunction with the
      type for the rendering.  A valid value is a string (see
      Section 4.6.6).  The attribute is optional.  There is no default
      value.

 Are these defined somewhere in more details?

   For example, the MS could support <variable> type/format combinations
   such as:

 Is this the complete list?

(b) Please clarify how implementations will achieve interoperability with regard to the <variable> element, given that there are no registries or specification for the 'type' and 'format' attributes. This applies also to the <variabletype> element.

We need some input from the mailing list on how we should proceed with this one: some options

1. Strengthen our descriptions of date, time and digits format/types. Limit interoperability requirements to these 3 types.

2. As 1), but introduce registry for adding additional types.

3. Delete the <variable> and <variabletype> elements.

I would like WG input on these options. My preference is for option 2 (or option 1 as 2nd choice).

Thanks

Scott

---

From: Victor Paulsamy <[email-masked]>
Date: Fri, 8 Oct 2010 03:14:10 +0700

I like to see option # 2 as well.

--victor

On Thu, Oct 7, 2010 at 4:31 PM, McGlashan, Scott <[email-masked]>wrote:

> (b) Please clarify how implementations will achieve interoperability with
> regard to the <variable> element, given that there are no registries or
> specification for the 'type' and 'format' attributes. This applies also to
> the <variabletype> element.
>
>
> 1. Strengthen our descriptions of date, time and digits format/types. Limit
> interoperability requirements to these 3 types.
>
> _______________________________________________
> MEDIACTRL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mediactrl
> Supplemental Web Site:
> http://www.standardstrack.com/ietf/mediactrl
>

---

From: Lorenzo Miniero <[email-masked]>
Date: Fri, 8 Oct 2010 13:07:41 +0200

I agree, I think that's the best option.

L.

On Fri, 8 Oct 2010 03:14:10 +0700

-- 
Lorenzo Miniero
Meetecho s.r.l.
http://www.meetecho.com