Subject: Re: comments for <draft-ietf-megaco-regs-05.txt>

From: Kimmo Rantanen <[email-masked]>
Date: Mon, 16 Aug 1999 08:59:45 +0300

Hello Nancy.

Below is my comments.

/Kimmo

> Kimmo, the changes I propose to make based on your comments are
interspersed
> below. Let me know if they are ok with you.
>
> Nancy
>
------------------------------------------------------------------------
--
> Nancy M. Greene
> Internet & Service Provider Networks, Nortel Networks
> T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
>
> > ----------
> > From:  Kimmo Rantanen[SMTP:[email-masked]]
> > Sent:  Thursday, July 01, 1999 5:56 AM
> > To:  [email-masked]
> > Subject:  comments for <draft-ietf-megaco-regs-05.txt>

((KIMMO snip))

> >
> >
> Change e. in 5.3 to read:
> e.   Allow the MGC to specify that MF/DTMF be extracted and handled in
any
> of the following ways:
>
> 1.   encoded/decoded as part of the RTP stream,
> 2.   extracted and sent to the MGC,
> 3.   received from teh MGC and inserted,
> 4.   handled according to a script of instructions,
> 5.   extracted and encoded in a separate RTP stream.
> 6.   decoded from a separate RTP stream and inserted.
>
> [end of new text]
>
((KIMMO))

I see that you put together sending and receiving functions, it is OK.

>
> > Chapter 5.7  Just question: is it accounting clear term or will it
be
> > charging (I see it like:  Charging -> Accounting -> Billing)??
> >
> I would like to just leave it as Accounting, and not get into this
debate.

((KIMMO))

OK, leave it so.

>
> > Chapter 5.8. According to points c. and d., please specify maximum
> > round-trip time (MGC-MG-MGC) or is it somewhere e.g. 1 sec ?
> >
> I don't think we can specify maximum round trip time at this time.
>

((KIMMO))

Could we say then that it is unlimited and transport protocol takes care
about it? (refer to cont. check timing).

> > Chapter 6.2. Allow to make outgoing routing i.e. allow to get "any"
DS0
> > from specific DS0 group e.g. ADD  1ANY DS0  or  ADD  2ANY DS0.  1ANY
> > means any DS0 from group number 1, 2ANY from group number 2 etc.
> >
> This is covered by the following - it says wildcards can be used - and
that
> I think, is what you mean by ANY:
> b.   Provide an ability for the MGC to indicate to an MG the resource
to
>      use for a call (e.g. DS0) exactly, or indicate a set of resources
>      (e.g. pick a DS0 on a T1 line or a list of codec types) via a
"wild
>      card" mechanism from which the MG can select a specific resource
>      for a call (e.g. the 16th timeslot, or G.723).
>
((KIMMO))

Actually I didn't mean that, but anyway I see now that it could be OK.

> > best regards Kimmo
> Nancy

Kimmo.
Kimmo, the changes I propose to make based on your comments are interspersed
below. Let me know if they are ok with you.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Kimmo Rantanen[SMTP:[email-masked]]
> Sent:         Thursday, July 01, 1999 5:56 AM
> To:   [email-masked]
> Subject:      comments for <draft-ietf-megaco-regs-05.txt>
>
> Nancy or to whom it concern.
>
> I have some comments for <draft-ietf-megaco-regs-05.txt>:
>
> chapter 5.3  need to be add MF/DTMF sending.
>
>    Allow the MGC to specify that MF/DTMF be inserted by any of the
>   following ways:
>
>    1. decoded as part of the RTP stream,
>    2. received from the MGC and inserted,
>    3. handled according to a script of instructions,
>    4. decoded from a separate RTP stream and inserted.
>
Change e. in 5.3 to read:
e.   Allow the MGC to specify that MF/DTMF be extracted and handled in any
of the following ways:

1.   encoded/decoded as part of the RTP stream,
2.   extracted and sent to the MGC,
3.   received from teh MGC and inserted,
4.   handled according to a script of instructions,
5.   extracted and encoded in a separate RTP stream.
6.   decoded from a separate RTP stream and inserted.

[end of new text]

> Chapter 5.7  Just question: is it accounting clear term or will it be
> charging (I see it like:  Charging -> Accounting -> Billing)??
>
I would like to just leave it as Accounting, and not get into this debate.

> Chapter 5.8. According to points c. and d., please specify maximum
> round-trip time (MGC-MG-MGC) or is it somewhere e.g. 1 sec ?
>
I don't think we can specify maximum round trip time at this time.

> Chapter 6.2. Allow to make outgoing routing i.e. allow to get "any" DS0
> from specific DS0 group e.g. ADD  1ANY DS0  or  ADD  2ANY DS0.  1ANY
> means any DS0 from group number 1, 2ANY from group number 2 etc.
>
This is covered by the following - it says wildcards can be used - and that
I think, is what you mean by ANY:
b.   Provide an ability for the MGC to indicate to an MG the resource to
     use for a call (e.g. DS0) exactly, or indicate a set of resources
     (e.g. pick a DS0 on a T1 line or a list of codec types) via a "wild
     card" mechanism from which the MG can select a specific resource
     for a call (e.g. the 16th timeslot, or G.723).

> best regards Kimmo
Nancy

---

From: Chip Sharp <[email-masked]>
Date: Wed, 18 Aug 1999 11:55:23 -0400

>Below is my comments.

...snip...

>about it? (refer to cont. check timing).

The round-trip time will be dependent on the network design.  I don't
believe we are including requirements on network design in the
protocol.  In a practical sense, the greater the RTT, the more chance of
collisions and other anomalies.
...snip...

--------------------------------------------------
Chip Sharp                 Consulting Engineering
Cisco Systems              Telco Bio-region
Reality - Love it or Leave it.
--------------------------------------------------