Subject: Re: Topology

From: "Alessandro Mordacci (ERA)" <[email-masked]>
Date: Tue, 24 Aug 1999 19:09:30 +0200

Hello everybody,
I'd like to spend my few coins on the issue of lawful interception or legal wiretap, if you prefer.

1) It's true that a CPE residential GW is not the place for intercepting calls (also illegal in most places). On the other hand, there are applications in which it will be a requirement, like the trunking GW. For example, nothing prevents a Telecommunication Provider to build the whole network with just MGs. In that case the law oblige you to have at least some of them to provide interception (see also point 3). If, where and how it will be safe to send the interception is an implementation and operational issue, but the protocol should support it.

2) As Brian correctly pointed out, we do not need any wiretapping device connected to the MG. The call content is usually delivered with a normal call. It IS set-up on a call by call basis. Inside the network, the call that delivers the speech/data to the monitoring center is just like any other call. There are also hardware-based methods still used around, but they are losing favor because they are inflexible and they are too visible. I don't think they need support in megaco, because they are mostly external to the MG (as far as I know).

3) I also think that megaco should only care about intercepting the communication at the "media" level. If there is an interception at the network level, this is not something that megaco needs to worry about (with network level I mean in a router). Also, to be honest, I dont know if an interception in a router can establish a correlation between the control and user plane information able to stand up in a court. And, there is not always a 1 to 1 correspondence between IP address and interception target.

4) You can have a lot of different topologies. For example, if you have a call between A and B, you can have FBI monitoring A AND another agency monitoring B (in the same call). Or, you can have A and B monitored with two independent calls to a monitoring center (would you like to mix the channels in an ISDN data call?). Or any combination...

Regards,

Alessandro

---

From: Christian Huitema <[email-masked]>
Date: Tue, 24 Aug 1999 13:48:39 -0400

At 07:09 PM 8/24/99 +0200, Alessandro Mordacci (ERA) wrote:

>4) You can have a lot of different topologies. For example, if you have a
>call between A and B, you can have FBI monitoring A AND another agency
>monitoring B (in the same call). Or, you can have A and B monitored with two
>independent calls to a monitoring center (would you like to mix the channels
>in an ISDN data call?). Or any combination...

I think we have some confusion between "monitoring a call" and "monitoring
a transmission direction." As far as I can tell, when the police builds a
wiretap, they are interested in the whole call, not in just what one of the
parties says. Suppose that the FBI is monitoring A and the Swedish police
monitoring B (do they actually do that in Sweden?). Then the FBI will have
a call originating from gateway A, and the Swedish police a call
originating from gateway B.  None of them will know that the other is also
monitoring the call.

My point is, you can easily do that with a basic star topology.
Christian Huitema