Subject: Re: CAS packages (Re: Aspect of IP and Sat digital telephony not considered by sigt ran)

From: [email-masked]
Date: Thu, 26 Aug 1999 17:39:21 +0530

Brian,
           Since it is very important that  "We have one way to do this", it is
time now that we thrash this issue
   and decide on it.

Regards,

Vikas Bajaj
Gateway Development Team
Hughes Software Systems Ltd.

Brian Rosen <[email-masked]> on 08/26/99 04:56:20 AM

Please respond to Brian Rosen <[email-masked]>

To:   [email-masked]
cc:    (bcc: Vikas Bajaj/HSS)

Subject:  Re: CAS packages (Re: Aspect of IP and Sat digital telephony not
      considered by sigt ran)

You CAN do a lot of things with the MEGACO protocol.
That doesn't mean you SHOULD do them!

Defining a package for PRI is a good example.  Yes, you
can do this.  But should you?  I don't think so.
The assumption so far is that the MGC terminates CCS,
using SIGTRAN for transport.

We want ONE way to do this, not 2 ways.  2 ways means incompatibility
unless I force everyone to implement both (or at least the
MGC).  In this case, I would argue strenuously that it would
be a BAD idea to have two ways to do Q.931.

We have been having the CAS debate for a long time.
I have been in favor of translation to Q.931 with SIGTRAN,
but more than anything I want ONE way to do CAS.

If we do CAS with a package, then:
        That is the ONLY way we should do CAS
        The package should cover all national variants
                or be easily extendable to do so.

There have been several people who have offered the opinion
that unless there is a short, guaranteed roundtrip time
between MG and MGC, that doing CAS with events is impossible.
Others believe that, with ONE level of embedding, it can be
done.  I have yet to see the latter, but I allow that it
might be possible.  There is certainly not a guaranteed,
relatively short round trip MG-MGC time.

Brian

> -----Original Message-----
> From: Boris Bekkerman [mailto:[email-masked]]
> Sent: Wednesday, August 25, 1999 5:59 PM
> To: [email-masked]
> Subject: Re: CAS packages (Re: Aspect of IP and Sat digital telephony
> not considered by sigt ran)
>
>
> Matt,
>
> Your assumption is that MGC already supports backhauling of
> PRI D-channel. This
> may not be always the case for PRI gateways. For example, I
> can create a PRI
> package that defines events and signals sufficient enough to
> pass all signaling
> information between MG and MGC. In fact, MEGACO architecture
> promotes this
> option instead of relying on the yet another protocol. The
> same argument, I
> think, is applicable to R2 signaling.
>
> Boris Bekkerman
>
>
>
>
>
> Matt Holdrege <[email-masked]> on 08/25/99 11:55:17 AM
>
> Please respond to Matt Holdrege <[email-masked]>
>
> Sent by:  Matt Holdrege <[email-masked]>
>
>
> To:   [email-masked]
> cc:    (Boris Bekkerman/MW/US/3Com)
> Subject:  Re: CAS packages (Re: Aspect of IP and Sat digital
> telephony not
>       considered by sigt ran)
>
>
>
>
> At 09:51 AM 8/25/99 +0530, [email-masked] wrote:
>
>
> >Matt,
> >        Given that the major part of R2 signaling protocol
> will have to be
> >handled at the MG (to reduce the call
> >   setup time and to keep the country variants out of the
> MGC), only the
> >significant events necessary for call
> >    control need to be reported to the MGC. This can be done
> either by
> >backhauling as suggested in your mail
> >    below or using the concept of packages defined by the
> MEGACO protocol.
> >
> >    The latter of the two approaches is consistent with the
> basic MEGACO
> >philosophy that all media related
> >    stuff should be handled by the MEGACO protocol. This
> will also avoid
> >unnecessary complexity at the MG of inetrworking/translation
> from R2 to DSS1.
>
> How is R2 to DSS1 any harder than an R2 to MEGACO/R2 package?
> It's the same
> messages coming in and going out. It's just one format versus another.
> Since the MGC already is digesting DSS1 messages from a PRI D
> channel, it
> is easier for the MGC to do the same for R2. By sending R2 messages in
> MEGACO, you have lost that coupling and have to implement yet another
> scheme in the MGC.
>

---

From: Matt Holdrege <[email-masked]>
Date: Thu, 26 Aug 1999 08:51:11 -0700

I thought for Q.931 it had already been decided as it is a work item for
the SIGTRAN WG.