Subject: Re: Transport layer interface

From: Brian Rosen <[email-masked]>
Date: Sat, 28 Aug 1999 16:46:22 -0400

Yeah, I understand.

The issue is whether we have this text that describes an interface that
doesn't exist, for a set of transports that aren't defined.  ALF isn't
up for discussion -- it's in there.

I offered a compromise - make it an informative annex with an appropriate
disclaimer.  So far, no takers.

Like many things, nice neat boundaries are very useful teaching devices.
In practice, you most often get better results when you aren't so pristine.

Brian

> -----Original Message-----
> From: Hong Liu [mailto:[email-masked]]
> Sent: Friday, August 27, 1999 2:19 PM
> To: [email-masked]
> Subject: Re: Transport layer interface
>
>
> Brian,
>
> I think Rex is entitled to have his opinion on this subject.
> But I don't think the intent
> of this thread is to remove ALF from the protocol spec.
>
> ALF is already there, and was shown to work in similar
> context as MEGACOP/ H.248. I
> believe it has EVERY reason to be in the protocol spec as it
> is. What else status you
> want than this?
>
> I don't think there was a consensus in Berlin to remove ALF.
> So there is no point in
> revoking what was agreed in Oslo.
>
> --Hong
>
> Rex Coldren wrote:
>
> > Brian,
> >    Well, clear and decisive conclusions from Santiago and
> Berlin have easily
> > been reversed so I expect that this one can be too.  ALF
> has no place in the
> > protocol spec.  It should be required to stand on its own
> as a transport mechanism
> > just as SCTP has been required to do.  Once ALF reaches the
> status required,
> > we can reference it from the H.248/MEGACO protocol spec.
> So far, I believe
> > ALF is probably far behind SCTP in achieving the status
> required for such
> > inclusion.  This is the normal way of doing things.
> >
> >    Now if you're really desperate to include this kind of
> thing in the protocol spec,
> > I think you need to bend a little and allow for other
> not-yet-standard concepts to
> > be included (e.g.-the transport layer interface, SCTP, etc.).
> >
> > Rex
> >
> > Brian Rosen wrote:
> >
> > > It was clearly and decisively concluded in Oslo that
> there was a consensus
> > > that ALF using UDP should be one of the transport
> mechanisms.  Similarly,
> > > TCP had a strong consensus.  SCTP was discussed, and
> there was, at that
> > > time, no consensus.
> > >
> > > This debate is NOT about which tranports Megaco/H.248
> should be defined
> > > for.  It is whether defining an abstract layer to
> describe the interface
> > > between the protocol and some undefined, future, non-IP
> transport is
> > > appropriate.
> > >
> > > It has the curious characteristic that it's absence will
> not be missed -
> > > there are no protocols defined using it, and it's use or
> non use would not
> > > change externally visible behavior.  In particular, it is
> missing the
> > > following statement:
> > > "NOTE: The abstract layer DOES NOT define nor suggest an
> IMPLEMENTATION's
> > > interface between protocol and transport.  It is strictly
> a convenience for
> > > describing transports.  Not all transports are, or will
> be described using
> > > this abstraction."
> > >
> > > I'm in the mood for a compromise.  Suppose we take the
> text, add the
> > > disclaimer, and move it to an INFORMATIVE annex.
> > >
> > > Brian
> > >
>

---

From: Mike Buckley <[email-masked]>
Date: Sun, 29 Aug 1999 16:03:39 +0000

Brian,

>ALF isn't up for discussion -- it's in there.

I thought the purpose of the mailing lists was to hold a discussion?

Mike

____________________ Begin Original Message
___________________________
Date: Sat Aug 28 16:46:22 -0400 1999
From: internet!ENG.FORE.COM!brosen (Brian Rosen)
Subject: Re: Transport layer interface
To: internet!STANDARDS.NORTELNETWORKS.COM!MEGACO
Content-Type: Generic-Text
Content-Length: 3411

Yeah, I understand.

Brian