Subject: Re: Topology

From: "Alessandro Mordacci (ERA)" <[email-masked]>
Date: Wed, 25 Aug 1999 09:48:51 +0200

No, you have different agencies in the very same country. To be clear, I do not care of Sweden more than any other country :-)

        I agree that we could do that in a lot of ways, the point is to agree on one. It seems to me that the topology is a very clear model of what is going on.
        Alessandro Mordacci

> -----Original Message-----
> From: Christian Huitema [SMTP:[email-masked]]
> Sent: Tuesday, August 24, 1999 7:49 PM
> To:   Alessandro Mordacci (ERA); [email-masked]
> Subject:      Re: Topology
>
> At 07:09 PM 8/24/99 +0200, Alessandro Mordacci (ERA) wrote:
>
> >4) You can have a lot of different topologies. For example, if you have a
> >call between A and B, you can have FBI monitoring A AND another agency
> >monitoring B (in the same call). Or, you can have A and B monitored with two
> >independent calls to a monitoring center (would you like to mix the channels
> >in an ISDN data call?). Or any combination...
>
> I think we have some confusion between "monitoring a call" and "monitoring
> a transmission direction." As far as I can tell, when the police builds a
> wiretap, they are interested in the whole call, not in just what one of the
> parties says. Suppose that the FBI is monitoring A and the Swedish police
> monitoring B (do they actually do that in Sweden?). Then the FBI will have
> a call originating from gateway A, and the Swedish police a call
> originating from gateway B.  None of them will know that the other is also
> monitoring the call.
>
> My point is, you can easily do that with a basic star topology.
> Christian Huitema

---

From: Michael Thomas <[email-masked]>
Date: Wed, 25 Aug 1999 10:12:15 -0700

Alessandro Mordacci (ERA) writes:
 >         I agree that we could do that in a lot of ways, the point
is to agree on one. It seems to me that the topology is a very clear
model of what is going on.

  The general problem with this model is that if
there are *any* untrustable MG's in your network
which can talk to either another trusted or
untrusted MG, you cannot use MG based snooping in
the general case. Since I think that is the norm
going forward in a whole lot of networks, it makes
me wonder why one would want to go to great
lengths to build a wiretap infrastructure which
won't scale to present or future packet based
voice networks. This is especially true when what
is required to suppport it adds a fair bit of
complexity to the MG and MGC.
  Even for pure transit networks where everything
is trusted the edge snooping technique works. It
most likely could be a permutation of the same
device as is going to be necessary for the
untrusted MG situation.

                Mike

---

From: John Segers <[email-masked]>
Date: Thu, 26 Aug 1999 09:15:36 +0200

Mike,

I think it is beside the point whether a network may contain untrusted
MGs: if a particular MG cannot be trusted, e.g. because it is located on
the customer premises, you don't implement the wiretap in that MG.  This
does not mean that we should just ignore the legal intercept
requirements altogether in MEGACO.  A trunking GW would normally be a
trusted device, right?

One other thing: couldn't your edge device be a service-provider-owned
access GW with a bunch of DTMF lines connected to regular phones?  Such
a device could be controlled by means of MEGACO/H.248.

John

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: Michael Thomas <[email-masked]>
Date: Thu, 26 Aug 1999 12:40:14 -0700

> requirements altogether in MEGACO.  A trunking GW would normally be a

   You've misunderstood my intent here. A service
provider must provide the ability to do lawful
intercept. If part of the overall system has
untrusted MG's, and those untrusted MG's can have
a bearer channels between them, then from an
overall system standpoint putting lawful intercept
on the TGW doesn't solve the whole problem; I
still need to provide a method to tap the
untrusted MG's traffic. Therefore, it seems to me,
that the whole problem reduces to the problem of
the *untrusted* MG. Since the solution for the
trusted MG can most likely be solved in the same
fashion as the untrusted MG (which is easy: just
declare that you don't trust the TGW :-), then I
wonder what the point is of solving the problem
for the less general case.

 > a device could be controlled by means of MEGACO/H.248.

   Yes, of course, but that doesn't say whether
the LEA's trust it from being tampered with. I
don't think we get to make that decision :-)

                Mike

---

From: John Segers <[email-masked]>
Date: Fri, 27 Aug 1999 11:25:31 +0200

Mike,

Is your argument then that
- devices controlled by means of MEGACO/H.248 can in general not be
trusted and legal intercept should not be implemented on any of them
- there are other types of devices that can all be trusted and legal
intercept should be implemented there?

I'm curious to what other types of devices you have in mind then.

John