Subject: Re: Topology

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 25 Aug 1999 18:14:41 -0500

This seems to make a lot of sense.  Scott: should we line up a legal
interception BOF for the next meeting?

> -----Original Message-----
> From: Brian Rosen [SMTP:[email-masked]]
> Sent: Wednesday, August 25, 1999 6:06 PM
> To:   Taylor, Tom-PT [CAR:B901-I:EXCH];
> [email-masked]
> Subject:      RE: Topology
>
> I think supporting CALEA, and similar national
> wiretap laws in VoXXX networks requires a careful
> system design.  It affects MGs, MGCs, edge routers,
> and possibly other elements.
>
> If every group tried to meet the requirements independently,
> the resulting "system" is guaranteed to not meet all
> the requirements, and have wasteful duplication.
>
> I suggest:
>       Wiretap be deferred to Version 2
>       The IESG and the ITU get together a group
>               to do the system design.  This needs to
>               include:
>                       From IETF:
>                               MEGACO
>                               MMUSIC
>                               IPTEL
>                               ?Security?
>                               ???? Others
>                       From ITU
>                               SG16
>                               SG11
>                               ???? Others
>       When the system design is complete, the various groups
>               need to hammer out implementations
>
> Doing it piecemeal will fail.  We are wasting effort.
> Doing it right is practical.  It will succeed.
> The vendors (and operators) HAVE to implement it.
> It's in everyone's best interest to coordinate a
> sensible systematic design and implementation effort.
>
> Brian
>
> > -----Original Message-----
> > From: Tom-PT Taylor [mailto:[email-masked]]
> > Sent: Wednesday, August 25, 1999 1:40 PM
> > To: [email-masked]
> > Subject: Re: Topology
> >
> >
> > I have sympathy with the argument that there should be a
> > general solution
> > for wiretapping, since its scope extends beyond telephony.
> > On the other
> > hand, we still have to handle operator break-in, which has a similar
> > selective requirement.
> >
> > We're in an odd position -- support for wiretapping is
> > certainly listed as
> > one of our requirements, while operator break-in is not.  In
> > the end the
> > IESG won't OK our work if we don't meet all of our requirements.
> >
> > > -----Original Message-----
> > > From: Michael Thomas [SMTP:[email-masked]]
> > > Sent: Wednesday, August 25, 1999 1:12 PM
> > > To:   [email-masked]
> > > Subject:      Re: Topology
> > >
> > > Alessandro Mordacci (ERA) writes:
> > >  >       No, you have different agencies in the very same
> > country. To be
> > > clear, I do not care of Sweden more than any other country :-)
> > >  >
> > >  >         I agree that we could do that in a lot of ways, the point
> > > is to agree on one. It seems to me that the topology is a very clear
> > > model of what is going on.
> > >
> > >   The general problem with this model is that if
> > > there are *any* untrustable MG's in your network
> > > which can talk to either another trusted or
> > > untrusted MG, you cannot use MG based snooping in
> > > the general case. Since I think that is the norm
> > > going forward in a whole lot of networks, it makes
> > > me wonder why one would want to go to great
> > > lengths to build a wiretap infrastructure which
> > > won't scale to present or future packet based
> > > voice networks. This is especially true when what
> > > is required to suppport it adds a fair bit of
> > > complexity to the MG and MGC.
> > >   Even for pure transit networks where everything
> > > is trusted the edge snooping technique works. It
> > > most likely could be a permutation of the same
> > > device as is going to be necessary for the
> > > untrusted MG situation.
> > >
> > >                 Mike
> >

---

From: Christian Groves <[email-masked]>
Date: Thu, 26 Aug 1999 11:31:50 +1000

I see several issues here:

1. Legal Intercept in the Internet/IP networks
2. Topology in Megaco/H248
3. Context Parameters

Issue 1:
I agree with Brian that its a wide issue. Several bodies are already are
looking at the issue. A BOF may be started (it may be duplicating work)
but I think this goes across IETF Areas - Transport, Security, O&M? and
getting an output by January I think would prove to be an impossible
task. Legal Intercept is a requirement that we have from day 1 version 1
and we will not be able to roll out networks without it. We can however
take this requirement and implement what is necessary for Megaco/H.248.
It may not be applicable to residential gateways but when we design a
general purpose protocol we need to cover other MG type requirements.

Issue 2:
Topology is not just Legal Intercept, Tom also mentioned the case of
Operator breakin and then there's general monitoring of terminations. We
shouldn't get hung up on the LI case. Therefore there's several
requirements to have it.

Issue 3:
Topology is just one of many possible Context parameters. We need to
make an update to the H.248/Megaco syntax to allow placing parameters on
a context. Like many other parameters they are optional, you don't have
to support this in your gateway if you don't want to.

Cheers, Christian