Subject: H248 Adding and Deleting Streams

From: Christian Groves <[email-masked]>
Date: Tue, 31 Aug 1999 22:58:08 +1000

G'Day all,

I've been checking through the protocol to see if there is a mechanism
for deleting streams from a termination. The 'subtract' command removes
a termination and all associated stream from a context. The 'modify'
doesn't allow for deleting an individual or range of streams.

It seems to me that the ability to add and delete individual streams
from a termination would be a good thing.

Does anybody have any ideas on this?

Cheers, Christian

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 31 Aug 1999 20:18:23 -0500

Wouldn't setting mode to inactive and leaving it there do the job?  Remember
that you will have multiple terminations and context parameters all
referring to a given streamID.  I assume that here we're talking about
deleting participation in a given stream at one termination only.

> -----Original Message-----
> From: Brian Rosen [SMTP:[email-masked]]
> Sent: Tuesday, August 31, 1999 5:54 PM
> To:   [email-masked]
> Subject:      Re: H248 Adding and Deleting Streams
>
> Christian
>
> Good observation.
>
> Adding a stream is easy, Modify can do that.
> Deleting a stream isn't there.
>
> The simplest way I can imagine defining delete is to
> have a value for Mode which is delete.  Then you would
> say:
>
> ...Modify=<tid>{Media{Stream=3{LocalControl{Mode=Delete}}}}
>
> It's pretty ugly, but it's simple and unambiguous.
>
> We COULD allow Subtract to be stream specific, with a
> default of (no stream specified as) delete the termination.
> ...Subtract=<tid>{Media{Stream=3{}}}
> I'm less exited about that than the first alternative.
>
> I think adding a new command is even worse:
> ...DeleteStream=<tid>{Media{Stream=3{}}
>
> I don't like it because adding a stream is done with Modify
> (and should be done with Modify unless you demand that
> EVERY   stream, including the first one be done with
> something like an AddStream, which breaks all the current
> syntax, especially the dictum that audio only be stream
> invisible).  Also, modifying a stream is done with Modify.
>
> So, I'm back to mode=delete
>
> Brian
>
>
>
>
>
>
> > -----Original Message-----
> > From: Christian Groves [mailto:[email-masked]]
> > Sent: Tuesday, August 31, 1999 8:58 AM
> > To: [email-masked]
> > Subject: H248 Adding and Deleting Streams
> >
> >
> > G'Day all,
> >