Subject: base packages

From: Michael Thomas <[email-masked]>
Date: Fri, 27 Aug 1999 10:33:46 -0700

I've been looking through the requirements to
figure out which base packages must be annexes of
H.248, and of course it just lists things in terms
of requirements, not how the packages need to be
structured to accommodate the requirements.

So, I guess, I'd like to start a discussion about
those packages. We've been sort of dancing around
this issue with R2, so here goes...

First of all, are we all in agreement that the
normative text for all of the packages must be
present in the H.248 recommendation which is
supposed to be complete in November and up for
determination in February? That seems pretty
straightforward to me (a base H.248 without
packages is useless), but I'm prepared to hear
that others will see it differently.

If we take the base media requirements:

Trunk+ISUP
Trunk+MF        (does this include PBX style CAS?)
ISDN PRI        (does this include BRI too? the requirement
                 mentions access)
Analog POTS     (I notice that the requirement doesn't
                 include analog modem; was this on
                 purpose?)
Restricted      (not quite sure what this is)
Capability
Gateway

Application     (ivr's and friends)
Termination

Multimedia      (is there anything to do here, except
H.323            support other media types than audio?)

Multimedia
H.320

and then if we look at the packet side:

IP/RTP
ATM             (aal1 and aal2 only I assume)
FR

(I don't think that ISDN and SS7 count as
packet transports, but if other people have
other ideas we should discuss that.)

Therefore, I'll take a stab at what the
actual packages should be to support all
of the requirements:

1) Trunk/ISUP: this seems pretty straighforward
2) Trunk/MF: "simple" kinds of MF signaling where
     the MG can easily terminate the signaling
3) Trunk/R2: another package which adds the
     complexity necessary to drive much more
     complicated interactions. Or not, if backhaul
     is The answer.
4) Trunk/PRI: I don't think there is a requirement
     for H.248, unless we need analogous things
     to COT and that sort of thing as in
     Trunk/ISUP. I'm assuming D channel backhaul,
     of course.
5) Line/ISDN: is this a requirement? Does it make
     any sense?
6) Line/Analog: must support all of the class
     features, etc, etc. Should there be different
     "sub" packages for DTMF, say?
7) Application/Announcement: does it make sense to
     break this into two packages for send only
     annoucement servers, or just fold them
8) Application/Wiretap: we need to define the
     scope of this in H.248. My sense is that what
     needs to be defined here is a H.248 control
     of a routing/switching network element, but
     others disagree (or they think it can more
     limited).
9) Multimedia: sounds like there may be many
     packages involved here. I'm not very up
     to date here, so I'll defer that to people
     who know more.
10) IP/RTP: needs to cover the base RTP needs,
    but also QoS (diff/integrated), RTP crypto
    (including cipher suite negotiation?) Also
11) ATM/AAL1: may need to include SVC support.
    any security issues?
12) ATM/AAL2: almost certainly needs to include
    AVC support. I hear that AAL2 security is
    being worked on(?) should that be included?
13) FR: at base we need to incorporate all of the
    annexes of FRF.11

The Big Question:

The one big question I have for a lot of these is
how we deal with National varients. The line
variety (the one I'm most familiar with) is
riddled with national variations. My general
opinion is that normative packages should be
*fully* specified (down to cadences, frequencies,
and the like). This pretty much implies that there
will be many national variants.

If we take that as a given (which I know not
everybody agrees with me), then would it be
sufficient to pick one national variety as being
the template/style that all other varients should
follow as much as possible? This seems like a
sensible compromise to me and avoids having
underspecified normative text which I think would
be big mess. Even if we had a parametric
representation of the package in terms of national
variations, it does *not* remove the requirement
to make certain that each national varient can be
represented with the 1:1 mapping implied in the
parametric representation.

Anyway, grist for the mill, hopefully.

                Mike

---

From: Gunnar Hellstrom <[email-masked]>
Date: Fri, 27 Aug 1999 23:31:29 +0200

There is a need for packages for V.18/T.140 text telephony on the analogue
Trunk/Access side

And in general support for media type text/T140 on the IP side.

This is reflected in the requirements spec in
"11.2.4.  Trunking/Access Gateway with text telephone access ports"
---------------------------------------------------------------------------

Other packages may be influenced by the text conversation needs:
Media type text/T140 carried by H.224, Client ID 02 in H.320 to be gated to
text/T140 carried by TCP or RTP in H.323.

The other channels for T.140 may also need to be covered:
text/T140 carried by AL1 in H.324 and H.324M
text/T140 carried by T.134 in T.120.

They are just to be added as one of the media in the general multimedia
case.

Regards
Gunnar Hellström
______________________________________
Gunnar Hellström
L M Ericsson

Tel +46 751 100 501
Fax +46 8 556 002 06
Video +46 8 556 002 05
Txt (All kinds) +46 8 556 002 05
E-mail [email-masked]
WWW:     http://www.omnitor.se

> -----Ursprungligt meddelande-----
> Från: Media Gateway Control (megaco)
> [mailto:[email-masked]]För Michael Thomas
> Skickat: den 27 augusti 1999 19:34
> Till: [email-masked]
> Ämne: base packages
>
>