Subject: Re: Aspect of IP and Sat digital telephony not considered by sigt ran

From: Brian Rosen <[email-masked]>
Date: Wed, 18 Aug 1999 09:24:45 -0400

I don't think this thread has much to do with sigtran.
It does have relevance to megaco, and maybe others.

Can someone dig out the format of this parameter?  Maybe
we should add it to the localDescriptor.

Brian

> -----Original Message-----
> From: Adams, Richard Anthony (Richard) [mailto:[email-masked]]
> Sent: Wednesday, August 18, 1999 9:07 AM
> To: [email-masked]
> Subject: Re: Aspect of IP and Sat digital telephony not considered by
> sigt ran
>
>
> ITU ISUP are working (or maybe have agreed) a parameter in
> some of their
> messages called (I think!) geodetic location. It's linked to GPS.
>
> > ----------
> > From:         Spencer Dawkins[SMTP:[email-masked]]
> > Reply To:     Spencer Dawkins
> > Sent:         Wednesday, August 18, 1999 1:30 PM
> > To:   [email-masked]
> > Subject:      Re: Aspect of IP and Sat digital telephony
> not considered by
> > sigt ran
> >
> > I am NOT current on the topic, but two or three years ago I
> know that
> > there
> > was a requirement being discussed in the US to present 911 location
> > information for 911 ("emergency", for non-North American
> readers) calls
> > from
> > PBXs, and from cellular phones - both of which typically weren't
> > presenting
> > anything useful at the time.
> >
> > It's certainly worth noticing the possibility and checking it out.
> >
> > Which IETF working group should worry about this? I don't know.
> >
> > Spencer
> >
> > > -----Original Message-----
> > > From: Brian Rosen [SMTP:[email-masked]]
> > > Sent: Wednesday, August 18, 1999 7:31 AM
> > > To:   [email-masked]
> > > Subject:      Re: Aspect of IP and Sat digital telephony
> not considered
> > by
> > > sigt ran
> > >
> > > I moved this to megaco.
> > >
> > > There is a key issue here:
> > > > Among other things, the law would force U.S. telephone
> > > > companies to give
> > > > the FBI the technical ability not only to tap into
> wireless telephone
> > > > calls but also pinpoint the calls' point of origin.
> > > Depending on the exact wording of the act, we may get off on
> > > a technicality but the "calls' point of origin" on a data
> network cannot
> > > usually be determined in a geographic sense.
> > >
> > > Looking forward, I wonder if we should have some standard way
> > > to report location?
> > >
> > > Brian
> > >
> > > > -----Original Message-----
> > > > From: [email-masked] [mailto:[email-masked]]
> > > > Sent: Tuesday, August 17, 1999 6:10 PM
> > > > To: [email-masked]
> > > > Subject: Aspect of IP and Sat digital telephony not
> considered by
> > > > sigtran
> > > >
> > > >
> > > > (this is only for general amusement, but it will play into IP
> > > > telephony
> > > > in future)
> > > >
> > > > Friday, July 16, 1999
> > > >
> > > > Tiny TMI trapped in FBI's national security web;
> > > > FBI objects because it can't wiretap satellite phone calls
> > > >
> > > > Peter Morton
> > > > Financial Post (Canada)
> > > >
> > > >
> > > >  Dave Chan, National Post
> > > > Ted Ignacy of TMI Communications says his firm is blazing the
> > > > trail for
> > > > other satellite phone firms -- at the price of a tussle
> with the FBI.
> > > >
> > > >
> > > > WASHINGTON - All tiny TMI Communications Inc. wanted
> was to sell its
> > > > satellite telephone service in the United States.
> > > >
> > > > Little did the Ottawa-based firm owned by BCE Inc. and
> Telesat Canada,
> > > > know that, before long, its application would be swept
> up in a complex
> > > > web that includes the FBI, the major U.S. government
> departments, and
> > > > ultimately the White House -- with nothing less than
> the integrity of
> > > > America's national security at stake.
> > > >
> > > > The FBI is continuing to block TMI's 16-month-old bid
> to get a licence
> > > > that would allow it to sell mobile telephone service to
> > > > Americans. That's
> > > > because new U.S. wiretap laws demand the FBI be able to
> listen to all
> > > > kinds of telephone calls, including ones on satellite
> telephones.
> > > >
> > > > But the agency cannot easily do this in TMI's case, because
> > > > the company
> > > > is in Canada.
> > > >
> > > > "The nightmare scenario for us is the word gets around
> in the drug
> > > > trafficking community that the thing to do if you are a
> Detroit drug
> > > > trafficker or a New York one or a New Orleans one, for that
> > > > matter, is to
> > > > go to a telephone reseller in Toronto," said one senior
> U.S. Justice
> > > > Department official. "And that shows up on the system
> as a Canadian
> > > > person."
> > > >
> > > > From the FBI's perspective, it cannot legally use the
> evidence from a
> > > > wiretap on TMI's equipment because it cannot prove the call
> > > > was made on
> > > > U.S. soil or by an American.
> > > >
> > > > TMI is not alone in getting caught up in the FBI's new
> > > > national security
> > > > concerns. Iridium LLC, the troubled U.S. satellite company,
> > > > is facing the
> > > > same FBI objections because of its plans to build a
> groundstation in
> > > > eastern Canada to serve the U.S. northeast. The
> groundstation has been
> > > > temporarily shelved because of Iridium's restructuring.
> > > >
> > > > As well, Globalstar Canada LP, a partnership of U.S.
> Globalstar and
> > > > Canadian Satellite Communications, is facing a similar FBI
> > > > threat because
> > > > of its plans to use groundstations in Smith Falls, Ont., and
> > > > High River,
> > > > Alta., to reach the market in the United States.
> > > >
> > > > But TMI is the first to run the new U.S. national security
> > > > gauntlet and
> > > > is now being seen by dozens of other satellite companies as
> > > > the stalking
> > > > horse for how wiretapping will be handled on the cutting edge of
> > > > telephone technology.
> > > >
> > > > "And we're just a rinky-dink company," said Ted Ignacy, TMI's
> > > > vice-president of finance.
> > > >
> > > > TMI's slide into U.S. regulatory limbo began innocently
> > > > enough in March,
> > > > 1998. It was just one month after the U.S., Canada and 131 other
> > > > countries in the World Trade Organization ratified an
> > > > sweeping agreement
> > > > to liberalize telecommunications services around the world.
> > > >
> > > > "We adopt a presumption that entry by WTO member satellite
> > > > systems will
> > > > promote competition in the U.S. satellite services
> market," said the
> > > > Federal Communications Commission in trumpeting the deal.
> > > >
> > > > TMI wasted little time, becoming the first foreign satellite
> > > > telecommunications company to apply for an FCC licence.
> > > >
> > > > Largely overlooked at the time was a tiny clause
> included in the U.S.
> > > > enabling legislation. The clause said that, before the
> FCC can give a
> > > > foreign satellite company a "common carrier" licence to
> > > > operate, national
> > > > security concerns must be met first.
> > > >
> > > > But few people, even the FCC, thought that the FBI and
> its boss, the
> > > > Department of Justice, would be so worried about being
> able to wiretap
> > > > satellite telephones that they would take the
> extraordinary step of
> > > > blocking a foreign licence.
> > > >
> > > > "The FBI was somewhat late in letting us know their
> > > > concerns," said one
> > > > senior FCC official. "This is the very first time we
> had any kind of
> > > > sense the FBI had a national security concern about
> these satellites."
> > > >
> > > > The source of the FBI's worry is both simple and
> intensely complex.
> > > >
> > > > The FBI and other U.S. security agencies have been
> fretting for years
> > > > about their technical inability to track money launderers, drug
> > > > smugglers, kidnappers and murderers who are beginning
> to use the new
> > > > wireless telephone world to hide their whereabouts and
> their criminal
> > > > deeds.
> > > >
> > > > In 1994, Congress passed a law updating existing wiretap
> > > > laws, called the
> > > > Communications Assistance for Law Enforcement Act, or CALEA.
> > > >
> > > > Among other things, the law would force U.S. telephone
> > > > companies to give
> > > > the FBI the technical ability not only to tap into
> wireless telephone
> > > > calls but also pinpoint the calls' point of origin.
> Still, to do that,
> > > > the FBI must have physical access to the U.S. ground
> stations, called
> > > > gateways.
> > > >
> > > > Enactment of the law has long been delayed because of the
> > > > U.S. telephone
> > > > industry's concerns about costs, and concerns about privacy
> > > > by U.S. civil
> > > > liberties groups.
> > > >
> > > > After all that, the law will be adopted in FCC regulations this
> > > > September. However, there's a wrinkle.
> > > >
> > > > Somehow overlooked was how the FBI would get the same access
> > > > to foreign
> > > > satellite telecommunications companies with their
> gateways outside the
> > > > U.S.
> > > >
> > > > "You have technology that leapfrogs national boundaries,"
> > > > said the senior
> > > > Justice Department official. "And we have to figure out what
> > > > then is in
> > > > our national interest."
> > > >
> > > > Because it has no jurisdiction outside the United States, the
> > > > FBI wants
> > > > the ability to tap telephones from any foreign satellite
> > > > companies with a
> > > > U.S. licence, if a call is being made to what it calls
> an "American
> > > > person" -- either a U.S. citizen or a foreigner on U.S. soil.
> > > >
> > > > But that is not an easy or cheap thing to do.
> > > >
> > > > TMI is using Telsat Canada's new MSAT-1 satellite, now
> parked over the
> > > > equator, to offer satellite telephone service to as
> many as 400,000
> > > > subscribers in Central America, the Caribbean, the
> United States and
> > > > Canada. But TMI's telephone technology, at least from the FBI's
> > > > perspective, is not new.
> > > >
> > > > Ideally, what the FBI and the Department of Justice
> wants is TMI to
> > > > retrofit -- at its own expense -- all of its suitcase
> telephones to
> > > > include a global positioning satellite receiver, much like
> > > > those used in
> > > > boats and now cars. That way, the FBI reasons, the built-in
> > > > GPS receiver
> > > > could always tell whether a telephone call was being
> made to or in the
> > > > United States.
> > > >
> > > > In on-again, off-again talks between the two sides over
> the past year,
> > > > TMI balked. It argued the GPS solution was too
> expensive and instead
> > > > suggested to the Justice Department that it would simply
> > > > route all calls
> > > > it thought were being made by or to "American persons" to a
> > > > U.S. gateway,
> > > > called a "point of presence," that it would set up. There,
> > > > the FBI could
> > > > simpy tap in.
> > > >
> > > > But that would not work, countered the Department of Justice.
> > > >
> > > > The main problem, it said, is that the only way TMI call tell
> > > > if a call
> > > > is being made by a Canadian or an American is via a code
> > > > built into the
> > > > handset, which only shows where it was purchased. And that
> > > > leads directly
> > > > to the FBI's nightmare scenario.
> > > >
> > > > "This is really crucial for us," the Justice official said.
> > > > "Even if the
> > > > company is willing to bring all calls we think we can
> identify as U.S.
> > > > across the border, the problem is that we don't know
> where the call is
> > > > from but just where the subscription was purchased."
> > > >
> > > > The "bad guys," he said, would waste little time in
> figuring out that
> > > > Canada -- or another country -- is the place to buy satellite
> > > > telephones
> > > > hidden from U.S. authorities.
> > > >
> > > > Ottawa is not particularly happy about TMI's proposal
> either, saying
> > > > Canada's privacy laws may be violated if the FBI can listen
> > > > in on calls
> > > > made by Canadians.
> > > >
> > > > There has also been some talk, as well, about Canada
> and the United
> > > > States signing a bilateral agreement that would allow
> the FBI to more
> > > > easily get wiretaps in Canada.
> > > >
> > > > Again, though, that does not satisfy the Justice Department.
> > > >
> > > > "It's not the silver bullet," the official said.
> > > >
> > > > Quick to defend the close Canada-U.S. law enforcement
> > > > relationship, the
> > > > official also points to some Canadian realities: "We
> know Canadian
> > > > governments have changed over the years, your laws may
> change or you
> > > > simply would not be able to comply with the speed we need."
> > > >
> > > > And then, finally, there is the secrecy issue. U.S.
> court orders for
> > > > wiretaps are relatively rare -- about 200 a year at the state
> > > > and federal
> > > > level -- and they are only given if the FBI or other
> law enforcement
> > > > agencies cannot find another way to collect evidence.
> > > >
> > > > "The fact you are conducting electronic surveillance must be
> > > > kept secret
> > > > from the target," the Justice official said. "One of the
> > > > concerns we have
> > > > is if we go to a foreign country we have less control
> over security
> > > > conditions."
> > > >
> > > > What worries the FCC and the "open trade" side of the Clinton
> > > > administration is the dangerous message such national
> > > > security concerns
> > > > send to countries looking for ways to keep U.S.
> satellite telephone
> > > > companies out of their own markets. Other countries may adopt
> > > > U.S.-style
> > > > national security rules as a way of keeping U.S. firms out.
> > > > "We certainly
> > > > wouldn't want every other country adopting those kinds of
> > > > requirements,"
> > > > the FCC official said. "It would be expensive."
> > > >
> > > > Despite some skepticism about its motives, the FCC insists
> > > > that for its
> > > > part all it wants to see is more competition in the
> U.S. satellite
> > > > telecommunications market. "We want to reach an accommodation
> > > > that would
> > > > be reasonable but, at the same time, keep our markets open
> > > > and not impose
> > > > such onerous burdens on the industry to make it difficult for
> > > > them to do
> > > > business," said the official. "This is a high-priority issue."
> > > >
> > > > So high, in fact, that a rare inter-agency group has
> been put together
> > > > within the administration. The group includes the U.S. trade
> > > > representative, the commerce, state and treasury departments
> > > > as well as
> > > > the National Security Council in the White House. Janet
> Reno, the U.S.
> > > > attorney general, and Lawrence MacAulay, the Canadian
> > > > solicitor general,
> > > > have also talked about the stalemate.
> > > >
> > > > For its part, TMI insists it is not being unreasonable.
> > > > "We're prepared
> > > > to do what is necessary, as long as it's same
> requirement for other
> > > > carriers," Mr. Ignacy said.
> > > >
> > > > The Department of Justice is also firm in its stance,
> > > > especially because
> > > > TMI will be seen as a crucial precedent for other
> foreign satellite
> > > > companies. "We need to be able, when we have lawful
> > > > authority, to go to
> > > > the carrier at the point where they got those calls and
> > > > execute a wiretap
> > > > order," the Justice official said.
> > > >
> > > > As a result, no one believes a solution is just around the
> > > > corner. "The
> > > > timing is not tomorrow," the FCC official admitted.
> > > >
> > > > Mr. Ignacy says he takes a little comfort in the fact that
> > > > TMI is being a
> > > > trailblazer for other satellite companies.
> > > >
> > > > "We are the first," he said. "But we won't be the last."
> > > >
> > > >
> ___________________________________________________________________
> > > > Get the Internet just the way you want it.
> > > > Free software, free e-mail, and free Internet access
> for a month!
> > > > Try Juno Web: http://dl.www.juno.com/dynoget/tagj.
> > > >
> >
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 18 Aug 1999 09:58:11 -0500

There is a good question whether it would be up to the MG to query the GPS
system built into the user terminal or whether the necessary information
should be a mandatory part of the call signalling protocol.  In either case,
I would think that the same principle applies: any information coming from
an user terminal has to be taken with a grain of salt, because the user
could have tampered with it.

Leaving aside the GPS case, the only instance in which the MG could add more
information on location than the MGC already has is when the call is coming
in on an analogue line.  The TerminationID covers that one.  The relevance
to SIGTRAN comes in when ISDN is involved, and SIGTRAN might be the place
where the specific signalling interface originating the call is identified.

> Sent: Wednesday, August 18, 1999 9:25 AM
> To:   [email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Wed, 18 Aug 1999 12:01:00 -0400

I guess I'll back off.  Media gateways are gateways.  They aren't terminals.
The requirement is to identify the location
of the terminal.  The gateway probably doesn't know where the
terminal is.

Brian

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Wednesday, August 18, 1999 10:58 AM
> To: [email-masked]

---

From: Al Varney <[email-masked]>
Date: Fri, 20 Aug 1999 12:55:59 -0500

>where the specific signalling interface originating the call is identified.

   I don't understand how the MG would know more about an analog(ue) line
than the MGC.  Wouldn't any location-related information regarding a line
be provisioned at the Call Agent, rather than in a Gateway?  The MGC would
also be the place for billing information, line restrictions, etc.  The MG
should be required to have very little line-related information (loop-start
vs. ground-start, in-service vs. out-of-service) and even that could be
controlled by the MGC rather than provisioned in the MG.

   SIGTRAN should be capable of identifying an instance of a signalling
interface (a D-channel of a BRI/BRA interface, for example) using something
similar to MEGACO's TerminationID.  SIGTRAN itself should not be expected
to know/care about the "location" of that interface, any more than an MG
should know/care about the "location" of a line port.

>> It does have relevance to megaco, and maybe others.

   I disagree.  MEGACO should not internally generate or send location
information.  Any signalling by or about those interfaces may send such
information, but that's "transparent" to MEGACO.  If there is ever an
access interface requiring special procedures to query a location
(at a wireless gateway, perhaps), then that mechanism should be part of
the "package" supporting that interface.

>> we should add it to the localDescriptor.

   I believe it's in ISUP 2000 -- ITU-T Study Group 11 sent in out for
determination in March (?) and had been discussing it for a year or so.
Note that ISUP only "transports" the information; other procedures are
needed to generate it and deliver the Geodetic Location information.

It is also in the process of being added to ANSI ISUP (T1S1.3 effort) and
to ANSI ISDN (T1S1.7 effort on T1.628) for delivery to an ISDN user (PSAP).
This is for emergency services (E911 in the USA).  Also, wireless standards
in TIA (TR45.2) are developing documents:
  PN3890, Enhanced Wireless 9-1-1 Phase 2, and
  PN4288, Beyond Enhanced Wireless 9-1-1 Phase 2
for delivery of location information from wireless networks to emergency
service providers.

   Where the location information comes from, and when, is an evolving story.

Al Varney - Lucent Technologies  +1 630 224-7493    [email-masked]

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 20 Aug 1999 13:01:00 -0500

I agree with you.  What I meant was that the MG has to identify which line
the call is coming in on in the first place, and does that through the
terminationID.

> From: Al Varney [SMTP:[email-masked]]
> Sent: Friday, August 20, 1999 1:56 PM
> To:   Taylor, Tom-PT [CAR:B901-I:EXCH]
> Cc:   [email-masked]