Subject: Re: Transport layer interface

From: Brian Rosen <[email-masked]>
Date: Fri, 27 Aug 1999 08:55:13 -0400

Randall

The attractiveness of ALF is that you can make your product as
complex, or as simple, as you want.  As defined, it requires only
that you send messages in UDP packets, and you retry based on some timers.
If you want to simply queue messages and treat the queue as FIFO,
that is fine.

My implementation may take a more active approach, reordering, or even
modifying messages based on the current conditions.  That may allow
my product to be distinguished from your product, and yet they are
completely interoperable.

If you like simple, reliable mechanisms, I recommend TCP to you, but,
as Van said at the meeting, we have quite a lot of experience that says
you can achieve substantially better performance in loaded networks
when you let the application monitor and react to network conditions.

Brian

> -----Original Message-----
> From: Randall Stewart [mailto:[email-masked]]
> Sent: Thursday, August 26, 1999 5:46 PM
> To: [email-masked]
> Subject: Re: Transport layer interface
>
>
> Christian Huitema wrote:
> >
> > At 01:34 PM 8/26/99 -0700, Rex Coldren wrote:
> > >Hong,
> > >   THE reason that we balked on using SCTP as a transport mechanism
> > >is that, even though it is "mature",  it is not yet a
> standard.  I also note
> > >that
> > >ALF is not a standard and I don't believe that anyone has
> even tried to
> > >define it as such.
> >
> > ... And for a good reason. ALF is not a standard, it is a design
> > philosophy, based on the idea that "network conscious"
> applications should
> > really have direct access to the network information, not
> delegate that
> > task to a generic transport interface.
> > Christian Huitema
> Hmm..
>
> I think that we could go with this... but why not have the
> "network conscious" application fire off IP packets. No need
> to bother with UDP... it just adds an extra layer... and maybe if
> it is real aware, it could fire out ether-net frames at a even lower
> level, and thus not have to put up with any queueing that the lower
> layer drivers/streams are putting out.. This way it could get the
> aborts/reset/frees to the real head of the line....
>
> And since most applications are CPU and Memory conscious, how
> about the
> O/S? Could not a smart application better utilize the memory of the
> machine
> or the CPU instead of letting the MMU or Scheduler in the O/S
> get in the
> way?
>
> Layers are put in for a reason, they simplify the task of writting the
> application.
> And provide a way to uniformily re-use hard to implement
> concepts, such
> as
> congestion control, fault management, memory management, Bus
> arbitration,
> scheduling ... et.al...
>
> It is true that a application can improve or better utilize resources
> if it takes complete control of them, however there is a price to pay
> for this..... do we want to pay this price is the real question... if
> the
> answer is yes... then maybe the application area and the
> transport area
> of the
> IETF should be merged together? It becomes the next logical step if we
> firmly
> believe that ALF is the future...
>
> I am afraid though that I am to old fashion for this
> besides.. all I can
> visualize
> when someone says "ALF" is a small fat brown dogish looking alien that
> was on
> a TV show...
>
> It just does not work for me... :-) maybe we could find a
> better name at
> least...
>
> R
> --
> Randall R. Stewart
> Member Technical Staff
> Network Architecture and Technology (NAT)
> 847-632-7438 fax:847-632-6733
>

---

From: Ian Rytina <[email-masked]>
Date: Mon, 30 Aug 1999 18:16:06 +1000

Hi Brian,

Scott or Vern will correct me if I am wrong, but I remember
that an important concern of the Transport A-D's during the
work in Sigtran was that applications of UDP are not
perceived as having higher priority than TCP applications,
i.e. they do not flood the network at the expense of
everything else.

The upshot of this is that SCTP was steered towards specifically
using the TCP congestion control mechanisms. Is the proposed
ALF mechanism going to have the same safeguards ?

Regards,

Ian.