Subject: Alternatives in capabilities other than stream descriptors

From: Brian Rosen <[email-masked]>
Date: Fri, 13 Aug 1999 15:19:16 -0400

The Berlin text adds the capability to describe streams using a
syntax that is like the rest of the protocol, viz property=value.
It further allows alternatives and >, < and quanitity of.
At the moment, such a capability is limited to the stream
descriptor.

Audit returns descriptors other than stream descriptors, and
they need similar ability.  Today, the mechanism is repeat the
descriptor with alternate values.

IF we accept the Berlin "native" format for stream descriptors,
could we allow at least the alternative syntax foo={1,2,3}
in the other descriptors?  We could allow ><, range, etc.

Brian

---

From: Nancy-M Greene <[email-masked]>
Date: Fri, 13 Aug 1999 14:21:47 -0500

> in the other descriptors?  We could allow ><, range, etc.
see msg entitled T12) Annex D and ABNF (copied below) for ABNF for the
localDescriptor, i.e. the descriptor for information between an MGC and an
MG.

ABNF was added in Berlin for parameters in the localDescriptor (or
internalDescriptor) - allowing operations between propertyParm and its value
to be =, <, >, range, quantityOf . The following completes what needs to be
added:

(Note: We assume that quantityOf is a string like second or msecond, e.g.,
package/item # s 
package/item # ms )

The ABNF for propertyParm is: 

propertyParm = pckgdName (EQUAL PackageParm | INEQUAL VALUE) 
packageParm = VALUE | 
                           LBRKT VALUE *(COMMA VALUE) RBRKT  | 
                           LSBRKT VALUE DOT DOT VALUE RSBRKT 

; less than "<" 
; greater than  ">" 
; quantity of "#" 
INEQUAL = LWSP (">"|"<" | "#" ) LWSP 
LSBRKT   = LWSP "[" LWSP 
RSBRKT   = LWSP "]" LWSP 

Since we are using "..", "#", "=" as part of the range, and inequal defs, 
we can not use them in VALUE 

VALUE  = 1*64(SafeChar) | quotedString 
SafeChar = DIGIT | ALPHA | "+" | "-" | "_" | "&" | "!" | 
                "'" | "/" | "?" | "@" | "^" | "`" | "~" 

Therefore, SafeChar won't have ".", "#", or "=". 

Nancy Greene  &  Abdallah Rayhan

--------------------------------------------------------------------------
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]