Subject: Re: MGC Failure

From: Ashok Khuntia <[email-masked]>
Date: Tue, 24 Aug 1999 13:06:15 -0500

What if the application is such that the MG does not send any Notify (or sends very infrequently) to the MGC. All the commands are issued by the MGC and the MG just responds. How does the MG detect MGC failure in such cases?

Any comments will be appreciated.

Ashok

----- Begin Included Message -----

---

From: Michael Thomas <[email-masked]>
Date: Tue, 24 Aug 1999 18:26:04 -0700

Ashok Khuntia writes:
 > What if the application is such that the MG does not send any
Notify (or sends very infrequently) to the MGC. All the commands are
issued by the MGC and the MG just responds. How does the MG detect MGC
failure in such cases?

   Case 1: it doesn't, nor should it. This is probably
    the right thing to be done for residential
    gateways. High fan out MG's should not be
    gratuitously pinging the MGC while they are
    quiescent.

   Case 2: the MGC pings the MG periodically. The
    MG, through provisioning, can expect traffic
    from the MGC and if it does not see any, it
    can assume that the MGC has failed and
    initiate a ServiceChange to the failover MGC.

   In both cases, it keeps the traffic throttling
in the control of the MGC, which is the main focus
of traffic congestion.

                Mike