Subject: Re: T4) rx/tx Descriptor vs local/remote Descriptor

From: Abdallah Rayhan <[email-masked]>
Date: Fri, 13 Aug 1999 12:05:26 -0400

The problem is that we need to describe two descriptors that
have local semantics. How about this:

"Local" is MG-MGC
"MGLocal" is MG-MG Local
and "MGRemote" is MG-MG Remote

Every descriptor has a token that describes its intended semantics.

Does that make everyone happy ?

regards
Abdallah Rayhan

Brian Rosen wrote:

> I readily admit to not really understanding all of this issue.
>
> There needs to be a descriptor which describes items of interest
> only between the MGC and MG.  There needs to be at least one
> descriptor that is primarily of interest between the two MGs.  The
> format of the former is like that of all the other descriptors, the format
> of the latter is SDP or any other alternate we agree on.
>
> The former should be called "local".
>
> If there is indeed only one SDP/whatever descriptor, it should be
> called "remote".  If there needs to be two descriptors representing
> information of interest to the two MGs, then we need two names,
> and Tom proposed "send and receive" which I renamed "rx" and "tx".
>
> Brian
>
> > -----Original Message-----
> > From: Nancy-M Greene [mailto:[email-masked]]
> > Sent: Thursday, August 12, 1999 1:33 PM
> > To: [email-masked]
> > Subject: T4) rx/tx Descriptor vs local/remote Descriptor
> >
> >
> > > T4) Section 6.2.3.5: ***There is still an issue with tx and
> > rx descriptor
> > > names: when you do an add on the RTP termination, in the
> > response you will
> > > get params for RxDescriptor (local information). BUT it is
> > also a transmit
> > > descriptor. So, there is still a wish to call rxDescriptor the
> > > localDescriptor, and txDescriptor the remoteDescriptor. Note added.
> > >
> > There seems to be strong support for renaming the rx and tx
> > Descriptors to
> > be local and remote Descriptors - see the argument below from
> > Christian
> > Huitema, it is also the argument Chip Sharp brought up at the
> > ITU meeting.
> > When this thread happened, a number of others also preferred
> > the names local
> > and remote for these descriptors.
> >
> > From Christian Huitema's email of July 22/99 title "RE:
> > Local, RX and TX
> > descriptors":
> > I think we are drifting on the wrong track there.  In fact, I
> > believe that
> > "Tx, Rx" are soemwhat misleading names.  let's face it, it
> > always take two
> > to communicate. My prefered acronym is "local., remote", not
> > "transmit,
> > receive."  Local = my address, my port, both for transmit and receive.
> > Remote = remote address, remote prot, both for transmit and receive.
> >  True, the need to know the remote transmit port is a bit
> > fuzzy -- it only
> > provides weak security.  By definition, all these information apply to
> > simplex and duplex channels alike.
> > ---------
> >
> > Proposal:
> > - rename: localDescriptor to internalDescriptor, rxDescriptor to
> > localDescriptor, and txDescriptor to remoteDescriptor.
> > Note: internalDescriptor is information shared between the
> > MGC and the MG
> > that is not of interest to the remote MG. This could be
> > policy information
> > the MGC wants to share with the MG, such as the order in
> > which to choose a
> > codec, or it could be information such as gain or echo
> > cancellation that are
> > parameters set on the MG, but are of no interest to the other MG.
> >
> > Nancy
> > --------------------------------------------------------------
> > ------------
> > Nancy M. Greene
> > Internet & Service Provider Networks, Nortel Networks
> > T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
> >
> > --------------------------------------------------------------
> > ------------
> > Nancy M. Greene
> > Internet & Service Provider Networks, Nortel Networks
> > T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
> >

---

From: Chip Sharp <[email-masked]>
Date: Wed, 18 Aug 1999 17:02:50 -0400

Okay,  I'll try to explain what I'm thinking about.  Hopefully someone can
correct me where I mess it up.  I'm assuming that an MGC controls both MGs
used for the call.

Assume MGC is setting up a call between MG-A and MG-B.
The MGC sends an ADD to MG-A.  Included in the ADD is information about the
call that the MGC wants MG-A to use (policy stuff).  I'll call this the
LocalStuff ("LS") descriptor.

MG-A returns a session description in SDP describing the session parameters
to use for the call.  For example, for the RTP termination this would have
the IP address and port number to use for the RTP traffic.  This would be
contained in what I call the LocalDescriptor.

The MGC then contacts MG-B.  It passes the information for the call in the
LocalStuff descriptor.  It also passes the SDP received from the MG-A to
MG-B in the RemoteDescriptor.  MG-B returns its session info to the MGC in
its LocalDescriptor.

MGC then sends a MODIFY to MG-A containing a RemoteDescriptor with the
session info received from MG-B.

I guess that you could use TxDescriptor instead of RemoteDescriptor and
RxDescriptor instead of LocalDescriptor if you wish.

I found it easier to think of these descriptors as defining the remote side
and the local side of the call.

Chip

> > parameters set on the MG, but are of no interest to the other MG.

--------------------------------------------------
Chip Sharp                 Consulting Engineering
Cisco Systems              Telco Bio-region
Reality - Love it or Leave it.
--------------------------------------------------