Subject: Re: Destroying Terminations

From: Brian Rosen <[email-masked]>
Date: Fri, 20 Aug 1999 08:19:19 -0400

The text states that physical terminations return to null
context when they are subtracted, ephemeral terminations,
of which RTP is an example, are destroyed upon subtract.

Management action could conceivably destroy physical terminations, although
they are more likely just taken out of
service.

Brian

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Friday, August 20, 1999 7:01 AM
> To: [email-masked]
> Subject: Destroying Terminations
>
>
>
> I have one question.
>
> In the document, it says that we can add, and create new,
> terminations (using
> the Add command). It also says that we can remove a
> termination from a context
> (using the Subtract command), and it will then be a part of
> the null context
> (not belonging to a context). My question is: how do we, if
> it's even possible,
> remove ("destroy") a termination completely? For example, if we have a
> termination representing a RTP stream, after we've ended the
> call we might want
> to remove the termination from the MG, and not having it
> "hanging around" in
> the null context, and then create a new RTP termination next
> time we set up a
> call.
>
> Thanks,
>
> Christer
>
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 20 Aug 1999 07:28:28 -0500

Only physical terminations persist in the null context after subtraction.
RTP terminations are ephemeral, so subtraction destroys them.  As a working
definition for which Brian Rosen would probably chastise me, I see a
physical termination as one that has been provisioned in the MG rather than
created through a Megaco/H.248 command..

> From: Christer Holmberg [SMTP:[email-masked]]
> To:   [email-masked]
> In the document, it says that we can add, and create new, terminations
> (using
> the Add command). It also says that we can remove a termination from a
> context
> (using the Subtract command), and it will then be a part of the null
> context
> (not belonging to a context). My question is: how do we, if it's even
> possible,
> termination representing a RTP stream, after we've ended the call we might
> want
> to remove the termination from the MG, and not having it "hanging around"
> in
> the null context, and then create a new RTP termination next time we set
> up a
> call.
>
> Thanks,
>
> Christer
>  << File: Card for Christer Holmberg >>