Subject: Service Change Failover method

From: Chuong Nguyen <[email-masked]>
Date: Wed, 15 Sep 1999 08:31:47 -0500

draft-ieft-megaco-protocol-04.txt

Section 11.4 Failure of MGC
"It sends a ServiceChange message with a "Failover" method and a "Failed
MGC" reason."

Is or should this "Failover" method be mention in Section 7.2.8
ServiceChange?
Does Section 7.28 define all ServiceChange methods that are allowed or
there are others as Failover which
is mention in Section 11.4?

Section 7.2.4 ServiceChange

Second to last paragraph of section:
"A ServiceChange Command specifying the "Root" for the TerminationID is
a registration command by
which a Media Gateway announces its existence to the Media Gateway
Controller .......
...........   The ServiceChangeMethod shall be "forced" for this usage."

Should "forced" be "restart"?
Section 11.2 Cold Start uses "Restart".

Can I do the following?

From MGC to MG
MEGACO .....
Transaction = 5000 {
    Context = * {
        Subtract = *
    }
}

That is can I clear/remove all contexts in a MG?
Section 6.1.1 Context Properties and Descriptors said that contextID can
be ALL "*".

Section 7.2.5 AuditValue

"The following illustrates other information that can be obtained with
the Audit Command:
Context ID            TerminationID        Information Obtained"
Unspecified            all                                List of all
Terminations in the MG and the Context(s) to which they

are associated.

In which return descriptor are the "Information Obtained" as mentioned
above returned?

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Tim Vetter <[email-masked]>
Date: Thu, 16 Sep 1999 13:46:50 -0500

[snip]

> Can I do the following?
>
> >From MGC to MG
> MEGACO .....
> Transaction = 5000 {
>     Context = * {
>         Subtract = *
>     }
> }
>
> Could this be used to clear/remove all contexts in a MG?
[snip]

The grammar and the text do not appear to match on this issue.  I would
say the answer is yes, and the grammar needs to be updated.

The ABNF currently has the production:
   ContextID = (UINT32 | "-" | "$")

The 6.1.1 text says:
  "Context ID, a 32 bit integer chosen by the MG.  It may be specified
  as ALL "*" or NULL "-" in some circumstances.the topology (who
  hears/sees whom).