Subject: Does Statistics return cumulative stats?

From: Brian Rosen <[email-masked]>
Date: Mon, 27 Sep 1999 09:25:04 -0400

Remember the discussion of statistics on Move?

The decision is, you don't automatically get them,
but you can ask for them in the move.

Okay, suppose we have done a:
Context=<C1>{Add=T1{....

Later on, we specify
Context=<C2>{Move=T1{Audit{Statistics....

We clearly get the statistics of T1 while in context C2.

Now we do:
Context=<C2>{Subtract=T1{...

We get statistics on T1.  The question is, are they:
        C2 only
        C1+C2

I think you get the latter, C1+C2, implying that statistics are cumulative
while a termination exists outside of null context.

Other opinions?  Text will be added to clarify, however we decide.

Brian

------------
Brian Rosen, Principal Engineer
FORE Systems, 1000 FORE Drive, Warrendale, PA 15086
(724) 742-6826  mailto:[email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Mon, 27 Sep 1999 10:01:06 -0400

> We clearly get the statistics of T1 while in context C2.

is incorrect, we get the statistics of T1 while in context
C1 of course!

Brian

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Monday, September 27, 1999 9:25 AM
> To: [email-masked]
> Subject: Does Statistics return cumulative stats?
>
>