Subject: MegacoHGCP10 is available

From: Brian Rosen <[email-masked]>
Date: Tue, 14 Sep 1999 18:00:30 -0400

We have released a new version of the MEGACO/H.248 protocol
document.

The pdf can now be found at:
ftp://standards.nortelnetworks.com/megaco/docs/latest/megaco-h248_protocol.p
df

This link will always be maintained "current" to the latest
version that we release as an IETF draft, so you could
"bookmark" this one.

The following two links provide this version in .doc and .pdf forms:

ftp://standards.nortelnetworks.com/megaco/docs/wash99/megacoH248v10.pdf
ftp://standards.nortelnetworks.com/megaco/docs/wash99/megacoH248v10.doc

There WILL be an I-D of this version, as draft-ietf-megaco-protocol-04.txt

This will be a full text version of the document, not a pointer to the pdf
file.  It will take a few days to prepare this version, so don't look for it
on the IETF I-D sites yet.

I apologize for the delay in getting this out; we had good intentions, but
lots of issues to deal with.

Comments and suggestions are, as always, welcome.

Brian
------------
Brian Rosen, Principal Engineer
FORE Systems, 1000 FORE Drive, Warrendale, PA 15086
(724) 742-6826  mailto:[email-masked]

---

From: Ruppelt Christian <[email-masked]>
Date: Thu, 16 Sep 1999 10:33:36 +0200

Thanks for this good news!
A lot of people round the world are now reading and reviewing this paper
most of them have done it with the older ones too.
So, it would be VERY helpful, to have a small history chapter saying the
audience
and implementers what are the major changes.

Christian

---

From: Brian Rosen <[email-masked]>
Date: Thu, 16 Sep 1999 08:53:24 -0400

You are probably correct.  This release was delayed a
while to get quite a few changes made, and I stopped keeping my list of what
was done.

Here is approximately what has changed from the Berlin draft:
 * Authors have been changed
 * The boilerplate for IETF documents was updated
 * Editors notes were removed for the most part after
     addressing the issues raised
 * Most IETF references were made normative
 * Some IETF references were added
 * Definitions were reworded to fit use in the document.
 * Some defined terms no longer used were deleted
 * The section called "protocol" was broken into several
    first level sections
 * Some rewording was done to increase clarity in what is
    now section 6, Connection Model
 * The topology section was moved, and made optional to
    implement
 * "Local", "Rx" and "Tx" were renamed to be "LocalControl"
    "Local" and "Remote"
 * Wording around the "root" termination was clarified
 * "Overspecified" parameters was clarified.  In general,
     you can use overspecified (i.e. alternative)
     parameters in several additional places, not just
     local/remote.
 * Wording around event buffering was clarified
 * ServiceStates parameter was added to terminationState
 * The mode parameter has fewer options (they are now in
     ServiceStates)
 * The concept that setting Mode to delete as a way to
     remove a stream from a termination was added
 * Wording around Local/Remote was changed to improve
     clarity
 * One level of embedding was enforced
 * Clarity on digitmaps was improved
        == Note == I still need to add more explanatory
                text on the syntax of a digit map
 * It was clarified that you can specify a digit map name,
     or an actual (unnamed) digitmap value in
     EventsDescriptor
 * All commands were changed so that the parameters to
     every command is a descriptor
 * The RequestedInfoDescriptor was renamed the
     AuditDescriptor and is now allowed in
     Add/Subtract/Move/Modify.  One of the most significant
     uses for this is to get midcall statisitics on a Move
 * When wildcarding terminationIDs, each match is attempted
     on commands even if an error is encountered in one of
     the attempts.
 * ServiceChange lost Version (it's in every message) and
     gained Profile, with a version.
 * Error messages were added, numbering was alterted
        Note
                There is more work to do here
 * TransactionAccept/Reject was combined into
     TransactionReply.  Each command attempted is reported.
     If it suceeded, requested descriptors, if any are
     returned.  If it failed, an ErrorDescriptor is
     returned.
 * Errors for higher level constructs (indecipherable
     transactionRequest, for example, were added
 * Examples were updated, and moved to an Annex
 * The transport "layer" definition was removed
 * TCP and UDP/ALF transports were moved to annexes
       it is anticipated that additional non-ip transports
       which use the layer definition will be offered as
        additional annexes.
 * Guidelines for defining packages were added
 * Packages can now define statistics
 * The standard statistics are removed
 * The IANA considerations section was reworked
 * An IETF author contact section was added
 * The ABNF has undergone substantial editing to conform
     to the above changes

Brian

> -----Original Message-----
> From: Ruppelt Christian [mailto:[email-masked]]
> Sent: Thursday, September 16, 1999 4:34 AM
> To: [email-masked]
> Subject: AW: MegacoHGCP10 is available
>
>