Subject: Re: Service Change Failover method

From: Brian Rosen <[email-masked]>
Date: Thu, 16 Sep 1999 15:11:52 -0400

Well it looks like we have a conflict all right.
Should we allow ALL in ContextID?

Please remember that there is not anything that limits
the size of a transactionReply.  If you have 1000 contexts
active and each has an average of 2 terminations, your reply will have 2000
statistics descriptors if you
were to execute Transaction=1234{ Context=*{ Subtract=*}}}
If each statistics descriptor was 200 bytes, your
reply would be 200 * 2000 or 400K in a single transaction reply.  Buffer
overruns might be a problem.

Brian

> -----Original Message-----
> From: Tim Vetter [mailto:[email-masked]]
> Sent: Thursday, September 16, 1999 2:47 PM
> To: [email-masked]
> Subject: Re: Service Change Failover method
>
>
> [snip]
>
> > Can I do the following?
> >
> > >From MGC to MG
> > MEGACO .....
> > Transaction = 5000 {
> >     Context = * {
> >         Subtract = *
> >     }
> > }
> >
> > Could this be used to clear/remove all contexts in a MG?
> > Section 6.1.1 Context Properties and Descriptors said that
> contextID can
> > be ALL "*".
> >
> [snip]
>
> The grammar and the text do not appear to match on this
> issue.  I would
> say the answer is yes, and the grammar needs to be updated.
>
> The ABNF currently has the production:
>    ContextID = (UINT32 | "-" | "$")
>
> The 6.1.1 text says:
>   "Context ID, a 32 bit integer chosen by the MG.  It may be specified
>   as ALL "*" or NULL "-" in some circumstances.the topology (who
>   hears/sees whom).
>

---

From: Jennifer Liu <[email-masked]>
Date: Thu, 16 Sep 1999 14:55:55 -0500

> Should we allow ALL in ContextID?

Using All "*" wildcard in subtract command would be very useful if we want to
reset all terminations on MG,  for example, after MGC outage or other system
error conditions.   Indeed buffer overrun might be a problem if we have a
large number of active contexts on MG, so is it possible to send the
statistics in multiple reply message when they exceeds certain size
threshold??   or perhaps to have additional parameter in Subtract command to
allow the user turn statistics request off?

Jennifer

--
**************************************************************************
*  Jennifer Liu                           Mail Stop: SDVS2               *
*  Email: [email-masked]           Alcatel USA, Inc.              *
*  Tel  : 972-477-9036                    1000 Coit Road                 *
*  Fax  : 972-477-9700                    Plano, TX  75075               *
*                                                                        *
*  ** The opinions expressed are not those of Alcatel USA, Inc. **       *
**************************************************************************

---

From: Christian Huitema <[email-masked]>
Date: Thu, 16 Sep 1999 17:41:03 -0400

>overruns might be a problem.

MGCP allows to "delete all connections for endpoints that match the
specified patterns."  This form of delete does not return any per
connection data. MGCP also allows an "all" endpoint pattern in the
AuditEndpoint command, but in this case it only returns a list of available
endpoints. Event that, just a list, is problematic in large gateways.
Apart from these special form of Delete and Audit, all commands only allow
the "any" pattern.

At a minimum, we need a way to get the list of all available contexts.
Maybe something like T=1234{C=*{}}.
-- Christian Huitema