Subject: Messages and Transactions

From: Harpreet Singh Anand <[email-masked]>
Date: Mon, 27 Sep 1999 17:20:28 +0530

Brian,

I have a few questions on the concept of "Message" (section 8.3). A message is
defined as containing multiple transactions, all of them sharing a common
header. What is the processing semantics of message ?

- is the processing of individual transaction independent of the processing of
other transactions in the same message or
- the processing of a transaction depends on the successul execution of the
transactions before it ?

Assuming that it is the former approach and that it is possible for the receiver
to send multiple response messages for a single message containing multiple
transactions, I have the following question:

What is the relationship of "Message" w.r.t. the retransmission strategy  ---

Is one retransmission timer started for the message or multiple timers started -
one for each transaction in the message ?
What is the retransmission unit - is it the full message or the modified message
(depending on the transactions that have been responded to) ?

We need additional text in section 8.3 to explain these conditions.

Thanks and Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com

---

From: Brian Rosen <[email-masked]>
Date: Mon, 27 Sep 1999 09:54:43 -0400

> header. What is the processing semantics of message ?
A message is a set of transactions sent as a unit by the transport
mechanism.

The transactions in a message are treated independently.  There is no order
implied, there is no application or
protocol acknowledgement, etc.

> - the processing of a transaction depends on the successful
> execution of the
> transactions before it ?
No, transactions are always independent.  They can be processed in any
order, even "simultaneously".

> retransmission strategy  ---
That is transport dependent.  There is a discussion of
an application level timer.  That would be on a per transaction basis.

> one for each transaction in the message ?
One per transaction

> (depending on the transactions that have been responded to) ?
If you are talking about the application level timeout,
then you resend the transaction.  The transport mechanism may have it's own
retransmission mechanism, which probably is at the level of the message.

> We need additional text in section 8.3 to explain these conditions.
Okay, I'll work on it