Subject: stats on TDM termination

From: Nancy-M Greene <[email-masked]>
Date: Wed, 8 Sep 1999 11:10:35 -0500

The following is an example of a reply to a Subtract. A5555 is a TDM
termination, and A5556 is an RTP termination. What stats are returned for
the TDM termination? Obviously NOT what I have below.....

MEGACO [124.124.124.222]:55555
Reply = 50007 {
 Context = 5000 {
 Subtract= A5555  {
          Statistics { ; what are the stats for a TDM connection?
             PacketsSent=1245,
             OctetsSent=62345,
             PacketsReceived=780,
             OctetsReceived=45123,
             PacketsLost=10,
             Jitter=27,
             AverageLatency=48
          }
       },
       Subtract= A5556  {
          Statistics {
             PacketsSent=1245,
             OctetsSent=62345,
             PacketsReceived=780,
             OctetsReceived=45123,
             PacketsLost=10,
             Jitter=27,
             AverageLatency=48
          }
       }
   }
}

Nancy

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Wed, 8 Sep 1999 16:14:20 -0400

I've already proposed that we eliminate the standard
stats and make all stats package defined.  This
would make stats sensible for all cases.

Brian

> -----Original Message-----
> From: Nancy-M Greene [mailto:[email-masked]]
> Sent: Wednesday, September 08, 1999 12:11 PM
> To: [email-masked]
> Subject: stats on TDM termination
>
>

---

From: Christian Huitema <[email-masked]>
Date: Thu, 9 Sep 1999 09:56:59 -0400

>          Statistics { ; what are the stats for a TDM connection?

The stats for a TDM connection were defined in the Minneapolis draft...
basically, you want either octets sent or duration -- octets is easier,
because it removes the need to define a time unit.
-- Christian Huitema

---

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 9 Sep 1999 09:23:57 -0500

This is where we'd better look at our requirements, particularly those sent
in by the MSF.  Our statistics in general are missing a number of the items
asked for, including resource usage in the MG.

> From: Christian Huitema [SMTP:[email-masked]]
> Sent: Thursday, September 09, 1999 9:57 AM
> To:   [email-masked]
> Subject:      Re: stats on TDM termination
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 10 Sep 1999 10:28:47 -0400

I thought we covered this - remove the stats from the base
protocol, add them to the generic packages.  Then you get the
"right" set of stats.

Brian

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 10 Sep 1999 11:06:29 -0400

Right.  Here's a reminder to the package writers.

> From: Brian Rosen [SMTP:[email-masked]]
> Sent: Friday, September 10, 1999 10:29 AM
> To:   Taylor, Tom-PT [CAR:B901-I:EXCH];
> [email-masked]
> Subject:      RE: stats on TDM termination
>