Subject: Megaco/H.248 reqs -06

From: Nancy-M Greene <[email-masked]>
Date: Mon, 20 Sep 1999 21:39:02 -0500

The text below lists additions and clarifications made to
<draft-ietf-megaco-reqs-05.txt>, and now found in
<draft-ietf-megaco-reqs-06.txt>.

Until it is available in the IETF I-D directory, you can get a copy of it
at: ftp://standards.nortelnetworks.com/megaco/docs/latest

It includes clarifications asked for by ITU-T SG16 at their Berlin meeting.

If there are no more comments on this requirements draft, then I would
ask Tom Taylor to send it for WG last call.

Note that there are references to fill in, and a few editor's notes to
remove. I will do this in a few days if there are no other comments.

Nancy

-------------

5.4.  Signal/Event Processing and Scripting

l.   Provide an extension mechanism for implementation defined events
     and signals with, for example, IANA registration procedures. [ADD
FOLLOWING
SENTENCE:]It may be useful to have an Organizational Identifier (i.e. ITU,
ETSI,
ANSI. . .) as part of the registration mechanism.

5.6.  Test Support

b. Specifically support [DELETE103, 105, and 108 ] test line operation [ADD]
(e.g.
103, 105, 108).

5.8.  Signalling Control

Establishment and provisioning of signalling backhaul channels (via
SIGTRAN for example is out of scope. [QUESTION: WHY was this marked as out
of
scope?] Answer: it has been decided that this capability is not fundamental
to the protocol, so can be kept out of scope, and handled some other way.

6.1.  Resource Status Management

c.   Provide a method for the MGC to request that the MG release all
resources [ADD THE FOLLOWING] under the control of a particular MGC [END OF
ADD]
currently in use, or reserved, for any or all connections.

6.2.  Resource Assignment

c.   Allow the use of DNS names and IP addresses to identify MGs and
MGCs. [ADD FOLLOWING SENTENCE] This shall not preclude using other
identifiers
for MGs or MGCs when other non IP transport technologies for the protocol
are
used.

8.1  MG-MGC Association Requirements

b.   Allow multiple MGCs to send control messages to an MG. Thus, the
protocol must allow control messages from multiple [DELETE] IP
[ADD]signalling
addresses to a single MG.

7.3 MIB Requirements

[ADD c.]
c. H.248 MG MIB must support spirit of H.341 by either the MG, MGC, or both
acting
together.

8.2.  Performance Requirements

d.   Support peak calling rates (e.g. in the order of 140 calls/second) at
the
     MGC on a moderately loaded [DELETE IP] IP network.

11.  Requirements specific to particular bearer types

Table 1: Bearer Types and Applications

Bearer Type                   Applications       Transit Network
================================================================

[ADD FR]

Multimedia H.323                   H.323 Multimedia       IP, ATM, FR
                                   Gateway and MCU
[REPLACE SS7 with IP, ATM, FR]
Multimedia H.320              H.323 GW and MCU   ISDN, IP, ATM, FR

11.1.1.  Requirements for TDM PSTN (Circuit)

b. Missing - inconsistent numbering - renumber section

11.1.3.3.  Media adaptation

b.   Allow [ADD AAL1] AAL1/AAL2 multiple narrow-band calls to be mapped to a
single
VCC.
     [ADD For AAL2] For AAL2, these calls are differentiated within each VCC
by a AAL2
channel
     identifier. An AAL2 connection may span more than 1 VCC and transit
     AAL2 switching devices. ATMF standards are working on an end-to-end
     AAL2 connection identifier as part of the AAL2 signalling set.[REPLACE
LAST
SENTENCE WITH:] ITU Q.2630.1 defines an end-to-end identifier the Served
User
Generated Reference (SUGR). It carries information from the originating user
of the
AAL2 signalling protocol to the terminating user transparently and
unmodified.

11.2.10. Multipoint Control Units

[ADD g.]
g. The ability for the MG to function as an H.323 MP, and for the MGC to
function
as an H.323 MC, connected by this protocol (MEGACOP/H.248).  It should be
possible
for audio, data, and video MG/MPs to be physically separate while being
under the
control of a single MGC/H.323 MC.
--------------

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Tue, 21 Sep 1999 16:54:38 -0400

No, want to start such an effort?  Volunteers accepted!

Brian

> -----Original Message-----
> From: Irina Suconick [mailto:[email-masked]]
> Sent: Tuesday, September 21, 1999 4:41 PM
> To: [email-masked]
> Subject: Re: Megaco/H.248 reqs -06
>
>
>         This document mentions H.248 MG requirements for the
> MIB. Is any
> work being started on the MIB?
>         Irina.
>
>
> > -----Original Message-----
> > From: Nancy-M Greene [SMTP:[email-masked]]
> > Sent: Monday, September 20, 1999 10:39 PM
> > To:   [email-masked]
> > Subject:      Megaco/H.248 reqs -06
> >
> > b. Specifically support [DELETE103, 105, and 108 ] test
> line operation
> > [ADD]
> > (e.g.
> > 103, 105, 108).
> >
> >
> > 5.8.  Signalling Control
> >
> > resources [ADD THE FOLLOWING] under the control of a
> particular MGC [END
> > OF
> > ADD]
> > c. H.248 MG MIB must support spirit of H.341 by either the
> MG, MGC, or
> > both
> > acting
> > together.
> >
> >
> > b.   Allow [ADD AAL1] AAL1/AAL2 multiple narrow-band calls
> to be mapped to
> > a
> > single
> > VCC.
> >      [ADD For AAL2] For AAL2, these calls are
> differentiated within each
> > VCC
> > by a AAL2
> > channel
> > Generated Reference (SUGR). It carries information from the
> originating
> > user
> > of the