Subject: Re: Usage of SDP

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 2 Sep 1999 06:57:21 -0500

Yes, this sounds like a good idea.  Basically, since we are not using
fully-formed SDP messages, we have to provide a profile describing what we
do use.

> -----Original Message-----
> From: Bilalis Zacharias [SMTP:[email-masked]]
> Sent: Thursday, September 02, 1999 7:13 AM
> To:   [email-masked]
> Subject:      Usage of SDP
>
> In order to avoid confusions, I propose that in MEGACO/H.248 should be
> defined:
>
> 1. which SDP parameters can be used in MEGACO/H.248
> 2. their meaning and possible values
> 3. in which commands or descriptors they are used
>
> e.g. mode = rec, send, etc. in the local descriptor
>
>
> Best Regards
>
> Zacharias Bilalis
>
> SIEMENS ICN WN CS EC D12
> > Schertlinstr. 8
> > D-81359 Muenchen
> > Germany
> >
> Tel: + 49 89 722 28391
> Fax: + 49 89 722 61243
> Mail to: [email-masked]

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 3 Sep 1999 13:29:26 -0400

We could move this forward by accentuating the positive.  That means that we
describe how SDP is used to achieve specific results -- essential because we
need to document Christian's method for presenting mutually exclusive
alternatives.  We leave it to the implementation to find a meaning in
currently irrelevant stuff like the i= header.

> From: Chip Sharp [SMTP:[email-masked]]
> Sent: Friday, September 03, 1999 11:39 AM
> Subject:      Re: Usage of SDP
>
> At 01:13 PM 9/2/99 +0200, Bilalis Zacharias wrote:
> I don't agree.  We can include and define the SDP parameters we want to
> use
> in packages as examples, but explicitly stating the SDP parameters that
> can
> be used and explicitly excluding all others unnecessarily limits the
> usefulness and extensibility of the protocol.
>
> Chip
>
>
>
> >Best Regards
> >
> >Zacharias Bilalis
> >
> >SIEMENS ICN WN CS EC D12
> > > Schertlinstr. 8
> > > D-81359 Muenchen
> > > Germany
> > >
> >Tel: + 49 89 722 28391
> >Fax: + 49 89 722 61243
> --------------------------------------------------
> Chip Sharp                 Consulting Engineering
> Cisco Systems              Telco Bio-region
> Reality - Love it or Leave it.
> --------------------------------------------------

---

From: Bilalis Zacharias <[email-masked]>
Date: Mon, 6 Sep 1999 13:21:38 +0200

The fact is, that we have to explain the meaning of SDP parameters, that are
used in H.248. The list does not have to be exhaustive.
But somebody who reads the protocol and wants to implement it, must find the
definitions of the parameters in it. At least the parameters explicitely
mentioned in the draft (in descriptors, in examples etc.) must be clearly
defined.

Best Regards 

Zacharias Bilalis

SIEMENS ICN WN CS EC D12
Tel: + 49 89 722 28391
Fax: + 49 89 722 61243

> -----Ursprüngliche Nachricht-----
> Von:  Chip Sharp [SMTP:[email-masked]]
> Gesendet am:  Freitag, 3. September 1999 17:39
> An:   Bilalis Zacharias; [email-masked]
> Betreff:      Re: Usage of SDP
>