Subject: Re: Service Change Failover method

From: Brian Rosen <[email-masked]>
Date: Fri, 17 Sep 1999 13:19:17 -0400

I agree that we need an audit that returns the list of
active contexts.  Perhaps it's just a Context item in
AuditDescriptor.  T=1234{C=-{AuditValue{Contexts}}}

If it is felt that delete all is a necessary function,
then we would have to allow * in ContextID.  Suppose that
if you actually included the AuditDescriptor without any
items in it in a Subtract, the statistics were not send.
 T=123{c=*{S=*{Audit{}}}}
In fact we could define the automatic statistics in Subtract as an implicit
Audit{Statistics}, and any actual Audit overrid that.

Brian
Brian
> -----Original Message-----
> From: Christian Huitema [mailto:[email-masked]]
> Sent: Thursday, September 16, 1999 5:41 PM
> To: [email-masked]
> Subject: Re: Service Change Failover method
>
>
> At 03:11 PM 9/16/99 -0400, Brian Rosen wrote:
> >Well it looks like we have a conflict all right.
> >Should we allow ALL in ContextID?
> >
> >Please remember that there is not anything that limits
> >the size of a transactionReply.  If you have 1000 contexts
> >active and each has an average of 2 terminations, your reply
> will have 2000
> >statistics descriptors if you
> >were to execute Transaction=1234{ Context=*{ Subtract=*}}}
> >If each statistics descriptor was 200 bytes, your
> >reply would be 200 * 2000 or 400K in a single transaction
> reply.  Buffer
> >overruns might be a problem.
>
> MGCP allows to "delete all connections for endpoints that match the
> specified patterns."  This form of delete does not return any per
> connection data. MGCP also allows an "all" endpoint pattern in the
> AuditEndpoint command, but in this case it only returns a
> list of available
> endpoints. Event that, just a list, is problematic in large gateways.
> Apart from these special form of Delete and Audit, all
> commands only allow
> the "any" pattern.
>
> At a minimum, we need a way to get the list of all available contexts.
> Maybe something like T=1234{C=*{}}.
> -- Christian Huitema
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 17 Sep 1999 13:23:06 -0400

You are correct, it is not listed there.  I will have
to update that section.  AuditDescriptor contains the
names of the descriptors you want returned.  So, for
examle, Audit{Statistics}

Brian

> From: Jennifer Liu [mailto:[email-masked]]
> Sent: Thursday, September 16, 1999 4:56 PM
> Brian,
> Audit Descriptors are not listed under MEGACO 7.1
> Descriptors' section.  From
> which section can we find parameter specification for Audit
> Descriptors?   Also
> when you talk about possibility to turn on/off statistics,
> which paramter will
> be used?  Will it be incorporated into the standard?
>
> Thanks,
>
> Jennifer
>
> Brian Rosen wrote:
>
> > Control over the size of reply has been discussed, but so
> far we have
> > not decided to supply any controls.  Returning multiple
> replies with the
> > same transactionID won't work - they would be discarded as
> duplicates.  Even
> > if
> > we had the parsers look into the message to try to spot
> continuation, I
> > suspect
> > it would be messy.  We would have to do something like have
> a settable
> > parameter which was the max message size, and have a
> transaction response
> > like ReplyPartial that told you that this message contains
> only part of the
> > reply.
> > You would also need a sequence number.  What if you got fragment 2
> > but not fragment 1?  See how it starts to get complicated?
> >
> > I proposed to have controls on always sending statistics
> with subtract.
> > There were negative comments on that idea and it was dropped.  The
> > specific proposal was to have a property of root that
> controlled it.  We did
> > make the change that allows AuditDescriptor in subtract, so
> that if there
> > were
> > a way to turn off the statistics, there is a way to get
> them on demand.
> >
> > I'll point out that you almost always want the statistics
> when you do the
> > subtract *.
> >
> > brian
> >
> >
> > From: Jennifer Liu [mailto:[email-masked]]
> > Sent: Thursday, September 16, 1999 3:56 PM
> > Brian Rosen wrote:
> > Using All "*" wildcard in subtract command would be very
> useful if we want
> > to reset all terminations on MG,  for example, after MGC
> outage or other
> > system error conditions.   Indeed buffer overrun might be a
> problem if we
> > have a large number of active contexts on MG, so is it
> possible to send the
> > statistics in multiple reply message when they exceeds certain size
> > threshold??   or perhaps to have additional parameter in
> Subtract command to
> > allow the user turn statistics request off?
> >
> > Jennifer
> >
> >
>