Subject: Re: Dialed Digit Collection

From: Brian Rosen <[email-masked]>
Date: Thu, 23 Sep 1999 11:36:26 -0400

Well, I've always been confused somewhat by the interaction
between events and signals.  Christian always wanted to
have events and signals with the same names because he
thought that almost every event was a signal and vice versa.

Certainly, the setting of a new signalsDescriptor, either
from a command, or from an embeddedEvents descriptor
cancels any signals active.  What you seem to be saying
however, is that the detection of the dtmf EVENT causes
the canceling of the dialtone SIGNAL.  I had not assumed
this.

What is a "keep events active"?  I don't think we have
one of those.  Do we need one?

Brian

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Thursday, September 23, 1999 11:29 AM
> To: Brian Rosen
> Cc: [email-masked]
> Subject: Re: Dialed Digit Collection
>
>
> Brian Rosen writes:
>  > Woops.  There is one missing feature - silence after first
>  > dialed digit.
>  >
>  > It can't be done.  One level of embedding rule bites you.
>
>    In MGCP, the arrival of a new event
>    automatically shuts off previous events,
>    like dial tone, unless there is a keep
>    events active in the command.
>
>    Is this not the case for MEGACO? I thought
>    most of the signal handling verbiage stayed
>    around.
>
>       Mike
>
>  >
>  > Brian
>  >
>  > > -----Original Message-----
>  > > From: Brian Rosen [mailto:[email-masked]]
>  > > Sent: Thursday, September 23, 1999 10:30 AM
>  > > To: [email-masked]
>  > > Subject: Re: Dialed Digit Collection
>  > >
>  > >
>  > > I think you can have an embedded event descriptor that
>  > > would apply the dialtone and the digitmap.
>  > >
>  > > Event=3345a4{generic/offhook:Accumulate:Event=3345a5
>  > > {dtmf/tone:DigitMap=NAstd:Signals{generic/dialtone}}
>  > >
>  > > I think that is the right syntax, but others should check
>  > > me.
>  > >
>  > > I have made up package and itemIDs.  When we agree on
>  > > the default package definitions, this would change.
>  > >
>  > > Brian
>  > >
>  > > > -----Original Message-----
>  > > > From: Eric Cooper [mailto:[email-masked]]
>  > > > Sent: Thursday, September 23, 1999 9:43 AM
>  > > > To: [email-masked]
>  > > > Subject: Dialed Digit Collection
>  > > >
>  > > >
>  > > > I was wondering if the protocol permits a Media Gateway
>  > > Controller to
>  > > > atomically request the Media Gateway handle all the usual
>  > > > aspects of dialed
>  > > > digit collection (dialtone 'till first digit detection,
>  > > > silence thereafter),
>  > > > and just notify the MGC when dialing is complete?
>  > > >
>  > > > The example in the draft shows several MGC-MG interactions to
>  > > > accomplish
>  > > > this task, but it does not include dialtone.  I am curious if
>  > > > the job could
>  > > > be done without involving the MGC until the digits
> were collected.
>  > > >
>  > > > If the protocol does allow this, what would the
> message look like?
>  > > > Presumably it would involve modifying all terminations in the
>  > > > null context
>  > > > to look for an off-hook event, then accumulate digits
>  > > > according to some
>  > > > digitmap.   After this I get a bit fuzzy.  Is it possible
>  > > to embed the
>  > > > dialtone and clear signals appropriately, or do I have to use
>  > > > a script?
>  > > >
>  > > > Any insight appreciated,
>  > > >
>  > > > Eric.
>  > > >
>  > >
>  >
>

---

From: Michael Thomas <[email-masked]>
Date: Thu, 23 Sep 1999 08:41:25 -0700

> thought that almost every event was a signal and vice versa.

   I think that Christian's sense is right here.
   Every time I've thought that it wouldn't make
   any sense to have a particular event as a
   signal or visa versa, there's been a case where the
   non-obvious use made a great deal of sense.

 > the canceling of the dialtone SIGNAL.  I had not assumed

   Yes, that is what I meant, and that is what
   MGCP does by default.

 > one of those.  Do we need one?

   I meant keep signals active, of course.

           Mike