Subject: Re: ModemDescriptor proposed text

From: Brian Rosen <[email-masked]>
Date: Tue, 14 Sep 1999 08:45:58 -0400

Keeping in mind that Megaco/H.248 is a gateway control
protocol and not a RAS, I expect there needs to be several 
parameters in the Modem descriptor.  What we need is a 
concrete proposal, and I would expect the most expeditious 
way to do that is to bring a contribution to Red Bank, 
although an I-D in the IETF would also be a reasonable way 
to start discussion.

Right now we are in a position I am very uncomfortable
with - we have this half done descriptor, with nothing
but an (expanding) list of modem choices, and no controls.
My sentiments on such things are, uh, well known?
If they aren't actually useful, delete them until they
are brought up to the level of the rest of the document.

If someone who plans to build a decomposed gateway incorporating a modem
would care to think carefully and let us know if just having the name of the
modem (list of choices is actually allowed) is functional enough to build
such a beast, then we can leave what we have in the text.
If you need other parameters to do anything sensible, then let's delete the
descriptor, write up a complete 
description & ABNF (or ASN.1, I'll translate), and we can 
consider putting it back in some later edition.

With the present definition of a package, you cannot add
parameters to the Modem descriptor.  If you would care to redefine the modem
to be a kind of termination, as the Mux termination is, then packages would
be an appropriate way to add additional properties.  Expanding the
definition of a package to cover modem would be unwise in my opinion.

Brian

> -----Original Message-----
> From: Gunnar Hellstrom [mailto:[email-masked]]
> Sent: Tuesday, September 14, 1999 1:33 AM
> To: [email-masked]
> Subject: SV: ModemDescriptor proposed text
> 
> 
> I support the ModemDescriptor proposal, and the inclusion of 
> V.18 in the
> list of possible modems.
> 
> A modem usually implements a set of options, and is controlled by some
> mechanism for its control.
> 
> One option, mandatory in some modems, is the handshaking 
> protocol V.8 bis,
> that can be used during a voice call on a voice line to 
> detect a modem at
> the other end and negotiate what modem type should be activated.
> 
> The common control language for modems; V.250 - V.253; (AT command
> standards) reflect some functionality in modems expressed in 
> an ordered way.
> 
> Questions:
> 1. I assume that there is a need for common definitions on 
> some level of
> such common features of modems. Can these aspects be left to package
> authors?
> 
> 2. V.18 is made so that it can coexist with other modems and 
> be actively
> monitoring a voice line for text telephone signals. That 
> functionality can
> be important in a gateway. This functionality seems possible 
> by adding more
> than one modem package type to a termination and activate 
> them concurrently
> to monitor the line. Agree?
> 
> Regards
> Gunnar Hellström
> 
> ______________________________________
> Gunnar Hellström
> LM Ericsson
> Sweden
> 
> Tel +46 751 100 501
> Fax +46 8 556 002 06
> Video +46 8 556 002 05
> Txt (All kinds) +46 8 556 002 05
> E-mail [email-masked]
> WWW:     http://www.omnitor.se
> 
> 
> > -----Ursprungligt meddelande-----
> > Från: Media Gateway Control (megaco)
> > [mailto:[email-masked]]För Nancy-M Greene
> > Skickat: den 8 september 1999 23:43
> > Till: [email-masked]
> > Ämne: ModemDescriptor proposed text
> >
> >
> > Just as there is a list of multiplexer types in the protocol, we
> > need to add
> > the same kind of list for modem types. Based on text 
> telephony and NAS
> > requirements, I propose the following be added to the 
> Megaco protocol.
> >
> > Proposed text for the ModemDescriptor section:
> >
> > The Modem descriptor specifies the modem type and 
> parameters, if any. The
> > descriptor includes the modem types:
> > - V.18
> > - V.34
> > - V.90
> > - V.91
> > - Synch ISDN
> >
> > By default, no modem descriptor is present in a Termination.
> >
> > ------
> > Change ABNF as follows:
> >
> > modemDescriptor = ModemToken EQUAL ModemType
> >
> > ModemType = (V18Token | V34Token | V90Token |
> >                        V91Token | SynchISDNToken | 
> extensionParameter)
> >
> > V18Token = ("V18")
> > V34Token = ("V34")
> > V90Token = ("V90")
> > V91Token = ("V91")
> > SynchISDNToken = ("SynchISDN")
> >
> > Nancy
> >
> >
> > 
> --------------------------------------------------------------
> ------------
> > Nancy M. Greene
> > Internet & Service Provider Networks, Nortel Networks
> > T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
> >
>

---

From: Roy Spitzer <[email-masked]>
Date: Wed, 15 Sep 1999 15:34:18 -0400

I have the following questions:
1.      Which modems are supported?  Is it restricted to V.34 and higher
speeds?  Will there be any intention of supporting lower speed modems such
as V.32, V.22, or V.27?
2.      Does Megaco intend to support only modem termination?  Does modem
relay need to be supported?
3.      Is modem signaling end-to-end?
4.      What function does the call agent have in a modem call?  What events
does the modem termination signal to the call agent?

Thank you,
Roy

Roy Spitzer                             Telogy Networks, Inc.
Phone:  (301) 515-6531                  20250 Century Blvd.
Fax:    (301) 515-7954                  Germantown, MD 20874
Email:  [email-masked]

                -----Original Message-----
                From:   Brian Rosen [mailto:[email-masked]]
                Sent:   Tuesday, September 14, 1999 8:46 AM
                To:     [email-masked]
                Subject:        Re: ModemDescriptor proposed text

                If someone who plans to build a decomposed gateway
incorporating a modem
                would care to think carefully and let us know if just having
the name of the
                modem (list of choices is actually allowed) is functional
enough to build
                such a beast, then we can leave what we have in the text.
                If you need other parameters to do anything sensible, then
let's delete the
                descriptor, write up a complete
                description & ABNF (or ASN.1, I'll translate), and we can
                consider putting it back in some later edition.

                With the present definition of a package, you cannot add
                parameters to the Modem descriptor.  If you would care to
redefine the modem
                to be a kind of termination, as the Mux termination is, then
packages would
                be an appropriate way to add additional properties.
Expanding the
                definition of a package to cover modem would be unwise in my
opinion.

                Brian