Subject: Re: Dialed Digit Collection

From: Brian Rosen <[email-masked]>
Date: Thu, 23 Sep 1999 11:14:37 -0400

Woops.  There is one missing feature - silence after first
dialed digit.

It can't be done.  One level of embedding rule bites you.

Brian

> -----Original Message-----
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Thursday, September 23, 1999 10:30 AM
> To: [email-masked]
> Subject: Re: Dialed Digit Collection
>
>
> I think you can have an embedded event descriptor that
> would apply the dialtone and the digitmap.
>
> Event=3345a4{generic/offhook:Accumulate:Event=3345a5
> {dtmf/tone:DigitMap=NAstd:Signals{generic/dialtone}}
>
> I think that is the right syntax, but others should check
> me.
>
> I have made up package and itemIDs.  When we agree on
> the default package definitions, this would change.
>
> Brian
>
> > -----Original Message-----
> > From: Eric Cooper [mailto:[email-masked]]
> > Sent: Thursday, September 23, 1999 9:43 AM
> > To: [email-masked]
> > Subject: Dialed Digit Collection
> >
> >
> > I was wondering if the protocol permits a Media Gateway
> Controller to
> > atomically request the Media Gateway handle all the usual
> > aspects of dialed
> > digit collection (dialtone 'till first digit detection,
> > silence thereafter),
> > and just notify the MGC when dialing is complete?
> >
> > The example in the draft shows several MGC-MG interactions to
> > accomplish
> > this task, but it does not include dialtone.  I am curious if
> > the job could
> > be done without involving the MGC until the digits were collected.
> >
> > If the protocol does allow this, what would the message look like?
> > Presumably it would involve modifying all terminations in the
> > null context
> > to look for an off-hook event, then accumulate digits
> > according to some
> > digitmap.   After this I get a bit fuzzy.  Is it possible
> to embed the
> > dialtone and clear signals appropriately, or do I have to use
> > a script?
> >
> > Any insight appreciated,
> >
> > Eric.
> >
>

---

From: Michael Thomas <[email-masked]>
Date: Thu, 23 Sep 1999 08:29:27 -0700

> It can't be done.  One level of embedding rule bites you.

   In MGCP, the arrival of a new event
   automatically shuts off previous events,
   like dial tone, unless there is a keep
   events active in the command.

   Is this not the case for MEGACO? I thought
   most of the signal handling verbiage stayed
   around.

        Mike