Subject: Re: WildCards

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 7 Sep 1999 15:44:47 -0500

Actually, why not use regular expressions when trying to define a subset of
terminations?

> -----Original Message-----
> From: Brian Rosen [SMTP:[email-masked]]
> Sent: Tuesday, September 07, 1999 2:38 PM
> To:   [email-masked]
> Subject:      WildCards
>
> Should the wildcard character ("*") be allowed anywhere
> in a TerminationID?  Or should it be restricted to the
> last character, as in "foo/*"
>
> By insistence of several people, the name no longer has
> any hierarchy connotations.  The slash has no significance.
> I argue that if it's just a string, then wildcards should
> be allowed anywhere in the string.  This*Test matches
>         ThisTest
>         ThisIsATest
>         This1Test
> etc.  It's certainly trivial to implement a general
> wildcard pattern match, and may have several uses.
> One specific use is to control the amount of text output
> you get from an audit.
>
> Brian

---

From: Shyamal Prasad <[email-masked]>
Date: Tue, 7 Sep 1999 17:51:21 -0500

"Tom-PT" == Tom-PT Taylor <[email-masked]> writes:

    Tom-PT> Actually, why not use regular expressions when trying to
    Tom-PT> define a subset of terminations?

Hi Tom,

While the idea is elegant, in general when you use a regular
expression you need to compile it into a state machine, and then run
the names through the state machine to find the ones that match. With
the simple wildcards allowed today, the state machine is fairly
trivial, and can be built at compile time.

There is a reason that this compilation is a problem: regular
expressions are often non-deterministic, which means the state
machines you build will often have sizes that are exponentially
related (in compilation time and/or size) to the original state
machine. Though this does not happen in practice very often, it is the
reason Unice's have two types of regular expression based searchers,
'grep' and 'egrep'.

So, I'd say you need a very good reason to use regular expressions for
the subsets. (Incidentally, the same applies to the good old digit
maps in MGCP, but fortunately there is only so much you can do with
digit maps.....I suppose).

Cheers!
Shyamal

---

From: Kelvin Porter <[email-masked]>
Date: Wed, 8 Sep 1999 09:46:26 -0500

If the protocol is going to use regular expressions to match identifiers,
why not replace digit maps with regular expressions, as well?  At least, it
would be consistent.  - KRP

-----Original Message-----
From:   Media Gateway Control (megaco)
[mailto:[email-masked]] On Behalf Of Shyamal Prasad
Sent:   Tuesday, September 07, 1999 5:51 PM
To:     [email-masked]
Subject:        Re: WildCards

Hi Tom,

Cheers!
Shyamal

---

From: Michael Thomas <[email-masked]>
Date: Fri, 10 Sep 1999 16:25:47 -0700

> would be consistent.  - KRP

   I haven't checked lately, but a grep syntax
   was used for digit maps matching in MGCP.

       Mike