Subject: ModemDescriptor proposed text

From: Nancy-M Greene <[email-masked]>
Date: Wed, 8 Sep 1999 16:43:17 -0500

Just as there is a list of multiplexer types in the protocol, we need to add
the same kind of list for modem types. Based on text telephony and NAS
requirements, I propose the following be added to the Megaco protocol.

Proposed text for the ModemDescriptor section:

The Modem descriptor specifies the modem type and parameters, if any. The
descriptor includes the modem types:
- V.18
- V.34
- V.90
- V.91
- Synch ISDN

By default, no modem descriptor is present in a Termination.

------
Change ABNF as follows:

modemDescriptor = ModemToken EQUAL ModemType

ModemType = (V18Token | V34Token | V90Token |
                       V91Token | SynchISDNToken | extensionParameter)

V18Token = ("V18")
V34Token = ("V34")
V90Token = ("V90")
V91Token = ("V91")
SynchISDNToken = ("SynchISDN")

Nancy

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Gunnar Hellstrom <[email-masked]>
Date: Tue, 14 Sep 1999 07:32:54 +0200

I support the ModemDescriptor proposal, and the inclusion of V.18 in the
list of possible modems.

A modem usually implements a set of options, and is controlled by some
mechanism for its control.

One option, mandatory in some modems, is the handshaking protocol V.8 bis,
that can be used during a voice call on a voice line to detect a modem at
the other end and negotiate what modem type should be activated.

The common control language for modems; V.250 - V.253; (AT command
standards) reflect some functionality in modems expressed in an ordered way.

Questions:
1. I assume that there is a need for common definitions on some level of
such common features of modems. Can these aspects be left to package
authors?

2. V.18 is made so that it can coexist with other modems and be actively
monitoring a voice line for text telephone signals. That functionality can
be important in a gateway. This functionality seems possible by adding more
than one modem package type to a termination and activate them concurrently
to monitor the line. Agree?

Regards
Gunnar Hellström

______________________________________
Gunnar Hellström
LM Ericsson
Sweden

Tel +46 751 100 501
Fax +46 8 556 002 06
Video +46 8 556 002 05
Txt (All kinds) +46 8 556 002 05
E-mail [email-masked]
WWW:     http://www.omnitor.se

> -----Ursprungligt meddelande-----
> Från: Media Gateway Control (megaco)
> [mailto:[email-masked]]För Nancy-M Greene
> Skickat: den 8 september 1999 23:43
> Till: [email-masked]
> Ämne: ModemDescriptor proposed text
>
>