Subject: terminationId in the mux descriptor

From: Nancy-M Greene <[email-masked]>
Date: Fri, 10 Sep 1999 13:29:04 -0500

You may have an Add $, and within that Add, a Mux descriptor that wants to
refer to the new terminationId that will be assigned by the MG because of
the $. How do you refer to that terminationID in the Mux descriptor? Can we
put $ as well, and have that mean put in the newly assigned terminationID?
For example:

Add = $ {
      Mux = H225-0 {$},
...
}

This is taken from the Single Media Call example in the protocol spec.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 10 Sep 1999 14:45:24 -0400

Makes sense.  I trust you mean that each $ in the example below refers to a
different terminationID (the first to that of the MUX termination, the
second to that of the bearer).

I'd like someone on the SG 16 side to express an opinion on whether the
H.225.0 mux type would ever be used except when H.245 is running in the MG.
Otherwise it seems like excess baggage.

> -----Original Message-----
> From: Greene, Nancy-M [CAR:5N10:EXCH]
> Sent: Friday, September 10, 1999 2:29 PM
> To:   [email-masked]
> Subject:      terminationId in the mux descriptor
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 10 Sep 1999 15:07:13 -0400

Wait a minute, this can't happen.

An Add $ is for a packet, not a circuit connection
The mux in (or out) is always a circuit bearer, never a packet bearer.

Brian

> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Friday, September 10, 1999 2:45 PM
> To: [email-masked]
> Subject: Re: terminationId in the mux descriptor
>
>
> > the $. How do you refer to that terminationID in the Mux
> descriptor? Can
> > we

---

From: Tom-PT Taylor <[email-masked]>
Date: Fri, 10 Sep 1999 18:50:36 -0500

Add $ says "Create a termination with the indicated properties and give me
back the name you've chosen".  Why shouldn't it work with a Mux termination?
I should point out that an H.225.0 mux termination is a strange beast whose
bearers are RTP terminations and possibly an H.245 control channel.  That's
why I asked SG 16 whether it would ever be used without the H.245 member.

BTW, Add DSxxx$ would ask the MG to choose a provisioned termination whose
name begins with DSxxx, assign to it the indicated property values, and
place it in the context.

> From: Brian Rosen [SMTP:[email-masked]]
> Sent: Friday, September 10, 1999 3:07 PM
> To:   Taylor, Tom-PT [CAR:B901-I:EXCH];
> [email-masked]
> Subject:      RE: terminationId in the mux descriptor
>

---

From: Brian Rosen <[email-masked]>
Date: Mon, 13 Sep 1999 09:30:46 -0400

Of course you can create a Mux termination with $, that
would be the normal case.  However, you would never see
a $ in the Mux descriptor (which contains a list of
bearers).   I think they were trying to do something like:
Transaction = 11223{ Context=156 {
        Add=${Media{...create one bearer...}},
        Modify=Mux219{Mux{H225,AnotherTerm1,$}}
}}

I don't think such a construct should be allowed, using
the interpretation that $ is local to the command.

With regard to DSxxx$, I had thought that by getting rid of
name significance, such a construct would be meaningless.
Whether it should be legal is another question I suppose.

Brian

> Sent: Friday, September 10, 1999 7:51 PM

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 14 Sep 1999 09:01:04 -0400

> Sent: Monday, September 13, 1999 9:31 AM
        [[TomT]]  ...
> the interpretation that $ is local to the command.
        [[TomT]]  I guess I agree with that.

> Whether it should be legal is another question I suppose.
        [[TomT]]
        There's a difference between name as something that denotes an
entity and name which carries an additional meaning.  Maybe I'M assuming too
much by assuming that a name is a series of characters, so that string
matches are a valid operation.  What do others say about this one?