Subject: Re: WildCards

From: Brian Rosen <[email-masked]>
Date: Tue, 7 Sep 1999 17:10:48 -0400

Regular expressions?

You want to introduce expression syntax, with operators and precedence??

Seriously, what kind of regular expression would you allow,
and why would it be easier/better than wildcards everywhere?  Expressions in
the terminationID would really torque the syntax.  I rather like the idea in
principal, in practice, the residential gateway/IPPhone folks would kill
us.

How about MyT<("a"-"c") | ("e"-"z")>/1 to match
        MyTa/1 or MyTg/1 but not MyTd/1

I always liked SNOBOL.  It had a killer regular expression syntax for
pattern matching.

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Tuesday, September 07, 1999 4:45 PM
> To: [email-masked]
> Subject: Re: WildCards
>
>
> Actually, why not use regular expressions when trying to
> define a subset of
> terminations?
>
> > -----Original Message-----
> > From: Brian Rosen [SMTP:[email-masked]]
> > Sent: Tuesday, September 07, 1999 2:38 PM
> > To:   [email-masked]
> > Subject:      WildCards
> >
> > Should the wildcard character ("*") be allowed anywhere
> > in a TerminationID?  Or should it be restricted to the
> > last character, as in "foo/*"
> >
> > By insistence of several people, the name no longer has
> > any hierarchy connotations.  The slash has no significance.
> > I argue that if it's just a string, then wildcards should
> > be allowed anywhere in the string.  This*Test matches
> >         ThisTest
> >         ThisIsATest
> >         This1Test
> > etc.  It's certainly trivial to implement a general
> > wildcard pattern match, and may have several uses.
> > One specific use is to control the amount of text output
> > you get from an audit.
> >
> > Brian
>

---

From: Abdallah Rayhan <[email-masked]>
Date: Tue, 7 Sep 1999 17:11:17 -0400

I see version 2 ideas are coming up already ;-)

Abdallah