Subject: Re: Dialed Digit Collection

From: Brian Rosen <[email-masked]>
Date: Thu, 23 Sep 1999 11:50:25 -0400

I defer to the experience of the MGCP crowd.

If no one has any problems, I think we should have this
behavior.  I'll have to look up what the syntax of "keep signals active" and
see what we need to do there.

Brian

> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Thursday, September 23, 1999 11:41 AM
> To: Brian Rosen
> Cc: 'Michael Thomas'; [email-masked]
> Subject: RE: Dialed Digit Collection
>
>
> Brian Rosen writes:
>  > Well, I've always been confused somewhat by the interaction
>  > between events and signals.  Christian always wanted to
>  > have events and signals with the same names because he
>  > thought that almost every event was a signal and vice versa.
>
>    I think that Christian's sense is right here.
>    Every time I've thought that it wouldn't make
>    any sense to have a particular event as a
>    signal or visa versa, there's been a case where the
>    non-obvious use made a great deal of sense.
>
>  > Certainly, the setting of a new signalsDescriptor, either
>  > from a command, or from an embeddedEvents descriptor
>  > cancels any signals active.  What you seem to be saying
>  > however, is that the detection of the dtmf EVENT causes
>  > the canceling of the dialtone SIGNAL.  I had not assumed
>  > this.
>
>    Yes, that is what I meant, and that is what
>    MGCP does by default.
>
>  > What is a "keep events active"?  I don't think we have
>  > one of those.  Do we need one?
>
>    I meant keep signals active, of course.
>
>          Mike
>

---

From: Christian Huitema <[email-masked]>
Date: Mon, 27 Sep 1999 10:10:28 -0400

>see what we need to do there.

Brian,

An analysis of signalling protocols show that in most cases the "signal" is
really a poll for an "event." For example, ringing is a poll for off-hook,
dialtone is a poll for digits, busy tone a poll for hangup.  We have thus a
very common situation where the production of the signals is expected to
stop as soon as the expected event is noticed. This led us to the MGCP
specification that, by default, the production of signals stops as soon as
one of the requested events is detected. It also leads to the definition of
the "timed out" class of events, that can be produced for a fixed duration
and produce a time out if nothing happen after that duration.

The "keep signal active" notation is a way to override the default, in case
where the signal shall in fact be maintained. An example may be some test
procedures. If would be encoded as an action, on par with "Notify."
-- Christian Huitema