Subject: Re: MGCP/MEGACO for broadband services

From: Brian Rosen <[email-masked]>
Date: Thu, 23 Sep 1999 09:19:19 -0400

Arik

I wouldn't limit MEGACO to voice.  It works pretty nicely for video and
T.120 style data, as well as text terminal
type stuff.

Having said that, I mostly agree with Henry; it's a pretty
comprehensive, yet fairly simple protocol to control any
kind of voice/video/multimedia device where there is
some kind of call control software, and a reason to separate it from the
part of the system that is handling the data.

Brian

> -----Original Message-----
> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Thursday, September 23, 1999 8:26 AM
> To: [email-masked]
> Subject: Re: MGCP/MEGACO for broadband services
>
>
> Arik,
>
> What you are really asking for is provided by the Internet
> architecture and
> is the object of many other WG's and published RFC's. IMHO,
> MEGACO as is, is
> really designed for voice services as they exist on the PSTN
> to be hauled
> across the Internet or private IP networks. It may also use
> frame relay or
> ATM network instead of IP networks, but I believe to a lesser
> extent.  It is
> a job well done, but does this only and no more. The main
> merit of MEGACO is
> the tremendous telephony complexity it is dealing with, as I
> believe never
> to have been the case in standards bodies before. Funny, to
> find in the IETF
> the most thorough and consistent approach to telephony
> signaling interfaces,
> packaged in one document...
>
> Think of MEGACO as the internal bus of a gateway that has one
> port group on
> the PSTN and another on the IP network. That's all.
>
> Beware the flame throwers :-)... Would deserve it for this
> simplified view.
>
> Henry
>
>
> > -----Original Message-----
> > From: Media Gateway Control (megaco)
> > [mailto:[email-masked]]On Behalf Of Arik Klein
> > Sent: Thursday, September 23, 1999 1:10 AM
> > To: [email-masked]
> > Subject: MGCP/MEGACO for broadband services
> >
> >
> > As I understand, the current MGCP/MEGACO protocol is mostly
> VOICE services
> > oriented.
> > Could anyone say if, and from which version, the MGCP
> protocol inteds to
> > support DATA services,
> > such as:   IPoA, MPLS, IP-VPN, video delivery services and
> other broadband
> > services ?
> > What are the main shortcomings in the protocol regarding
> those issues ?
> >
> > Could you also help me understand the differences (if any)
> > between the MGCP
> > and the MEGACO work, and what
> > is currently available ?
> >
> > Best Regards,
> > Arik Klein
>

---

From: Michael P DiGioia <[email-masked]>
Date: Thu, 23 Sep 1999 10:33:06 -0400

>>What you are really asking for is provided by the Internet architecture and
>>is the object of many other WG's and published RFC's. IMHO, MEGACO as is, is  >>really designed for voice services as they exist on the PSTN to be hauled
>>across the Internet or private IP networks. It may also use frame relay or
>>ATM network instead of IP networks, but I believe to a lesser extent.  It is  >>a job well done, but does this only and no more. The main merit of MEGACO is
>>the tremendous telephony complexity it is dealing with, as I believe never
>>to have been the case in standards bodies before. Funny, to find in the IETF
>>the most thorough and consistent approach to telephony signaling interfaces,

Henry, Well said!
Now all we need to do is build it.

/mpd

---

From: Fernando Cuervo <[email-masked]>
Date: Thu, 23 Sep 1999 10:33:56 -0400

Megaco plays a role in a decomposed gateway or interworking function where
there is a separation of the control plane and the switching/forwarding
plane. Of course, telephony gateways are of great interest to many and
initial applications will fall in this space. Other applications of Megaco
such as MPLS, anything over ATM and Broadband services are within the scope
of Megaco. For instance, the Mutliservice Switching Forum architecture
(www.msforum.org) uses Megaco in the interworking function between the
access and core networks, the MSF is looking at MPLS, and native broadband
services. The connection and termination models supported by Megaco provide
the flexibility to apply the protocol on many different interworking
functions.

Fernando Cuervo

> ----------
> From:         Henry Sinnreich[SMTP:[email-masked]]
> Sent:         September 23, 1999 8:26 AM
> To:   [email-masked]
> is the object of many other WG's and published RFC's. IMHO, MEGACO as is,
> is
> really designed for voice services as they exist on the PSTN to be hauled
> ATM network instead of IP networks, but I believe to a lesser extent.  It
> is
> a job well done, but does this only and no more. The main merit of MEGACO
> is
> Think of MEGACO as the internal bus of a gateway that has one port group
> on
> Beware the flame throwers :-)... Would deserve it for this simplified
> view.
>
> Henry
>
>
> > As I understand, the current MGCP/MEGACO protocol is mostly VOICE
> services
> > oriented.
> > Could anyone say if, and from which version, the MGCP protocol inteds to
> > support DATA services,
> > such as:   IPoA, MPLS, IP-VPN, video delivery services and other
> broadband
> > services ?
> > What are the main shortcomings in the protocol regarding those issues ?
> >