Subject: WildCards

From: Brian Rosen <[email-masked]>
Date: Tue, 7 Sep 1999 14:38:24 -0400

Should the wildcard character ("*") be allowed anywhere
in a TerminationID?  Or should it be restricted to the
last character, as in "foo/*"

By insistence of several people, the name no longer has
any hierarchy connotations.  The slash has no significance.
I argue that if it's just a string, then wildcards should
be allowed anywhere in the string.  This*Test matches
        ThisTest
        ThisIsATest
        This1Test
etc.  It's certainly trivial to implement a general
wildcard pattern match, and may have several uses.
One specific use is to control the amount of text output
you get from an audit.

Brian

---

From: Abdallah Rayhan <[email-masked]>
Date: Tue, 7 Sep 1999 15:14:14 -0400

Wildcards add flexibility but could be problematic too.
Each time a wildcard is used you have to search all
the terminations trying to find which ones match.
How many terminations are we talking about ???

If we use restricted last character wildcard, there is
a window for efficiency since you can organize your
termination lookup tables by before and after "/".

Recommendations:
1- Guide lines for naming terminations are needed
2- Allow wildcards in certain places, e.g., after
"/" or between two "/" only.

Abdallah