Subject: Terminations names

From: Bilalis Zacharias <[email-masked]>
Date: Fri, 3 Sep 1999 14:54:34 +0200

Are termination names always defined by MG? In which cases can MGC define
the termination ID? (e.g in case of ISUP trunks)

Best Regards

Zacharias Bilalis

SIEMENS ICN WN CS EC D12
> Schertlinstr. 8
> D-81359 Muenchen
> Germany
Tel: + 49 89 722 28391
Fax: + 49 89 722 61243
Mail to: [email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Fri, 3 Sep 1999 09:13:54 -0400

Termination IDs are ALWAYS defined by the MG.
The expectation is that they are provisioned for
large gateways.  For small ones, they could be provisioned,
or they could be "built in".

Since ISUP trunks are connected to something that is
provisioned, the names should be provisioned appropriately.

Brian

> -----Original Message-----
> From: Bilalis Zacharias [mailto:[email-masked]]
> Sent: Friday, September 03, 1999 8:55 AM
> To: [email-masked]
> Subject: Terminations names
>
>

---

From: Bilalis Zacharias <[email-masked]>
Date: Fri, 3 Sep 1999 15:16:07 +0200

By who will they be provisioned?
What is meant by "ISUP trunks are connected to something that is
provisioned"?

Best Regards 

Zacharias Bilalis

SIEMENS ICN WN CS EC D12
Tel: + 49 89 722 28391
Fax: + 49 89 722 61243

> -----Ursprüngliche Nachricht-----
> Von:  Brian Rosen [SMTP:[email-masked]]
> Gesendet am:  Freitag, 3. September 1999 15:14
> An:   [email-masked]
> Betreff:      Re: Terminations names
>

---

From: Brian Rosen <[email-masked]>
Date: Fri, 3 Sep 1999 09:37:34 -0400

> By who will they be provisioned?
The network operator

> What is meant by "ISUP trunks are connected to something that is

A gateway that connects to "ISUP Trunks" is something on
the order of a trunk exchange gateway.  The trunks come
from a local exchange (Class 5 central office).  The
local exchange IMTs are connected to the gateway either
directly, or through a SONET/SDH facility.  Regardless,
the trunks are wired, in some manner, to the C5 IMTs.

There is a provisioning process that takes place when
these trunks are connected to the gateway.  Part of the
provisioning would be to name the trunks.  These names
would, presumably, have some relationship to a routing
database that the MGC had access to.

Brian

---

From: Deepak Chugh <[email-masked]>
Date: Fri, 3 Sep 1999 11:10:07 -0400

I have been wondering about Termination Names as well.

So the thought is (let me see if I get this correct),  that the names
for Terminations
(Permanent--> Line Card) will be provisioned by the GC.

This will probably happen at system initialization (right??).

What about Packet Switched Terminations (Ephemeral)? The Termination IDs
for those types of
Terminations will be assigned by the Gateway or the GC??

Please advise..

Deepak

--
Deepak Chugh
SMG5000 Lines MGCP Development
ESN:      351-7238
External: (919)-991-7238

---

From: Brian Rosen <[email-masked]>
Date: Fri, 3 Sep 1999 11:52:05 -0400

So the thought is (let me see if I get this correct),  that the names for
Terminations 
(Permanent--> Line Card) will be provisioned by the GC.  

Not the GC, whatever provisioning system the network operator has.

In some systems, this implies (but does not require!), that the names are in
a MIB that is accessed with SNMP.  Other systems may have it in some other
database. 

Sort of.  You provision in some kind of stable storage,  This could be a
flash rom, or a disk file;  whatever.  This is outside the scope of the
protocol.  However it's done, when the MG boots, it will "know" what the
names of the terminations are.  

What about Packet Switched Terminations (Ephemeral)? The Termination IDs for
those types of 
Terminations will be assigned by the Gateway or the GC??  

Well, names are never assigned by the MGC, but otherwise, it does
not matter.  An MG implementation may choose to fix the name, maybe
something like RTPxxxx.  The front part could be provisioned.  Whatever it
is, the MGC asks for an RTP connection, and the MG makes up a name.  

This does bring up a problem.  How does an MGC find out what packet
connections an MG has?  Long ago, we had hierarchical names, and you could
do something like an audit of */ which would get you a list of all the base
terminations, and then you could audit that to find out what kind of
termination (what packages it implements).  Without it, you have no way to
audit an ephemeral before you create one.

We are going to have to invent something to fix it.  Right now, I'm
thinking of some property of root that returns a list of the interfaces and
the packages implemented on those interfaces. 

I miss hierarchical names and "base" terminations!

 Brian