Subject: Definition of digitLetter in WG draft version of ABNF

From: Murat Bog <[email-masked]>
Date: Tue, 19 Oct 1999 18:45:58 -0700

The following segment is copied from the current WG draft version of ABNF.

digitMapDescriptor = DigitMapToken EQUAL digitMapName
                    LBRKT digitMapValue RBRKT
digitMapName = NAME
digitMapValue=["L" COLON Timer COMMA] ["M" COLON Timer COMMA] digitMap
Timer = 1*2DIGIT
digitMap = (digitString | LWSP "(" LWSP digitStringList LWSP ")" LWSP)
digitStringList = digitString *( LWSP "|" LWSP digitString )
digitString = 1*(digitStringElement)
digitStringElement = digitPosition [DOT]
digitPosition = digitMapLetter | digitMapRange
digitMapRange = ("x" | LWSP "[" LWSP digitLetter LWSP "]" LWSP)
digitLetter = *((DIGIT "-" DIGIT ) | digitMapLetter)

Based on this, it is possible to have a digitMapDescriptor of the form:

DigitMap=ADialPlanName{ [ ] }

Is this intentional, or should the definition of digitLetter be changed to

digitLetter = 1*((DIGIT "-" DIGIT ) | digitMapLetter)

to require at least one instance of (DIGIT "-" DIGIT) or digitMapLetter?

----

Murat Bog

CopperCom
[email-masked]

---

From: Brian Rosen <[email-masked]>
Date: Thu, 21 Oct 1999 01:50:57 -0400

Two things

One is the ABNF for digitMapDescriptor should be
>                     (LBRKT digitMapValue RBRKT)
That is, value is optional.  This indicates delete of digitMapName

Now, your original issue is whether value = [ ] is "legal".
I don't feel that strongly, but generally I think we could change it to:
digitLetter = 1*((DIGIT "-" DIGIT ) | digitMapLetter)
which would fix the problem I think.

Brian
> -----Original Message-----
> From: Murat Bog [mailto:[email-masked]]
> Sent: Tuesday, October 19, 1999 9:46 PM
> To: [email-masked]
> Subject: Definition of digitLetter in WG draft version of ABNF
>
>