Subject: ATM SVC call binding issue in MEGACO

From: Faad Ghoraishi <[email-masked]>
Date: Mon, 25 Oct 1999 15:47:01 -0400

Has anyone addressed the call flow for  an
ATM SVC connection using MEGACO.

Specifically, what is the binding paramter that
binds an incoming/outgoing SVC ATM call with the
MEGACO signaling messages within the MG.
For example, how does the terminating MG (i.e, Trunk Gateway),
knows that an incoming ATM SVC call is related to a call
 with TerminationID=xxx and ContexID=yyy?
One way to do this is to send the far end MG's TerminationID
within the ATM UNI call setup message, so when it receives the
ATM SVC call setup message, it will know how to bind this
call with a particular ContextID.

How is this function emplimented within MEGACO. Should
there be an Event defined for looking in a particular ATM UNI
message parameter and sending this info up to the MGC?

Any suggestions?

Thanks,

Faad Ghoraishi
Telcordia Tech. Inc
USA

---

From: Stephen Terrill <[email-masked]>
Date: Mon, 25 Oct 1999 22:11:07 +0200

Hi Faad,

I would like to see that the solution can interworking with existing (or devoloping) protocols such as Q.BICC

The terminatin id could be one approach.  A further approach is to include the the details of the binding informating in a package - a package wich should handle the both the initiating and terminating id.

Regards,

..//Steve