Subject: Re: Optional commands

From: Tom-PT Taylor <[email-masked]>
Date: Thu, 28 Oct 1999 10:03:49 -0400

The first interpretation doesn't look right.  The argument for optional
commands in the first place was based on the 8.2.2 interpretation.

> -----Original Message-----
> From: Cliff Thomas [SMTP:[email-masked]]
> Sent: Thursday, October 28, 1999 9:20 AM
> To:   [email-masked]
> Subject:      Optional commands
>
> There are two sections in the standard that mention optional
> commands.  When I read them, I understand two slightly
> different things:
>
> Section 8:
> "optional commands may be executed even if a previous command
>  results in a error"
>
>  To paraphase--optional commands are not influenced by the
>                execution of other commands.
>
>  If we have commands A, B, C (optional), and D
>  And command B fails, then we may choose whether or not to
>  to execute C but we won't execute D.
>
> Section 8.2.2
> "If the optional command does generate an error, the transaction
>  still continues to execute..."
>
>  To paraphase--optional commands do not influence the execution
>                of other commands.
>
>  If we have commands A, B, C (optional), and D
>  And A and B are good but command C fails, then we still execute
>  command D.
>
> Are both interpretations correct?

---

From: John Segers <[email-masked]>
Date: Thu, 28 Oct 1999 16:50:07 +0200

Tom,

The text of section 8.2.2 is correct.  I rewrote the text in section 8.

John

> Tom-PT Taylor wrote:
>
> The first interpretation doesn't look right.  The argument for
> optional commands in the first place was based on the 8.2.2
> interpretation.
>

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 306
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954