Subject: Re: Stopping BR signals

From: Brian Rosen <[email-masked]>
Date: Fri, 29 Oct 1999 17:50:27 -0400

The problem with letting BR run to completion is that
a new SignalsDescriptor with another BR would have to
queue.  If you introduce queues, you get all sorts of side
effects.

Brian

> -----Original Message-----
> From: Chip Sharp [mailto:[email-masked]]
> Sent: Friday, October 29, 1999 5:29 PM
> To: [email-masked]
> Subject: Stopping BR signals
>
>
> There has been discussion of treating BR signals as follows:
>
>       * BR signals are stopped on receipt of a
> SignalDescriptor without
>         that signal in it.
>
>       * If the MGC wants the BR signal to continue, it includes the BR
>         signal in the subsequent SignalDescriptor.
>
> This causes a synchronization problem between the MGC and MG.
>  The same
> problem exists for TO signals but there is less of a glare window.
>
> The problem is that the MGC doesn't really know if the BR
> signal is playing
> or not.  If the MGC doesn't want to interrupt a BR signal, it has to
> include the BR signal in the SignalDescriptor.  However if the MG has
> already finished playing the BR signal when it receives the
> SignalDescriptor, the result is that the BR signal is played twice.
>
> I don't see any way to fix this for brief signals given the
> treatment being
> proposed on the list.
>
> If BR signals are played to completion, then this problem doesn't
> exist.  Instead there is the concern that the MGC can't turn
> off a BR signal.
>
> My feeling is that if the MGC shouldn't start BR signals it
> doesn't want to
> run to completion.
>
> Chip
> Support NetAid!  http://www.netaid.org
> --------------------------------------------------
> Chip Sharp                 Consulting Engineering
> Cisco Systems              Telco Bio-region
> Reality - Love it or Leave it.
> --------------------------------------------------
>

---

From: Chip Sharp <[email-masked]>
Date: Fri, 29 Oct 1999 16:54:09 -0500

Or it could play over the top of the current signal.

Either way (Interrupt or not) there are anomalous conditions that aren't
well defined.

Chip