Subject: Re: Annex G Examples - UPDATE

From: Emre Gunduzhan <[email-masked]>
Date: Mon, 11 Oct 1999 10:32:24 -0400

Nancy, please see my comments below.

At 04:24 PM 10/8/99 -0400, Greene, Nancy-M [CAR:5N10:EXCH] wrote:
>Emre, Thanks for your comments!
>
>> ----------
>> From:        Gunduzhan, Emre [MDGAI:DS48:EXCH]
>> Sent:        Thursday, September 30, 1999 5:51 PM
>> To:  [email-masked]
>> Subject:     Re: Annex G Examples - UPDATE
>>
>> Nancy, I think the following parts need correction in the first
>> example in Annex G:
>>
>> 1) In step 12 the MGC specifies two codecs, G723 and PCMU. MG1
>> replies in step 13 by choosing BOTH of them in the LocalDescriptor,
>> but it should have chosen only one value from the list (section
>> 7.1.2).
>>
>No, it should stay as it is, because I wanted MG1 to indicate two
>choices to MG2 and let MG2 choose one codec.
[...]

For over-specified parameters, section 7.1.2 says: "...The command
responder chooses one value from the offered list and returns that
value to the command initiator." That's why I thought returning two
or more choices was not allowed.

On the other hand, I agree that we should allow specifying multiple
codecs in local and remote descriptors. However, I think that the
meaning of such usage should be made clear. It might mean that
a) MG1 is offering a choice, or
b) MG1 wants to use the listed codecs simultaneously.
I would prefer (b), since it is more coherent with SDP semantics, and
also it will be needed in certain cases, e.g. you may want to use a
voice codec and a DTMF codec simultaneously.

Emre

--
Emre Gunduzhan
Signal Processing Group, Nortel Networks
Phone: (301)250-3653  Fax: (301)921-0161

---

From: Nancy-M Greene <[email-masked]>
Date: Tue, 12 Oct 1999 13:42:43 -0500

> but it should have chosen only one value from the list (section 7.1.2).
>
No, it should stay as it is, because I wanted MG1 to indicate two choices to
MG2 and let MG2 choose one codec.

> 2) In steps 12-14, the preferred/chosen packetization (20ms) is
> inconsistent with the preferred/chosen codec (G.723), whose frame
> size is 30ms.
>
Thanks, I forgot to change this in the update I just sent to Brian.

> 3) It looks like step 18 is not needed, since ringing signal was
> already sent in step 14.
>
Actually, I removed the ringing from step 14 - it was too early.

> I also have a question related to (1). How would the MGC ask using
> different codecs for the encoder and the decoder? We probably need two
> parameters, PreferredEncoders and PreferredDecoders, in addition to
> PreferredCodecs?
>
Good point.
Mike Kallas, Zach Bilalis please note: in the basic packages document,
instead of
g/PreferredCodecs, we need two properties:

g/PreferredEncoders and
g/PreferredDecoders

> Emre
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]