Subject: Re: Response from Service Change

From: Brian Rosen <[email-masked]>
Date: Tue, 5 Oct 1999 16:37:49 -0400

I'm not sure if I agree or don't with your conclusion,
but you made one error.

Wildcard response would simply return whatever string the
request specified.  No string optimization.

Brian

> -----Original Message-----
> From: Abdallah Rayhan [mailto:[email-masked]]
> Sent: Tuesday, October 05, 1999 4:29 PM
> To: Brian Rosen
> Cc: [email-masked]
> Subject: Re: Response from Service Change
>
>
> This is an interesting problem, thanks to wildcard.
>
> Zillion responses is out of the question, if TCP is slow as being
> argued before, this is a killer.
>
> Wildcard response leads to strings optimization which introduces
> delay. On the other hand, TerminationIDList seems be lengthy
> in some cases.
>
> If we assume that a terminationID string length is 10 bytes
> in average,
> and the MG/MGC supports/controls 1k-10k terminations, then we are
> looking into 11k-110k byte transaction, not to mention few bytes for
> the header. What is the average segment length ? Here where we will
> disagree, but for the sake of argument, say 5k. Then we are
> looking into
> 2-22 segments. Wildcard optimization may not be bad after all but we
> must allow temrinationIDList as well for cases where wildcard
> calculation
> is expensive.
>
> The ROOT is general and may not apply to all cases.
>
> My choice: is to allow wildcard and terminationIDList in
> service change reply.
>
> In case of audit, if the MGC decides to know what terminations exist,
> then there is no other way but to flood it with all
> terminations it asked for
> and no wildcards in this case.
>
> Probably, we need to point out in the MEGACO document that these kind
> of cases generate traffic bursts and should be handled with
> caution of the
> request side.
>
> Abdallah Rayhan
>
> Brian Rosen wrote:
>
> > Chuong Nguyen [[email-masked]] pointed out
> > a problem to me:
> >
> > What happens if you take a group of terminations out of
> > service with ServiceChange using a wildcard?
> >
> > Do you get a response for each termination that matches the
> > wildcard?  Is that what you want?
> >
> > The simple case of the whole gateway, using root, is
> > easy, you get one response.
> >
> > A trunk gateway with an OC3 going down is another story.
> >
> > I see 3 choices:
> >         Leave it, accept the zillion response messages
> >         Allow ServiceChange to return a terminationIDList
> >                 of all terminations that match
> >         Just say you only ever get one response, which
> >                 matches what you sent (wildcard response)
> >
> > Please remember, your answer may affect what the next
> > guy wants to do with an audit response using a wildcard!
> >
> > Brian
>

---

From: Abdallah Rayhan <[email-masked]>
Date: Tue, 5 Oct 1999 17:09:21 -0400

Oh no, you would need to optimize if part of the wildcard is
matched and executed successfully and part of was not.
In other words, returning the wildcard as is will not work
for all cases.

Abdallah Rayhan