Subject: Re: Creation of Contexts

From: Brian Rosen <[email-masked]>
Date: Thu, 14 Oct 1999 14:56:47 -0400

Whoa, nice problem, I like it!!!

Transaction = 10000 {
>         Context = $ {
>                 Modify = A5263 {....
>                 }
>         }
> }
>
> an error probably occurs, even if A5263 does exist in another
> context. Which
> error code will be returned?
Boy, your choice.   Probably
411 - The transaction refers to an unknown ContextId
but you could also say
421 - Unknown action or illegal combination of actions

Maybe we need a new one
423  Unspecified ContextID illegal for this action

> Is a new context created?
NO!

> If yes, we have an empty context. What does it become?
>
> If no, which ContextID is returned in "Reply"? It is specified that a
> ContextID in a "Reply" may be specific or null, but not "unspecified"
> (section 8.2.2)
I'd say this is a bug, and it should reply with unspecified.

Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 14 Oct 1999 15:10:13 -0500

> I'd say this is a bug, and it should reply with unspecified.

No context ID needed at all.

ABNF Specification said
transactionReply = ReplyToken EQUAL TransactionID LBRKT
                                 ( errorDescriptor / actionList ) RBRKT

For this scenario, it would be
transactionReply = ReplyToken EQUAL TransactionID LBRKT ( errorDescriptor
) RBRKT

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****