Subject: Re: TransactionPending message flow

From: Brian Rosen <[email-masked]>
Date: Wed, 27 Oct 1999 19:51:27 -0400

Flow A

Brian

> -----Original Message-----
> From: Tim Vetter [mailto:[email-masked]]
> Sent: Wednesday, October 27, 1999 7:27 PM
> To: [email-masked]
> Subject: TransactionPending message flow
>
>
> What the TransactionPending message communication
> look like?  Does it look like flow A or B?
>
> Flow A (Seems indicated by Section 8.2.3):
> 1. Message Request X goes from MGW to GW
> 2. The GW sends TransactionPending Message to MGW
> 3. The GW sends TransactionPending Message to MGW
> 4. The GW (finally) sends Reply to MGW.
>
> Flow B (Seems indicated by Section E.4):
> 1. Message Request X goes from MGW to GW
> 2. The MGW resends Message Request X to GW
>    (MGW times out waiting for Response)
> 3. The GW sends TransactionPending to MGW
> 4. The MGW resends Message Request X to GW
>    (MGW times out waiting for Response)
> 5. The GW sends TransactionPending to MGW
> 6. The GW (finally) sends Reply to MGW.
>
> What triggers the Transaction Pending in GW?  Is it
> timer in GW, or is it receiving the same command again
> from the MGW?
>

---

From: Harpreet Singh Anand <[email-masked]>
Date: Thu, 28 Oct 1999 10:41:53 +0530

Hello Brian,

TransactionPending should also be sent in the case of MGW receiving the same
command again. Consider the following flow:

1. Message Request X goes from MGW to GW
2. The GW sends TransactionPending Message to MGW
3. The TransactionPending Message gets lost OR reaches after MGW has already
timed out for the response.
4. The MGW resends Message Request X to GW
    (MGW times out waiting for Response)
5. The GW sends TransactionPending to MGW
6. The GW (finally) sends Reply to MGW.

Please comment.

Regards,
Harpreet

--

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com