Subject: Re: Questions on megacop

From: Brian Rosen <[email-masked]>
Date: Wed, 13 Oct 1999 16:11:36 -0400

> Got a few questions on "draft-ietf-megaco-protocol-05.txt" or v11 of
> megacop document:
>
> 1. Section 7.2.8, Page31, it says "The profile includes the version of
> the profile supported.". Is it referring to the version of the megacop
> stack? If so, it is already there in every message.
No, it's the version of the Profile, not the stack

>
> 2. Section 7.2.8, Page31, it says "A ServiceChange Command specifying
> the "Root" for the TerminationID is a registration command by which a
> Media Gateway announces its existence to the Media Gateway
> Controller.".
> Is this a true statement ? One could specify "ROOT" in the
> ServiceChange
> Command to take all terminations out of service.
Yes, and yes, indeed.  That is the intention.

> 3. Section 8, Page 34, the 2nd paragraph "Applications SHOULD
> implement
> an application level timer per transaction. Expiration of the ......".
> This paragraph was not there in v10 of the document. It has
> been addded
> in v11 of the document. Is this referring to the timers in the stack
> (for ALF)? Or is it some other timer to be implemented by applications
> that sit on top of the stack?
It is recommended (but not required) that the application
have a timer per transaction.  There are things other than
transport problems that can cause a transaction to be
lost, and it is prudent to have another mechanism.  This
is not a requirement.  If your MG never makes a mistake,
your transport never loses a message, and you general leave
a clean and virtuous life, then the timers won't be
usefull to you.

---

From: Chuong Nguyen <[email-masked]>
Date: Wed, 13 Oct 1999 15:53:06 -0500

> Yes, and yes, indeed.  That is the intention.

What was confusing about this paragraph was the third sentence:
"The ServiceChangeMethod shall be "forced" for this usage".
So if you use ROOT and Forced, it implies registration which I don't think
was the intention.

Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****