Subject: Re: AW: AW: Basic Package and NAS

From: Faad Ghoraishi <[email-masked]>
Date: Mon, 11 Oct 1999 15:01:39 -0400

Brian Rosen writes:
>The model we have is that the MGC has all the call state,
>and the MGC has very little state at all.  Anything that
>affects call state should be communicated to the MGC for it
>to take action.  ....

Well put.  So there is no MGC EVENT defined for AAA or L2TP failure to be
sent to MG. And the MG never sends a Subtract message when a call
failes due to AAA failure.

So, in this failure case, the call is never going to be disconnected in the MG,
is it?

I think we MUST allow the MGC to be in charge of the complete call.
The AAA and the PPP/L2TP sessions are part of the NAS call , similar to
TCAP (Query/Response) being part of the end to end 800 toll free calls.

Also, using the A,O&M interface to notify the MGC (as some suggest) is also a
major mistake, since there will be too many call related messages put on this
interface and could hinder management.

Faad Ghoraishi
Telcordia Tech. Inc.
USA

Brian Rosen <[email-masked]> on 10/11/99 02:45:42 PM

Please respond to Brian Rosen <[email-masked]>

To:   [email-masked]
cc:    (bcc: Faad Ghoraishi/Bellcore)
Subject:  Re: AW: AW: Basic Package and NAS

> The MG
> >doesn't send Subtract or Modify messages to the MGC.  There is no
> >"disconnect" message in Megaco.
>
> Isn't disconnect the same things as subtract?
>
> The MG must be allowed to choose to disconnect (or subtract)
> on it's own.
>
There is no provision for the MG to disconnect (or
subtract) a termination except on actual failure of the
termination.  ServiceChange(forced) is used to
notify the MGC of such a failure.  This is expected to
be used in true failure of the hardware (or software),
not a routine event like AAA authentication denial.

The correct way to handle this case is an event, which
would cause the MGC to Subtract the Termination.

The model we have is that the MGC has all the call state,
and the MGC has very little state at all.  Anything that
affects call state should be communicated to the MGC for it
to take action.  The MG should never take action on it's
own except for irretrievable failure.

Brian

---

From: Matt Holdrege <[email-masked]>
Date: Mon, 11 Oct 1999 12:50:53 -0700

>interface and could hinder management.

Just as there are too many AAA related messages which would hinder call
management? It's a heck of a lot more than an accept/deny message and an
L2TP setup.