Subject: Are Signals and Events Stream Dependent

From: Brian Rosen <[email-masked]>
Date: Thu, 7 Oct 1999 09:43:54 -0400

This may be an issue best left to the SG16 folks, but:

At the moment, signals and events apply to an entire
termination.  This does not seem to be correct.
Signals clearly are stream dependent (although you could
think about a single signal that had both audio and video
data).  In all the cases I can think about, events are
stream dependent.

This leads me to suggest that EventsDescriptor and
SignalsDescriptor belong in StreamDescriptor, with the current assumption
that if they are found at the command parameter level (where they are
currently defined),
they are assumed to be stream=1, audio.

Brian

---

From: Chip Sharp <[email-masked]>
Date: Thu, 7 Oct 1999 20:28:22 -0400

Not that I care to design a H.320-H.323 gateway, but wouldn't some events
have to map to the BAS codes which aren't necessarily a per-stream event?
Actually, even though there is text in H.248 about how to use it for such a
gateway, I have not seen any contributions showing how it would actually
work in a real H.320-H.323 gateway.  For example, there is no real mapping
defined in H.248 for H.320 BAS "messages" for mode change, for capability
exchange, for H.230, H.235, H.242, H.243, etc. commands, for T.120 MLP
message exchange, conference control commands, etc. ad-nauseum.

In other words, there are so many big gaping holes in the H.320 support I'm
not sure if this matters too much.

Chip

>they are assumed to be stream=1, audio.

--------------------------------------------------
Chip Sharp                 Consulting Engineering
Cisco Systems              Telco Bio-region
Reality - Love it or Leave it.
--------------------------------------------------

---

From: Bryan Hill <[email-masked]>
Date: Fri, 8 Oct 1999 13:35:37 -0400

Not that I care to design an H.320 to H.323 gateway either, but the ITU
H.246 spec maps BAS code to H.245 commands.  As far as streams go one could
consider the BAS channel a control stream separate from the Audio, Video and
T.120 data stream in an H.320 connection.  There is also the well documented
issue about latency between an MG and MGC and the need for BAS commands to
take effect on 20 msec H.221 framing boundaries so handling BAS/H.245 events
in an H.320/H.323 may be handled locally on an MG.

Bryan

= = = = = = = = = = =
Bryan Hill
Gotham Networks

 -----Original Message-----
From:   Media Gateway Control (megaco)
[mailto:[email-masked]]  On Behalf Of Chip Sharp
Sent:   Thursday, October 07, 1999 8:28 PM
To:     [email-masked]
Subject:        Re: Are Signals and Events Stream Dependent

Chip

---

From: Tim Vetter <[email-masked]>
Date: Wed, 20 Oct 1999 11:47:35 -0500

Has the issue of allowing EventsDescriptor to belong to
StreamDescriptor been decided?  The version 11 ABNF does not
allow it.  However, the Annex G has example that shows this
being used (G.1.2/Step #12):

MEGACO/1.0 [123.123.123.4]:55555
Transaction = 10003 {
    Context = $ {
       Add = A4444 {
           Media {
             Stream = 1 {
               Events = 2224 {glinesup/onhook} }    <--- *********
           }
       },
       Add = $ {
           Media {
             Stream = 1 {
                  LocalControl {
                      Mode = ReceiveOnly,
                      g/NetworkType = RTP/IP4, ;
                      g/MaxJitterBuffer=40, ; in ms
                      g/PreferredPacketization=30, ; in ms
                      g/PreferredPacketization=30, ; in ms
                      g/PreferredEncoders =[G723, PCMU],
                      g/PreferredDecoders=[G723, PCMU],
                      g/Gain=0 ; in dB
                  }

              }
           }

    }
}