Subject: Re: Review of V12 ABNF

From: Brian Rosen <[email-masked]>
Date: Wed, 3 Nov 1999 20:17:14 -0500

> from:
> localDescriptor = LocalToken EQUAL octetString
> to:
> localDescriptor = LocalToken EQUAL SdpToken LBRKT octetString RBRKT
>
> from:
> remoteDescriptor = RemoteToken EQUAL octetString
> to:
> remoteDescriptor = RemoteToken EQUAL SdpToken LBRKT octetString RBRKT
No, the text was changed so that text encoding is always SDP, binary
encoding is always Tag/Value.  There is no need for an encoding token.

> from:
> MuxType = ( H221Token / H223Token / H226Token / extensionParameter )
> to:
> MuxType = ( H221Token / H223Token / H226Token / V75Token/
> extensionParameter )
Okay

> from:
> eventOther = eventParameterName EQUAL parmValue
> to:
> eventOther = eventParameterName parmValue
Ah yes, of course, parmValue has the EQUAL/notequal...

> from:
> signalList  = SignalListToken EQUAL LWSP signalListId
>       LWSP LBRKT sigListParm *(COMMA sigListParm RBRKT
> to:
> signalList  = SignalListToken EQUAL signalListId LBRKT
>             signalListParm *(COMMA signalListParm) RBRKT
Yeah, I saw that but didn't fix it, EQUAL and LBRKT have whitespace already

> from:
> sigOther = sigParameterName EQUAL parmValue
> to:
> sigOther = sigParameterName parmValue
yep, same thing

> from:
> serviceChangeAddress = ServiceChangeAddressToken EQUAL
>      VALUEserviceChangeMgcId   = MgcIdToken   EQUAL mId
> to:
> serviceChangeAddress = ServiceChangeAddressToken EQUAL VALUE
> serviceChangeMgcId   = MgcIdToken   EQUAL mId
I missed a "return"? silly me!

> from:
> extension = extensionParameter EQUAL parmValue
> to:
> extension = extensionParameter parmValue
again!

> from:
> priorityToken
> to:
> PriorityToken
Yes, must have the case right!

> Deleted:
> BufferedEventHandlingToken = ("BufferedEventHandling" / "BE")
> LoopToken  = ("Loop" / "LP")
Yes

> Added:
> KeepActiveToken = ("KeepActive" / "KA")
> MTPToken = ("MTP")
> SignalTypeToken = ("SignalType" / "SY")
> V75Token = ("V75")
Ooops

Thanks for finding all these.  We all owe you and your collegues
for all your efforts to make the grammar accurate when we go in and
fiddle with it!

Brian

---

From: "Sanjay Kr. Gupta" <[email-masked]>
Date: Thu, 4 Nov 1999 11:00:23 +0530

Hello Brian,

> encoding is always Tag/Value.  There is no need for an encoding token.

Agreed that we do not need the encoding token, but we still need the RBRKT to
detect the end of the OctetString. The rule should be :

localDescriptor = LocalToken LBRKT octetString RBRKT
remoteDescriptor = RemoteToken LBRKT octetString RBRKT

Sanjay Kr. Gupta
Ficon Technology
e-mail : mailto:[email-masked]
web    : http://www.ficon-tech.com

---

From: Abdallah Rayhan <[email-masked]>
Date: Thu, 4 Nov 1999 08:24:11 -0500

Brian,

If we decide to get ride of SdpToken, then LBRKT and RBRKT must stay. Otherwise
we can not contain octetString.

Abdallah