Subject: Re: Washington Issue 9 - Wildcards in SDP

From: Nancy-M Greene <[email-masked]>
Date: Tue, 16 Nov 1999 11:47:59 -0600

I'd like to know who proposed this and why?

Here is how I thought things worked: We have a LocalDescriptor in the
StreamDescriptor that allows the MGC to give preferred SDP choices to the
MG, e.g., preferred encoding method, decoding method, packetization time,
bandwidth - see the Network package (E.9.1).

Thus, the MGC does not need to send a partially completed SDP to the MG. It
uses the Local descriptor and the MG then returns valid SDP - no need for $
or * in the SDP. See the example in Appendix I.

Thus, no change is needed to the SDP.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Brian Rosen[SMTP:[email-masked]]
> Sent:         Monday, November 15, 1999 2:26 PM
> To:   [email-masked]
> Subject:      Washington Issue 9 - Wildcards in SDP
>
> A number of issues were raised in the Washington meeting that
> were "send to the list".  This is one of these issues, with the
> problem and my suggested fix.
>
> Problem:
>
> It may be desirable to allow a wildcard in SDP, which would
> be filled in by the responder.
>
> Proposed Solution:
> Allow ={value,value...}, or "$" or "*" in the SDP
>
> Please note: this is a real syntax change to SDP.
> It may be better to suggest that the work be done in MMUSIC
>
> Brian
>

---

From: Chip Sharp <[email-masked]>
Date: Tue, 16 Nov 1999 13:24:46 -0500

I concur.  I haven't heard any application for such a thing.
If someone wants it, that person should right up the application with a
proposal.

The LocalDescriptor SDP provides the description of what the local MG is
willing/able to receive.  The RemoteDescriptor SDP provides a description
of what the remote MG is willing/able to receive.

Chip

At 11:47 AM 11/16/99 -0600, Nancy-M Greene wrote:

>Thus, the MGC does not need to send a partially completed SDP to the MG.
>It uses the Local descriptor and the MG then returns valid SDP - no need
>for $ or * in the SDP. See the example in Appendix I.
>
>----------  From:   Brian Rosen[SMTP:[email-masked]]  Sent:   Monday,
>November 15, 1999 2:26
>PM  To:     [email-masked]  Subject:
>Washington Issue 9 - Wildcards in SDP
>
>A number of issues were raised in the Washington meeting that  were "send
>to the list".  This is one of these issues, with the  problem and my
>suggested fix.
>
>Problem:
>
>It may be desirable to allow a wildcard in SDP, which would  be filled in
>by the responder.
>
>Proposed Solution:  Allow ={value,value...}, or "$" or "*" in the SDP
>
>Please note: this is a real syntax change to SDP.  It may be better to
>suggest that the work be done in MMUSIC
>
>Brian

Support NetAid!  http://www.netaid.org
--------------------------------------------------
Chip Sharp                 Consulting Engineering
Cisco Systems              Telco Bio-region
Reality - Love it or Leave it.
--------------------------------------------------

---

From: Nancy-M Greene <[email-masked]>
Date: Wed, 17 Nov 1999 14:44:41 -0600

The LocalControl descriptor is used for CHOOSE. That way we do not need to
change the sdp.

Nancy

> Sent:         Wednesday, November 17, 1999 10:48 AM
> Subject:      Re: Washington Issue 9 - Wildcards in SDP
>
> Sorry, "$" is what I propose, not "$" or "*".
>
> > -----Original Message-----
> > From: Christian Groves [mailto:[email-masked]]
> > Sent: Wednesday, November 17, 1999 10:22 AM
> > To: Brian Rosen
> > Cc: [email-masked]
> > Subject: Re: Washington Issue 9 - Wildcards in SDP
> >
> >
> > G'Day all,
> >
> > I support the use of wildcarded (ie. CHOOSE) in properties.
> >
> > I gathered this was the underspecified property which is supported in
> > the binary
> > version of the protocol.
> >
> > I'm not sure of the use of '*' ALL though. Any examples?
> >
> > Cheers, Christian
> >
> > Brian Rosen wrote:
> > >