Subject: Re: Digit Collection and Notification

From: Brian Rosen <[email-masked]>
Date: Thu, 11 Nov 1999 17:03:24 -0500

> Hi Brian
>      Thanks for the response. I continue with another query
> on Digit collection
> 1) If user dials  digits, not according to dial plan, by
> virtue of which there
> is no "notify" message to MGC. What does the User listens in
> response to this as
> he/she might not be aware of the dial plan in the MG?
> Probably a timer at MGC
> might result in further message to MG for feeding some  tone to that
> termination. Correct me if iam wrong.
If there is NO event in the event descriptor for the DTMF digits,
the gateway does nothing.  This might be normal when the
call is connected to an IVR for example.  If the MGC wants to
decide what to do with the digits, it would set a Notify action
on the DTMF events.

Does that answer the question?

> 2) How does dial tone stopps, as soon a digit is dialed. (
> Does the "digits"
> event result in stopping of dial tone?).
Events stop signals if the signal is TO.  If it is OO, then
you COULD use an embedded signal descriptor to turn it off.
There is still some discussion on this subject.

>      Another query not related to Digit collection
> What is the significance of events and signals in "Audit
> Capabilities" command,
> Since the events and signals possible on that termination are
>  defined in  the
> package supported by the terminations ( Package descriptor ).
If you auditValue the EventsDescriptor, you get what is currently
the events enabled (pretty much what you sent as the last EventsDescriptor.
If you AuditCapabilities, you get a list of all the possible events,
and for each event, all of the parameters possible for that event.

Brian
>
>
>
>
> Brian Rosen <[email-masked]> on 11/10/99 01:17:27 AM
>
> To:   Madhu B Babu/HSS@HSS, [email-masked]
> cc:
>
> Subject:  RE: Digit Collection and Notification
>
>
>
>
> > HI Brian
> >      Few queries on Digit collection in Residential Gateway Call
> > 1) What is the event to be specified (by MGC) in the event
> > descriptor to
> > indicate MG for collection of  digits. The example in the
> > Appendix show that the
> > digit map is specified in "Action" of Onhook event. Please clarify.
> The digitmap itself is the "event", although the syntax is, I agree
> confusing on the matter.  I need to consult with a few more people
> before I answer this fully, so hang on a little.
>
> > 2) If digits need to be notified to MGC after collection at
> > MG, Are the digits
> > specified as sequence of events detected or as specified in
> > the example
> > "detected tone = 161355...".
> Again, we have some syntax confusion, but the event returns the
> digits as a string as shown in the examples.
>
>
> Brian
>

---

From: Harpreet Singh Anand <[email-masked]>
Date: Fri, 12 Nov 1999 18:25:12 +0530

Hello Brian,

> you COULD use an embedded signal descriptor to turn it off.

According to the text in sec 7.1.9, whenever an event for which there is a
notify action is detected, the signals that were active would be stopped. The
text does not say that only TO signals would be stopped and that OO signals
would not be stopped.

Am I missing something ?

I have few more questions on EventsDescritor handling which I am listing below:

1.  When an event with an action as Notify occurs, then MG reports the event to
the MGC and
clears the signals.

What happens to the Events - will the the MG continue to listen on the events ?

Basically, what happens during the "quarantine" period (after a Notify has been
sent and before a new EventDescriptor is received) ?

2. What is the difference between the BufferedEventProcessingMode as "Process"
and the event action "Accumulate" ?

What will happen if the BufferedEventProcessingMode as "Discard" and the event
action is set to "Accumulate" ?

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com