Subject: Re: Summary of Megaco Meetings

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 15 Nov 1999 15:35:44 -0500

The SIGTRAN stuff is work in hand, agreed because Qiaobing Xie and Randy
Stewart took the trouble to put the proposal on the table.  It is not
mentioned in the body of the protocol document -- it will appear as an annex
to H.248 (and presumably as a separate RFC).  So I guess we are in the
position of not mentioning either SIP or SCTP in the main document, as per
your second alternative.

> -----Original Message-----
> From: Henry Sinnreich [SMTP:[email-masked]]
> Sent: Monday, November 15, 1999 3:11 PM
> To:   Taylor, Tom-PT [CAR:B904-I:EXCH];
> [email-masked]
> Cc:   [email-masked]
> Subject:      RE: Summary of Megaco Meetings
>
> >I think this is an idea worth pursuing
> the only issue in this discussion is to mention SIP as an option for
> inter-gateways signaling and not only to mention SIGTRAN alone. Suggest
> the SIP WG paper as reference
> "SIP Best Current Practice for Telephony Interworking"
> < <
> <http://search.ietf.org/internet-drafts/draft-zimmerer-sip-bcp-t-00.txt>>>
>  and any other from the SIP WG.
>
> Can we get agreement and closure on mentioning both SIP and SIGTRAN? Or
> not mention either...
>
> Henry
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 16 Nov 1999 08:05:49 -0500

That's where we need the BOF.  The picture I got was of an Enhanced Services
Node sending SIP back to an MGC with encapsulated Megaco/H.248 messages
destined for the MG.

> From: Ong, Lyndon [SC1:470-I:EXCH]
> Sent: Monday, November 15, 1999 4:49 PM
> To:   [email-masked]
> Subject:      Re: Summary of Megaco Meetings
>
> Hmm, maybe I can ask for more context on Henry's email:
>
> -- SIP could be used for transport, but it uses application layer framing
> in the same way that Megaco over UDP would use application layer framing,
> so there's no advantage, is there?
>
> -- on the other hand, the email that Henry sent out seems to suggest that
> there might be some combination of SIP and Megaco, something like a mix of
> functional and stimulus in the same terminal.  Is that more what we're
> talking about?
>
> Cheers,
>
> L. Ong
>
> At 03:16 PM 11/15/99 -0600, Qiaobing Xie wrote:
> >On Nov 15,  2:11pm, Henry Sinnreich wrote:
> >> Subject: Re: Summary of Megaco Meetings
> >...snip..
> not
> >> mention either...
> >Henry,
> >What's wrong with mentioning SIGTRAN as an additional megaco transport?
> >I simply do not understand your logic of tieing SIP and SIGTRAN togather.
> >
> >SIGTRAN is a transport protocol, designed to carry formatless payload
> >datagrams from A to B at the request of whatever application protocol
> >sitting on top of it. SIGTRAN is comparable to TCP or UDP..
> >
> >However, as Chip pointed out in an earlier email, SIP is NOT a
> >transport protocol. Instead, it is an application protocol with its
> >own message syntax. It's fine if, for whatever reason, you want to
> >carry messages from another protocol in side your SIP messages. But it
> >is really not transporting... Piggy-backing or application message
> >bundling may be a better term..
> >
> >-Qiaobing Xie
> >
> >>
> >> Henry
> >>
> >> [ Attachment (multipart/alternative): 61731 bytes ]
> >>-- End of excerpt from Henry Sinnreich
> >

---

From: Pyda Srisuresh <[email-masked]>
Date: Tue, 16 Nov 1999 07:06:38 -0800

--- Lyndon Ong <[email-masked]> wrote:
> -- SIP could be used for transport, but it uses application layer framing in
> the same way that Megaco over UDP would use application layer framing, so
> there's no advantage, is there?
>

I believe, the advantage is that the MGC is able to work with a SIP network.
I.e., MGC (telephony gateway) and SIP UAC(say, IP phone) will simply be
clients to SIP network.

cheers,
suresh
__________________________________________________
Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

---

From: Brian Rosen <[email-masked]>
Date: Wed, 17 Nov 1999 07:36:57 -0500

Okay, I tried to keep it simple.  Not everyone knows/understands
what BICC is.

Yes, BICC should replace ISUP in the diagram. Maybe I should
have written ISUP(BICC)

Brian

> From: Alf Heidermark [mailto:[email-masked]]
> Sent: Wednesday, November 17, 1999 2:28 AM
> To: [email-masked]
> I assume you should add BICC as one of the protocol running between
> MGCs.
>
> Roy, Radhika R, ALARC wrote:
> >
> > Hi, Everyone:
> >
> > Yes, I agree with Nancy that this is much clearer diagram.
> >
> > I appreciate Henry and others who took the lead for clarifying this
> > important issue.
> >
> > Best regards,
> > Radhika R. Roy
> > AT&T
> > + 1 732 420 1580
> > [email-masked]
> >
> > > From: Nancy-M Greene [SMTP:[email-masked]]
> > > Sent: Tuesday, November 16, 1999 10:34 AM
> > > Taking the picture from Brian's email:
> > >        MGC     ---   SIP/ISUP/H.323   ---   MGC
> > >           |                                                   |
> > >       Megaco                                       Megaco
> > >           |                                                   |
> > >         MG      ---   RTP/AAL2/....       ---   MG
> > >
> > > Altering to show interaction with a SIP client, as in
> Pyda's email below:
> > >
> > >        MGC     ---   SIP       ---------------   SIP UAC
> (i.e. SIP IP
> > > Phone)
> > >           |                                                   |
> > >       Megaco                                         /
> > >           |                                             /
> > >         MG      ---   RTP/AAL2/....  ------/
> > >
> > > In this case the RTP/AAL2 goes from the MG to the SIP IP
> Phone. The SIP
> > > UAC is a peer to the MGC. The SIP UAC does not need to
> know that the MGC
> > > uses Megaco to talk to its MG.
> > >
> > >
> > >
> > > Note that here we do not get SIP and Megaco overlapping - they are
> > > happening in different places.
> > >
> > >
> > > Nancy
> > >
> --------------------------------------------------------------
> ------------
> > >
> > > Nancy M. Greene
> > > Internet & Service Provider Networks, Nortel Networks
> > > T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
> > >
> > >       ----------
> > > From:   Pyda Srisuresh[SMTP:[email-masked]]
> > > Sent:   Tuesday, November 16, 1999 10:06 AM
> > > > -- SIP could be used for transport, but it uses
> application layer
> > > framing in
> > > > the same way that Megaco over UDP would use application
> layer framing,
> > > so
> > >       I believe, the advantage is that the MGC is able to
> work with a SIP
> > > network.
> > > Bid and sell for free at <http://auctions.yahoo.com>
> > >
>