Subject: Re: Washington Issue 18 - Wildcard Subtract

From: Brian Rosen <[email-masked]>
Date: Mon, 15 Nov 1999 17:14:30 -0500

I agree that ALL does not include NULL in Subtract!

WRT DigitMaps, it does not make any sense IMO to have a digitmap
on a termination not in a context.  When you Add it to a context,
or later Modify it, then you can specify a DigitMap.

It may be that an MG allows/requires digitmap definitions to be global.
There are three ways I can think about to define
global digitmaps:
        1) Define them in any termination, they are useable in
                any others - bad if an MG allows, but does not
                require, global digitmaps
        2) Define them on root
        3) Define them with wildcard

I'd say the answer depends on Issue 3 - Packages adding properties to root.
If we do say that packages are allowed to
add properties to root, then I think 2 is the answer, otherwise
3.

Brian

> -----Original Message-----
> From: Wai-tak Siu [mailto:[email-masked]]
> Sent: Monday, November 15, 1999 4:38 PM
> To: [email-masked]
> Subject: Re: Washington Issue 18 - Wildcard Subtract
>
>
> Brian,
>     From the proposed solution, I suppose this ALL context ID does not
> apply to the NULL context, since terminations cannot be
> removed from the
> NULL context.
>     If so, when an MGC wants to apply a digit map to all the
> terminations,
> it will have to generate two actions, one for the
> terminations in the NULL
> context, and the other for the terminations in ALL other
> contexts. In fact,
> the definition of ALL for context ID is not stated clearly in
> the protocol.
>
>     Thanks.
> Waitak
>
> Brian Rosen wrote:
>
> > A number of issues were raised in the Washington meeting that
> > were "send to the list".  This is one of these issues, with the
> > problem and my suggested fix.
> >
> > Problem:
> > There is no way to express deleting all terminations that
> are part of a
> > multichannel physical interface.  The issue is that
> > you can construct a wildcard terminationID, but they will be
> > in multiple contexts.  Wildcard of ContextID in Subtract is not
> > currently allowed
> >
> > Proposed Solution
> > Allow ALL in ContextID of Subtract.
> >
> > Brian
>

---

From: Chuong Nguyen <[email-masked]>
Date: Thu, 18 Nov 1999 16:17:42 -0500

Brian

If an MGC wants to clear out all the context in the MG and does not want to
use Audit to find out
what contexts were created, the MGC would use Subtract w/context=ALL.
(It is a special scenario.)

In some earlier discussion you said that using ServiceChange to take
terminations out of service,
does not remove the terminations from contexts.  MGC has to Subtract all
terminations from the
context to remove the context.

Can you clariity how can an MGC remove all contexts at MG with a single
command?

Thanks
Chuong

On Wed, 17 Nov 1999 15:32:01 -0500, Brian Rosen <[email-masked]> wrote:

>I'm not sure I would recommend someone do a
>Context=*{Subtract=*}
>That does seem to me to be in the range of a service change.
>
>I was thinking about:
>Context=*{Subtract=d19c332/1/*}
>That is, take down all the ds0s in a ds1 on this ds3.
>I get a nice response, which is the contextIDs of every
>affected context.
>
>This IS an optimization.  The MGC must know the contextIds
>of every DS0 in every DS1 on the DS3.
>
>Brian
>
>> From: Michael Brown [mailto:[email-masked]]
>> Sent: Wednesday, November 17, 1999 2:21 PM
>> I didn't remember that ALL was allowed in the ASN.1 so I just
>> took a quick
>> look and indeed it is.  I do, however, wonder about the use
>> of it in the
>> original problem description. That is, it seems that ALL is
>> too broad to do
>> the removal of all terminations for a multichannel physical interface.
>> Perhaps I'm missing something, but it would seem that ALL
>> used in a SUBTRACT
>> would remove the terminations and take down ALL the contexts
>> on the MG. I
>> guess I just don't see how this applies to the problem described.
>>
>> Assuming that the description of the behavior of ALL is
>> correct, wouldn't
>> this kind of function be better handled with ServiceChange? I
>> guess the
>> question is do we really need ALL wildcarding for context ids
>> in subtract?
>>
>> Michael
>>
>> Christian Groves wrote:
>>
>> > G'Day Brian,
>> >
>> > I thought this was already in the base protocol. In the
>> ASN1 contextID =
>> > ALL. If not then we should add it.
>> >
>> > Cheers, Christian
>> >
>> > Brian Rosen wrote:
>> > >

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 19 Nov 1999 08:26:33 -0500

It may be that in a small gateway you want to clear them all
with one command, but in that instance, you know all the
names of the terminations and you could wildcard the
contextid.

If you had a big gateway, you can't tolerate the size of the
reply to a single command - you need to restrict the response
in some way.  Depending on how the suggestion to allow a
wildcard response (W-) comes out, you could think about something like:
Context=*{W-Subtract=*{Audit{}}}
That would give you a one line response.  Anything else is
likely to overwhelm you.

I consider Context=*{Command=*{.... to be dangerous unless you
can control the output from it.

brian

> From: Chuong Nguyen [mailto:[email-masked]]
> Sent: Thursday, November 18, 1999 4:18 PM