Subject: Re: MG-MGC control interface

From: Giuseppe Ricagni <[email-masked]>
Date: Wed, 3 Nov 1999 16:31:12 +0100

Sorry Brian, but now I' m confused too.

Brian Rosen wrote:

> > By the way, how does a virtual MG know that a message coming
> > from the MGC is
> > destined
> > for this virtual MG? I assume that messages to all virtual
> > MGs in the same
> > physical MG go to the
> > same IP address. The MGC IP address can be used as a way to
> > route messages to
> > the right
> > virtual MG provided that the list of MGC for each virtual MG
> > are mutually
> > exclusive.
> Actually it's more complicated than that, since, at least in
> theory, the same MGC could control multiple virtual MGs on the same physical
> MG.
>
> The answer is that the mId of the message would be unique for each virtual
> MG.  That implies you have something like
> aliases in your DNS.
>

In section 8.3 I read "Messages have a header, which includes the identity of
the sender. The Message Identifier (MID) of a message is set to a provisioned
name (e.g. domain address/domain name/device name) of the entity transmitting
the message."

The mId identifies the sender' s (MGC) name, and not the target name (MG),
doesn' t it ?
Do we assume that we need multiple "virtual MGCs" to cater for virtual MGs ?

Best Regards
Giuseppe Ricagni

--
----------------------------------------------------------
Giuseppe RICAGNI
System Architecture and Product Planning
Broadband Networks
Italtel
via Reiss Romoli - C10
20019 Castelletto di Settimo Milanese (MILANO)
ITALY

mailto:[email-masked]
----------------------------------------------------------

---

From: Brian Rosen <[email-masked]>
Date: Wed, 3 Nov 1999 20:17:11 -0500

Sorry I confused you.  You are correct. I must have been asleep; this issue
was raised and answered before.

The transport differentiates the streams.  Using IP transport, for example,
each flow is on a different port.  Using ATM transport with SSCOP, each
stream is a different VC.

Brian

> -----Original Message-----
> From: Giuseppe Ricagni [mailto:[email-masked]]
> Sent: Wednesday, November 03, 1999 10:31 AM
> To: Brian Rosen
> Cc: [email-masked]
> Subject: Re: MG-MGC control interface
>
>

---

From: "Petros N. Mouchtaris" <[email-masked]>
Date: Thu, 4 Nov 1999 09:26:56 -0500

Brian,
The previous answer you gave (mId) could work but it would not be pretty.
The new answer you are giving would work too but it will not be pretty either.

How will the MGC and MG know which port corresponds to which MG?
Are you planning to reserve more than one well known port for the protocol?

Petros

Brian Rosen <[email-masked]> on 11/03/99 08:17:11 PM

Please respond to Brian Rosen <[email-masked]>

To:   [email-masked]
cc:    (bcc: Petros N. Mouchtaris/Telcordia)
Subject:  Re: MG-MGC control interface

Brian

---

From: Brian Rosen <[email-masked]>
Date: Thu, 4 Nov 1999 17:14:16 -0500

You would have a separate port for each association.

The thing now called ServiceChangeAddress would specify it
if necessary.

> From: Petros N. Mouchtaris [mailto:[email-masked]]
> Sent: Thursday, November 04, 1999 9:27 AM