Subject: Re: Summary of Megaco Meetings

From: Qiaobing Xie <[email-masked]>
Date: Mon, 15 Nov 1999 15:16:59 -0600

On Nov 15,  2:11pm, Henry Sinnreich wrote:
> Subject: Re: Summary of Megaco Meetings
...snip..
> Can we get agreement and closure on mentioning both SIP and SIGTRAN? Or not
> mention either...

Henry,

What's wrong with mentioning SIGTRAN as an additional megaco transport?
I simply do not understand your logic of tieing SIP and SIGTRAN togather.

SIGTRAN is a transport protocol, designed to carry formatless payload
datagrams from A to B at the request of whatever application protocol
sitting on top of it. SIGTRAN is comparable to TCP or UDP..

However, as Chip pointed out in an earlier email, SIP is NOT a
transport protocol. Instead, it is an application protocol with its
own message syntax. It's fine if, for whatever reason, you want to
carry messages from another protocol in side your SIP messages. But it
is really not transporting... Piggy-backing or application message
bundling may be a better term..

-Qiaobing Xie

>
> Henry
>
> [ Attachment (multipart/alternative): 61731 bytes ]
>-- End of excerpt from Henry Sinnreich

---

From: Henry Sinnreich <[email-masked]>
Date: Mon, 15 Nov 1999 15:35:31 -0600

> What's wrong with mentioning SIGTRAN as an additional megaco transport?
Nothing wrong. Brian Rosen got it right as shown:

       MGC     ---   SIP/ISUP/H.323   --- MGC
        |                                  |
      Megaco                             Megaco
        |                                  |
        MG      ---   RTP/AAL2/....    ---MG

Henry

> -----Original Message-----
> From: Media Gateway Control (megaco)
> [mailto:[email-masked]]On Behalf Of Qiaobing Xie
> Sent: Monday, November 15, 1999 3:17 PM
> To: [email-masked]

---

From: Lyndon Ong <[email-masked]>
Date: Mon, 15 Nov 1999 13:49:08 -0800

Hmm, maybe I can ask for more context on Henry's email:

-- SIP could be used for transport, but it uses application layer framing in the same way that Megaco over UDP would use application layer framing, so there's no advantage, is there?

-- on the other hand, the email that Henry sent out seems to suggest that there might be some combination of SIP and Megaco, something like a mix of functional and stimulus in the same terminal.  Is that more what we're talking about?

Cheers,

L. Ong

---

From: Henry Sinnreich <[email-masked]>
Date: Tue, 16 Nov 1999 15:57:39 -0600

Lyndon wrote:
> -- SIP could be used for transport, but it uses application layer
> framing in the same way that Megaco over UDP would use
> application layer framing, so there's no advantage, is there?
I did not mean SIP to transport signaling, but SIP is the signaling between
gateways and other devices such as SIP phones and other multimedia clients.
Between any type of clients and call setup servers. It is the any-to-any
argument. A gateway is also a SIP client. For gateways please see:
"SIP Best Current Practice for Telephony Interworking"
http://search.ietf.org/internet-drafts/draft-zimmerer-sip-bcp-t-00.txt

> -- on the other hand, the email that Henry sent out seems to
> suggest that there might be some combination of SIP and Megaco,
> something like a mix of functional and stimulus in the same

I did not mean anything else than what is shown in Brian's drawing.

       MGC---SIP/ISUP/H.323---MGC
        |                      |
      Megaco                Megaco
        |                      |
       MG --- RTP/AAL2/....--- MG

Thanks for mentioning these points.

Henry

> [mailto:[email-masked]]On Behalf Of Lyndon Ong
> Sent: Monday, November 15, 1999 3:49 PM
> -- SIP could be used for transport, but it uses application layer
> framing in the same way that Megaco over UDP would use
> application layer framing, so there's no advantage, is there?
>
> -- on the other hand, the email that Henry sent out seems to
> suggest that there might be some combination of SIP and Megaco,
> something like a mix of functional and stimulus in the same
> terminal.  Is that more what we're talking about?
>
> Cheers,
>
> L. Ong
>