Subject: Re: MEGACO reserved names

From: Nancy-M Greene <[email-masked]>
Date: Tue, 2 Nov 1999 14:49:43 -0500

The protocol is extendable. In the text encoding of the protocol, you can
extend the commands and parameters by prefixing the new commands/parameters
with "X-".

On the issue of Megaco reserved names - I think we need to state in section
12 on Packages,  that the PackageName part of the pkgdName MUST be present
to qualify the ItemID. If we do this then I think we are ok. We only need to
ensure that PackageName/ItemID (=pkgdName) is not a Megaco reserved word,
and since PackageName/ItemID always has a "/" in it, and no Megaco reserved
word has a slash, there is no problem.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Pete Cordell[SMTP:[email-masked]]
> Sent:         Tuesday, November 02, 1999 6:25 AM
> To:   [email-masked]
> Subject:      Re: MEGACO reserved names
>
> A question...
>
> If the parsing of the protocol is predicated on knowing what are reserved
> words, surely that means that new reserved words can not be added and
> hence
> the protocol becomes un-extendable.  This sounds rather dangerous to me.
> But maybe I've missed something.
>
> Pete
>
> =============================================
> Pete Cordell
> [email-masked]
> =============================================
>
>

---

From: Harpreet Singh Anand <[email-masked]>
Date: Thu, 4 Nov 1999 14:14:03 +0530

Nancy,

> extend the commands and parameters by prefixing the new commands/parameters

In v12, there is no mention of extension of commands. The text encoding allows
extension of only the following:

- muxType
- requestedAction
- modemType
- ServiceChangeParam
- ServiceChangeMethod
- StatisticsParameter

Is there any other paramter / command that can be extended ?

Thanks and Regards,
Harpreet

>
>
> On the issue of Megaco reserved names - I think we need to state in section 12
> on Packages,  that the PackageName part of the pkgdName MUST be present to
> qualify the ItemID. If we do this then I think we are ok. We only need to
> ensure that PackageName/ItemID (=pkgdName) is not a Megaco reserved word, and
> sincePackageName/ItemIDalways has a "/" in it, and no Megaco reserved word has
> a slash, there is no problem.
>
> Nancy
--

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com