Subject: Re: transaction in H.248

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 16 Nov 1999 14:43:05 -0600

No, the quoted statement is the correct one.  "o-" means that the command so
marked will not stop a transaction if it fails.  Any other command will,
even if there are subsequent "o-" commands.

More comments below.

> -----Original Message-----
> From: Vikas Bansal [SMTP:[email-masked]]
> Sent: Tuesday, November 16, 1999 2:40 PM
> To:   [email-masked]
> Subject:      Re: transaction in H.248
>
> Wai-tak Siu wrote:
>
> > Hi,
> >
> >     I have a few questions on how transactions are handled in error
> > cases.
> >     Scenario: A transaction consists of multiple commands, and the
> > transaction processing stops at the last command that generates an
> > error, unless the command is optional.
>
> If a command is marked "optional", it means that the command may be
> executed
>
> even if a previous command results in an error. So in case of an error,
> stopping the transaction processing does not depend on whether the erred
> command is optional or not, it only depends on whether the subsequent
> command(s) are optional. Rephrasing ur sentence
> "A transaction consists of multiple commands, and the
> transaction processing stops at the last command that generates an
> error, unless the SUBSEQUENT command(s) are optional AND gateway decides
> to
> execute these optional commands".
>
> > The commands before the one that
> > generates the error are not rolled back.
>
> ok.
>
> >
> >     Question: Is the command that generates the error atomic, and
> > treated as if it has not been processed? Specifically, if this command
> > contains an EventDescriptor, will it not replace the existing one at the
> > termination?
>
> Gateway implementation should take care that any command which results in
> a
> an error does not have any side effects. I suppose thats the way it should
> work. The draft is silent about this.
        [[TomT]]
        I think we managed to agree that command execution is atomic.  If we
need clarifying wording, then from the ITU's point of view it would go into
the H.248 Implementor's Guide.

> >
> >     Making it a bit more complicated... If the command applies to
> > multiple terminations, and the command fails only at one termination T.
> > I suppose the descriptors of this command still apply to all
> > terminations other than T, and the whole transaction is stopped. Is my
> > interpretation correct?
>
> The draft says "if a command contains a wildcarded TerminationID, the
> command is attempted with each of the actual TermIds matching the
> wildcard.
> A response within the TransactionReply is included for each matching
> TermID,
>
> even if one or more instances generated an error".
> So, ur interpretation is correct that the descriptors of the command
> spplies
>
> to all terminations other than T.
        [[TomT]]
        Agreed.

> Regards
> Vikas Bansal
> mailto:[email-masked]
> http://www.ficon-tech.com
>
>
> >
> >     Thank you in advance for your explanations.
> >
> > Regards,
> > Waitak
> > Cisco Systems

---

From: Wai-tak Siu <[email-masked]>
Date: Thu, 18 Nov 1999 11:50:31 -0800

Tom,
    Your response is contrary to that of Brian. This is quoted from his

> work. The draft is silent about this.
[BR] Yep, because it was considered too hard to insist on this.
An example would be a Subtract which used a connection oriented
protocol.  If you get an error taking down the connection, it's
going to be down, and you can't put it back!

    Could you please resolve the conflict? Thanks.
Waitak
Cisco Systems

Tom-PT Taylor wrote:

>      Gateway implementation should take care that any command which
>      results in a
>      I think we managed to agree that command execution is atomic.  If
>      we need clarifying wording, then from the ITU's point of view it
>      would go into the H.248 Implementor's Guide.
>
>