Subject: Washington Issue 23: digit map event pkg needed

From: Nancy-M Greene <[email-masked]>
Date: Thu, 18 Nov 1999 11:09:31 -0500

In Washington, we talked about the need for an event to be sent when a digit
map is satisfied. This needs to go into a digit map event package.

Here is an example of how it would be used, taken from a corrected Appendix
A that I am working on. The digit map event is called
digitmapdetectpkg/dmevent until an actual package has been defined:

Megaco/H.248 Appendix A
<snip>

8.      The MGC Modifies  the termination to now looks for digits.
MGC to MG1:
MEGACO/1.0 [123.123.123.4]:55555
Transaction = 10001 {
    Context = $ {
        Modify = A4444 {
            Events = 2223 { ; look for onhook, and for digit map
                al/on, digitmapdetectpkg/dmevent {
                    Action { DigitMap=Dialplan0 }
                }
            },
            DigitMap= Dialplan0{
{0S| 00S|[1-7]xLxx|8Lxxxxxxx|#xxxxxxx|*xx|9L1xxxxxxxxxx|9L011x.S}
        }
    }
                }

<snip>

10.     Next, digits are accumulated by MG1 as they are dialed by User 1.
When an appropriate match is made of collected digits against the currently
programmed Dialplan for A4444, another Notify is sent to the Media Gateway
Controller.
MG1 to MGC:
MEGACO/1.0 [124.124.124.222]:55555
Transaction = 10002 {
   Context = - {
       Notify = A4444 {ObservedEvents =2223 {
         19990729T22010001: digitmapdetectpkg/dmevent
{tones="16135551212"}}}
   }
}

<snip>

any comments? has someone written up the digit map event package?

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 19 Nov 1999 07:56:42 -0500

This was covered in Washington Issue 4 - Events, I proposed:
E) DigitMap can either stay pretty much as is, with a simple change in
Events Descriptor syntax - there is a DigitMap event, that has a parameter
"Map" which enables the DigitMap. This event is notified, with a string
result which is the digits matched.

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Thursday, November 18, 1999 11:10 AM
To: [email-masked]
Subject: Washington Issue 23: digit map event pkg needed

Megaco/H.248 Appendix A
<snip>

        }

<snip>

MG1 to MGC:

<snip>

Nancy