Subject: Re: Washington Issue 1 - Audit of Ephemerals at start up

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 19 Nov 1999 09:45:54 -0500

> Having thought about this a little more I think there are a few issues:
>
> 1. The property for the structure may be very complex.
> Currently we are
> limited to in the ABNF/ASN to 64? bytes for the length of a property.
> In a complex trunking gateway this will not be enough to handle the
> whole tree.
> Segmentation of properties????? I don't want to go down there.
Hmmmm, I'm not sure this really will be a problem but it
might be.  Ugh.  Three properties:
        MaxPatterns: Read only integer of how many patterns
        PatternNumber: Read Write integer of pattern number
        Pattern: string of one pattern

> 2. How is this described for the binary syntax? Binary scheme needs to
> be developed.
Yup.

>
> 3. Potentially this scheme has to have mechanism to describe
> both levels
> and sets (different lengths). Must describe every path through
> termination schema leading to large amount of information.
Nah, I don't think so.  The canonical is the examples used,
the levels are the slashes, the sets are the wildcards.

> Thus I think that to do this properly then this could be one for CS2.
> Names in CS1 can be pre-provisioned. The MGC can audit with these
> pre-provisioned names. This is something that if we're serious about
> plug and play needs to be looked at in the border scope.
I don't agree.  Too much provisioning, and I think the
proposal is reasonable enough.

> This type of description doesn't sound new. It sounds like a
> university
> research paper. Does anyone know of an existing tree description
> language?
It's not a tree, it's a string pattern match.  Not a research
paper, it's been done, lot's of times.  If you like, we can
use a more familiar language (egrep perhaps?).  I'd rather not.

Brian

---

From: Christian Groves <[email-masked]>
Date: Mon, 22 Nov 1999 17:52:04 +0100

G'Day Brian,

Please see CHG below.

Cheers, Christian

> the levels are the slashes, the sets are the wildcards.

[CHG] I agree the levels are the slashes. Set may not be the wildcard.
For this to be usable I think you need to be able to give all the
potential values.

Brian below is an example termination naming schema (I've tried to make
it complex). Could you explain how the current method would define this
(for text)? I think it would help to come up with some compact syntax.
Text
ie.  TerminationID
     Level1  Level2    Level3            Level4
     foo/
     foo/    bar/      [fred,john,harry]
     foo/    man/      chu/              [steve,garry]
     fbb/    you
     fcc/    bar/      1..10

    this is a structure. / separates level, [] sets
    So we have 5 patterns.

Binary
    Level    Level2    Level3            Level4
    001
    001      01        [00,01,11]
    001      10        [11111111]        [0,1]
    010      11
    011      [0000..1010]

> proposal is reasonable enough.

[CHG] I think provisioning will most likely be used in large gateways.
Provisioning is not always bad.

> use a more familiar language (egrep perhaps?).  I'd rather not.

[CHG] Would you buy a string pattern that may have hierarchy (tree) in
some part of the string??? :)