Subject: Review of V12 ABNF

From: Abdallah Rayhan <[email-masked]>
Date: Wed, 3 Nov 1999 11:58:28 -0500

I took a pass through the ABNF of V12. The following are the PRs
where the ABNF needs to be corrected.

from:
localDescriptor = LocalToken EQUAL octetString
to:
localDescriptor = LocalToken EQUAL SdpToken LBRKT octetString RBRKT

from:
remoteDescriptor = RemoteToken EQUAL octetString
to:
remoteDescriptor = RemoteToken EQUAL SdpToken LBRKT octetString RBRKT

from:
MuxType = ( H221Token / H223Token / H226Token / extensionParameter )
to:
MuxType = ( H221Token / H223Token / H226Token / V75Token/ extensionParameter )

from:
eventOther = eventParameterName EQUAL parmValue
to:
eventOther = eventParameterName parmValue

from:
signalList  = SignalListToken EQUAL LWSP signalListId
      LWSP LBRKT sigListParm *(COMMA sigListParm RBRKT
to:
signalList  = SignalListToken EQUAL signalListId LBRKT
            signalListParm *(COMMA signalListParm) RBRKT

from:
sigOther = sigParameterName EQUAL parmValue
to:
sigOther = sigParameterName parmValue

from:
serviceChangeAddress = ServiceChangeAddressToken EQUAL
     VALUEserviceChangeMgcId   = MgcIdToken   EQUAL mId
to:
serviceChangeAddress = ServiceChangeAddressToken EQUAL VALUE
serviceChangeMgcId   = MgcIdToken   EQUAL mId

from:
extension = extensionParameter EQUAL parmValue
to:
extension = extensionParameter parmValue

from:
priorityToken
to:
PriorityToken

Deleted:
BufferedEventHandlingToken = ("BufferedEventHandling" / "BE")
LoopToken  = ("Loop" / "LP")

Added:
KeepActiveToken = ("KeepActive" / "KA")
MTPToken = ("MTP")
SignalTypeToken = ("SignalType" / "SY")
V75Token = ("V75")

regards
Abdallah Rayhan

---

From: Brian Rosen <[email-masked]>
Date: Thu, 4 Nov 1999 16:28:25 -0500

Yes, of course

> -----Original Message-----
> From: Sanjay Kr. Gupta [mailto:[email-masked]]
> Sent: Thursday, November 04, 1999 12:30 AM
> To: Brian Rosen
> Cc: [email-masked]
> Subject: Re: Review of V12 ABNF
>
>
>
> Hello Brian,
>
>
> > No, the text was changed so that text encoding is always SDP, binary
> > encoding is always Tag/Value.  There is no need for an
> encoding token.
>
> Agreed that we do not need the encoding token, but we still
> need the RBRKT to
> detect the end of the OctetString. The rule should be :
>
> localDescriptor = LocalToken LBRKT octetString RBRKT
> remoteDescriptor = RemoteToken LBRKT octetString RBRKT
>
> Sanjay Kr. Gupta
> Ficon Technology
> e-mail : mailto:[email-masked]
> web    : http://www.ficon-tech.com
>
>