Subject: Re: Washington Issue 15 - Scope of Names

From: Chuong Nguyen <[email-masked]>
Date: Thu, 18 Nov 1999 16:29:55 -0500

Briian

I agree with Abdallah that pkgName should not be optional in the ABNF and
from
Megaco v12, Section 12.1:
" .. and the ID of the item (which uniquely identifies the item in that
package)."

This implies that itemID is unique only in package and not across package.
Therefore, pkgNamer is needed as a qualifier for itemID.
It makes everything simpler to implement and one does not have to do extra
work to see if there is any
conflict in the itemID and tries to decide if pkgName is needed in the
descriptor or not.

Chuong

On Tue, 16 Nov 1999 14:59:32 -0500, Brian Rosen <[email-masked]> wrote:

>PackageNames were proposed as optional so that if there were
>no name conflict you didn't have to use a fully qualified
>name.  You know what packages a termination implements, so
>any confusion is readily apparent.
>
>pkgdNames only appear in:
>    TerminationState and LocalControl
>    Events
>    Signals
>    Statistics
>Within these descriptors, they are the only names
>permitted (if you include names of parameters, and assume
>that things like "KeepActive" are in fact automatically
>declared parameters like SignalType).
>
>I think this means its really easy for the symbol table
>to handle overlap of names spaces in any way we want to.
>
>It's vital to have a signal and an event have the same name
>Once you have dealt with that, the rest is easy, I think.
>
>Brian
>
>> -----Original Message-----
>> From: Abdallah Rayhan [mailto:[email-masked]]
>> Sent: Tuesday, November 16, 1999 2:45 PM
>> To: [email-masked]
>> Subject: Re: Washington Issue 15 - Scope of Names
>>
>>
>> What makes this issue interesting is the fact that packageName is
>> optional in pkgdName. Therefore, even if you restrict packageName,
>> you still have the ItemID which is not restricted by solution 1.
>>
>> The current ABNF says:
>> pkgdName = [ (PackageName / "*") SLASH ] (ItemID / "*" )
>>
>> What would completely resolve this issue is making packageName
>> mandatory. This will change the ABNF to:
>>
>> pkgdName = (PackageName / "*") SLASH  (ItemID / "*" )
>>
>> This resolves the ItemID and tokens problem. This is true because
>> by the time pkgdName is due, the parser would know for sure that
>> it is expected to parse pkgdName. As far as pkgdNames are
>> considered they are strings with "/" in the middle. All programming
>> languages allow tokens to be subtrings of variable names.
>>
>> But how about parameters which  are of the form
>> NAME=VALUE. NAMEs should not be tokens IMO.
>> However, I think it would hard to enforce at this time.
>>
>> As for overlapping, I am not sure I understand what you mean
>> by that ! Is that within the same package ? Could you elaborate
>> on it ?
>>
>> Abdallah Rayhan
>>
>> Brian Rosen wrote:
>>
>> > A number of issues were raised in the Washington meeting that
>> > were "send to the list".  This is one of these issues, with the
>> > problem and my suggested fix.
>> >
>> > Problem:
>> > What is the scope of names?  Can package item (property, signal,
>> > event, statistic) overlap Megaco protocol tokens and/or
>> > other package items?
>> >
>> > Proposed Solution 1:
>> > Overlap of names in property, signal, event, statistic is
>> > allowed.  Overlap of package item with protocol tokens is
>> > prohibited
>> >
>> > Problem with Solution 1:
>> > Extensions to protocol may make a pre-existing package definition
>> > invalid
>> >
>> > Proposal Number 2:
>> > Overlap of names in property, signal, event, statistic is
>> > allowed.  Overlap of package item with protocol tokens is
>> > allowed.
>> >
>> > Brian
>>

---

From: Ashok Khuntia <[email-masked]>
Date: Thu, 18 Nov 1999 16:31:57 -0600

And also it is not optional in ASN.1.

Ashok Khuntia

--
  Alcatel USA                         Email:
[email-masked]
  1000 Coit Road Plano, Texas 75075   Phone: 972-477-7073
  **** The opinions expressed are not those of Alcatel USA ****