Subject: Re: Washington Issue 8 - Deleting Multiplexed Bearers

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 19 Nov 1999 09:53:31 -0500

In my personal view, MGs are "dumb" and Option 2 is far
more likely.

Anyway, we have to handle both.  I agree that the mechanisms
for Option 1 are already in the protocol (needing some
SDP stuff for text encoding and some packages for localControl).

As no one has proposed any other solutions for representing
the VC independent of the subchannels within it, I suppose
we have to use the special termination idea. I'll work out
a package definition for it and post it soon.  I'd like to
go with the "they are in a special context, add one to the context creates
the VC, subtract from the context deletes it".

Brian

> -----Original Message-----
> From: Stephen Terrill [mailto:[email-masked]]
> Sent: Thursday, November 18, 1999 7:03 AM
> To: Brian Rosen; [email-masked]
> Subject: Re: Washington Issue 8 - Deleting Multiplexed Bearers
>
>
> Hi Brian,
>
> There are two main ways of viewing this.
> 1. The termination represents the sub channel (and the
> handling of the ATM level is completely upto the media gateway).
> 2. The termination represents the sub channel (and the
> handling of the ATM level is handled by the media gateway controller).
>
> In my personal view, option 1 would be the most likely,
> however I can envisage cases for both.  Following Option 1 is
> the same as T1 circuit emulation for AAL1 trunking (where the
> termination will represent a "circuit" in the emulated T1),
> and indeed STM itself, where the timeslots are multiplexed
> into the SDH transport heiracy.  I think that we both would
> agree that this is handled by the protocol in a
> straightforward manner.
>
> The other case might be handled in the case where there are
> two protocols in the media gateway controller.  An ATM
> signalling protocol (ie UNI, PNNI, B-ISUP, DSS2), with the
> resources in the media gateway, and the Q.2630.1 signalling
> protocol for the handling of AAL2 connections.  In such a
> case, it would be reasonable that the ATM signalling protocol
> has a number of applications, one of which is establishing
> ATM paths (ie Soft PVCs) for the use as "AAL2 paths".  In
> such a case, it would be reasonable to have a termination per
> ATM VCC.  It would also mean that there would be a
> termination per AAL2 channel, even though they may not be all
> usable at the same time (which is the same as a group of STM
> terminations being unavailble due to timing errors in the SDH
> network).
>
> Is it really abuse of the protocol if it turns out that in
> some cases the termination is not placed in a context with
> another termination.  I would say that is an application
> choise ... ie NASs for example.
>
> In summary, I would say that IF it is required to go for the
> second scenario, then it would be OK to create a termination
> per ATM VCC and leave that it its own contexts.
>
> Regards,
>
> ..//Steve
>
> Brian Rosen wrote:
>
> > The AAL2 problem is very real.  The termination represents the
> > subchannel, not the VC.  You can specify which VC to use for
> > the subchannel.  You can specify that a VC be created for the
> > subchannel.  When you subtract the termination, the subchannel
> > would be deleted.  However if there are no subchannels in use,
> > you can't reference the VC, and you can't delete it.
> > That is the problem.
> >
> > I am very uncomfortable using a separate termination to represent
> > a multiplexed bearer.  The problem is that the termination would
> > never be in any real context, yet the subchannels within it would.
> > You also refer to the VC by it's VPI/VCI not the termination.
> >
> > I do see a couple of ways to make the idea "work":
> >         Warp the protocol to allow ephemerals to be created
> >                 in null context.  Subtract deletes them.
> >         Create a context to hold them.  Adding a termination
> >                 creates the VC, subtracting it deletes the VC
> >         Use a set of contexts, one termination per context
> >                 with the same add/subtract implications.
> > All of these have the distinct advantage that they solve the
> > problem.  I think it's an ugly solution :(
> >
> > Brian
> >
> > Brian
> >
> > > -----Original Message-----
> > > From: Stephen Terrill [mailto:[email-masked]]
> > > Sent: Wednesday, November 17, 1999 9:41 AM
> > > To: Brian Rosen
> > > Cc: [email-masked]
> > > Subject: Re: Washington Issue 8 - Deleting Multiplexed Bearers
> > >
> > >
> > > Hi Brian,
> > >
> > > I am not clear on whether this is really a problem.  In the
> > > case of AAL2, the termination could represent the
> > > board/VP/VC/CID, hence we don´t see the multiplexing.  In the
> > > case that separate handling must be done to establish the ATM
> > > resources, there could be another termination which
> > > represents board/VP/VC.
> > >
> > > Regards,
> > >
> > > ..//Steve
> > >
> > > Brian Rosen wrote:
> > >
> > > > A number of issues were raised in the Washington meeting that
> > > > were "send to the list".  This is one of these issues, with the
> > > > problem and my suggested fix.
> > > >
> > > > Problem
> > > > When you have a multiplexed bearer (more than one stream with
> > > > some explicit multiplexing method), it is pretty clear how to
> > > > create a new one, add a stream, and delete a stream, but it
> > > > is not clear how to delete the multiplexed bearer.
> > > >
> > > > Two clear examples are ATM AAL2s, and the proposed multiplexed
> > > > RTP.  By specifying both the addressing of the endpoints, and
> > > > the multiplex information, a new one can be created, with
> > > > the command returning some kind of identifier to be used in
> > > > subsequent commands.  Adding streams using the identifier is
> > > > obvious.  Subtract of a termination would delete a stream.
> > > >
> > > > In general, it is desirable to NOT always delete the
> stream when the
> > > > last substream is deleted - the MGC may wish to cache the
> > > > bearers for later use (it is possible for the MG to do this
> > > > and no new syntax would be needed).   However, there is no
> > > > way to reference a bearer independent of a termination to
> > > > which it applies.
> > > >
> > > > Proposed Solution:
> > > > I don't have any good ones to offer.  The best I can do is
> > > > something like:
> > > >   Context=-{Subtract=*{LocalControl{AAL2/Network=AAL2, VPI=13,
> > > > AAL2/VCI=22}}}
> > > > But this is more than a little weird to me.
> > > >
> > > > Brian
> > >
> > >
> > >
> > >
>
>
>

---

From: Stephen Terrill <[email-masked]>
Date: Mon, 22 Nov 1999 13:04:38 +0100

Hi Brian,

It seems that we are in some sort of concenses regarding the "two termination" or "overlay" approach.  At this stage though, I would be a bit reluctant to specify that would be in a special "context".

Regards,

..//Steve