Subject: Re: Washington Issue 22 - Root Package

From: Prashant Jain <[email-masked]>
Date: Fri, 26 Nov 1999 15:10:42 +0530

Harpreet,
   With this thread of mails, I have few doubts below marked by <PJ>.

I am not sure if that is the meaning of ProvisonalResponseTimerValue. The text
is ambiguous and does not say who (MG / MGC) is expecting PendingResponse.

I am rephrasing my query as below:

At any instant of time, MG will need two type of timers:

1. Provisional Response timer: This timer is used by the MG to send provisional
responses to the MGC. This timer would be based on the value
normalMGExecutionTime.

2. Retry timer: This timer is used by MG to wait for a reply for commands send
by MG to MGC (example, Notify, ServiceChange etc). This timer would be based on
the value of  normalMGCExecutionTime.

>>> <PJ> Don't we need the above two timers to be run by MGC,
ProvisionalResponseTimers, taking into account normalMGCexcutionTime, to send
TransactionPending Responses to MG and Retry Timers, taking into account
normalMGExecutionTime.

Given the above understanding, my questions are:

1. What is the need of ProvisonalResponseTimer ?  normalMGExecutionTime &
normalMGCExecutionTime are sufficient for the MG to derive  values for the two
timers that are kept by MG.

2. Assuming that there is a need for ProvsionalResponseTimer, it can be used for
only one purpose, that is either to derive value for Provisional Response Timer
or the value for Retry Timer and NOT both. The text seems to suggest that the
variable gets initialised to "normalMGExecutionTime or normalMGCExecutionTime as
appropriate". My point is that it can be initialised to just one of them.

<PJ> How ProvisionalTimerValue can be used to calculate  Retry Timer. Its not
clear.

Regards,

Prashant Jain

>
>
> Nancy
> --------------------------------------------------------------------------
> Nancy M. Greene
> Internet & Service Provider Networks, Nortel Networks
> T:514-271-7221 (internal:ESN853-1077) E:[email-masked]
>
>      ----------
>      From:   Harpreet Singh Anand[SMTP:[email-masked]]
>      Sent:   Thursday, November 25, 1999 6:48 AM
>      To:     [email-masked]
>      Subject:        Re: Washington Issue 22 - Root Package
>
>      Hello Brian,
>
>      A few questions on normalExecutionTime and ProvisionalResponseTimerValue:
>
>      1. The purpose of having normalMgExecutionTime is to tell MG, how much
>      time MGC
>      expects MG to take for executing a transaction. Therefore, if MG would
>      take more
>      time then, the MG should send a TransPending.
>
>      The same purpose is being served by ProvisionalResponseTimerValue,
>      whereby, MGC
>      tells MG to send a provisional response every
>      ProvisionalResponseTimerValue
>      millisecs.
>
>      MG would *always* be using ProvisionalResponseTimerValue to start a
>      provisional
>      timer.
>
>      When would MG use normalMgExecutionTime ? I believe only
>      ProvisionalResponseTimerValue is sufficient.
>
>      > ProvisionalResponseTimerValue
>      >                 PropertyId: ProvisionalResponseTimerValue
>      >                 Indicates the time within which to expect a Pending
>      >                         Response if a Transaction cannot be completed.
>      >                         Initially set to normalMGExecutionTime or
>      >                         normalMGCExecutionTime as appropriate, but
>      >                         may be lowered.
>
>      How can ProvisionalResponseTimerValue be initialised to either
>      normalMGExecutionTime  or normalMGCExecutionTime  ?
>
>      It has only one meaning and should be initialised to
>      normalMGExecutionTime.
>
>      Regards,
>      Harpreet
>
>      _________________________________
>      Harpreet Singh Anand
>      Ficon Technology
>      E-mail :  mailto:[email-masked]
>      Web    :  http://www.ficon-tech.com
>
--

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com

---

From: Harpreet Singh Anand <[email-masked]>
Date: Fri, 26 Nov 1999 15:31:35 +0530

Hello Prakash,

> TransactionPending Responses to MG and Retry Timers, taking into account

Yes.

> <PJ> How ProvisionalTimerValue can be used to calculate  Retry Timer. Its not

If the ProvisionalTimerValue is initialised to normalMGCExecutionTime then it can be
used to derive Retry Timer.

Regards,
Harpreet