Subject: Washington Issue 21 - Property or Signal

From: Brian Rosen <[email-masked]>
Date: Mon, 15 Nov 1999 16:28:00 -0500

A number of issues were raised in the Washington meeting that
were "send to the list".  This is one of these issues, with the
problem and my suggested fix.

Problem
Several suggested packages used a signal as a sort of arbitrary
function call in a package.  It seemed to the authors that
signals had the requisite syntax - procedure name, named and
typed parameters.  Signals can be "instantaneous", so, why not?

The alternative is to use properties.  Typically, several
properties, representing the parameters, with some explicit
or implied invocation of a procedure.

Words in the text need to be added to clarify the "right" way
to do this.

Proposed Solution
Despite the attractiveness of the syntax of signals for this
purpose, I believe that is an inappropriate use of the signal
mechanism, and should be discouraged in favor of using
properties.  I'd like to add words to that effect in the documentation.

Brian

---

From: Christian Groves <[email-masked]>
Date: Wed, 17 Nov 1999 16:30:43 +0100

G'Day Brian,

I haven't seen any good reasons for going to either method and wouldn't
be happy to add text on a gut feeling.

I've thought about this before and there are +/-'s for using properties
vs signal/events. The choice really depends on what you want to achieve.
I would rather each package that introduced these consider each method
on its own merit.

Cheers, Christian