Subject: Washington Issue 12 - Synchronization of Streams

From: Brian Rosen <[email-masked]>
Date: Mon, 15 Nov 1999 14:45:52 -0500

A number of issues were raised in the Washington meeting that
were "send to the list".  This is one of these issues, with the
problem and my suggested fix.

Problem:

The Text is silent on the issue of stream synchronization.

Proposed Solution

Add text that states that streams in a context are synchronized to each
other.

brian

---

From: Christian Groves <[email-masked]>
Date: Wed, 17 Nov 1999 16:24:08 +0100

G'Day all,

I'm a little uncomfortable with adding such a statement to the document.

What does synchronization of streams mean?

There's synchronisation for lip synch, for nx64 etc.
Is it on incoming streams or/and outgoing streams?
Do individual pairs of streams need to be synchronised? ie. audio and
video but not data.

There could be other solutions:
How about a stream synch ID per stream?
How about a synchronization mux?

I think this needs more thought.

Cheers, Christian

---

From: Danny Levin <[email-masked]>
Date: Sun, 21 Nov 1999 19:02:38 -0500

Hi All,

I agree with Christian.
I think that Association, Synchronization and Routing (enabled via Topology
descriptor)is not clear as it specified Today in the spec.

Association :

for example in a Video Conferencing bridge when video switch is depended on
the speaker (I am not sure that it is clear how to implement it if Audio &
Video from the same user comes on two different terminations).

Synchronization :
Christian has already explained the problem.

Topology:

The control is enabled only in a level of a termination.
Routing should be controlled per a stream (for example : I want to mute only
audio).

In addition the semantic of a termination for a Non physical "port" is not
clear
(What is the meaning of two streams that share the same termination ?  Is it
only an implementation issue ?)

Danny.
> -----Original Message-----
> From: Media Gateway Control (megaco)
> [mailto:[email-masked]]On Behalf Of Christian
> Groves
> Sent: Wednesday, November 17, 1999 10:24 AM
> To: [email-masked]
> Subject: Re: Washington Issue 12 - Synchronization of Streams
>
>
> G'Day all,
>