Subject: Re: questions regarding hook state in residential gateways

From: Nancy-M Greene <[email-masked]>
Date: Fri, 19 Nov 1999 21:16:45 -0600

Waitak, I'm not sure I understand the issue.

In Annex E.7, the Analog Line Supervision Package defines events "on" for
onhook, and "off" for offhook. The MGC asks the MG to look for them using a
Modify command with SignalsDescriptor set as follows:

To look for onhook:
Context = contextID {
  Modify = terminationID { Signals {al/on} } }

To look for offhook:
Context = contextID {
  Modify = terminationID { Signals {al/off} } }

What do you mean when you say the MGC always has to request both offhook and
onhook transitions?

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Wai-tak Siu[SMTP:[email-masked]]
> Sent:         Friday, November 19, 1999 4:40 PM
> To:   [email-masked]
> Subject:      questions regarding hook state in residential gateways
>
> Hi,
>     If H.248 is used in residential gateway applications, because the
> protocol does not define how MGC and MG can be synchronized on the
> gateway's hook state (i.e. offhook vs onhook), MGC, when requesting the
> gateway to detect hook state change, always has to request both offhook
> and onhook transitions. Is this too cumbersome?
>     Explicit detection (as defined in MGCP) should help solve this
> problem. What is the reason why it is left out in H.248?
>     Thanks.
> Waitak
> Cisco Systems
>

---

From: Wai-Tak Siu <[email-masked]>
Date: Sat, 20 Nov 1999 09:40:37 -0800

Nancy,
        I was asking about event detection, not signal generation.
        My original question is best illustrated by this scenario:

A residential gateway has just cold-started. Before the gateway generates
a restart ServiceChange, the user picks up the handset. The gateway
detects the offhook transition, but since it does not have an
EventDescriptor, it does not generate Notify.
Soon later, the gateway generates a restart ServiceChange. After the MGC
receives the message, it generates a Modify to the gateway to request for
offhook detection. However, since the offhook transition has happened, the
gateway does not generate Notify.
Since the gateway does not play any tone to the user, the user hangs up
the phone. Since the MGC has not requested the gateway to detect onhook
transition, the gateway does not generate Notify either.

        Explicit detection could solve this problem. When the phone is
offhook, and the gateway receives an EventDescriptor, the gateway can
reject the descriptor with a specific error code to tell the MGC that the
phone is already offhook. Since there has been no call established, the
user must have wanted to make a phone call, and the MGC can sends a
SignalDescriptor in time to instruct the gateway to generate dialtone.
        However, v12 does not define explicit detection.

        Thanks.
Waitak

---

From: Jon Steer <[email-masked]>
Date: Sun, 21 Nov 1999 22:22:14 -0500

At 09:40 AM 11/20/99 -0800, Wai-Tak Siu wrote:

Waitak,

  I'm wondering how you differentiate this scenario from the
  scenario where the phone is already off-hook when the MG
  starts up.

  Offhook without idle supervision should always be a
  GW side error and generate the appropriate tone.

  jon

---

From: David Stonehouse <[email-masked]>
Date: Mon, 22 Nov 1999 07:41:27 -0500

Events that relate to the state of a termination - e.g., on-hook and off-hook -
should be Notify'ed the same way whether the line is already in that state when it
gets the EventsDescriptor, or if it transitions to that state in the future.
I.e., the event "on-hook" should not just refer to detecting the transition to
on-hook.  I don't see the value in restricting its meaning in that way.

Dave Stonehouse
Succession Multi-service Gateways
Nortel Networks
T:919-991-2776 (internal:ESN351-2776) E:[email-masked]

---

From: Sophia Scoggins <[email-masked]>
Date: Mon, 22 Nov 1999 09:45:34 -0500

Even though the MG is supposed to be dumb and only do things that the MGC asks it to
do, in some cases the MG can actually handle events that it was not told to watch for.
In this case, the MG handles the events appropriately and changes the status of a
termination as necessary. Since the MG has no state machine, it is not supposed to
expect what will happen next, and therefore, simply records the change of termination
status, rather than treating unexpected events as errors. The MG will not remember the
event. The only trace of an event happening is the termination status. Later on, if
the MGC asks for notification of certain events with corresponding changes of status.
The MG does not remember what the events have happened, but it knows that its status
maps to the state of an event. Therefore, the MG notifies the MGC that the event has
already happened.

For the case where off-hook occurred prior to ServiceChange(method=restart), there is
no line termination created yet. So, the MG won't notice the off-hook and will not
have the initial status=off-hook. It will simply use the default status=on-hook.When
the MGC asks the MG to scan off-hook after receiving the
ServiceChange(method=restart), the MG performs off-hook scan and reports the
status=off-hook.

Regards, Sophia