Subject: Disaccords in Annex B About Descriptor's Form

From: Qiu Xiuping <[email-masked]>
Date: Mon, 29 Nov 1999 16:47:16 +0800

Hi, Megacofans.

There are disaccords in Annex B when describing the descriptors. We think that all
definitions of descriptors are in the form of:

    DescriptorName [ = < someID > ] { [ parm1 [ = value1 ] [ , parm2 [ = value2 ] ,
.. ] ] }

    Note:
    1, Name of descriptor is mandatory, uniquely identifying this descritptor. It is
a string which consists of digits, alpha or hyphen, the first character must be
alpha and the last character is alpha or digit.
    2, The 'someID' is optional, in some case, such as modem descriptor, it is
unnecessary. It is a digit-string. May think about limiting its length.
    3, A couple of brackets is mandatory, conveniently identifying end of a
descriptor.
    4, 'parm1=value1, parm2=value2,...' is optional, if no parameter is provided.
    5, 'parm=value' is optional, which means if this parameter is
unspecified-mandatory, current value will be used, if this parameter is
unspecified-optional, default value will be used.
    6, '=value' is optional, which means CHOOSE mode is used, selecting a value from
all possible values, just like the value equating to '$'. For example, 'parm'
equivalent of 'parm = $'.
    7, ', parm=value...' is optional, if only a parameter exists.

Declaration of format will help defining all descriptors in Annex B.
Else, we think explanation of rules should be showed clearly in specification, about
how to encode text context of message. For example, if a selective value is
necessary, its format is defined as '[ v1, v2, ... ]', if a range value is
necessary, its formmat should be '[ v1..v2 ]'.

            Thanks

            Qiu Xiuping
            [email-masked]

                    ÖÂ
Àñ£¡

            Qiu Xiuping
            [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 29 Nov 1999 20:37:34 -0500

Perhaps if you pointed out places that you think are conflicting
with the general form, because I think we conform in most places.
I'm aware of a couple of places where we have some extra syntax
within a parm (EventDescriptors is one).

If we have inadvertantly made something not fit the pattern, we
might consider changing it, but there is no real reason we have to.
We are trying to finish, so if there is some specific thing, we need
to consider it NOW.

Several of your notes are not correct.  For example, note 6 
CHOOSE is always explicit.  Unmentioned items either have default values
or retain prior values, the MG doesn't select a value.  Most cases
where there is no =value the keyword stands alone, as in the Statistics
and Audit Descriptors.

Brian

> -----Original Message-----
> From: Qiu Xiuping [mailto:[email-masked]]
> Sent: Monday, November 29, 1999 3:47 AM
> To: [email-masked]
> Subject: Disaccords in Annex B About Descriptor's Form
> 
> 
> Hi, Megacofans.
> 
>