Subject: Re: Washington Issue 7 - Time Local or UTC

From: Brian Rosen <[email-masked]>
Date: Wed, 17 Nov 1999 07:33:43 -0500

Can we declare this issue decided:
     Time is UTC
     If you need synchronized time, use NTP
 
Brian

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 10:29 PM
To: [email-masked]
Subject: Re: Washington Issue 7 - Time Local or UTC

Scott, and Al, 
Thanks for bringing us back to reality. I made a mistake. We are already
using ISO8601, and as Scott says, it is Y2K compliant! The following is from
the ABNF.

TimeNotation = Date "T" Time; per ISO 8601:1988 
; Date = yyyymmdd 
Date = 8(DIGIT) 
; Time = hhmmssss 
Time = 8(DIGIT) 
statisticsDescriptor = StatsToken LBRKT statisticsParameter *(COMMA
statisticsParameter ) RBRKT 

Let's go back to what Time is being used for: 

1) a timestamp for events in the ObservedEvents descriptor 
2) a timestamp in TransactionPending 
3) in packages, time will be one of the stats that will be returned for TDM
terminations - start time and stop time. 
-------------------- 
Al Varney writes (Nov 16/99): 
 It seems to me the use of time-stamps in MEGACO is primarily (and 
perhaps ONLY) for determining durations between events and/or the sending 
of messages.  Thus the actual Date/Time reference point doesn't matter. 
Certainly there is no need to synchronize the MG time with MGC time or 
other MG times.  What DOES matter is the ability to measure duration in 
fractions-of-seconds. 

<snip> 

   SUMMARY:  For text-based MEGACO, pick either X.680 (YYMMDDHHMMSS) or the 
ISO 8601 form (UTC implied) but ADD 2 fractional seconds to the 
representation. 
If folks would like the "T" delimiter (so time-stamps stand out visually), 
fine.  Don't place any requirements on synchronization of time-stamps
between 
MGs or between MG and MGCs. 

   In binary versions of the protocol, a timestamp in NTP (middle 32 bits) 
format is probably useful (and RTP-based MGs will need it anyway for
reports). 

end of excerpt from Al Varney 
--------------- 
I agree with Al, that we just need timestamps for 1) and 2) above. 

In statistics, you still only need the timestamp. So ISO8601 seems to be
good enough. I assume this means we forget about time zones. Or are time
zones important for statistics - if so maybe having them at the MGC is
sufficient.

Nancy 
-------------------------------------------------------------------------- 
Nancy M. Greene 
Internet & Service Provider Networks, Nortel Networks 
T:514-271-7221 (internal:ESN853-1077) E:[email-masked] 

        ---------- 
From:   Scott W Brim[SMTP:[email-masked]] 
Sent:   Tuesday, November 16, 1999 12:08 PM 
To:     [email-masked] 
Subject:        Re: Washington Issue 7 - Time Local or UTC 

        >Date: Mon, 15 Nov 1999 14:26:35 -0500 
>From: Nancy-M Greene <[email-masked]> 
>Subject: Re: Washington Issue 7 - Time Local or UTC 
>To: [email-masked] 
> 
>The time should be UTC time. Below is an excerpt from X.680, defining 
>what that is. 

        ... 

        >a)      the six digits YYMMDD where YY is the two low-order digits
of 
>the Christian year 

        Someone made a suggestion here that if you use ISO 8601 format you
avoid 
the y2k ambiguities. 

        ...Scott

---

From: Shalini Philip <[email-masked]>
Date: Thu, 18 Nov 1999 09:04:27 +0530

Hello All,
    There is something I would like to point out on the definition of
TimeNotation in the ABNF.
It is not clear that why 8 digits are being used for "Time" field.
The information of hours, minutes and seconds can come in 6 digits
(hhmmss) if we always assume UTC,
Or in 7 digits (hhmmssz) to explicitly specify UTC.

Thanks & Regards,
    Shalini.

Brian Rosen wrote:

>  Can we declare this issue decided:     Time is UTC     If you need
> synchronized time, use NTPBrian
>
>      Thanks for bringing us back to reality. I made a mistake. We
>      are already using ISO8601, and as Scott says, it is Y2K
>      compliant! The following is from the ABNF.
>
>      statisticsDescriptor = StatsToken LBRKT statisticsParameter
>      *(COMMA statisticsParameter ) RBRKT
>
>      3) in packages, time will be one of the stats that will be
>      returned for TDM terminations - start time and stop time.
>      --------------------
>      fine.  Don't place any requirements on synchronization of
>      time-stamps between
>      format is probably useful (and RTP-based MGs will need it
>      anyway for reports).
>
>      In statistics, you still only need the timestamp. So ISO8601
>      seems to be good enough. I assume this means we forget about
>      time zones. Or are time zones important for statistics - if
>      so maybe having them at the MGC is sufficient.
>
>      Nancy
>
>      -------------------------------------------------------------------------
>
>      Nancy M. Greene
>           >a)      the six digits YYMMDD where YY is the two
>           low-order digits of
>           >the Christian year
>
>           Someone made a suggestion here that if you use ISO 8601
>           format you avoid
>           the y2k ambiguities.
>
>           ...Scott
>
--
Regards,

Shalini Philip
Ficon Technology
E-Mail : mailto:[email-masked]
Web    : http://www.ficon-tech.com