Subject: H.248 Initialization and recovery procedures

From: Arik Klein <[email-masked]>
Date: Thu, 11 Nov 1999 17:07:26 +0200

I couldn't understand from the protocol the exact way of MG registration and
coordination with the MGC.
Is the idea as follows?:
1.  MG sends ServiceChange(root) to the MGC
2.  (??) MGC sends AuditCapabilities for all MG terminations
3.  MG sends reply with all its capabilities.
The same question for a specific termination that gets in service.

Now, if an existing connection fails and is locally disconnected, but the
terminations are still usable, what is the right way to notify the MGC? (by
Notify, ServiceChange, other ways???)

I hope someone can clear this for me.

Thanks, Arik

---

From: Brian Rosen <[email-masked]>
Date: Sat, 13 Nov 1999 18:31:54 -0500

> 1.  MG sends ServiceChange(root) to the MGC
Yes, and then if the MGC accepts it for service you get a reply with
things like a port #, Profile of MGC, etc.  This is the actual
registration

> 2.  (??) MGC sends AuditCapabilities for all MG terminations
If it needs/wants to

> 3.  MG sends reply with all its capabilities.
Yes

> The same question for a specific termination that gets in service.
Of course of subset of 2 & 3

> Notify, ServiceChange, other ways???)
I would say Service change out of service - MGC responds with Subtract,
ServiceChange in service, MGC can then resume using.

Others could have a different interpretation

 Brian