Subject: Re: Washington Issue 14 - Errors when parsing

From: Brian Rosen <[email-masked]>
Date: Wed, 17 Nov 1999 07:59:13 -0500

Hello Brian,
> 
> 1. Should the error messages be sent if there is a syntax error in
> TransactionReply ?
We clearly need new error messages for this
 
> 2. If yes, then what should be the handling on receiving 
> error message for a
> TransactionReply ?
These errors are pretty serious.  They indicate a programming
error (conceivably could be a provisioning error not caught
by someone's code).  It is unlikely that recovery is possible.
If you sent a syntax error once, you will do it again.
 
> 3. If there is a semantic error in the TransactionReply, say the
> TransactionReply does not have all the command responses or say if the
> termination Id in the reply does not match the termination id 
> in the command
> (considering the case when termination id is always sent in 
> the reply), then
> what should the receiver of TransactionReply do ?
More new error messages
 
> I feel on receiving a erroneous TransactionReply, the 
> receiver should reject the
> reply (without sending any response message) and behave as if 
> it did not receive
> any reply. That is, it would retransmit the Transaction after timeout.
That would be, IMO, a poor choice.  You have close to 100%
probability you would simply get the same reply, or you
would get a "illegal duplicate request" (yet another new message)

Let' see, we have:
540 – Syntax Error in Transaction Reply
541 – TransactionIDs in Reply do not match Request
542 - Missing command in Transaction Reply
543 - Illegal Duplicate Transaction Request
544 - Illegal Duplicate Transaction Reply

Brian

---

From: Harpreet Singh Anand <[email-masked]>
Date: Wed, 17 Nov 1999 18:50:08 +0530

Hello Brian,

What should be the action on receiving an indication of an error in
TransactionReply ? Should the receiver continue other transactions or
"disconnect" ?

We can add one more error code:

545 - Syntax Error in Transaction Pending

There can be other error conditions like, more command replies in
TransactionReply then in the corresponding command request.

Regards,
Harpreet

--

Regards,
Harpreet

_________________________________
Harpreet Singh Anand
Ficon Technology
E-mail :  mailto:[email-masked]
Web    :  http://www.ficon-tech.com