Subject: Re: Comments on v12

From: Nancy-M Greene <[email-masked]>
Date: Thu, 4 Nov 1999 07:31:49 -0600

> ----------
> From:         Harpreet Singh Anand[SMTP:[email-masked]]
>
<snip>

> 10. Meaning of optional command: This issue has been raised earlier also
> on the
> mailing list but I am not sure of the result.
>
> Does the optional command mean:
>
> "Commands may be marked as "Optional" which can override this behavior -
> if an
> optional command results in an error, subsequent commands in the
> Transaction
> will be executed." (as specified in section 8)
> OR
> "If a command is marked as optional, the MG has the choice of executing it
> or
> not, and if it does
> execute it, it returns the Response, or Error." (as specified in section
> 8.2.2)
> OR
> Both ?
>
> If the meaning is both then I suggest both the interpretations should be
> given
> in section 8 itself.
>
[Nancy] In fact, I think both are valid. But if the MG does not execute an
optional command, it needs to indicate this to the MGC - thus I think we
would need another error code: "command not executed".

Nancy

        <snip>

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Abdallah Rayhan <[email-masked]>
Date: Thu, 4 Nov 1999 08:56:01 -0500

This is a new interpretation of optional which I believe never intended.

All commands must be executed. This is why they are there in the
first place. However, in order to reduce the effect of less important
commands on the execution of a context, they are marked optional.
In other words, don't fail context if optional fails.
But all commands must be executed.

Abdallah Rayhan

"Greene, Nancy-M (N.) [EXCHANGE:CAR:5N10]" wrote:

>      10. Meaning of optional command: This issue has been raised
>      earlier also on the
>      "Commands may be marked as "Optional" which can override this
>      behavior - if an
>      "If a command is marked as optional, the MG has the choice of
>      executing it or
>      not, and if it does
>      execute it, it returns the Response, or Error." (as specified in
>      section 8.2.2)
>      OR
>      Both ?
>
>      If the meaning is both then I suggest both the interpretations
>      should be given
>      in section 8 itself.
>
> [Nancy] In fact, I think both are valid. But if the MG does not
> execute an optional command, it needs to indicate this to the MGC -
> thus I think we would need another error code: "command not executed".
>
> Nancy
>
>      <snip>
>
>
> -------------------------------------------------------------------------
>
> Nancy M. Greene