Subject: Re: Washington Issue 21 - Version Incompatibilities

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 22 Nov 1999 14:04:37 -0500

The ITU likes to keep major versions backward compatible.  The IETF has no
such compunctions.  I suppose operationally this means that Megaco versions
will always be backwards compatible, meaning that we have no use for minor
versions.  Comments from the list?

> -----Original Message-----
> From: Christian Groves [SMTP:[email-masked]]
> Sent: Monday, November 22, 1999 10:52 AM
> To:   Taylor, Tom-PT [CAR:B904-I:EXCH]
> Cc:   [email-masked]
> Subject:      Re: Washington Issue 21 - Version Incompatibilities
>
> G'Day all,
>
> I believe this should be in the base H.248 protocol specification.
>
> I agree with Tom that the major and minor numbering needs to be
> considered? Tom what would cause a minor re-numbering compared to a
> major renumbering considered that we need to keep each version (minor or
> major) backwards compatible.
>
> Cheers, Christian
>
>

---

From: Dave Walker <[email-masked]>
Date: Mon, 22 Nov 1999 14:34:23 -0500

Major and minor version changes have marketing implications.  When
a major version changes, one normally expects some significant
change (ostensibly enhancements) to functionality.  Minor changes
should be tweaks and corrections.  For example, I could argue that
rolling 60 some pages of fixes captured in the H.323 Implementors
Guide into H.323 version 2 should have resulted in version 2.1,
not version 3, since little new functionality was added.  Of course
with 60 pages of essentially errata and no provision for minor
versions, it wasn't really practical in that case.  If we only
have one level of versioning, we lose flexibility with little
benefit in return.

Dave Walker
Mitel Corporation
Ontario, CANADA

> Tom-PT Taylor wrote:
>
> The ITU likes to keep major versions backward compatible.  The IETF has no such compunctions.  I suppose operationally this means that Megaco versions will always be backwards compatible, meaning that we have no use for minor versions.  Comments from the list?
>

---

From: Mike Buckley <[email-masked]>
Date: Mon, 22 Nov 1999 20:48:02 +0000

I believe backward compatibility is an essential market requirement.  However, as
not all features of H.248 will be present in any particular implementation this
implies a core of the protocol within which backward compatibility must be
maintained.

H.323 for example could therefore call up whatever features are essential in the
H.323 architecture.  Other architectures could do the same.  Backward
compatibility is therefore a requirement in the context of each of these profiles
and should be maintain as the protocol evolves.

It is up to the relevant system specs therefore to define over which features
backward compatibility should be maintained.

Mike Buckley

____________________ Begin Original Message
___________________________
Date: Mon Nov 22 14:04:37 -0500 1999
From: internet!NORTELNETWORKS.COM!taylor (Tom-PT Taylor)
Subject: Re: Washington Issue 21 - Version Incompatibilities
To: internet!STANDARDS.NORTELNETWORKS.COM!MEGACO
Content-Type: multipart
Content-Length: 3203

---

From: Christian Groves <[email-masked]>
Date: Tue, 23 Nov 1999 12:04:45 +0100

G'Day Tom,

I think that in IETF/ITU should only work with the major versions of the
protocol.

Cheers, Christian

Tom-PT Taylor wrote:
>
> The ITU likes to keep major versions backward compatible.  The IETF
> has no such compunctions.  I suppose operationally this means that
> Megaco versions will always be backwards compatible, meaning that we
> have no use for minor versions.  Comments from the list?
>