Subject: Re: Washington Issue 18 - Wildcard Subtract

From: Brian Rosen <[email-masked]>
Date: Wed, 17 Nov 1999 15:32:01 -0500

I'm not sure I would recommend someone do a
Context=*{Subtract=*}
That does seem to me to be in the range of a service change.

I was thinking about:
Context=*{Subtract=d19c332/1/*}
That is, take down all the ds0s in a ds1 on this ds3.
I get a nice response, which is the contextIDs of every
affected context.

This IS an optimization.  The MGC must know the contextIds
of every DS0 in every DS1 on the DS3.

Brian

> -----Original Message-----
> From: Michael Brown [mailto:[email-masked]]
> Sent: Wednesday, November 17, 1999 2:21 PM
> To: [email-masked]
> Subject: Re: Washington Issue 18 - Wildcard Subtract
>
>
> I didn't remember that ALL was allowed in the ASN.1 so I just
> took a quick
> look and indeed it is.  I do, however, wonder about the use
> of it in the
> original problem description. That is, it seems that ALL is
> too broad to do
> the removal of all terminations for a multichannel physical interface.
> Perhaps I'm missing something, but it would seem that ALL
> used in a SUBTRACT
> would remove the terminations and take down ALL the contexts
> on the MG. I
> guess I just don't see how this applies to the problem described.
>
> Assuming that the description of the behavior of ALL is
> correct, wouldn't
> this kind of function be better handled with ServiceChange? I
> guess the
> question is do we really need ALL wildcarding for context ids
> in subtract?
>
> Michael
>
> Christian Groves wrote:
>
> > G'Day Brian,
> >
> > I thought this was already in the base protocol. In the
> ASN1 contextID =
> > ALL. If not then we should add it.
> >
> > Cheers, Christian
> >
> > Brian Rosen wrote:
> > >
> > > A number of issues were raised in the Washington meeting that
> > > were "send to the list".  This is one of these issues, with the
> > > problem and my suggested fix.
> > >
> > > Problem:
> > > There is no way to express deleting all terminations that
> are part of a
> > > multichannel physical interface.  The issue is that
> > > you can construct a wildcard terminationID, but they will be
> > > in multiple contexts.  Wildcard of ContextID in Subtract is not
> > > currently allowed
> > >
> > > Proposed Solution
> > > Allow ALL in ContextID of Subtract.
> > >
> > > Brian
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 18 Nov 1999 09:22:16 +0100

G'Day Mike,

Don't read too much into ALL. Its just another name for wildcard. As
there is no schema for Context IDs (nor should there be) a wildcard on
CtxtID does mean ALL.

Coupled with a certain wildcarded TerminationID it gives the subtract a
scope.

Cheers, Christian

---

From: Michael Brown <[email-masked]>
Date: Thu, 18 Nov 1999 17:16:15 -0500

OK, I see what you are suggesting and how that can be a very useful construct
(although it would seem likely to be something that would be driven by
maintenance actions rather than call processing). So, let's go ahead and add
it to the ABNF.

Mike