Subject: Re: Washington Issue 17 - Use of Choose in Property Values

From: Nancy-M Greene <[email-masked]>
Date: Tue, 16 Nov 1999 15:31:26 -0500

Brian, can you remind us what this is about again? and to which command it
applies (i.e. Add and Modify?).

Why would you need to put CHOOSE? Why not just refrain from putting that
property in the Add or Modify - that way the MG would choose the default
value.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

> ----------
> From:         Brian Rosen[SMTP:[email-masked]]
> Sent:         Monday, November 15, 1999 4:10 PM
> To:   [email-masked]
> Subject:      Washington Issue 17 - Use of Choose in Property Values
>
> A number of issues were raised in the Washington meeting that
> were "send to the list".  This is one of these issues, with the
> problem and my suggested fix.
>
> problem:
>
> It has been suggested that property values be allowed to be specified as
> "CHOOSE", with the MG choosing a value.
> It is presently possible to specify alternatives, ranges,
> and inequalities, but not an arbitrary CHOOSE.
>
> Proposed Solution
> Allow CHOOSE (in text encoding, "$") as a value for a property
>
> Brian
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 16 Nov 1999 15:56:51 -0500

I think leaving a value out causes it to retain it's prior value (from null
context),
not that the MG is free to choose a value.
 
We allow alternative, but we don't allow the equivalent of all alternatives
available.
 
You can say Codec={G.711, G.723, G.729, G729a} , but you can't say
Codec=$
 
It would be legal in Add or Modify.

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 3:31 PM
To: [email-masked]
Subject: Re: Washington Issue 17 - Use of Choose in Property Values

Nancy 

        ---------- 

        problem: 

        It has been suggested that property values be allowed to be
specified as 
"CHOOSE", with the MG choosing a value. 
It is presently possible to specify alternatives, ranges, 
and inequalities, but not an arbitrary CHOOSE. 

        Proposed Solution 

        Brian

---

From: Nancy-M Greene <[email-masked]>
Date: Tue, 16 Nov 1999 15:13:04 -0600

Brian, by Codec below, I think you mean the Local Control parameter for
Codec - which looks like this right now:

LocalControl {
nt/em=[PCMU,G723,G729] , ; where em is a list of RTP profiles in order of
preference
nt/dm=[PCMU,G723,G729] } ; where dm is a list of RTP profiles in order of
preference

nt/em is the property preferred encoding method, and nt/dm is the perferred
decoding method, they are defined in E.9.1. In E.9.1. it says that the MGC
may leave em and dm out, and just provide a bandwidth value, leaving the MG
to choose the em, dm and packetization period.

If the MGC had no preference, it would simply leave out the nt/em and nt/dm
properties from the LocalControl descriptor.

Is there another example that would use the $? 

Nancy

> ----------
> From:         Brian Rosen[SMTP:[email-masked]]
> Sent:         Tuesday, November 16, 1999 3:56 PM
> To:   Greene, Nancy-M [CAR:5N10:EXCH]; [email-masked]
> Subject:      RE: Washington Issue 17 - Use of Choose in Property Values
> 
> I think leaving a value out causes it to retain it's prior value (from
> null context),
> We allow alternative, but we don't allow the equivalent of all
> alternatives available.
>  
>       Brian, can you remind us what this is about again? and to which
> command it applies (i.e. Add and Modify?). 
> 
>       Why would you need to put CHOOSE? Why not just refrain from putting
> that property in the Add or Modify - that way the MG would choose the
> default value.
> 
>       Nancy 
>

---

From: Nancy-M Greene <[email-masked]>
Date: Tue, 16 Nov 1999 16:15:17 -0500

Brian, there is a key line in your email that I didn't address:

>       I think leaving a value out causes it to retain it's prior value
> (from null context),
Maybe you are right then, we do need the CHOOSE....

Where is the default encoding/decoding method set? Does a default need to be
specified in the network package, or is that done by provisioning somehow?

Nancy

> ----------
> From:         Greene, Nancy-M [CAR:5N10:EXCH]
> Sent:         Tuesday, November 16, 1999 4:13 PM
> To:   [email-masked]'
> nt/em is the property preferred encoding method, and nt/dm is the
> perferred decoding method, they are defined in E.9.1. In E.9.1. it says
> that the MGC may leave em and dm out, and just provide a bandwidth value,
> leaving the MG to choose the em, dm and packetization period.
> 
> If the MGC had no preference, it would simply leave out the nt/em and
> nt/dm properties from the LocalControl descriptor.
> 
>       I think leaving a value out causes it to retain it's prior value
> (from null context),
>               Brian, can you remind us what this is about again? and to
> which command it applies (i.e. Add and Modify?). 
> 
>               Why would you need to put CHOOSE? Why not just refrain from
> putting that property in the Add or Modify - that way the MG would choose
> the default value.
> 
>               Nancy 
>

---

From: Brian Rosen <[email-masked]>
Date: Tue, 16 Nov 1999 16:25:53 -0500

I think it's okay for the package to define a boot time default, or for
provisioning to do so, but thereafter it's changeable in null context by the
MGC.
 
Brian

-----Original Message-----
From: Nancy-M Greene [mailto:[email-masked]]
Sent: Tuesday, November 16, 1999 4:15 PM
To: [email-masked]
Subject: Re: Washington Issue 17 - Use of Choose in Property Values

Nancy 

        ---------- 

        Brian, by Codec below, I think you mean the Local Control parameter
for Codec - which looks like this right now: 

        LocalControl { 

        nt/em is the property preferred encoding method, and nt/dm is the
perferred decoding method, they are defined in E.9.1. In E.9.1. it says that
the MGC may leave em and dm out, and just provide a bandwidth value, leaving
the MG to choose the em, dm and packetization period.

        If the MGC had no preference, it would simply leave out the nt/em
and nt/dm properties from the LocalControl descriptor.

        Nancy 

        ---------- 

  

        -----Original Message----- 
From: Nancy-M Greene [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: Tuesday, November 16, 1999 3:31 PM 
To: [email-masked] 
Subject: Re: Washington Issue 17 - Use of Choose in Property Values 

        Nancy 

                ---------- 

                A number of issues were raised in the Washington meeting
that 
were "send to the list".  This is one of these issues, with the 
problem and my suggested fix. 

                problem: 

                Proposed Solution 

                Brian