Subject: Re: FW: Questions on MEGACOP

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 1 Dec 1999 01:16:15 -0500

Are we agreeing - the MG executes topology changes as if the topology
descriptor was a command - commands are executed in the order presented.
t,c1,c2 - change topology, then execute c1 then c2
c1,t,c2 = execute c1, change topology, then execute c2
c1,c2,t = execute c1, then c2, then change topology

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Tuesday, November 30, 1999 3:34 AM
> To: [email-masked]
> Subject: Re: FW: Questions on MEGACOP
>
>
> G'Day Tom and Shalini,
>
> In the case of a topology I would expect a) that the Topology context
> parameters should be given before a command. The topology is
> 'local' to
> the next command. If it fails it should come back as part of the
> following command response.
>
> Ie. You give the topology,
>     then you ADD a termination with that topology. It overrides the
> default.
>
>
> if the topology came after the command then you could interpret it as:
>     ADD a termination connected to all other connections,
>     Now change the topology based on these parameters
> to me it seems 2 actions when it comes after.
>
> Cheers, Christian
>
> Tom-PT Taylor wrote:
> >
> > What are your feelings about this one?  Do context properties get
> > applied after the individual commands have been executed?
> This feels
> > right to me, since it provides a known state as a basis for the
> > execution of the context-wide stuff.
> >
> > You can reply to Megaco at large -- I haven't been able to reach the
> > list since last Tuesday.
> >
> > -----Original Message-----
> > From:   Shalini Philip [SMTP:[email-masked]]
> > Sent:   Friday, November 26, 1999 3:34 AM
> > [[TomT]]  ...
> > 2. MGC can modify the properties of a context. Suppose MG receives a
> > Transaction Request from the MGC containing the context
> properties and
> >
> > some commands. When should MG affect the change in the context
> > properties:
> >
> > (a) before executing any command ? (assuming the case where
> > termination
> > id in the topology descriptor does not depend on the
> execution of the
> > first command). If the modification of context property fails, will
> > the
> > commands be executed?
> >
> > (b) after the execution of the first command. In this case, if the
> > first
> > command execution succeeds but the topology change fails
> then will the
> >
> > subsequent commands be executed ?
> >
> > Regards,
> >
> > Shalini Philip
> > Ficon Technology
> > E-Mail : mailto:[email-masked]
> > Web    : http://www.ficon-tech.com
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 3 Dec 1999 10:24:50 +0100

G'Day Brian,

I think we are, fancy that! - Who's going to change his mind?

Just to make 100% sure.
t,c1,c2 - c1 will 'add/mod/mov' a termination with topology t
          c2 will 'add/mod/mov' a termination in the default way

Is this your understanding?

Cheers, Christian