Subject: Annex E edits to Network, RTP, and DS0 pkgs

From: Nancy-M Greene <[email-masked]>
Date: Thu, 9 Dec 1999 13:26:08 -0500

Here are a set of proposed edits for Annex E of Megaco/H.248.

E.9 Network Package

Due to recent discussions on not duplicating in LocalControl what can be
sent in sdp, it is proposed to delete the properties for nt/nt, nt/em,
nt/dm, nt/ptime, nt/ba, and nt/encr.

- nt/nt is replaced with the c= sdp line and NOTE there are definitions to
be made thru IANA for this c= line for ATM, and for T38
- nt/em, nt/dm are replaced by the m= lines - one line per codec, and
ordered in order of preference
- nt/ptime is replaced by a=ptime:xx in sdp
- nt/ba is replaced with b= sdp line
- nt/encr is replaced with the k= sdp line

- nt/jit is left where it is, unless it is something that needs to be set
per codec. Can it be set per codec??? If so, then it should be an attribute
in the a= line in the sdp.

***Also, add to section 7.1.8 Local and Remote Descriptors
Using SDP for capability negotiation
If an MG or MGC wishes to propose more than one choice for the SDP, it does
so by sending more than one m= line. All a=, k= lines associated with an m=
line directly follow it before the subsequent m= line.

E.10 RTP Package

The following two stats are missing:

- Add to E.10.4 Statistics
Octets Sent
  StatisticID: os (0x000x)
  Type: double
  Possible values: any 64 bit integer
Octets Received:
  StatisticID: or (0x000x)
  Type: double
  Possible values: any 64 bit integer

- Change Type & Possible Values in PacketLoss - Value can be a fraction such
as 0.2  - so Type is double, with the top 32 bits  for the left of the
decimal and the bottom 32 bits  for the right of the decimal. Add 0.2 as
example of a Possible Value.

E.11 DS0 Package

Here, the silence suppression property should instead be set in the sdp - it
can apply per codec.

Therefore, delete ds0/ss property. Instead, if silence suppression, or voice
activity detection is to be used, it is marked in the sdp for the specific
codec it is to be used with.

Nancy
--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

--------------------------------------------------------------------------
Nancy M. Greene
Internet & Service Provider Networks, Nortel Networks
T:514-271-7221 (internal:ESN853-1077) E:[email-masked]

---

From: Christian Groves <[email-masked]>
Date: Mon, 13 Dec 1999 15:11:14 +0100

G'Day Nancy,

I believe that we need to discuss the complete content of these
packages. In Redbank at the plenary we accepted this package in concept
but not the contents.

I have several concerns on these packages:
o The packages are SDP centric and are not applicable to the binary
version of the protocol. ie. This is not acceptable for base packages.
o Properties in the base package are not applicable for extended
packages. ie. DS0 has RTP properities

I make the following proposals to start to move forward:
o DS0 package
- Don't see the point in extending Network package which is very RTP
specific. Makes more sense to have a stand alone DS0 package. ie.
     Reasons:
     > em < not applicable to DS0
     > em < not applicable to DS0
     > ptime < not applicable to DS0
     > encryption < not applicable to DS0
     > jit
     > event:quality alert < rtp specific

Cheers, Christian

Nancy-M Greene wrote:
> Due to recent discussions on not duplicating in LocalControl what can
> be sent in sdp, it is proposed to delete the properties for nt/nt,
> nt/em, nt/dm, nt/ptime, nt/ba, and nt/encr.
>
> - nt/nt is replaced with the c= sdp line and NOTE there are
> definitions to be made thru IANA for this c= line for ATM, and for T38
>
> - nt/jit is left where it is, unless it is something that needs to be
> set per codec. Can it be set per codec??? If so, then it should be an
> attribute in the a= line in the sdp.
>
> If an MG or MGC wishes to propose more than one choice for the SDP, it
> does so by sending more than one m= line. All a=, k= lines associated
> with an m= line directly follow it before the subsequent m= line.
>
> E.10 RTP Package
>
> - Change Type & Possible Values in PacketLoss - Value can be a
> fraction such as 0.2  - so Type is double, with the top 32 bits  for
> the left of the decimal and the bottom 32 bits  for the right of the
> decimal. Add 0.2 as example of a Possible Value.
>
> E.11 DS0 Package
>
> Here, the silence suppression property should instead be set in the
> sdp - it can apply per codec.
>
> Therefore, delete ds0/ss property. Instead, if silence suppression, or
> voice activity detection is to be used, it is marked in the sdp for
> the specific codec it is to be used with.
>
> Nancy

---

From: Michael Brown <[email-masked]>
Date: Tue, 14 Dec 1999 16:21:17 -0500

I agree with Christian's comments about the issues with the base Network
package, but I would suggest that the problem is that the RTP specific things in
the Network package be moved to RTP package. The reasoning is that we had
planned to add the ATM package to extend Network and it has similar problems to
the DS0 extension of Network (stuff that doesn't apply universally).

Cheers,

Michael