Subject: FW: Dialing a number on FXO ports using MGCP/MEGACO

From: Oren Kudevitzki <[email-masked]>
Date: Wed, 22 Dec 1999 21:18:33 +0200

Question :

What is the MGCP command for dialing a number on an analog FXO ?
On FXS, dialed number digits are collected using Dial Plans, and are sent to
the Call Agent as one event (e.g.. O:5394000).
But what about the opposite case of FXO. Should the Call Agent send
different signal request for Each digit to be dialed ?
Is it more clearly defined in MEGACO ?

Oren.

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 22 Dec 1999 15:41:03 -0500

This is usually called "outpulsing".

Two solutions have been proposed.  One is the "signal list"
which places a list of signals sequentially.  The current text
has that in it, but we have not yet reached consensus on how signals work.

The other proposal is to have a signal that is called something like
"outpulse" that has a string parameter.  You might then say:
...Signals{op/outpulse{"555-1212"}}
This would be in a package.  No package definition for this has
yet been made.

Brian

> -----Original Message-----
> From: Oren Kudevitzki [mailto:[email-masked]]
> Sent: Wednesday, December 22, 1999 2:19 PM
> To: [email-masked]
> Subject: FW: Dialing a number on FXO ports using MGCP/MEGACO
>
>
> Question :
>

---

From: Bill Foster <[email-masked]>
Date: Wed, 22 Dec 1999 16:49:39 -0800

>This would be in a package.  No package definition for this has

FYI: There are a number of  MGCP packages (e.g. PacketCable ) that use this second approach. In these packages two signals are presently defined - "sup" if sequencing is done as part of a call setup (e.g. send off-hook, wait for wink then send digits etc.) and "inf" for information if digits that are not directly associated with an initial call setup sequence (e.g. sending additional digits in the case of overlapped sending for EANA and EAIN FGD)

In the case of the "sup" event which is used for MF FGD and MF or DTMF CAS PBX interconnect some examples are (without the package name):

DTMF wink start or immediate start PBX:

         sup(addr(5,5,5,1,2,1,2))

MF FGD Operator Services or EANA Signaling that includes both address and caller id:

         sup(addr(k0,5,5,5,1,2,1,2,s0), id(k0,5,9,9,4,0,0,0,s0))

or sending digits that does not involve call setup sequencing:

         inf(5,5,5,1,2,1,2)

Comma separated lists are used rather than strings to make it easier to separate symbols (like k0 etc. in MF). This is also consistent with way digits are presented as events i.e. a digit is like any other event - in theory you could see a sequence of digits as a comma separated list with some other event in the middle (i.e. event ordering preserved)

> > Is it more clearly defined in MEGACO ?

-----------------------------
Bill Foster
Phone: (408) 527-8791
Page:   (800) 365-4578
Fax:     (781) 998-6492