Subject: Re: Local and Remote Clarification

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 22 Dec 1999 07:48:22 -0600

I would be pleased to change the description of operation I sent out to
match this.  I wasn't able to get agreement when I was trying to close this
issue earlier, but it is a much more sensible use of Remote than the one I
presented last night.

> -----Original Message-----
> From: Chip Sharp [SMTP:[email-masked]]
> Sent: Wednesday, December 22, 1999 1:08 AM
> To:   [email-masked]
> Subject:      Re: Local and Remote Clarification
>
> At 12:38 PM 12/8/99 +0100, Christian Groves wrote:
> >G'Day all,
> >
> >It seemed that I had picked up the wrong thread earlier.
> >
> >I believe there is still confusion as to what Local and Remote means.
> >I've talked to several people and each has a different interpretation.
> >
> >I was under the impression that local described the properties of
> >the "received media" and that remote described the properties of the
> >"transmitted media". This is how I interpret the text in the Whitepaper.
>
> This is what it is intended to mean.
>
> Actually,  the LocalDescriptor defines in a session description what the
> local endpoint (MG) is able to receive and the RemoteDescriptor defines in
> a session description what the remote endpoint is able to receive.  Thus
> the local endpoint uses what it receives from the MGC in the
> RemoteDescriptor to determine what to transmit.
>
>
> >Attached is a PDF on how I view the configuration.
> >
> >After discussion with people that have been working with H248 for quite
> >awhile they were under the same impression, however others see it
> >differently. I continuously get questions regarding what local and
> >remote mean therefore I propose the addition of the diagram to the H.248
> >protocol.
> >
> >Local should have the properites/characteristics of
> >the "received media". Remote should have the properties/characteristics
> >of "sent media". This would also align the text and binary versions.
> >
> >Cheers, Christian
>
> Support NetAid!  http://www.netaid.org
> --------------------------------------------------
> Chip Sharp                 Consulting Engineering
> Cisco Systems              Telco Bio-region
> Reality - Love it or Leave it.
> --------------------------------------------------

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 22 Dec 1999 09:18:51 -0500

This is getting close, but not quite right.

What I have been saying, which is what I think Christian Huitema said is
that Local initially represents the MG's capability.  After negotiation,
Local specifies the local MG's
stream specification, and Remote specifies the far end's.

There are a couple of aspects to this.  First is addresses.  Local has the
local address,
Remote has the remote address.  Another is encoding of the stream.  Local
has what
the MG sends, Remote has what it expects to receive.

Given that, I propose yet another twist.  We have been wrapped around how to
express
asymmetric encoding (Tom proposed sendonly/recvonly in local, Nancy proposed
two
alternatives with a syntax twist on the same line).  How about simply using
Local for
send, Remote for receive FOR ENCODINGS.  So the MGC sets both local and
remote
on the Add to express policy, MG responds with both local and remote for
capability.
MGC sends negotiated results in both local and remote.

SIP based MGCs may have to do a little inspection to make sure that it
offers the
common subset of local/remote encoding in its negotiation.  H.245 can
express it,
so the two SDP statements can be combined into an H.245 message.

Other than addresses and encodings (and parameters that behave like
encoding,
such as echo cancel and packetization parameters), are there any other
things that
can get confused between local and remote?

Brian

        -----Original Message-----
From:   Chip Sharp [SMTP:[email-masked]]
Sent:   Wednesday, December 22, 1999 1:08 AM
To:     [email-masked]
Subject:        Re: Local and Remote Clarification

        Actually,  the LocalDescriptor defines in a session description what
the

>of "sent media". This would also align the text and binary versions.

        Support NetAid!  http://www.netaid.org <http://www.netaid.org>