Subject: Re: MGC-MGC communication

From: [email-masked]
Date: Thu, 6 Apr 2000 09:51:12 +0530

Hi Brian, I think you missed the important point in the document. it is not
trying to define
any new protocol for MGC-MGC communication rather proposing to use the existing
protocols (SS7, SIGTRAN and MEGACO) for such interface. Moreover i believe that
SS7 is ITU protocol and MEGACO and SIGTRAN are IETF protocols, so where comes
the question of not supporting another application or using it for another
interface,
by ITU and IETF.
I donot think that if somebody comes up with use of MEGACO for some other
interface
(other than MGC-MG), you are going to call it a new protocol definition.
I believe as most of the telecommunication (at the network level) network is
based on
SS7 signaling why not use the same for MGC-MGC, as this is also a trunk
interface or
 may be interface across networks.
Ok, may be let me put your question back to you, if existing standards
(SS7, SIGTRAN and MEGACO) can be used across MGC-MGC interface
why define new one (extension of SIP etc.) for such an interface?

The solution/problem that we were trying to explore is - is SS7 good enough
for MGC-MGC interface, may be it require little modification to protocol or to a
new
definition to the network architecture (new definitions of CIC in packet
network). But
it does give lot many advantages as well.

I haven't seen/read Q.BICC/Q.1901, can you give me pointers to where can i get
these drafts or standards? are these trying to address MGC-MGC communication
or rather a more generic problem which addresses MGC-MGC part as well? How
soon do you think we will get it as standard, as we may need MGC-MGC
interface fixed soon after we start building MGCs and MGs based on MEGACO
(MGC do need to talk).

Regards,
Sunil Mahajan

"Rosen, Brian" <[email-masked]> on 04/05/2000 01:21:43 AM

Please respond to "Rosen, Brian" <[email-masked]>

To:   [email-masked]
cc:    (bcc: Sunil Mahajan/HSS)

Subject:  Re: MGC-MGC communication

I'd second this.  If you want maximum ISUP compatibility, use
Q.BICC.  If you want more "flexibility", consider SIP (or H.323).
Another standard is, IMHO, unwarranted at this time.  I think
such an attempt would not get support in IETF, or ITU at this time.

Brian

> -----Original Message-----
> From: Stephen Terrill [mailto:[email-masked]]
> Sent: Tuesday, April 04, 2000 3:41 PM
> To: [email-masked]
> Subject: Re: MGC-MGC communication
>
>
> Hi Sunril,
>
> I think that you have overlooked the Q.BICC work which is
> being designed to support the ISDN service set over
> technologies other than STM - and it is a standardised
> interface..  The first phase is completed (supporting ATM
> bearers) - see Q.1901, and Q.765.5 (I think).
>
> The second phase will support IP bearers (both in the
> signalling and for the voice transport) and that is
> activively ongoing now.  There have certainly been
> discussions of using SCTP for the signalling transport, and
> for using H.248/megaco beteween the call and the
> bearer/transport level.
>
> Regards,
>
> ..//steve
>
> [email-masked] wrote:
>
> > Hi All,
> > As there exists multiple protocol options for MGC-MGC
> interface but nothing yet
> > standardized,
> > attached white paper proposes an interface definition
> (protocol) for MGC to MGC
> > communication
> > in SS7 networks based on MEGACOP, SIGTRAN and Packet-SS7 protocols.
> > Another attached document gives backgound on the Packet-SS7
> architecture.
> > Regards,
> > Sunil Mahajan
> > (looking for comments and feedback.............)
> >
> > (See attached file: packet-ss74mgc-mgc.zip)(See attached
> file: packet-ss7.zip)
> >
> >
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> -------------------------------
> >                                 Name: packet-ss74mgc-mgc.zip
> >    packet-ss74mgc-mgc.zip       Type: Winzip32 File
> (application/zip)
> >                             Encoding: base64
> >                          Description: .ZIP File
> >
> >                         Name: packet-ss7.zip
> >    packet-ss7.zip       Type: Winzip32 File (application/zip)
> >                     Encoding: base64
> >                  Description: .ZIP File
>

---

From: Stephen Terrill <[email-masked]>
Date: Thu, 6 Apr 2000 09:49:52 +0200

Hi,

Regarding Q.BICC (Q.1901), this is availble within the ITU organisaiton, it is defined as a MGC - MGC protocol (although different terminology is used).  It is an adaptation to ISUP to allow for different bearer technologies.  CS-1 (supporting ATM) is complete, CS-2 is scheduled to be completed at the end of this year.

I do tend to agree with Brian, that BICC would be the better protocol if ISDN service set transparence is required, and that SIP / H.323 would be better in the case of Mulitmedia type application are to be supported.

Regards,

..//steve