Subject: Multiple Profiles; Representation of Empty Descriptors

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 26 Apr 2000 12:27:54 -0500

Here are a couple of miscellaneous issues that have popped up.

(1) It seems reasonable that the MGC, at least, may be capable of supporting
multiple profiles.  The syntax should be altered to allow this.

(2) Suppose a given descriptor is empty on a given termination.  In
particular, suppose there is nothing in the Events descriptor, or no active
digit map.  What is the syntax for representing this in a response to the
MGC?

Proposal: represent an empty descriptor by giving its name alone.  The
simplest way to represent this is to change the syntax of
auditReturnParameter to add auditItem as an additional possibility.

e.g. In step 20 of the Annex A example, where the audit has requested Media,
DigitMap, Events, Signals, Packages, and Statistics descriptors, the
response would be

MEGACO/1 [125.125.125.111]:55555
Reply = 50007 {
   Context = - {
AuditValue = A5556 {
          Media {
             TerminationState { ServiceStates = InService,
EventBufferControl = OFF },
             Stream = 1 {
                 LocalControl { Mode = SendReceive,
                    nt/jit=40 },
                 Local {
v=0
c=IN IP4 125.125.125.111
m=audio 1111 RTP/AVP  4
a=ptime:30
                },
                 Remote {
v=0
c=IN IP4 124.124.124.222
m=audio 2222 RTP/AVP  4
a=ptime:30
                 } } },
          Events,
          Signals,
          DigitMap,
          Packages {nt-1, rtp-1},
          Statistics { rtp/ps=1200,  ; packets sent
                       nt/os=62300, ; octets sent
                       rtp/pr=700, ; packets received
                       nt/or=45100, ; octets received
                       rtp/pl=0.2,  ; % packet loss
                       rtp/jit=20,
                       rtp/delay=40 } ; avg latency
       }
    }
}

Tom Taylor
Phone and FAX: +1 613 736 0961
E-mail: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 26 Apr 2000 14:31:14 -0400

> multiple profiles.  The syntax should be altered to allow this.
I'm not sure a syntax change is needed for the case of MGC support
of multiple profiles.  The registration process always starts with
the MG sending serviceChange.  If it specifies a profile, the MGC
responds with the same profile if it can support it, or it's best
suggestion if it can't.  Words to that effect should be added.
Could consider an error code of "Can't support that profile"

> auditReturnParameter to add auditItem as an additional possibility.
This is okay with me, although Events{} would be okay with me also.

Brian

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 26 Apr 2000 15:12:44 -0400

Is there not a possibility that an MG supports multiple profiles?  I
shouldn't have been so cautious in my initial proposal.

The problem with Events{} in particular is that you're supposed to have a
requestId in there.

> -----Original Message-----
> From: Rosen, Brian [SMTP:[email-masked]]
> Sent: Wednesday, April 26, 2000 2:31 PM
> To:   Taylor, Tom-PT [NORSE:B901:EXCH];
> [email-masked]
> Subject:      RE: Multiple Profiles; Representation of Empty Descriptors
>

---

From: Tom-PT Taylor <[email-masked]>
Date: Wed, 26 Apr 2000 14:37:10 -0500

I'll accept your position on profiles, though with some uneasiness.

On the Events { } issue, yes, the ABNF requires requestID.  Similarly just
about all the other descriptors require content -- you can't have an empty
modem or digitMap descriptor, for instance.

We have another problem with digit maps: you can't set or report more than
one in the same command.

> Sent: Wednesday, April 26, 2000 3:30 PM
> I think MGs supporting multiple profiles is a cs2 issue,
> but I wouldn't rule out the following:
>
> Profile p3 is really an expansion of profile p2, which is actually
> an expansion of p1.  MG1 registers at MGC1 claiming to implement
> p3.  MGC only implements p2, so it declines.  MG1, persistent bugger
> that he is, tries again, claiming to implement p2.  MGC1 accepts.
> MG2 implements p1, registers with MGC1, which accepts, since it
> can also do p1 if it does p2.
>
> Takes no syntax change to handle that.  Beyond that, I think
> multiple profiles in MGs get you into complications I don't want to
> think about yet.
>
> Is your problem with Events the issue that the ABNF requires requestId?
> We'd have to fix that.
>
> Brian
>
> > From: Tom-PT Taylor [mailto:[email-masked]]
> > Sent: Wednesday, April 26, 2000 3:13 PM
> > To: [email-masked]
> > Subject: Re: Multiple Profiles; Representation of Empty Descriptors
> >
> >