Subject: Modify Request Syntax

From: Chuong Nguyen <[email-masked]>
Date: Sat, 1 Apr 2000 14:28:38 -0600

Hi

In ABNF,
ammRequest = (AddToken / MoveToken / ModifyToken) EQUAL TerminationID
                           [LBRKT ammParameter *(COMMA ammParameter)
RBRKT]

If an MGC send a Modify w/o any ammParameter should MG reply with error
code 442,
"Syntax Error in Command" even thought ABNF allows it.

Transaction = 1 {Context=1{Modify=t1}}

Or should the MG treats this modify as a no-op operation and reply with
the following?
Reply = 1 {context = 1{Modify=t1}}

If MG should reply w/error descriptor, can I do the following to do a
no-op Modify
Transaction = 1 { Context =1 {Modify=t1{Audit{} }}}

and expect MG to reply with the following:
Reply = 1 {Context = 1{Modify=t1}}

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: Tom-PT Taylor <[email-masked]>
Date: Tue, 11 Apr 2000 16:48:16 -0400

It's not a syntax error, so it must be a no-op.  Same with your second
example.

> -----Original Message-----
> From: Chuong Nguyen [SMTP:[email-masked]]
> Sent: Saturday, April 01, 2000 3:29 PM
> To:   [email-masked]
> Subject:      Modify Request Syntax
>
>
> Hi
>
> In ABNF,