Subject: Re: Wildcarded context ID?

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 27 Apr 2000 14:02:46 -0400

I've already sent a message to the list objecting to this interpretation.
I agree that wildcard does not include Null context.

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Thursday, April 27, 2000 1:55 PM
> To: [email-masked]
> Subject: Re: Wildcarded context ID?
>
>
> It came as a surprise to me.  I'm not really comfortable with
> it because
> wildcard audits suddenly get a lot larger.
>
> > -----Original Message-----
> > From: Christian Groves [SMTP:[email-masked]]
> > Sent: Wednesday, April 26, 2000 9:21 PM
> > To:   [email-masked]
> > Subject:      Re: Wildcarded context ID?
> >
> > G'Day,
> >
> > Is this a common understanding of the list? If so then
> perhaps we should
> > document it in the spec. I've asked different people and
> had different
> > thoughts on whether or not it should include the NULL context.
> >
> > Cheers, Christian
> >
> > Harpreet Singh Anand wrote:
> > >
> > > Hi Paul,
> > >
> > > Paul Hollis wrote:
> > >
> > > > Hi,
> > > >
> > > > just a quick question:
> > > >
> > > > Does the wildcard "ALL" for a context ID include the
> NULL context,
> > >
> > > Yes it includes the NULL context also.
> > >
> > > > or does it
> > > > only cover non-Null contexts?
> > > >
> > > > Regards Paul.
> > >
> > > --
> > >
> > > Regards,
> > > Harpreet
> > >
> > > _________________________________
> > > Harpreet Singh Anand
> > > Ficon Technology
> > > E-mail :  mailto:[email-masked]
> > > Web    :  http://www.ficon-tech.com
>

---

From: Michael Brown <[email-masked]>
Date: Thu, 27 Apr 2000 17:30:03 -0400

Somehow I missed the initial post of this issue.

I would also agree with the understanding that wildcard (ALL for contextid)
does not include the Null contextid, and I thought that the spec was clear
about it NOT being included, so I went to take a look..

In 8.1.2, I found the following sentence,

"The MGC may use the ALL wildcard to address all Contexts on the MG."

The clarification that implies that NULL would not be included above that
sentence is:

"The protocol makes reference to a distinguished value that may be used by
the Media Gateway Controller when referring to a Termination that is
currently not associated with a Context, namely the null ContextID."

While this does pretty clearly imply that a NULL is not really a context but
actually a special contextid, perhaps it's not clear enough.

Also, in the section 7.2.5 on Auditvalue, there is a table which again sort
of implies that Null is not included in the use of the ALL keyword, because
the table differentiates the behavior of NULL and ALL as the specified
context ID. However, the statement in the table for use of the ALL for
contextid could be interpreted to include NULL.

Based on that I would agree with Christian's suggestion that both of these
references should specifically exclude the NULL context.

Michael