Subject: Open Issue: Sublist vs. Alternatives

From: Tom-PT Taylor <[email-masked]>
Date: Mon, 24 Apr 2000 21:27:13 -0500

In production alternativeValue in Annex B.2, we still have the open issue
that the syntax for over-specification and that for sub-lists is apparently
the same: LSBRKT VALUE *(COMMA VALUE) RSBRKT.  How about enclosing sub-lists
in square brackets and sets of alternative values in curly brackets?
Combined with an accepted fix for ranges this gives:

 alternativeValue = (VALUE                                       ; single
value
       /  LSBRKT VALUE *(COMMA VALUE) RSBRKT  ; sub-list
       /  LBRKT VALUE *(COMMA VALUE) RBRKT      ; alternatives
       /   LSBRKT VALUE COLON VALUE RSBRKT )   ; range

ASN.1 encoding also lacks sub-list support.  I suggest that it be added as a
BOOLEAN choice in extrainfo within the PropertyParm production.

Tom Taylor
Phone and FAX: +1 613 736 0961
E-mail: [email-masked]

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Apr 2000 07:37:27 -0400

Works for me

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Monday, April 24, 2000 10:27 PM
> To: [email-masked]
> Subject: Open Issue: Sublist vs. Alternatives
>
>

---

From: David Cromwell <[email-masked]>
Date: Wed, 26 Apr 2000 15:08:29 -0400

Agreed.  The Advanced Audio Package already makes extensive use of square
bracket sublists.

David
--
[email-masked]                   Nortel Networks
ESN:            351-8870                              35 Davis Dr
Public:    919-991-8870                              RTP, NC 27709

> From: Taylor, Tom-PT [NORSE:B901:EXCH]
> To:   [email-masked]