Subject: Re: Choosing of ephemeral / physical Termination.

From: Chuong Nguyen <[email-masked]>
Date: Thu, 6 Apr 2000 10:16:50 -0400

Tom,

I was searching through the archives but I am not sure this issue was
settled.
Have you make a final decision on this issue yet?
Is it reflected somewhere in the latest version of the Standard?

Thanks
Chuong

On Thu, 27 Jan 2000 15:09:24 -0600, Tom-PT Taylor
<[email-masked]> wrote:

>I think one could interpret Context=${Add=${}} as follows:
>
>"Create a new context.  Allocate a terminationID and any software resources
>required to hold more information about that termination when that
>information is provided.  Return an error if there is any attempt to
>activate a media flow before there is enough information to do so."  Not
>sure why you'd do this really -- it means extra messaging to follow up.
>
>
>> -----Original Message-----
>> From: Rosen, Brian [SMTP:[email-masked]]
>> Sent: Wednesday, January 26, 2000 4:07 PM
>> To:   [email-masked]
>> Subject:      Re: Choosing of ephemeral / physical Termination.
>>
>> Generally determined by the "kind" of termination requested.
>> Which is in turn, easily discernable from the Media command.
>>
>> However, upon reflection, I think it's not a good answer.
>> I'd propose that we not allow selection of a physical termination,
>> in which case choose is always create an ephemeral.  In particular,
>> the following is perfectly legal:
>> Context=${Add=${}}
>> What do you get?
>>
>> Brian
>>
>> > -----Original Message-----
>> > From: Sachin Mittal [mailto:[email-masked]]
>> > Sent: Tuesday, January 25, 2000 9:01 AM
>> > To: [email-masked]
>> > Subject: Choosing of ephemeral / physical Termination.
>> >
>> >
>> > Annex B.1 says that "The CHOOSE TerminationID $ may be used
>> > to signal to the MG
>> > that it has to create an
>> > ephemeral Termination or select an idle physical Termination".
>> > How can MG determine when to create an ephemeral termination
>> > and when to choose
>> > idle physical termination.??
>> > What is the logic behind this decision making?
>> >
>> > regards
>> > -Sachin Mittal
>> >
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 6 Apr 2000 10:45:50 -0400

I'm okay with this interpretation.  I'll note that there is
no way to address this termination for media to flow,
so you can't get an error from that.  What might be a
problem is doing something to it before using a media
descriptor.  For example, putting a signal on it.

I will note that allowing this DOES complicate the design
of an MG.  Probably not too much.

Brian

> From: Chuong Nguyen [mailto:[email-masked]]
> Sent: Thursday, April 06, 2000 10:17 AM