Subject: Side Effects on streams or termination

From: Hemant Kumar <[email-masked]>
Date: Tue, 25 Apr 2000 09:21:39 +0530

Hi Everyone,

     The event descriptor provides for detection of events on a particular stream by means of the parameter :eventStream  (eventStream = StreamToken EQUAL StreamID). However I couldn't find any mention of whether the side effect of event detected on a particular stream within a termination are limited to that stream only and not all the streams on the termination.

Let me take an example :
         There are 2 streams Audio and Video on a termination. EventBufferControl is set to Lockstep for the termination and Events are being detected according to Event descriptor. The events being looked for on Audio and video stream are ( A, B, C ) and (X, Y, Z). Also some signals are being applied on both the streams. Suppose event A is detected and Notified. Which out of the following would be the side Effect of event detection.

1)    Signals on audio stream are stopped (keepactive was not specified) and any further events are stored in event buffer. 
       Signals continue on Video stream and the events (X,Y,Z) are still being detected on Video stream.
2)    Signals are stopped on both the streams and both start buffering events. 

Any comments ??

Regards,
Hemant Kumar

PS : Also find below my previous mail which went unanswered. Its regarding error codes for termination state changes.

Hi Brian, Tom, list,

    Pls consider the following comments ( inlined <HKG> )

Regards and thanks,
Hemant Kumar

    ----- Original Message -----
From: Rosen, Brian
To: Hemant ; [email-masked]
Sent: Tuesday, April 18, 2000 4:59 AM
Subject: RE: Service State Property "Out of Service"

I'd think you should not set a termination out of service unless it was in
null context (and thus would not have any media streams).

<HKG> I Agree. Regarding what Michael mentioned test might have to be
carried out in OOS state. I think that should be done in the service state
"Test" rather than "OOS"

Whether it should be illegal is another question.  I don't care.  I would
not
want setting the property to have side effects like moving to null, etc.

A line with at least "SHOULD" is needed I think.

<HKG>
(case : termination in non null context receives a command with service state OOS)
Think "SHALL" would me more appropriate and the MG NEEDS to send an error
code to indicate to the MGC that the termination is in a non null context
 and so its service state can't be changed to OOS). The error code can be
    433 - TerminationID is already in a Context

Another Error condition that needs to be identified here is the case when an
MGC attempts to Add an OOS terminaiton (Explicitly prohobited according to
the draft) but error code is not specified. An error code should be allocated here.
    4xx - TerminationId in OOS state

Third condition : A termination is presently in service and in null context. An Add commnad specifying service state OOS is received. Either of the above errore code should be used.

~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Hemant Kumar
Ficon Technology
E-mail: mailto:[email-masked]
Web: http://www.ficon-tech.com
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 25 Apr 2000 07:42:52 -0400

I agree with your interpretation - there is ONE eventDescriptor,
ONE eventBuffer, ONE signals list, and side effects like events
stopping signals occur for all the signals in the Signals descriptor,
all the events in the Events descriptor, etc.

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Monday, April 24, 2000 11:47 PM
> To: [email-masked]
> Subject: Re: Side Effects on streams or termination
>
>
> The following message from Hemant Kumar hasn't gotten through
> except as a
> bounce message, for some reason, so I'm forwarding it.  My
> response is that
> I believe current intent is that events detected on one
> stream make their
> side-effects felt on all streams of the termination.  We may
> alter that in
> v2 if experience shows that we should allow a more refined response.
>
> Tom Taylor
> Phone and FAX: +1 613 736 0961
> E-mail: [email-masked]
>
> Original message:
>
> Hi Everyone,
>
>      The event descriptor provides for detection of events on a > particular stream by means of the parameter :eventStream
> (eventStream > = StreamToken EQUAL StreamID). However I couldn't find any
> mention of > whether the side effect of event detected on a particular
> stream within > a termination are limited to that stream only and not all the
> streams on > the termination.
>
> Let me take an example :
>          There are 2 streams Audio and Video on a termination. > EventBufferControl is set to Lockstep for the termination and
> Events are > being detected according to Event descriptor. The events
> being looked > for on Audio and video stream are ( A, B, C ) and (X, Y, Z).
> Also some > signals are being applied on both the streams. Suppose event A is > detected and Notified. Which out of the following would be the side > Effect of event detection.
>
> 1)    Signals on audio stream are stopped (keepactive was not
> specified) > and any further events are stored in event buffer. 
>        Signals continue on Video stream and the events
> (X,Y,Z) are still > being detected on Video stream.
> 2)    Signals are stopped on both the streams and both start
> buffering > events. 
>
> Any comments ??
>
> Regards,
> Hemant Kumar
>
> PS : Also find attached my previous mail regarding error codes for > termination state changes which went unanswered.
>