Subject: Re: Multiple Profiles; Representation of Empty Descriptors

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 26 Apr 2000 15:29:45 -0400

I think MGs supporting multiple profiles is a cs2 issue,
but I wouldn't rule out the following:

Profile p3 is really an expansion of profile p2, which is actually
an expansion of p1.  MG1 registers at MGC1 claiming to implement
p3.  MGC only implements p2, so it declines.  MG1, persistent bugger
that he is, tries again, claiming to implement p2.  MGC1 accepts.
MG2 implements p1, registers with MGC1, which accepts, since it
can also do p1 if it does p2.

Takes no syntax change to handle that.  Beyond that, I think
multiple profiles in MGs get you into complications I don't want to
think about yet.

Is your problem with Events the issue that the ABNF requires requestId?
We'd have to fix that.

Brian

> -----Original Message-----
> From: Tom-PT Taylor [mailto:[email-masked]]
> Sent: Wednesday, April 26, 2000 3:13 PM
> To: [email-masked]
> Subject: Re: Multiple Profiles; Representation of Empty Descriptors
>
>
> Is there not a possibility that an MG supports multiple profiles?  I
> shouldn't have been so cautious in my initial proposal.
>
> The problem with Events{} in particular is that you're
> supposed to have a
> requestId in there.
>
> > -----Original Message-----
> > From: Rosen, Brian [SMTP:[email-masked]]
> > Sent: Wednesday, April 26, 2000 2:31 PM
> > To:   Taylor, Tom-PT [NORSE:B901:EXCH];
> > [email-masked]
> > Subject:      RE: Multiple Profiles; Representation of
> Empty Descriptors
> >
> > > (1) It seems reasonable that the MGC, at least, may be
> > > capable of supporting
> > > multiple profiles.  The syntax should be altered to allow this.
> > I'm not sure a syntax change is needed for the case of MGC support
> > of multiple profiles.  The registration process always starts with
> > the MG sending serviceChange.  If it specifies a profile, the MGC
> > responds with the same profile if it can support it, or it's best
> > suggestion if it can't.  Words to that effect should be added.
> > Could consider an error code of "Can't support that profile"
> >
> > >
> > > (2) Suppose a given descriptor is empty on a given
> termination.  In
> > > particular, suppose there is nothing in the Events
> > > descriptor, or no active
> > > digit map.  What is the syntax for representing this in a
> > > response to the
> > > MGC?
> > >
> > > Proposal: represent an empty descriptor by giving its
> name alone.  The
> > > simplest way to represent this is to change the syntax of
> > > auditReturnParameter to add auditItem as an additional
> possibility.
> > This is okay with me, although Events{} would be okay with me also.
> >
> >
> > Brian
>

---

From: Christian Groves <[email-masked]>
Date: Thu, 27 Apr 2000 10:11:29 +1000

G'Day Tom,

I tend to agreee with Brian. Profiles have largely been undefined in
H248. We have a field to carry profile but it pretty much undefined.
Brian brings up versioning below, we haven't considered that. We don't
even have a proforma on what the profile names should be. Rather than
adding support for multliple profiles now when we don't know the format
lets do it properly in v2 or fix it all in v1 (I suspect we don't want
to do that).

Cheers, Christian