Subject: Re: MGC-MGC communication

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 4 Apr 2000 15:51:43 -0400

I'd second this.  If you want maximum ISUP compatibility, use
Q.BICC.  If you want more "flexibility", consider SIP (or H.323).
Another standard is, IMHO, unwarranted at this time.  I think
such an attempt would not get support in IETF, or ITU at this time.

Brian

> -----Original Message-----
> From: Stephen Terrill [mailto:[email-masked]]
> Sent: Tuesday, April 04, 2000 3:41 PM
> To: [email-masked]
> Subject: Re: MGC-MGC communication
>
>
> Hi Sunril,
>
> I think that you have overlooked the Q.BICC work which is
> being designed to support the ISDN service set over
> technologies other than STM - and it is a standardised
> interface..  The first phase is completed (supporting ATM
> bearers) - see Q.1901, and Q.765.5 (I think).
>
> The second phase will support IP bearers (both in the
> signalling and for the voice transport) and that is
> activively ongoing now.  There have certainly been
> discussions of using SCTP for the signalling transport, and
> for using H.248/megaco beteween the call and the
> bearer/transport level.
>
> Regards,
>
> ..//steve
>
> [email-masked] wrote:
>
> > Hi All,
> > As there exists multiple protocol options for MGC-MGC
> interface but nothing yet
> > standardized,
> > attached white paper proposes an interface definition
> (protocol) for MGC to MGC
> > communication
> > in SS7 networks based on MEGACOP, SIGTRAN and Packet-SS7 protocols.
> > Another attached document gives backgound on the Packet-SS7
> architecture.
> > Regards,
> > Sunil Mahajan
> > (looking for comments and feedback.............)
> >
> > (See attached file: packet-ss74mgc-mgc.zip)(See attached
> file: packet-ss7.zip)
> >
> >
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> --------------------------------------------------------------
> -------------------------------
> >                                 Name: packet-ss74mgc-mgc.zip
> >    packet-ss74mgc-mgc.zip       Type: Winzip32 File
> (application/zip)
> >                             Encoding: base64
> >                          Description: .ZIP File
> >
> >                         Name: packet-ss7.zip
> >    packet-ss7.zip       Type: Winzip32 File (application/zip)
> >                     Encoding: base64
> >                  Description: .ZIP File
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 6 Apr 2000 09:42:07 -0400

Sunil

I think Christian and Steve have covered this, but just in case:
Q.BICC (Q.1901) is now available from ITU.  It is a very simple
extension to ISUP that allows you to carry the address/port of the
MG plus an identifying token (BNC-ID) that lets you correlate
the narrowband signalling with the broadband signalling.
Both of those features are required in order to use ISUP for
signalling with IP or ATM (or FR or ...) bearers, as I'm sure
you would discover if you thought about it.  You can argue over
where to put those things, and that is what Q.BICC answers.
So, it does exactly what you proposed to do, use ISUP for MGC to
MGC communications. Q.1901 is ISUP with one additional message
and one additional IE.

If you want an ISUP based way to build voice over packet/cell
systems, then Q.BICC is the answer, and I really don't think
there is any support for different answers.

SG11, which developed Q.BICC, is now looking into using Megaco
(H.248) for decomposed gateways that use Q.BICC -- the current
Q.1901 does not define the MG/MGC interface (they call it
BCF/CSF).  The present Q.1901 only defines ATM bearers, but
there is work underway to define IP bearers.

Q.1901 should be available from the usual ITU sources (TIES).
There are various drafts around in the T1S1 website.

In addition, there is SIP and H.323.  I'm more aware of the
SIP-ISUP interworking issues than the H.323-ISUP interworking
efforts.  The former is nearing completion.  There is a
draft out which contains a mapping of SIP and ISUP messages.
There is a mechanism to tunnel ISUP messages and IEs that have
no SIP equivalent across a SIP signaled network, and there
is a new method, INFO, that handles mid call events.  I would
expect that this effort will finish sometime this year.  Of course,
there are already complete systems that simply use SIP (and others
that use H.323) as the MGC-MGC protocol.  The ISUP interwork is
required to connect such systems to the PSTN in a standard way.

Brian

> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, April 06, 2000 12:21 AM
> Hi Brian, I think you missed the important point in the
> document. it is not
> trying to define
> any new protocol for MGC-MGC communication rather proposing
> to use the existing
> protocols (SS7, SIGTRAN and MEGACO) for such interface.
> Moreover i believe that
> SS7 is ITU protocol and MEGACO and SIGTRAN are IETF
> protocols, so where comes
> the question of not supporting another application or using
> it for another
> interface,
> by ITU and IETF.
> I donot think that if somebody comes up with use of MEGACO
> for some other
> interface
> (other than MGC-MG), you are going to call it a new protocol
> definition.
> I believe as most of the telecommunication (at the network
> level) network is
> based on
> SS7 signaling why not use the same for MGC-MGC, as this is
> also a trunk
> interface or
>  may be interface across networks.
> Ok, may be let me put your question back to you, if existing standards
> (SS7, SIGTRAN and MEGACO) can be used across MGC-MGC interface
> why define new one (extension of SIP etc.) for such an interface?
>
> The solution/problem that we were trying to explore is - is
> SS7 good enough
> for MGC-MGC interface, may be it require little modification
> to protocol or to a
> new
> definition to the network architecture (new definitions of
> CIC in packet
> network). But
> it does give lot many advantages as well.
>
> I haven't seen/read Q.BICC/Q.1901, can you give me pointers
> to where can i get
> these drafts or standards? are these trying to address
> MGC-MGC communication
> or rather a more generic problem which addresses MGC-MGC part
> as well? How
> soon do you think we will get it as standard, as we may need MGC-MGC
> interface fixed soon after we start building MGCs and MGs
> based on MEGACO
> (MGC do need to talk).
>
> Regards,
> Sunil Mahajan
>
>
>
>
>
>
>
> "Rosen, Brian" <[email-masked]> on 04/05/2000 01:21:43 AM
>
> Please respond to "Rosen, Brian" <[email-masked]>
>
> To:   [email-masked]
> cc:    (bcc: Sunil Mahajan/HSS)
>

---

From: [email-masked]
Date: Thu, 6 Apr 2000 19:35:51 +0530

Brian, Stephen, Kawa
Thanx a lot for the information. I donot have access to ITU-T TIES site, but i
will try to get it
from other sources as mentioned in your mails. But in case if you have copy of
these
documents (Q.BICC and Q.1901), can you please send it to me.
Regards,
Sunil Mahajan

"Rosen, Brian" <[email-masked]> on 04/06/2000 07:12:07 PM

To:   Sunil Mahajan/HSS@HSS, [email-masked]
cc:

Subject:  RE: MGC-MGC communication

Sunil

Brian