Subject: Re: MEGACO and Dial Pulse Lines

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 17 Apr 2000 19:29:06 -0400

This is another "provision vs. program" argument.
Yes, you could provision the timing characteristics.
Since I think provisioning is evil, I'd prefer the MGC do it.
As was pointed out, the MGC has to know if DTMF is "enabled"
on the line, possibly for billing.  Having to have two parts
with the same information is a cause of confusion and error.

I would think almost all of the MGC code wouldn't know the
difference.

Brian

> -----Original Message-----
> From: Stephen Terrill [mailto:[email-masked]]
> Sent: Monday, April 17, 2000 3:23 AM
> To: [email-masked]
> Subject: Re: MEGACO and Dial Pulse Lines
> 
> 
> Hi,
> 
> I was trying to find the correct message from this thread to 
> respond to, so I would hitch it onto this.
> 
> I would think that MGC shouldn´t be concerned with how the 
> digits were detected.  The MGC is requesting to detect 
> digits, and wether they are pulsed or DTMF shouldn´t matter - 
> this is matter of hardware.
> 
> Of course there is an issue of configuration, to have the 
> terminal adapter (or line card) to be set for the type of 
> subcriber, however I haven´t viewed H.248 as a configuration 
> protocol - I understood that was done in other ways.
> 
> Regards,
> 
> ..//steve
> 
> "Rosen, Brian" wrote:
> 
> > > I agree with George, since POTS transparency is key.
> > >
> > > It appears that a "Dial pulse" package is needed to inform
> > > the MG of the
> > > dial pulse characteristics (PPS, Make/Break Ratio). What else?
> > >
> > > What is the process for creating such a package? Can anyone
> > > create an IETF
> > > draft?
> > >
> > Anyone can create a DRAFT.  Just write it up in the proper format
> > and email it to the Internet Drafts editor.
> >
> > Now, if you want IETF to DO anything with it, some working group
> > (for example, Megaco) has to adopt it as a work item, and agree
> > to turn it into an rfc (through it's consensus process).  I'd
> > suspect we would be willing to do this for a dial pulse package,
> > but that is up to the group to decide.
> >
> > Brian
> > >
>

---

From: Stephen Terrill <[email-masked]>
Date: Tue, 18 Apr 2000 07:57:28 +0200

Hi Brian,

Now you are just argueing where to do the provisoning, not that provisoning can be avoided.  As it has to be done somewhere, why the MGC?

..//steve