Subject: Re: Summary of Issues Raised On the List

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 5 Apr 2000 12:44:18 -0400

G'Day All (Adelaide is still with me!)

Some comments on your comments to Johns comments to Tom's list

> > >
> > >    8          Command execution should be     Not clear
> what "atomic"
> > >               specified as atomic.            means, particularly
> > >                                               where
> events and signals
> > >                                               are concerned.
> [CHG] No roll back

Okay, so do you propose descriptors are executed in order?
What if part of a descriptor had an error?  For example, suppose
you said ...Signals{one,two} and it correctly applied one,
but could not apply two due to dsp resource exhaustion.
What should the state of the MG be?

Wouldn't you agree that it is essential that the MGC know what state
the MG is following this kind of error?

> > >    12.2,      Text indicates that statistics can have the
> sub-list data
> > >    B.2        type, but ABNF does not support that.
> [CHG] Isn't a list just an octet string? Does there need to
> be specific
> ABNF. This leads to 12.3. Does a list need to be IANA
> registered as the
> list name will be unique within a package. Proposal: remove last
> sentence of 12.3
You need lists to be IANA registered because multiple extensions
can be proposed, each extending the list.

I've asked for anyone to come up with a statistic that needed a list
without any responses.

> Chp 7.2.4
> Add:
> The "choose"CHOOSE option is an error, as the Move command may only be
> used on existing Terminations.
> Reason: To align with the subtract command
This would have to be clarified.  You can MOVE to a new context. So,
you might want to say "the CHOOSE option for a TerminationId is an
error...".  Might want to do the same in Subtract.
I do agree with the idea however.

> E.2.1
> Add:
> Properties shall be defined in Local Control Descriptor
> Reason:
> Root properties are not defined for any descriptor
All of the properties should be defined in Termination State,
as none of them are stream specific (streams of course have no
meaning for the Root Termination).

---

From: Christian Groves <[email-masked]>
Date: Thu, 6 Apr 2000 12:10:16 +1000

G'Day Brian,

Please see my comments CHG2 below.

Cheers, Christian

> the MG is following this kind of error?

[CHG2] I agree that the MGC should know the state on the MG following an
error. It should also be responsible for the action after this error.
When I say no rollback what I don't want to see is that given a command
which plays a signal and then fails when is changes a media property
that it doesn't "roll back" the signal. This is irrespective descriptors
processed in order. When you get an error you stop further processing
but it hard to undo previous processing. Rollback on a whole command
isn't valid, Rollback on a certain descriptor that is erroneous probably
is.

> I've asked for anyone to come up with a statistic that needed a list

[CHG2] I don't understand the "multiple extension" concept. If this this
is contained in a package then the package name scopes the extension
that you made to the enumerated list. Can you give an example?
> I do agree with the idea however.
[CHG2] Your clarification is good.

> meaning for the Root Termination).
[CHG2] Good point. I'm not particularly bothered on whether it should be
TermState or LocalCont. It just needs to be document.