Subject: Re: MEGACO and Dial Pulse Lines

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 12 Apr 2000 16:48:21 -0400

Well you are correct that there is no dial pulse package yet.
I imagine that if there was:
        It would assume the MG does the timing, not the MGC
                This means digitmaps should work, and the call flows
                are really close to what you would see
        It would have properties defining the timing with some
                provisioned defaults

Why don't you propose one along these lines!

Brian

> -----Original Message-----
> From: John Donak [mailto:[email-masked]]
> Sent: Wednesday, April 12, 2000 4:30 PM
> To: [email-masked]
> Subject: MEGACO and Dial Pulse Lines
>
>
> All Call Flows I have seen use DTMF for digit dialing. The MG
> collects the
> digits from the originator, based on the DigitMap, and then
> contacts the
> MGC.
>
> How about for Dial Pulse (Rotary) phones behind a Residential
> Gateway? They
> still exist.
>
> Is each individual onhook/offhook reported to the MGC, which
> performs the
> timing/collection? This seems very message intensive.
>
> Or is the Gateway expected to perform the timing/collection?
> If so, how does
> it know the required timing characteristics for the market it
> is in; I have
> not seen a "Dial Pulse" Package.
>
>
>         Regards,
>
>                         John
>
> John Donak
> Catena Networks
> Voice:  (613) 599-6430 x488     Email: [email-masked]
> Fax:    (613) 599-6433          URL:  www.catenanet.com
>

---

From: Michael Thomas <[email-masked]>
Date: Wed, 12 Apr 2000 14:39:19 -0700

Having the MG do the digit collection even for
pulse seems completely reasonable. If I recall
correctly, the only difference between pulse and
DTMF is that the switch has a different dial plan
for pulse phones vs. DTMF phones. I don't know
whether that's a statically provisioned thing
within the switch's profile for the line, or
whether it dynamically determines whether it's
a rotary phone given the first pulse dial
digit it sees for the call.

If it's the former, I don't think you need any
difference in digit packages at all. If it's the
latter, the MGC would need to differentiate pulse
from DTMF and send down a different digit map
once it can decide.

I hope it's the former. The latter is a whole lot
of work for not much gain.

        Mike

---

From: Sophia Scoggins <[email-masked]>
Date: Thu, 13 Apr 2000 15:48:00 -0400

Although the MG processes the rotary phone different from the digital
phone, the number (digits or dialed number) will be reported just the
same (the MG just tells the MGC the dialed number are XXXXXXXX...). Most
of the phone company charges extra $1+ for rotary services with digital
services and that was what most of users paid for. So, I can use either
rotary phone or digital phone at home. In either way, I can make phone
calls.

In most cases, the MGC does not know what type of the phone (digital or
rotary) is at the user end, so, the MGC will ask for scanning both digit
detection and paulse detection at the same time. When the MG receives
the scan command, it starts scaning for both types of dialed numbers and
reports whichever are detected. Because of that, a MG may choose to use
one DTMF event package for both types of phone. However, if we want to
have another dial pulse package, that will work, too.

Regards, Sophia