Subject: Re: NotifyRequest

From: "Rosen, Brian" <[email-masked]>
Date: Tue, 11 Jul 2000 11:34:23 -0400

Sure.  First of all, the original question covered more than
the "in Null Context" that your clarification covered.  Obviously,
you could have two actions, with separate contexts, each of which
had an Events Descriptor which asked for a Notify.

Transaction=1122 { Context=1 {Add=A{Events=111{al/hd}}},
                         Context=2 {Add=B{Events=222{al/hd}}}}

With the restriction of null context, you could ask "why would you
want to?", but it would be perfectly legal to use
Transaction=1123 {Context=- {Modify=A{Events=333{al/hd}}},
                        Context=- {Modify=B{Events=444{al/hd}}}}

but you could say
Transaction=1124 {Context=- {Modify=A{Events=555{al/hu}},
                                  {Modify=B{Events=666{al/hd}}}}

Does that answer your question?

Brian
> -----Original Message-----
> From: Prozan, Rakefet [mailto:[email-masked]]
> Sent: Tuesday, July 11, 2000 7:01 AM
> To: [email-masked]
> Subject: Re: NotifyRequest
>
>
> Hi,
>  I was asked to clarify the question,so this is what I ment:
> An Action consists of a series of Commands and a Transaction
> consists of
> one or more
> Actions,therefore can it be possible for an MG to send more than one
> Notify Commands
> in one Action(in Null Context)?
>
> Rakefet Prozan,
> Team Manager, S/W Development
> Nortel SBU
> Telrad Networks
> ESN 828-3043   Email:[email-masked]
>
>
>                                        """
>                                      -(o o)-
> +---------------------------------oOO--(_)--OOo--------------+
>
>                                .oooO         Oooo.
> -------------------------------(   )---------(   )------------
>                                 \ (           ) /
>                                  \_)         (_/
>
> Have fun !!!
>
>
>
>
> Mehul Shah wrote:
> >
> > hi,
> > your question is not clear.
> > Could you please clarify it in detail
> > thanks
> > mehul
> >
> > > -----Original Message-----
> > > From: Media Gateway Control (megaco)
> > > [mailto:[email-masked]]On Behalf Of
> > > Prozan, Rakefet
> > > Sent: Tuesday, July 11, 2000 1:12 AM
> > > To: [email-masked]
> > > Subject: NotifyRequest
> > >
> > >
> > > Hello everyone,
> > >
> > >    Can Mg send in the same transaction more than one
> Notifyrequest?
> > > (I'm not talking about a wildcarded Notifyrequest).
> > > Does it make sense? If so,can somebody give me an example
> on how will
> > > the transaction looks like?
> > >
> > >                          many thanks,
> > >                        Rakefet Prozan,
> > >                       Team Manager, S/W Development
> > >                       Nortel SBU
> > >                       Telrad Networks
> > >                       ESN 828-3043
> Email:[email-masked]
> > >
> > >
> > >
> > > --
> > >
> > >                                        """
> > >                                      -(o o)-
> > > +---------------------------------oOO--(_)--OOo--------------+
> > >
> > >                                .oooO         Oooo.
> > > -------------------------------(   )---------(   )------------
> > >                                 \ (           ) /
> > >                                  \_)         (_/
> > >
> > > Have fun !!!
> > >
>
> --
>

---

From: "Prozan, Rakefet" <[email-masked]>
Date: Wed, 12 Jul 2000 10:37:26 +0300

> > +---------------------------------oOO--(_)--OOo--------------+

Hi,
The given examples are quite obvious according to the protocol, but the
question
is if it makes sense for an MG to send the following transaction:

  Transaction=1150 {Context=- {Notify {ObservedEvents =
2222{19990729T00000:al/of}}},
                                 {Notify {ObservedEvents =
2222{19990729T00001:al/of}}}}

   thanks,

                                       """
                                     -(o o)-

                               .oooO         Oooo.

Have fun !!!