Subject: Signal descriptor returned in response.

From: Hussain F Mohammad <[email-masked]>
Date: Thu, 20 Jul 2000 12:27:08 -0700

It seems that nearly most of the time it may happen that MGC while auditing
signal descriptor receive empty signal descriptor...unless auditing the same as
soon as the command with signal descriptor is sent to MG.

-MFH

>>This kind of problem is age-old, and is almost always
>>settled by returning "current" state, whatever it is,
>>regardless of what asynchrony exists.

>>Sending back what was received is close to useless.

>>So, I think the MG should return what is currently
>>being "played" and what remains to be played (in the case
>>of a signal list).

>>Brian

> -----Original Message-----
> From: Hemant Kumar [mailto:[email-masked]]
> Sent: Friday, June 30, 2000 6:08 AM
> To: Rosen, Brian; [email-masked]
> Subject: Signal descriptor returned in response.
>
>
> Hi Everyone,
>          I think that in response to audit of signal
> descriptor, the signals
> and signal lists in the previous descriptor should be
> returned. As Brian had
> pointed out in his earlier mail (on June 16) the MG might not
> be in sync
> with the MGC. There is always the possiblity of completion of
> signal (or/and
> signal lists) play by the time the message containing the
> "active" signal
> (or/and signal lists)reaches the MGC (especially for brief signals).
> Therefore sending active signals (or/and signal lists)only in
> the audit
> response would be of little value (The MGC can never be sure
> of whether the
> signals(or/and signal lists) that have been received are
> actually playing or
> not)
>
> Regards,
> Hemant Kumar
>
> ----- Original Message -----
> From: Rosen, Brian <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, June 30, 2000 3:27 AM
> Subject: Re: signal descriptor returned in response.
>
>
> > I thought I had sent an answer to this,
> >
> > I believe you get "live" information, which would be
> > the signals playing at the time, not was last sent.
> > If there were no signals, you get an empty descriptor.
> >
> > For a signal list, I think it's not specified whether
> > you get only those active, or yet to be played items,
> > or whether you get the original list. I'd like to see
> > what is current and yet to go, but that may be hard to
> > implement.
> >
> > Brian
>

Get your FREE Email and Voicemail at Lycos Communications - http://comm.lycos.com

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 20 Jul 2000 16:02:21 -0400

Possibly, but so what?

Actually, signals last a while in computer time, so it may be that if you
audit
"frequently" you will see, for example, ringing signals.

Of course, it's not clear to me why you would audit frequently.

Brian

> From: Hussain F Mohammad [mailto:[email-masked]]
> Sent: Thursday, July 20, 2000 3:27 PM
> To: [email-masked]