Subject: Re: User Interface MGCP package

From: Peter Blatherwick <[email-masked]>
Date: Wed, 12 Jul 2000 15:25:49 -0400

I feel I must be somewhat blunt here.

This work replicates many aspects of the H.248 Annex G: User Interface
Elements and Actions Packages, currently in Standards Track Last Call under
IETF Megaco WG and in White Document form for ITU SG-16 Decision, well
agreed in both standards bodies.  Yet, the MGCP-based proposal is not in
direction of an open standard and is much less developed in terms of user
interface widget coverage and level of detail.

Why would anyone undertake to replicate work that is already near completion
in open standards?

Why would IETF Megaco WG in particular (or ITU SG-16 for that matter) want
to know about work going on to perpetuate a non-standardized proposal (MGCP)
which is now divergent from the real international open standards direction
(Megaco/H.248)?

Instead, for user interface packages please see
http://www.ietf.org/internet-drafts/draft-ietf-megaco-h248g-00.txt.  For
master/slave style IP Phone control under open standards see Megaco IP Phone
Media Gateway Application Profile at
http://www.ietf.org/internet-drafts/draft-ietf-megaco-ipphone-02.txt.

-- Peter Blatherwick

-----Original Message-----
From: Marc Petit-Huguenin [mailto:[email-masked]]
Sent: Monday, July 10, 2000 15:24
To: [email-masked]
Subject: User Interface MGCP package

Hi all,

We have just released an Internet Draft which defines a new MGCP package
for supporting the User Interface aspects of IP feature phones.
We look forward to your comments for improving and validating this
package.
This document is accessible at
http://www.ietf.org/internet-drafts/draft-petithuguenin-mgcp-ui-pkg-00.txt
or alternatively at
http://www.netergynet.com/protocols/draft-petithuguenin-mgcp-ui-pkg-00.txt

Andy Huckridge
Marc Petit-Huguenin

---

From: Bob Wise <[email-masked]>
Date: Wed, 12 Jul 2000 14:26:04 -0600

RE: User Interface MGCP packageTo claim that an MGCP effort is not in the
direction of an open standard is, bluntly,
not true.

MGCP is an IETF standard, and is now maintained by the Device Control
Working Group
of the International Softswitch Consortium. You can go to www.softswitch.org
for more
information.  Conversations exclusively about MGCP should probably be held
on the
list maintained there, not on this list.

You can download RFC 2705 from the ISC homepage or from many of the RFC
repositories.

CableLabs has taken MGCP to ITU SG-9, so it appears that MGCP has a chance
of
becoming an ITU protocol, too.

It is seems that MGCP and Megaco/H.248 will both live on indefinitely as
open standards.

-Bob
-------------------------
Bob Wise
Chief Architect
Vsys, Inc.
"The Softswitch Company"
www.vsys.com

  -----Original Message-----
  From: Media Gateway Control (megaco)
[mailto:[email-masked]]On Behalf Of Peter Blatherwick
  Sent: Wednesday, July 12, 2000 1:26 PM
  To: [email-masked]
  Subject: Re: User Interface MGCP package

  Why would anyone undertake to replicate work that is already near
completion in open standards?

  -- Peter Blatherwick

  -----Original Message-----
  From: Marc Petit-Huguenin [mailto:[email-masked]]
  Sent: Monday, July 10, 2000 15:24
  To: [email-masked]
  Subject: User Interface MGCP package

  Hi all,

  Andy Huckridge
  Marc Petit-Huguenin

---

From: Flemming Andreasen <[email-masked]>
Date: Wed, 12 Jul 2000 17:08:48 -0400

Please, let's not get into these types of counter-productive discussions
again. We are all entitled to our individual opinions and strategies in
this space, but this mailing list is neither the place to promote them
nor argue about them.

As far as the ip-phone package is concerned, I recall very clearly that
we agreed *not to* make this Standards Track in Adelaide, so I don't
know where you get the "standards" label from ? Maybe we should rename
it to "draft-blatherwick-..." to make that clear  ?

-- Flemming

Peter Blatherwick wrote:

> Elements and Actions Packages, currently in Standards Track Last Call
> under IETF Megaco WG and in White Document form for ITU SG-16
> Decision, well agreed in both standards bodies.  Yet, the MGCP-based
> proposal is not in direction of an open standard and is much less
> developed in terms of user interface widget coverage and level of
> detail.
>
> Why would IETF Megaco WG in particular (or ITU SG-16 for that matter)
> want to know about work going on to perpetuate a non-standardized
> proposal (MGCP) which is now divergent from the real international
> open standards direction (Megaco/H.248)?
>
> http://www.ietf.org/internet-drafts/draft-ietf-megaco-h248g-00.txt.
> For master/slave style IP Phone control under open standards see
> Megaco IP Phone Media Gateway Application Profile at
> ttp://www.ietf.org/internet-drafts/draft-petithuguenin-mgcp-ui-pkg-00.txt
>
> or alternatively at
>
> ttp://www.netergynet.com/protocols/draft-petithuguenin-mgcp-ui-pkg-00.txt
>
> Andy Huckridge
> Marc Petit-Huguenin

--
Flemming Andreasen                Phone: +1 732 452 1667
Cisco Systems                     Fax:   +1 240 359 5839