Subject: Questions about signalList Descriptor

From: Jack Wu <[email-masked]>
Date: Tue, 11 Jul 2000 22:50:31 -0700

Hi,

I've scrutinized the ietf-draft-merge-01, in my opion
the ASN.1 representaion should be

        SeqSigList ::= SEQUENCE
        {
                id              INTEGER(0..65535),
                signalList      SEQUENCE OF Signal,
                signalListType  SignalType
        }

other than
        SeqSigList ::= SEQUENCE
        {
                id              INTEGER(0..65535),
                signalList      SEQUENCE OF Signal,
        }

the ABNF representation should be

        signalList = SignalListToken EQUAL signalList Id
LBRKT
                     signalListType, SignalListParm
*(COMMA signalListParm) RBRKT

instead of

        signalList = SignalListToken EQUAL signalList Id
LBRKT
                     SignalListParm *(COMMA
signalListParm) RBRKT

I think it is an editorial error.

Regars,

Richie Wu

__________________________________________________
Do You Yahoo!?
Get Yahoo! Mail – Free email you can access from anywhere!
http://mail.yahoo.com/

---

From: Christian Groves <[email-masked]>
Date: Wed, 12 Jul 2000 19:06:58 +1000

Hello Jack,

It is not an editorial error. There are rules in H248 that define the
behaviour of a signallist given that individual signals in the list have
certain signal types.

Cheers, Christian

Jack Wu wrote:
> Get Yahoo! Mail - Free email you can access from anywhere!
> http://mail.yahoo.com/