Subject: topology descriptor

From: Hemant Agrawal <[email-masked]>
Date: Thu, 6 Jul 2000 10:34:05 +0530

Hi all,
         I have not received any response for my queries, so I am posting it
again.
         An early response will be highly appreciated.

Thanks
Hemant

> Hi all,
> I have a couple of questions regarding the processing of context
> properties.
>
>  1. When do we proces the topology descriptor in a Action Request ?
>     (a) Before processing any command in that action request or
>     (b) After processing all the commands in the action request.
>
> If it is in the end,  then what should the audit of context properties
> return?
> (a) the context properties  after applying the topology descriptor or
> (b) previous context properties?
>
>
>  2. How do we return a failure in applying  the topology descriptor ?
> If a topology descriptor fails, then should the
> further processing of commands in the action request be stopped?
>
> Thanks & regards,
> Hemant Agrawal
>
> ________________________________________
> Hemant Agrawal
> GlobeSpan Inc
> Tel: +91 575 4544028  ext 121
> E-mail:[email-masked]
> Web: http://www.globespan.net
>

---

From: Christian Groves <[email-masked]>
Date: Fri, 7 Jul 2000 11:46:17 +1000

G'Day Hemant,

Processing is before commands in the action request. I would assume the
topology descriptor follows the same behaviour as a failed command in a
sequence of commands.

Cheers, Christian

---

From: Shalini Philip <[email-masked]>
Date: Fri, 7 Jul 2000 09:58:05 +0530

Hello Christian, and all,

    Consider a transaction request containing the topology descriptor (involving
two terminations TermA and TermB) followed by two Add command requests adding
TermA and TermB into a new context. Now, would the processing of Topology
Descriptor before that of the commands make sense. IMHO, first the context should
get created, then the terminations should be added to the context and then finally

the topology should be set between the terminations as required.

The requirement of delaying the processing of Topology descriptor becomes even
more relevant when a choose termination ($) is specified in it. In this case, when

the topology descriptor is taken up for processing, the termination is not known.
Topology can be set only after a subsequent add command specifying the choose
termination and its descriptors has been processed.

Regards,
  Shalini Philip.

--
Regards,

Shalini Philip
Globespan Inc.
E-Mail : mailto:[email-masked]
Web    : http://www.globespan.net

---

From: Christian Groves <[email-masked]>
Date: Fri, 7 Jul 2000 14:57:25 +1000

G'Day Shalini,

The point of the topology is that a context doesn't get created with a
star connection between Ta and Tb first and then gets modified. The
context gets created according to how the topology modifies it. ie. You
must know how the topology is modifed before you can add the
termination.

Cheers, Christian

---

From: Hemant Agrawal <[email-masked]>
Date: Fri, 7 Jul 2000 10:52:00 +0530

Hi Christian,
            Thanks for your reply,
             I doubt if we can report the failure in topology descriptor
processing
as a failed command, because the command reply does not have the topology
token.

Another possibility is to report it as an Action level error. But still we
do not have any error code to give the reason as Topology Application
Failure.

Thanks
Hemant

---

From: Shalini Philip <[email-masked]>
Date: Fri, 7 Jul 2000 11:09:41 +0530

Hello Christian and others,

    Thanks for your prompt reply. I fully agree with your views on Topology. The
topology descriptor should be processed at the beginning and should be applied to the
terminations already part of the specified context and on the rest of the terminations
as and when they are added to the context.

Another question remains about the processing of Audit Context Properties. Consider a
situation where both Context properties and audit context properties are present in the
same action. I think the context audit should return the latest context properties
(taking into account the context properties specified in the same action).
Now if there is an unresolved termination ($) in the context properties, then the
context audit should return the context properties after resolving the termination. For
this the processing of context audit will have to wait till the Add command adding the
termination to the context is processed.

Regards,
  Shalini Philip.

--
Regards,

Shalini Philip
Globespan Inc.