Subject: Command Ids and Descriptor IDs in the ASN.1 descriptions?

From: Richie <[email-masked]>
Date: Mon, 3 Jul 2000 08:59:31 +0530

Hi, all the list:

In A.1 syntax specification of the H.248 protocol syntax.

After decoding BER, how will we know what command type of ID it is?

Also how will we know what descriptor sequence is present in each command, i.e. Descriptor
Id of Type ?

Thus 
AmmRequest ::= SEQUENCE
{
    terminationID    TerminationIDList,
    descriptors    SEQUENCE OF ammDescriptor,
    ...
}

should be:

AmmRequest ::= SEQUENCE
{
    command              commandTyep
    terminationID        TerminationIDList,
    descriptors          SEQUENCE OF ammDescriptor,
    ...
}

the same as descriptors.

---

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 3 Jul 2000 02:04:54 -0400

Richie,

When encoding/decoding H.248 message, I believe you should start at the root of the ASN.1 message structures: MegacoMessage.  So, this message to which you refer would be encoded as:

MegacoMessage
{
    mess {
        version = ##,
        mID    = (address)
        messageBody {
            transactions {
                transactionRequest {
                    transactionId = ##
                    actions {
                        contextID = <id>
                        commandRequests {
                            command {
                                addReq {
                                    ... AmmRequest parameters ....
                                }
                            }
                        }
                    }
                }
            }
        }
    }
}

Note, of course, that this is far from complete, but shows you generally where the AmmRequest will be placed.  Perhaps somebody else will jump in and correct me, but I believe all ASN.1 BER encoded H.248 messages are encoded with MegacoMessage as the root of the message.

Paul

  ----- Original Message ----- 
  From: Richie 
  To: [email-masked] 
  Sent: Sunday, July 02, 2000 11:29 PM
  Subject: Command Ids and Descriptor IDs in the ASN.1 descriptions?

  Hi, all the list:

  Thus 
  AmmRequest ::= SEQUENCE
  {

  should be:

  AmmRequest ::= SEQUENCE
  {
      command              commandTyep

  the same as descriptors.

---

From: John Segers <[email-masked]>
Date: Mon, 3 Jul 2000 12:55:04 +0200

Paul,

Jumping in here, not to correct you but to agree with you: every H.248
message is formatted as MegacoMessage.

Cheers,

John
--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954