Subject: Duplicate Token

From: Shiv Kumar <[email-masked]>
Date: Thu, 6 Jul 2000 12:32:39 +0530

Hi,

 A small correction in the abbreviated tokens list.

The token "EB" is used for both EmbedToken and EventBufferToken.
Pls correct it.

BTW, can we have a text message  containing both the abbreviated tokens
and their longer versions ?

i.e. is this kind of msg allowed....

MEGACO/1 [123.123.123.4]:55555
T  = 50007 {
Context = -  {AuditValue = A5556{
Audit {M, DM, E, SG, PG, SA }}
}
}

Is it necessary that the name of the tokens shall be Case Senstive. For example,
 should " AuditValue"
be treated same as "auditvalue". Please do clarify.

Regards,
Shiv

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 6 Jul 2000 21:03:07 -0400

Wow, a real bug!

Something crept into the syntax that I never noticed (or forgot)
For some reason, Event=123{al/hu{Event{al/hd}} got changed to
Event=123{al/hu{Embed{Event{al/hd)))
thus necessitating EmbedToken

I can't see why this was done, but assuming there is a
good reason, the best idea I have is to make
Emergency "EMG" and then make Embed "EM"

I thought we agreed tokens were NOT case sensitive

Yes you can mix long and short tokens.

I'd recommend that:
        parsers always accept either
        generators have an internal switch (some kind of debug
                thing) that can be set to long or short

The latter is a good reason to have a real message generator
rather than using literal strings in your code == just a
suggestion.

Brian

> -----Original Message-----
> From: Shiv Kumar [mailto:[email-masked]]
> Sent: Thursday, July 06, 2000 3:03 AM
> To: [email-masked]
> Subject: Duplicate Token
>
>
> Hi,
>