Subject: Re: Package extention

From: Peter Blatherwick <[email-masked]>
Date: Wed, 5 Jul 2000 14:35:19 -0400

Original intent of the Extends mechanism when we designed it was to extend
only one Package.  The issues John raises below were considered, and value
did not seem to warrant inherent extra confusion, risk of misinterpretation,
additional design complexity, etc.  Like multiple inheritance, its kinda
cool, but not a good idea here IMHO.  Keep it simple.

Currently the answer is "no, cannot extend more than one package".  If the
text does not say this, it should be clarified in later version,
implementation notes, or elsewhere.

-- Peter

-----Original Message-----
From: John Segers [mailto:[email-masked]]
Sent: Wednesday, July 05, 2000 03:06
To: [email-masked]
Subject: Re: Package extention

Madhu, Brian,

I don't think that we should allow this.  You run into problems if a
package C extends A and B, and A and B contain properties that have the
same name.  What property does C/x refer to if A and B both have a
property x?

John

"Rosen, Brian" wrote:
>
> At first, I was inclined to say, "sure, why not"
> However, I'm worried about implementation difficulty.
>
> If it's hard to do, I think the utility is small.
>
> Brian
>
> > -----Original Message-----
> > From: Madhu Babu [mailto:[email-masked]]
> > Sent: Monday, July 03, 2000 5:26 AM
> > To: [email-masked]
> > Subject: Package extention
> >
> >
> > Can a package extends more than one package??
> > -madhubabu
> >

--
John Segers                                  email: [email-masked]
Lucent Technologies                                        Room HE 303
Dept. Forward Looking Work                      phone: +31 35 687 4724
P.O. Box 18, 1270 AA  Huizen                      fax: +31 35 687 5954

---

From: Vikas Salota <[email-masked]>
Date: Thu, 6 Jul 2000 09:41:49 +0530

I think the desciprion about the package extension in Sec 12.1.1 already has the relevant text where it hints that a package can extend only one package at a time. I quote

"Extends (Optional):  A package may extend an existing package......."

with regards
Vikas Salota

Peter Blatherwick wrote:

> Original intent of the Extends mechanism when we designed it was to extend only one Package.  The issues John raises below were considered, and value did not seem to warrant inherent extra confusion, risk of misinterpretation, additional design complexity, etc.  Like multiple inheritance, its kinda cool, but not a good idea here IMHO.  Keep it simple.
>
> Currently the answer is "no, cannot extend more than one package".  If the text does not say this, it should be clarified in later version, implementation notes, or elsewhere.
>
> -- Peter
>