Subject: Re: topology descriptor

From: Madhu Babu <[email-masked]>
Date: Fri, 7 Jul 2000 11:53:10 +0530

Hi,
This means that topology descriptor should be reexecuted every time
there is change in the number of terminations in the context? and it is not
executed at the instant when it is received.

When a new topology descriptor is specfiied does it mean that together
with the earlier topology rules, the new rules are executed in order if there is
a change in the number of terminations in the context.

This means that topology descriptor always adds new rules and assume to
retain the earlier rules.
-Madhubabu

Christian Groves <[email-masked]> on 07/07/2000 10:27:25 AM

Please respond to Christian Groves <[email-masked]>

To:   [email-masked]
cc:    (bcc: Madhu B Babu/HSS)

Subject:  Re: topology descriptor

G'Day Shalini,

The point of the topology is that a context doesn't get created with a
star connection between Ta and Tb first and then gets modified. The
context gets created according to how the topology modifies it. ie. You
must know how the topology is modifed before you can add the
termination.

Cheers, Christian

Shalini Philip wrote:
>
> Hello Christian, and all,
>
>     Consider a transaction request containing the topology descriptor
(involving
> two terminations TermA and TermB) followed by two Add command requests adding
> TermA and TermB into a new context. Now, would the processing of Topology
> Descriptor before that of the commands make sense. IMHO, first the context
should
> get created, then the terminations should be added to the context and then
finally
> the topology should be set between the terminations as required.
>
> The requirement of delaying the processing of Topology descriptor becomes even
> more relevant when a choose termination ($) is specified in it. In this case,
when
> the topology descriptor is taken up for processing, the termination is not
known.
> Topology can be set only after a subsequent add command specifying the choose
> termination and its descriptors has been processed.
>
> Regards,
>   Shalini Philip.
>
> Christian Groves wrote:
>
> > G'Day Hemant,
> >
> > Processing is before commands in the action request. I would assume the
> > topology descriptor follows the same behaviour as a failed command in a
> > sequence of commands.
> >
> > Cheers, Christian
> >
> > Hemant Agrawal wrote:
> > >
> > > Hi all,
> > >          I have not received any response for my queries, so I am posting
it
> > > again.
> > >          An early response will be highly appreciated.
> > >
> > > Thanks
> > > Hemant
> > >
> > > > Hi all,
> > > > I have a couple of questions regarding the processing of context
> > > > properties.
> > > >
> > > >  1. When do we proces the topology descriptor in a Action Request ?
> > > >     (a) Before processing any command in that action request or
> > > >     (b) After processing all the commands in the action request.
> > > >
> > > > If it is in the end,  then what should the audit of context properties
> > > > return?
> > > > (a) the context properties  after applying the topology descriptor or
> > > > (b) previous context properties?
> > > >
> > > >
> > > >  2. How do we return a failure in applying  the topology descriptor ?
> > > > If a topology descriptor fails, then should the
> > > > further processing of commands in the action request be stopped?
> > > >
> > > > Thanks & regards,
> > > > Hemant Agrawal
> > > >
> > > > ________________________________________
> > > > Hemant Agrawal
> > > > GlobeSpan Inc
> > > > Tel: +91 575 4544028  ext 121
> > > > E-mail:[email-masked]
> > > > Web: http://www.globespan.net
> > > >
>
> --
> Regards,
>
> Shalini Philip
> Globespan Inc.
> E-Mail : mailto:[email-masked]
> Web    : http://www.globespan.net

---

From: Christian Groves <[email-masked]>
Date: Mon, 10 Jul 2000 16:30:24 +1000

G'Day,

Please see my comments [CHG]
Cheers, Christian

> executed at the instant when it is received.

[CHG] Topology is executed when it is received. If you add another
termination without specifying the topologyDescriptor that termination
will be added in the normal "*" connection.