Subject: RE: Adding Streams

From: [email-masked]
Date: Wed, 7 Mar 2001 19:33:04 +0530

If the example is that T1 is the source of audio (StreamID = 1) and video
(StreamID = 2)
and T2 should be receiving both audio and video but T3 should only be receiving
audio
then T2 will have StreamID = 1 connected to T1's stream and same for StreamID =
2.
T3 will not be connected to StreamID = 2.

By your logic I can't have T3 not connected to StreamId = 2.
Sachin

"Rosen, Brian" <[email-masked]> on 03/07/2001 06:42:24 PM

To:   "'Christian Groves'" <[email-masked]>
cc:   "[email-masked]'" <[email-masked]> (bcc: Sachin Mittal/HSS)

Subject:  RE: Adding Streams

We have a major disconnect on what a stream is, and what multiple streams
in a context mean.

My view of streams is that a termination normally is connected to all
streams in a context.  The canonical example is a video conference, which
would have an audio stream, a video stream and a T.120 stream.  All
terminations
in the context are in all streams.

In your example, if T1 & T2 are connected to streams 1 & 2, then when you
add
T3, it is connected to streams 1 & 2 and if you then add stream 3, then
T1 and T2 are connected to stream 3.

If you don't want streams 1 & 2 to be connected to T3, why are you putting
T3 in the context with T1 and T2?  By your argument, if I have T1 and T2
connected on stream 1 (forget stream 2 and 3), and Add T3 to the context
without any media descriptor, it is not connected to anything!

The example you used makes no sense -- if T1 is connected to stream 1 and
T2 is connected to stream 2, then there is no connection at all, you have
a bunch of one termination contexts.  If that is what you want, then use
separate contexts.

Stream IDs exist so you can modify the properties of each stream
independently.
They don't imply which terminations are connected to which streams

All terminations are always on all streams in the termination.

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Tuesday, March 06, 2001 8:49 PM
> To: Rosen, Brian
> Cc: [email-masked]'
> Subject: Re: Adding Streams
>
>
> The answer is ABSOLUTELY NO to both questions !!!!!!
>
> Stream IDs relate the different streams on terminations.
>
> Extend this a little:
> T1 and T2 have streams 1 & 2. Add T3 with stream 3. Should stream 3 be
> connected to 1 or 2? The MG can't possibly know. If you send
> down 1 or 2
> it is completely unambiguous. The very reason we had stream
> IDs was for
> this relation.
>
> Christian
>
>
>
> "Rosen, Brian" wrote:
> >
> > Suppose you create a context and add two terminations to it with
> > StreamId=1.  Then you add a third termination and specify
> > a media descriptor with StreamId=2.
> >
> > Is the third termination connected to the other two on StreamId=1?
> >
> > Are the first two terminations connected to the third on StreamId=2?
> >
> > I think the answer is yes to both questions.
> >
> > Brian
>

---

From: Preeti Sharma <[email-masked]>
Date: Wed, 07 Mar 2001 11:56:47 -0500

Section 7.1.18 says : The default topology of a Context is that each termination's
transmission
is received by all other terminations. Is this not in line with what Brian had to
say.
Preeti.