Subject: RE: Quick question on a Request for package registration

From: [email-masked]
Date: Wed, 7 Mar 2001 10:39:40 -0000

Dear all
 
FWIW, I agree entirely with Michelle's assessment. 3GPP specifications are
*definitely* public documents (and we require that any document which is
cited as a reference in a 3GPP specification is, in turn, a publicly
available document).
 
On Tom Taylor's point about the stability of the specifications, we agreed
at last week's working group meeting that the specifications are now ready
for approval (which means that they will be brought under a formal change
control system). They will be presented for approval at the meeting of
Technical Specification Group Core network next week (14 - 16 March) in Palm
Springs, CA.
 
I hope this helps.
 
Best regards
 
Ian Park
___________________________________________________ 
Ian Park
Chief Engineer, Core Network Signalling Standards
Vodafone Limited
*T: +44 1635 673 527 
*F: +44 1635 233 562 
?E: [email-masked] 
___________________________________________________ 

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: 26 February 2001 10:50
To: IANA
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: Quick question on a Request for package registration

3GPP is a public forum, and I believe their packages would be viewed as
public.  I'll note that it is desirable that the packages be considered
technically stable (though perhaps subject to some editing and minor
adjustment) before they are registered.

I've copied various parties for coordination purposes. 

> -----Original Message----- 
> From: IANA [ mailto:[email-masked] <mailto:[email-masked]> ] 
> Sent: Friday, February 23, 2001 5:28 PM 
> To: Taylor, Tom-PT [NORSE:B881:EXCH] 
> Subject: FW: Quick question on a Request for package registration 
> 
> 
> Tom, 
> 
> Quick question.  Which range should these packages be registered in? 
> Do I need to ask the applicants if these are public or private? 
> 
> From the RFC: 
> Public packages MUST be given serial numbers in the range 0x0001 to 
> 0x7fff.  Private packages MUST be given serial numbers in the range 
> 0x8000 to 0xffff. 
> 
> Thanks for any help.  If there is someone better to ask, please let me 
> know.  Don't want to bug you :) 
> 
> Michelle 
> IANA 
> 
> ************************************************************** 
> *********** 
> 
> Hi there 
> 
> I am the editor for a 3rd Generation Partnership Project 
> (3GPP) protocol 
> specification which defines extensions to the H.248/MeGaCo 
> protocol; I have 
> pasted in a copy of the "Scope" clause of this specification below. 
> 
> "The present document describes the protocol to be used on 
> the Media Gateway 
> Controller (MGC) - Media Gateway (MGW) interface. The Media Gateway 
> Controllers covered in this specification are the MSC server 
> and the GMSC 
> server. The basis for this protocol is the H.248/MEGACO protocol as 
> specified in ITU-T and IETF. The BICC architecture as 
> described in ITU-T 
> Q.1902 [7]-[11] and 3G TS 23.205 [3] defines the usage of 
> this protocol. 
> This specification describes the changes to H.248/MEGACO 
> which are needed to 
> handle 3GPP specific traffic cases. This is done by using the 
> H.248/MEGCO 
> standard extension mechanism. 
> The present document is valid for a 3rd generation PLMN 
> (UMTS) complying 
> with Release 2000 and later. " 
> We need to define three new packages for this specification, 
> and as the 
> custodians of the package identifiers you are the people I 
> need to contact 
> to ask for the package numbers! 
> 
> I have pasted in the first part of the definition of each 
> package below. 
> 
> 13.1.1        IuUP package. 
> PackageID: 3giuup (0x####) 
> [Editor's note: PackageID to be allocated by IANA] 
> Version: 1 
> Extends: None 
> This package identifies that the Iu User Plane is used for 
> the termination. 
> It also contains some parameters for the Iu User Plane 
> functions in the MGW. 
> The Iu User Plane is active in both directions independently 
> of the Stream 
> Mode. 
> 13.1.2        Circuit Switched Data package 
> PackageID: 3gcsd (0x####) 
> [Editor's note: PackageID to be allocated by IANA] 
> Version: 1 
> Extends: None 
> This package contains the information needed to be able to 
> support GSM and 
> UMTS Circuit Switched Data from the media gateway. 
> 13.1.3        TFO package 
> PackageID: 3gtfoc (0x####) 
> [Editor's note: PackageID to be allocated by IANA] 
> Version: 1 
> Extends: None 
> This package defines events and properties for Tandem Free 
> Operation (TFO) 
> control. TFO uses inband signalling and procedures for 
> Transcoders to enable 
> compressed speech to be maintained between a tandem pair of 
> transcoders. 
> This package allows an MGW which has inserted a transcoder to 
> support TFO. 
> Can you please let me know how I should go on from here to 
> have the package 
> numbers allocated? If you need any further information, 
> please contact me. 
> 
> Best regards 
> 
> Ian Park 
> 
> ___________________________________________________ 
> Ian Park 
> Chief Engineer, Core Network Signalling Standards 
> Vodafone Limited 
> *T: +44 1635 673 527 
> *F: +44 1635 233 562 
> *E: [email-masked] 
> ___________________________________________________ 
> 
> 
>

---

From: "Michael Brown" <[email-masked]>
Date: Thu, 8 Mar 2001 03:51:23 -0500

Not having been involved in the 3GPP work I was not aware of the 3 new
packages referred to in the initial email.

Could someone provide info on where to obtain copies of these packages?

Thanks,

Michael Brown

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, March 07, 2001 5:40 AM
To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: RE: Quick question on a Request for package registration

Dear all

 
I hope this helps.
 
Best regards
 
Ian Park

---

From: "Kevin Gorey" <[email-masked]>
Date: Thu, 8 Mar 2001 11:51:59 -0000

Dear all,

As I've been involved in 3GPP working group discussions regarding these 3GPP
H.248 extentions, I'd like to provide some additional information/comments.
Although the 3GPP working groups view is that the 3GPP specification that
contains the package definations in question is 95% complete.  In my opinion
these packages are not currently technically stable, during the last meeting
the technical details for the encoding of the TFO package were not agreed.
Additionally, there is the open issue within 3GPP as to whether these 3GPP
H.248 specifications should be specified for both text and binary encodings,
or whether only one encoding type should be chosen.  

However from reading clause 13.1 of H.248 (reproduced below) it seems that
its a mandatory requirement to specify both a text and binary encoding of
additional packages.
13.1	Packages
The following considerations SHALL be met to register a package with IANA:
1)	A unique string name, unique serial number and version number is
registered for each package. The string name is used with text encoding. The
serial number shall be used with binary encoding. Serial Numbers 60000-64565
are reserved for private use. Serial number 0 is reserved.
..."

Regards,

Kevin.

-----------------
Kevin Gorey
Nortel Networks, UMTS Strategic Product Planning
Tel: +44 (0)1628 434606
Fax: +44 (0)1628 434034
[email-masked]

> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Wednesday, March 07, 2001 10:40 AM

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 8 Mar 2001 09:28:02 -0500

Yes, you must specify both when defining a package.
 
Brian

-----Original Message-----
From: Kevin Gorey [mailto:[email-masked]]
Sent: Thursday, March 08, 2001 6:52 AM
To: [email-masked]'; Tom-PT Taylor; [email-masked]'
Cc: [email-masked]'; [email-masked]'
Subject: RE: Quick question on a Request for package registration

Dear all, 

13.1    Packages 

..." 

Regards, 

Kevin. 

----------------- 
Kevin Gorey 

	-----Original Message----- 
From:   [email-masked] [SMTP:[email-masked]] 
Sent:   Wednesday, March 07, 2001 10:40 AM 
To:     Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked] 
Cc:     [email-masked]; [email-masked];

	Dear all 

Springs, CA. 
  
I hope this helps. 
  
Best regards 
  
Ian Park 

	-----Original Message----- 
From: Tom-PT Taylor [ mailto:[email-masked]
<mailto:[email-masked]> ] 
Sent: 26 February 2001 10:50 
To: IANA 
Cc: [email-masked]; [email-masked]; [email-masked] 
Subject: RE: Quick question on a Request for package registration 

	3GPP is a public forum, and I believe their packages would be viewed
as 
public.  I'll note that it is desirable that the packages be considered 
technically stable (though perhaps subject to some editing and minor 
adjustment) before they are registered. 

> From: IANA [ mailto:[email-masked] <mailto:[email-masked]>  <
mailto:[email-masked] <mailto:[email-masked]> > ]