Subject: Provisional Timer Response

From: Christian Groves <[email-masked]>
Date: Tue, 27 Mar 2001 14:39:00 +1000

G'Day all,

An inconsistency has been brought to my attention on the Provisional
Timer Response value in package H.248 E.2.

The package currently has:
normalMGExecutionTime
PropertyId: normalMGExecutionTime (0x0003)
Settable by the MGC to indicate the interval within which the MGC
expects a response 
to any transaction from the MG (exclusive of network delay)

normalMGCExecutionTime
PropertyId: normalMGCExecutionTime (0x0004)
Settable by the MGC to indicate the interval within which the MG should
expects a 
response to any transaction from the MGC (exclusive of network delay)

ProvisionalResponseTimerValue
PropertyId: ProvisionalResponseTimerValue (0x0005)
Indicates the time within which to expect a Pending Response if a
Transaction cannot be 
completed.  Initially set to normalMGExecutionTime or
normalMGCExecutionTime as 
appropriate, plus network delay, but may be lowered.

What does the ProvisionalResponseTimerValue actually represent?
1. A read only property of the time that the MGC should expect a
Transaction Pending?
2. A RW property that specifies the time that a MGC and MG should expect
a Transaction Pending?
3. ?

If its 1) do we need a property for the MGC issued transaction pending?
If its 2) how do we account for different values of
normalMxxExecutionTime?

Cheers, Christian

---

From: Richie Wu <[email-masked]>
Date: Tue, 27 Mar 2001 02:48:27 -0800 (PST)

Hello Christian,

In my understanding1 is correct. Suppose MG detects an
event and send a notify command to MGC while a lot of
calling procedure are going on, the MGC can not
response timely. Thus we need a timer to deal with
this situation.

Best regards,

Richie Wu

--- Christian Groves <[email-masked]>
> If its 2) how do we account for different values of

=====
Huawei Technologies India Private Limited

Unit 10, 2nd Floor, Innovator Block
International Tech Park, Whitefield Main Road
Bangalore 560 066, India
TEL: 0091-80-841 0061/0753/0755
FAX: 0091-80-841 0063

__________________________________________________
Do You Yahoo!?
Get email at your own domain with Yahoo! Mail. 
http://personal.mail.yahoo.com/?.refer=text

---

From: Christian Groves <[email-masked]>
Date: Wed, 28 Mar 2001 13:50:46 +1000

Hello all,

Based on Richie's reply I then propose to add the following to the
implementors' additions. Note: I've also added characteristics which was
missing and the description text is updated.

1.41 Provisional Timer Response Value

Description:	There is an inconsistency in package H.248 E.2 in that it
has two values for execution time ie. normalMGExecutionTime and
normalMGCExecutionTime. It however only has one value to represent the
ProvisionalResponseTimerValue. This provisionalResponseTimerValue could
in fact be set to two different times based upon the execution timers,
one for the MGC and one for the MG. A second timer should be introducted
for the provisionalResponseTime so that the MGC and MG can send timers
at a different time.
Reference:	Subject: Re: Provisional Timer Response
Date: Tue, 27 Mar 2001 02:48:27 -0800 (PST)
From: Richie Wu <[email-masked]>
To: Christian Groves <[email-masked]>, megaco ietf
<[email-masked]>
 [Begin Correction]
Section E.2.1 Properties
MGProvisionalResponseTimerValue
PropertyId: MGProvisionalResponseTimerValue (0x0005)
Indicates the time within which the MGC shouldto expect a Pending
Response from the MG if a Transaction cannot be completed.  Initially
set to normalMGExecutionTime or normalMGCExecutionTime as 
appropriate, plus network delay, but may be lowered.
Type: Integer
Possible Values: any integer, represents milliseconds
Defined in: TerminationState
Characteristics: read only

MGCProvisionalResponseTimerValue
PropertyId: MGCProvisionalResponseTimerValue (0x0006)
Indicates the time within which the MG should expect a Pending Response
from the MGC if a Transaction cannot be completed.  Initially set to
normalMGCExecutionTime, plus network delay, but may be lowered.
Type: Integer
Possible Values: any integer, represents milliseconds
Defined in: TerminationState
Characteristics: read / write

…
[End Correction]

Cheers, Christian