Subject: Re: Protocol version re-negotiation

From: Nancy Devin <[email-masked]>
Date: Wed, 07 Mar 2001 09:09:53 -0500

Good morning Christian,

I agree with you that the reason "warm boot"
describes perfectly the state of the MG when it
upgrades to a new version of the H.248 protocol.

I have question on the use of "restart" and
"root".  According the RFC3015, this combination
indicates a registration command.  Since the
registration command should be the first command
received from an MG after it comes in service,
what happens when this command is received while
the MG is already in service?  Also, there seems
to be some difference between the ITU H.248
document and the RFC3015.  In the ITU document, it
is mentionned that a service change command
specifying "root" is a registration command and
that it should be "forced".  The ITU document also
mention that "restart" indicates that the service
will be restored on the specified termination
after expiration of the ServiceChangeDelay timer.
The termination are assumed to not be associated
with any contexts.  That last sentence makes me
wonder if we can really use "restart" on "root"
with the "warm boot" reason to perform protocol
version upgrade.

Another unrelated question, which document should
we reference to when the information in the ITU
document and the RFC3015 document differ?

comments,
Nancy

--
Nancy Devin
Software Designer

Alcatel
600 March Road, P.O. Box 13600
Kanata, Ontario, Canada
K2K 2E6

Telephone: (613) 591-3600 x6897
Fax:       (613) 599-3609
Internet:  [email-masked]

---

From: Christian Groves <[email-masked]>
Date: Thu, 08 Mar 2001 10:09:43 +1100

G'Day Nancy,

The ITU and RFC documents should be identical. The RFC is a copy of the
ITU H.248 so the ITU document takes precedence. Can you please point out
the exact text which is inconsistent. I need to record this in the
implementors' guide as a change needed to the RFC.

I didn't really see where the specification limits "forced" for "root
terminations or the problem with sending Servicechange whilst in
service.

Cheers, Christian

Nancy Devin wrote:
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> For help on this mail list, send "HELP ITU-SG16" in a message to
> [email-masked]

---

From: Nancy Devin <[email-masked]>
Date: Thu, 08 Mar 2001 07:27:59 -0500

Sorry Christian,

I just obtain the proper version of the ITU document.  There is no
difference at least regarding the use of the serviceChange descriptor.

cheers,
Nancy

--
Nancy Devin
Software Designer

Alcatel