Subject: Reply to an action with only Context properties

From: Dan Elbert <[email-masked]>
Date: Fri, 2 Mar 2001 17:21:29 -0500

Hi All

Suppose that we have a action like 

MEGACO/1 <dev1.iol.unh.edu>:2944
Transaction = 10006 {
  Context = 1 {
	Topology { term1,line/1, Oneway }
  }
}

What should be the reply to this action ? 
The reply should include the context id, and the syntax requires either
properties or commands or both. So we can reply:

MEGACO/1 127.127.127.127
Reply = 10006 {
  Context = 1 {
	Topology 
  }
}

But the syntax doesn't allows to have an empty topology descriptor, so I
need to put something there, for example echo the input:

MEGACO/1 127.127.127.127
Reply = 10006 {
  Context = 1 {
	Topology { term1,line/1, Oneway }

  }
}

It looks pretty ugly.
Does anybody has another idea ?

Dan Elbert
RADVISION

---

From: Christian Groves <[email-masked]>
Date: Sun, 04 Mar 2001 12:29:56 +1100

G'Day Dan,

Why have the Topology in the reply at all?

Cheers, Christian