Subject: RE: Use of "strict" parameter

From: Nurit Shenhar <[email-masked]>
Date: Mon, 19 Mar 2001 14:15:56 +0200

Hi Tom, Dan
 
'State' sounds as the logical default for the 'strict' parameter. 
 
The 'Init' parameter should appear only when 'state' was asked - it has no
meaning with 'exact'.So it is not a required parameter, but I guess that is
should be in the reply when 'state' was used in the request. We didn't use
it in the inter-op, because nobody really cared when the on/off hook
occurred, as long as we got it...
 
I have a question about the 'failWrong': What error should be used to
indicated the wrong state?
 
Nurit

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Tuesday, March 13, 2001 5:37 PM
To: 'Dan Elbert'; [email-masked]'
Subject: RE: Use of "strict" parameter

Hi.  Answers below. 

> -----Original Message----- 
> From: Dan Elbert [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, March 02, 2001 12:17 PM 
> To: [email-masked]' 
> Subject: Use of "strict" parameter 
> 
> 
> Hi All 
> 
> 1. What is the default behavior of the MG if the "strict" 
> parameter is not 
> set ( for events onhook, offhook of al package) ? 
> I'd suggest "state" since this allows to convey the maximal 
> information back 
> to the MGC. 

[PTT] We should choose whatever reflects the most frequent usage -- defaults
are there to save effort.  For people who don't want to look it up, "state"
means that if a line is already on/off-hook when told to watch for
on/off-hook, the corresponding state transition event will be reported.
Does this seem like the most likely setting?

> 
> 2. What is the correct use of the "exact" value for the 
> "strict" parameter ? 
> If the termination is already in the required state, I 
> understand that 
> this setting will cause the termination not to send the event 
> but to keep 
> waiting for it. Is this correct ? Seems like in this case there is 
> a risk of the MGC getting out of synch with the MG. 

[PTT] 
Your description of behaviour is correct.  There could be circumstances
where the MGC wants to use this one, for instance, to tell the MG to watch
for off-hook as a final step of call cleardown, where the line may still be
off-hook from the previous call.

> 
> 3. If the "init" parameter is not set when reporting a hook 
> event, should 
> this be considered the same as if it was set to "False" ? 
> (this is what makes more sense to me). Or is this a required 
> parameter ? (I 
> don't think that anybody was setting this in the interop...) 

[PTT] 
We need agreement on this, particularly when the "state" setting is used.
Comments, people? 
> Thanks, 
> Dan Elbert

---

From: "Randy Younts" <[email-masked]>
Date: Mon, 19 Mar 2001 16:33:22 -0500

That error would be 540.

Nurit Shenhar wrote:

>  Hi Tom, Dan'State' sounds as the logical default for the 'strict'
> parameter. The 'Init' parameter should appear only when 'state' was
> asked - it has no meaning with 'exact'.So it is not a required
> parameter, but I guess that is should be in the reply when 'state' was
> used in the request. We didn't use it in the inter-op, because nobody
> really cared when the on/off hook occurred, as long as we got it...I
> have a question about the 'failWrong': What error should be used to
> indicated the wrong state?Nurit
>
>      > From: Dan Elbert [mailto:[email-masked]]
>      [PTT] We should choose whatever reflects the most frequent
>      usage -- defaults are there to save effort.  For people who
>      don't want to look it up, "state" means that if a line is
>      already on/off-hook when told to watch for on/off-hook, the
>      corresponding state transition event will be reported.  Does
>      this seem like the most likely setting?
>
>      >
>      Your description of behaviour is correct.  There could be
>      circumstances where the MGC wants to use this one, for
>      instance, to tell the MG to watch for off-hook as a final
>      step of call cleardown, where the line may still be off-hook
>      from the previous call.
>
>      >
>      We need agreement on this, particularly when the "state"
>      setting is used.  Comments, people?
>      >
>      > Thanks,
>      >
>      > Dan Elbert
>      >
>
--
   Two roads diverged in a wood, and I-
   I took the one less traveled by,
   And that has made all the difference.
                         -Robert Frost
---------------------------------------------

W. Randy Younts      GWC Protocols
NORTEL NETWORKS      Dept. 3Z90
35 Davis Dr.         Voice: (919) 991-2014
RTP, NC  27709       ESN: 351-2014