Subject: DigitString parameter

From: James Adragna <[email-masked]>
Date: Fri, 2 Mar 2001 10:43:38 -0500

Hello,

When the digit string parameter is empty, how is it encoded?

Section E.6.2 describes the DigitString parameter as a
"string of digit map symbols (possibly empty) returned as a quotedString".
This suggests:

dd/ce{ds="",Meth=PM}

but this is not legal syntax.

Should the ds parameter just be omitted in this case? Like this:

dd/ce{Meth=PM}

Thanks

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 2 Mar 2001 12:09:16 -0500

hi James,
The QuotedString definition says one or more instances of "SafeChar /
RestChar/ WSP ". So instead of responding with dd/ce{ds="",Meth=PM} the MG
can respond with dd/ce{ds=" ",Meth=PM}with a space between the quotes, to
convey the same information.
Best Regards.
Madhubabu

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of James Adragna
Sent: Friday, March 02, 2001 10:44 AM
To: [email-masked]'
Subject: DigitString parameter

Hello,

dd/ce{ds="",Meth=PM}

dd/ce{Meth=PM}

Thanks

---

From: Troy Cauble <[email-masked]>
Date: Fri, 02 Mar 2001 12:29:37 -0500

"Space" is not a "digit map symbol".

Protocols are exactly the place to be picky.

-troy