Subject: Megaco ATM Package Queries

From: [email-masked]
Date: Tue, 27 Mar 2001 14:56:44 +0530

Hello,
     After going through the Megaco ATM Package (as given in
draft-rosen-megaco-atm-package-00.txt) I feel that the following events,
     properties and signals need to be added to the package  :-

a)   Signals to enable forwarding and receiving various Tones via ATM Packets.
For e.g. DTMF tone forwarding , MF tone forwarding etc.
     This is required for support of CAS signals.
b)   An event for modifying codecs dynamically.
c)   An event for modifying Packetization period.
d)   Property to set the Cell and Packet Loss Threshold and events to indicate
that Cell and Packet Loss Threshold have been exceeded.
     This may be useful for MGC to immediately come to know about the quality
degradation. If only statistics related to cell and packet
     loss are maintained, then MGC would have to get the statistics from MG on
periodic basis to know the QoS.
e)   An event to indicate Connection Failure
f)   An event to indicate that the bearer path fails to any predetermined
combination of quality criteria such as loss, delay, jitter
     (an event for Quality Alert).
     This is required so that MGC can control the QoS.

regards,

Monika Puri
Hughes Software Systems

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 28 Mar 2001 14:00:33 -0500

Glad to see someone looking at this critically.  Comments below:

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Tuesday, March 27, 2001 4:27 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Megaco ATM Package Queries
> 
> 
> 
> 
> Hello,
This would not be done in the ATM package.  There is a CAS package
being developed.

> b)   An event for modifying codecs dynamically.
Only AAL2 can do this.  The pftrans event does this for AAL2.

> c)   An event for modifying Packetization period.
This is not an event, this is set at the creation of the termination.

> that Cell and Packet Loss Threshold have been exceeded.
This has been discussed before.  Basically, we have not implemented
it in any other bearer, and I'm inclined to leave it out of the
basic package.  It could be part of an "advanced" package that extended
the base package.  Other opinions would be welcome on this suggestion.

> e)   An event to indicate Connection Failure
This is done with the cause event in the generic package

>      This is required so that MGC can control the QoS.\
Same as "e"

Probably the atmpackage should define error codes.

Brian

---

From: CHATRAS Bruno FTRD/DAC/ISS <[email-masked]>
Date: Thu, 29 Mar 2001 13:31:21 +0200

Hello,

I have a more basic question.

What is the difference between the VCChange event and the BNCChange event
defined in the Generic Bearer Connection Package defined in Q.1950?

If they are identical, I guess that the reason for not using the BNCChange
is that you don't want to support the whole Generic Bearer Connection
package (i.e. the signals used to trigger the sending of bearer control
messages). Is this a correct interpretation?

If yes, it probably means that the Q.1950 Generic Bearer Connection package
should have been split into two packages (one for the events and one for the
signals), in which case the same event would have been applicable
irrespective of the method used to trigger the sending of bearer control
messages. 

> -----Message d'origine-----
> De : Rosen, Brian [mailto:[email-masked]]
> Envoyé : mercredi 28 mars 2001 21:01
> À : [email-masked]'
> Cc : [email-masked]
> Objet : RE: Megaco ATM Package Queries
> 
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 29 Mar 2001 09:37:25 -0500

Yes, the reason for not using BNCChange is that I consider the idea that
a signal is used to create a VC is not a consensus position; it is SG11's
current position, and there are advocates in the SG16/Megaco community
for that position.  Yet, we have not had the opportunity to determine
how the majority feels about the issue.  I may well be that I am a very
small minority, but, as yet, we don't have any idea where we (collectively)
sit on the issue.  

Brian

> From: CHATRAS Bruno FTRD/DAC/ISS
> [mailto:[email-masked]]
> Sent: Thursday, March 29, 2001 6:31 AM
> To: 'Rosen, Brian'; [email-masked]'
> Cc: [email-masked]
> Subject: RE: Megaco ATM Package Queries
> 
> 
> Hello,
>