Subject: RE: Returned Descriptors in Media

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 5 Mar 2001 09:07:37 -0500

Christian

I'm confused by this response.  The premise was that LOCAL (not
LocalControl)
used CHOOSE.  Your response said LocalControl was returned.  Did you mean
that?

Brian

> -----Original Message-----
> From: Christian Groves [mailto:[email-masked]]
> Sent: Saturday, March 03, 2001 7:50 PM
> To: Chuong Nguyen
> Cc: megaco
> Subject: Re: Returned Descriptors in Media
> 
> 
> In this case I believe that you should only send back Local Control.
> Although there is a statement in H.248/Megaco that says the MG can
> include parameter in Local or Remote if it feels something isn't
> specified.
> 
> Cheers, Christian
> 
> Chuong Nguyen wrote:
> > 
> > There is no point in getting back the same info that one sends out.
> > It is a waste of bandwidth and having to parse through it.
> > 
> > But I agreed w/Brian last paragraph.
> > 
> > Chuong
> > 
> > 
> > "Rosen, Brian" wrote:
> > 
> > > If you send a Media Descriptor with a local, localControl 
> and Remote
> > >
> > > descriptors, but only use CHOOSE in the LocalDescriptor,
> > > what do you get back?
> > >
> > > One implementer believes Media was specified with CHOOSE,
> > > therefore the entire contents of Media should be returned.
> > > I think only Local should be returned.
> > >
> > > I would say, in the spirit of be strict in what you send,
> > > liberal in what you accept, that you should only send
> > > Local, but be prepared to receive all of Media.
> > >
> > > Brian
> > 
> > --
> >   Alcatel USA, Inc             Internet: 
> [email-masked]
> >   1000 Coit Road Plano, Texas 75075           Phone:    
> (972) 519-4613
> >   **** The opinions expressed are not those of Alcatel USA, Inc ****
> > 
> >
> 
>

---

From: Christian Groves <[email-masked]>
Date: Tue, 06 Mar 2001 12:45:17 +1100

G'Day Brian,

Local Control can use CHOOSE. Its part of the protocol both in the
procedural part of the text and the ASN1 and ABNF. Mike Brown had the
same question. So yes I meant it (you could have added Local/Remote as
well)and I think its rather could functionality.

Cheers, Christian

PS: Does the email reflector echo email to the sender of an email? I
sent in 10 or so emails to the list last night and I didn't see any
appear but obviously at least one got through.