Subject: RE: Profile Definition

From: "Michael Brown" <[email-masked]>
Date: Mon, 5 Mar 2001 10:25:20 -0500

The specification of the procedures at least for behaviors defined in
packages in the procedures section of the package documentation. Certainly,
a profile can enhance those descriptions and specify choices (as specified
in the package procedures) made about behavior.

Michael

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Saturday, March 03, 2001 8:26 PM
To: Rosen, Brian
Cc: 'Nancy Devin'; [email-masked]
Subject: Re: Profile Definition

G'Day Nancy,

As brian points out below the MSF have done a MINIMUM set of
requirements. I believe the more information in a profile the better for
interoperability reasons. The MSF profiles don't define procedures or
the like for the applications they are supporting. I would hope that
profiles define or at least point to somewhere on detailed procedures
and services that they are meant to support. 

Cheers, Christian

"Rosen, Brian" wrote:
> 
> Look at the MSF website (www.msforum.org) for some MSF profiles.
> 
> You will see:
>         A list of packages
>         Naming conventions
>         Transport Choices
>         Encoding Choices
>         Security Choices
>         Protocol option choices
> 
> The point of a profile is that an MG and MGC implementing the profile
> will interoperate with no further questions asked.  The profile could
> have MINUMUM requirements, but in all circumstances, an arbitrary MG
> implementing the profile will interoperate with an arbitrary MGC
> implementing the profile.
> 
> Brian
> 
> > -----Original Message-----
> > From: Nancy Devin [mailto:[email-masked]]
> > Sent: Tuesday, February 27, 2001 12:47 PM
> > To: [email-masked]
> > Subject: Profile Definition
> >
> >
> >
> > Hello all,
> >
> > We started to look at the Interoperability Test
> > Profile, draft-rosen-test-profile-01.txt, and it
> > seems to be a lot more than just a list of
> > packages.  What exactly is a profile?  What does
> > it represents? and What is its purpose?
> >
> > thanks,
> > Nancy
> >
> >
> > --
> > Nancy Devin
> > Software Designer
> >
> > Alcatel
> > 600 March Road, P.O. Box 13600
> > Kanata, Ontario, Canada
> > K2K 2E6
> >
> > Telephone: (613) 591-3600 x6897
> > Fax:       (613) 599-3609
> > Internet:  [email-masked]
> >
> >

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 7 Mar 2001 15:10:43 -0500

IETF will probably NOT standardize profiles.

Brian

> From: Ian Leighton [mailto:[email-masked]]
> Sent: Wednesday, March 07, 2001 10:04 AM
> To: [email-masked]
> Hi All
> Are future profiles going to be standardized or will
> they continue to be Internet-Drafts.
> 
> Regards
> Ian Leighton
> 
> "Rosen, Brian" wrote:
> >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 13 Mar 2001 11:27:04 -0500

This is up to the issuing parties.  What Megaco agreed was that we would
review them for technical validity if asked, and forward the results on for
publication as Informational RFCs.