Subject: RE: H248 Annex M

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 30 Mar 2001 10:01:39 -0500

The official Megaco list is at [email-masked] these days.  I have forwarded
your message to that list, but also to David Cromwell, a key designer for
Annex M.

> -----Original Message-----
> From: Sarika Gupta [mailto:[email-masked]]
> Sent: Friday, March 30, 2001 9:44 AM
> To: [email-masked]
> Subject: H248 Annex M
> 
> 
> Hi,
>    I have some queries regarding some information,
> which was present in the ietf draf version for Audio
> package for megaco
> (draft-cormwell-megaco-advanced-audio-pkg-00, Dated
> December 1, 1999, Expired June1, 2000) 
> but was missing in H248 Annex M draft version.
> 
> 1. For audcomp event , the Return Code giving the
> reason for completion of audio is present in the ietf
> draft, but is missing in H248 Annex M
> 
> 2. In Play announcement signal the following
> parameters were supported in the ietf draft and not in
> H248 Annex M
> - Possible values for Parameter ID an: included TextTo
> Speech and DisplayText
> -Duration Paramter ID: du
> 
> 3. In Play Collect signal the following parameters
> were supported in the ietf draft and not in H248 Annex
> M
> - EndInput Key (Indicating the end of input)
> 
> All these parameters may are valid enough  and may be
> required for actual implementation. So can anybody
> shed light on why they were removed from the H248
> Annex M.
> 
> Regards,
> Sarika
> 
> __________________________________________________
> Do You Yahoo!?
> Get email at your own domain with Yahoo! Mail. 
> http://personal.mail.yahoo.com/?.refer=text
>

---

From: "David Cromwell" <[email-masked]>
Date: Fri, 30 Mar 2001 11:29:39 -0500

Sarika,
 
The contents of this draft which were functionally equivalent to RFC-2897
(the MGCP version of the package) went through an industry peer review in a
CableLabs PacketCable working group and were simplified.  Annex M is based
on this work so there are some change which hopefully reduce package
complexity, increase functionality, and provide better partitioning of
functionality.  Comments below.

Regards,
David
--
[email-masked]                   Nortel Networks Cable
Telephony Solutions, Inc. 
Tel:   919-991-8870  (esn 351)                     35 Davis Dr
Fax:  919-991-4088                                    RTP, NC 27709

> From:	Taylor, Tom-PT [NORSE:B881:EXCH] 
> Sent:	Friday, March 30, 2001 10:02 AM
> To:	'Sarika Gupta'
> Cc:	Cromwell, David [NCRTP:B933:EXCH]; 'megaco'
> Subject:	RE: H248 Annex M
> 
> The official Megaco list is at [email-masked] these days.  I have
> forwarded your message to that list, but also to David Cromwell, a key
> designer for Annex M.
> 
	[<dcc>]  In RFC -2897 there is only one return code for success,
100.  In Annex M receipt of the audcomp event is the indication of success
and there is no separate return code.  Semantically they are equivalent.

> > -Duration Paramter ID: du
	[<dcc>]  These parameters represented functionality that was not
well defined and in a sense were placeholders.  Also it was decided that
these operations should each be separate packages, perhaps extending the
H.248 aasb package.  Since package impementation is on an all or nothing
basis modular partitioning of functionality into different packages is
highly desirable.  I am not aware that anyone is working on a either a text
to speech or a display text package.

> > - EndInput Key (Indicating the end of input)
	 
	[<dcc>]  In RFC-2897 the Return Key and the End Input Key were very
similar.  The RFC-2897 key sequences were deemed to be somewhat
overcomplicated and and not adding a lot of value and some of them were
removed.  The End Input key was one of these.  The Annex M Return Key can be
used instead.  Unlike the default behavior of the End Input Key the Return
Key will return the terminating key sequence, but the MGC application can
choose to ignore it.