Subject: Re: A question about digitmap

From: "Tom-PT Taylor" <[email-masked]>
Date: Sat, 24 Mar 2001 09:39:17 -0500

Number 3 is what would be reported.  The '9' would be recycled for
processing by the whatever events descriptor was active following the digit
map completion event.  Our original digit map rules came from MGCP, but we
modified them considerably to fit within Megaco syntax.  In the process, we
got rid of the extra digit.  Some people wanted it, but the consensus was
not to report it.  

> -----Original Message-----
> From: ?=@yahoo.com.cn [mailto:?=@yahoo.com.cn]
> Sent: Friday, March 23, 2001 7:46 PM
> To: Taylor, Tom-PT [NORSE:B881:EXCH]
> Subject: A question about digitmap
> 
> 
> Hi,Tom!  
>   I have a question when considering the scenario of
> collecting digits on MG.
>   If there is a digitmap like this '458'. After
> collecting '45', there comes '9'. The possible notify
> to MGC maybe the following:
> 
>   1.Move the '9' out, report '45' to MGC with causing
> partial match dtmf event '9'. That is:
>     ...
>     Notify=A8888{ObservedEvents=1234{
>       20010323T17300001:dd/ce{ds="45"}:Meth=PM},dd/d9}
>     ...
>   2.Report the whole string with partial match.
>     ...
>     Notify=A8888{ObservedEvents=1234{
>       20010323T17300001:dd/ce{ds="459"}:Meth=PM}}
>     ...
>   3.Move the '9' out ,report '45' to MGC with partial
> match.
>     ...
>     Notify=A8888{ObservedEvents=1234{
>       20010323T17300001:dd/ce{ds="45"}:Meth=PM}}
>     ...
> 
>    According to RFC3015 page39 procedure(5). I bet the
> first. But this seems different from MGCP(Rfc2705). In
> this case, the MGCP would report '459' with fail.
>    Thanks sincerely.
>    
>    Zhou Zichun
> 
>    And more, when writing to the [email-masked], mail
> delivering tells me there are too many unprocessing
> mail in that mail box as the fail delivering reason.
> 
> 
> _________________________________________________________
> Do You Yahoo!? ????????! http://mail.yahoo.com.cn
> ????????????????http://cn.clubs.yahoo.com
> 

Tom Taylor
Multimedia Control and Applications Standards
Ph.  +1 613 736 0961
Cell +1 613 290 0844
[email-masked]

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Sat, 24 Mar 2001 10:36:55 -0600 (CST)

MGC wants the extra digit due to which the match is failed, this is
because MGC has to show the digits in Call data record indicating that the
call is failed due to wrong digit dailed. I feel MG can impliment any of 1
& 2 and MGC must support receiving digits in both 1 & 2.  If MG gives
digits as per 3, MGC has to send another command to MG to get the extra
digit.  

thanks
Chak

  ALCATEL, USA Inc.                      Email: [email-masked]
  1000 Coit Road Plano, Texas 75075
  ******** The opinions expressed are not those of Alcatel USA, Inc.********