Subject: Re: Context Id in Service Change

From: Paul Rheaume <[email-masked]>
Date: Thu, 29 Mar 2001 12:34:17 -0500

Hi Brian,

You seem to be saying that the MG should subtract terminations from
their context when those terminations go out-of-service, but the
protocol clearly states that the MGC is responsible for cleaning up the
contexts. So I think the subtract should come from the MGC.

Am I understanding your statement correctly?

Cheers,
Paul

"Rosen, Brian" wrote:
> 
> Technically correct.
> 
> However, if you were taking terminations out of service, it would
> be very wise to subtract them out of whatever terminations they
> were in first, then execute the service change to take them out
> of service.  It should be possible to do it in the other order,
> and it should be possible to leave them in a context, but
> I wouldn't recommend it!
> 
> Brian
> 
> > -----Original Message-----
> > From: Christer Holmberg [mailto:[email-masked]]
> > Sent: Thursday, March 29, 2001 11:08 AM
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: Context Id in Service Change
> >
> >
> >
> > Hi Revital,
> >
> > An MG can use any Context, depending on what is the purpose of the
> > Service Change command.
> >
> > For example, if the MG sends ServiceChange to "register" itself to the
> > MGC, the NULL Context will be used, but if the ServiceChange
> > is sent to
> > indicate that terminations have been taken out or service (or put back
> > in service) you can use an ANY-wilcarded ContextId value or a specific
> > ContextId value.
> >
> > Regards,
> >
> > Christer Holmberg
> > Ericsson Finland
> >
> >
> >
> > [email-masked] wrote:
> > >
> > > Hi List,
> > >
> > > Which Context should the MG use when generating Service
> > Change Command?
> > >
> > > Revital Malka
> > > Voice Over IP
> > > E.C.I NGTS
> > > Tel: 03-9287516
> > > Fax: 03-9287010
> >

---

From: "Rosen, Brian" <[email-masked]>
Date: Thu, 29 Mar 2001 11:18:15 -0500

Technically correct.

Brian