Subject: About definition of value and PropertyParm

From: Richie Wu <[email-masked]>
Date: Tue, 13 Mar 2001 03:30:05 -0800 (PST)

Hello everybody,

Previously the Value is defined by ASN.1 as:
Value ::= OCTET STRING
Then in Impelementors' guide V7, it is changed to 
Value ::= SEQUENCE OF OCTET STRING.

But, as per the newly released Implementors' guide,
the EventParameter and SigParameter are changed to the
following syntax:

EventParameter ::= SEQUENCE
{
		eventParameterName Name,
		value SEQUENCE OF Value,
		-- For use of extraInfo see the comment related to
PropertyParm
		extraInfo CHOICE
		{
				relation Relation,
				range BOOLEAN,
				sublist BOOLEAN
		} OPTIONAL,
		...
}

SigParameter ::= SEQUENCE
{
		sigParameterName Name,
		value SEQUENCE OF Value,
		-- For use of extraInfo see the comment related to
PropertyParm
		extraInfo CHOICE
		{
				relation Relation,
				range BOOLEAN,
				sublist BOOLEAN
		} OPTIONAL,
		...
}

So what's the meaning of Value here? In my
understanding, the value in here is just one value
other than multiple values. And in the other place,
where we use value is ServiceChangeReason and
statisticParameter is just one value also. Thus, I
think we need change the Value definition back to the
previous definition, viz.

Value ::= OCTET STRING

And for consistance we can change the PropertyParm
definitaion to:

PropertyParm ::= SEQUENCE
{
        name            PkgdName,
        value           SEQUENCE OF Value,
        extraInfo       CHOICE
                {
                        relation        Relation,
                        range           BOOLEAN,
                        sublist         BOOLEAN
                } OPTIONAL,
        ...
}

Best regards,

Richie Wu

=====
Huawei Technologies India Private Limited

Unit 10, 2nd Floor, Innovator Block
International Tech Park, Whitefield Main Road
Bangalore 560 066, India
TEL: 0091-80-841 0061/0753/0755
FAX: 0091-80-841 0063

__________________________________________________
Do You Yahoo!?
Yahoo! Auctions - Buy the things you want at great prices.
http://auctions.yahoo.com/

---

From: Christian Groves <[email-masked]>
Date: Wed, 14 Mar 2001 15:38:46 +1100

Hello Richie,

I don't really follow the email. Is there a problem or something wrong?
I don't think stylistic inconsistency  is worth updating. The idea
behind SEQUENCE OF VALUE is when you overload a property or parameter.
ie. fred/codec = GSM EFR, G711, G721

Christian

---

From: Richie Wu <[email-masked]>
Date: Tue, 13 Mar 2001 21:50:55 -0800 (PST)

Hello Christian,

Since we have used SEQUENCE OF Value instead with
Value in SigParameter and EeventsParameter as per the
newly released Implementors' Guide, the Value should
be just ONE value other than multiple value. 

Now the Value is used in an other places
serviceChangeReason and StatisticsParameter, in which
it is clear there is only one value also.

So I think the Value is defined as SEQUENCE OF
OCTETSTRING is not correct.

In PropertyParm, instead SEQUENCE OF OCTET STRING with
SEQUENCE OF value is just a represent issue. 

Best regards,

Richie Wu

--- Christian Groves <[email-masked]>

=====

---

From: Christian Groves <[email-masked]>
Date: Thu, 15 Mar 2001 12:21:43 +1100

Hello Richie,

You confused me. Which version of the implementors' guide additions are
you working with? Somebody else send me a email stating that the problem
was in the 16/01/01 v1. V2 and V3 no longer contain SEQUENCE OF value. 

All: Please use the latest version of the implementors' guide and heed
the warnings saying that things are likely change until approved.

Christian