Subject: RE: ContextId for an error

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 30 Mar 2001 11:31:03 -0500

The problem with b is that the MGC sends a CHOOSE, expecting a
new ContextId back, but gets an error, with an EXISTING contextId back.
I'm worried it will be confused
 
You can read that as a concern that you get a complicated implementation
to deal with getting a ContextId that exists back from a command that
specified CHOOSE.  It implies that you ignore the ContextId until you 
parse the command (and discover an error).
 
Brian

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Friday, March 30, 2001 11:17 AM
To: 'Rosen, Brian'; [email-masked]'
Subject: RE: ContextId for an error

(b) would supply the maximum information, so long as everyone agrees. 

> -----Original Message----- 
> From: Rosen, Brian [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Friday, March 30, 2001 8:55 AM 
> To: [email-masked]' 
> Subject: ContextId for an error 
> 
> 
> Suppose you sent an Add to an MG with a CHOOSE ContextId, 
> but the termination was already in a context.  You get an 
> error (433), but in the reply, what ContextId do you get: 
> 
> a) Null 
> b) Context termination is already in 
> c) Context you would have assigned 
> d) CHOOSE 
> 
> I think a) 
> c) is clearly wrong 
> 
> Need words in the Implementor's Guide 
> 
> Brian 
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Fri, 30 Mar 2001 12:47:19 -0500

RE: ContextId for an errorHi all,
option (d) seems to resolve the problem. The MGC is aware of the  command
failure, irrespective of whether ContextID is ignored or considered while
parsing/processing the command.
Best Regards
Madhubabu

 -----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Rosen, Brian
Sent: Friday, March 30, 2001 11:31 AM
To: 'Tom-PT Taylor'; [email-masked]'
Subject: RE: ContextId for an error

  Brian
    -----Original Message-----
    From: Tom-PT Taylor [mailto:[email-masked]]
    Sent: Friday, March 30, 2001 11:17 AM
    To: 'Rosen, Brian'; [email-masked]'
    Subject: RE: ContextId for an error

    > From: Rosen, Brian [mailto:[email-masked]]