Subject: Re: physical vs. ephemeral terminations

From: Christian Groves <[email-masked]>
Date: Sun, 04 Mar 2001 12:48:20 +1100

G'Day,

I agree with Brian (hey there's some things we agree on ;-)!) there's a
need to indicate that a range of ephemerals are no longer available. 

In terms of context ID that is returned if the ephemeral is in a context
return that contextID. else use "*".
In terms of catastrophic loss ie. loose a card then I think its up to
the MG to return the appropriate wildcarded "*" fields that would be
associated with that card.

Cheers, christian

"Rosen, Brian" wrote:
> 
> The reason you want to execute a service change against
> an ephemeral is to notify the MGC that the network
> interface is down, and it can no longer ask the MG
> to create that range of ephemerals.  That is the
> point of ServiceChange - terminations out of service.
> 
> Yes, you can get an error when you try.  We could have
> done that for physical terminations.  However, we
> believed it useful for the MG to tell the MGC in
> advance that terminations are being taken out of
> service.
> 
> In the same light, you want to be able to AuditCapabilities
> of these terminations, so that you can discover, in
> advance of attempting an Add/Modify, what capabilities
> the terminations have.  You could try it and get an error,
> but that might be a hard way to find out what ephemerals
> the MG supports!
> 
> Brian
> 
> > -----Original Message-----
> > From: Kevin Boyle [mailto:[email-masked]]
> > Sent: Wednesday, February 21, 2001 4:27 PM
> > To: Madhu Babu Brahmanapally
> > Cc: 'Willy Reheul'; 'megaco'
> > Subject: Re: physical vs. ephemeral terminations
> >
> >
> > Unless the MGC explicitly audits looking for ephemeral
> > terminations, the MGC
> > has NO idea about them until such time as they are created.
> > ServiceChanges on
> > ephemerals sounds like a bad idea, as it could be confusing
> > to the MGC.
> >
> > Further, Why would you want/need to perform ServiceChanges on
> > ephemerals?
> > There are error codes in existence for denoting that a MG is
> > in service but not
> > able to comply with requests due to resource limitations.
> > Ephemerals would
> > fall under that category, IMHO.
> >
> > Kevin
> >
> > Madhu Babu Brahmanapally wrote:
> >
> > > HI Willy,
> > > Yes this sounds correct and should be legal. Since when the
> > MG registered
> > > itself with MGC ..it is a common understanding  what
> > physical and ephemeral
> > > terminations are present in the MG. If the board with some physical
> > > terminations go out, service change is generated for all of
> > them. This is
> > > true for ephemeral terminations also.
> > >
> > > Best Regards.
> > > Madhubabu
> > >
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]]On Behalf Of Willy Reheul
> > > Sent: Wednesday, February 21, 2001 1:25 PM
> > > To: megaco
> > > Subject: Re: physical vs. ephemeral terminations
> > >
> > > Continuing with the same line of thinking ( ".....A MG
> > knows what is the
> > > range of ephemeral termination that it can create, etc.
> > ......" ) can
> > > one then also assume that a Media Gateway shall send a
> > ServiceChange to
> > > its MGC when boards that realise these ephemeral terminations are
> > > going/taken out of service or return to in service, even when NO
> > > ephemerals are created on them ?
> > > Or can Media Gateways only do that when ALL ephemerals are
> > affected by
> > > the ServiceChange ?
> > >
> > > thanks,
> > > Willy.
> >

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 13 Mar 2001 10:54:30 -0500

As I think I've said in the past, I think the answer is to define
terminations representing physical interfaces and have a property associated
with them which gives the names of the other terminations they support.  I
could think of a couple of other relevant properties (bearer type,
capacity).  It's time I knocked out some packages supporting this.

> From: Christian Groves [mailto:[email-masked]]
> Sent: Saturday, March 03, 2001 8:48 PM
> To: Rosen, Brian
> Cc: Boyle, Kevin [NCRTP:3Z70:EXCH]; Madhu Babu Brahmanapally; 'Willy
> Reheul'; 'megaco'