Subject: ContextId for an error

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 30 Mar 2001 08:54:53 -0500

Suppose you sent an Add to an MG with a CHOOSE ContextId,
but the termination was already in a context.  You get an
error (433), but in the reply, what ContextId do you get:

a) Null
b) Context termination is already in
c) Context you would have assigned
d) CHOOSE

I think a)
c) is clearly wrong

Need words in the Implementor's Guide

Brian

---

From: "Tom-PT Taylor" <[email-masked]>
Date: Fri, 30 Mar 2001 11:17:02 -0500

(b) would supply the maximum information, so long as everyone agrees.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Friday, March 30, 2001 8:55 AM
> To: [email-masked]'
> Subject: ContextId for an error
> 
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Fri, 30 Mar 2001 13:20:57 -0500

I don't think this is so bad.

First of all, this is a VERY serious problem -- the MGC lost track
of terminations and contexts.  You are pretty much forced to do a 
complete audit -- if you lost one termination, how many others have
you lost?

Then, it's an error.  Who really cares how efficient an error of this
magnitude is handled?

Brian

> From: PAUL RHEAUME [mailto:[email-masked]]
> Sent: Friday, March 30, 2001 12:52 PM
> To: [email-masked]'
> Cc: Tom-PT Taylor; 'Rosen, Brian'
> Subject: Re: ContextId for an error
> 
> 
> Brian, Tom, List,
> 
> The problem, as I see it, with using CHOOSE in the reply is that it
> forces an extra step to be carried out, i.e. the MGC will 
> need to do an
> Audit on the TerminationID to find out what Context the termination
> belongs to.  The MGC can then go ahead and do whatever clean up is
> necessary.
> 
> By returning the (b) Context termination is already in, the 
> MG provides
> all the information the MGC will require to clean up.
> 
> Cheers,
> Paul
> 
> Tom-PT Taylor wrote:
> 
> >  Good point.  I suppose that leaves us with CHOOSE as the response,
> > but is this going to upset things?
> >
> >      Sent: Friday, March 30, 2001 11:31 AM
> >      To: Taylor, Tom-PT [NORSE:B881:EXCH]; [email-masked]'
> >      Subject: RE: ContextId for an error
> >
> >      The problem with b is that the MGC sends a CHOOSE, expecting
> >      anew ContextId back, but gets an error, with an EXISTING
> >      contextId back.I'm worried it will be confusedYou can read
> >      that as a concern that you get a complicated
> >      implementationto deal with getting a ContextId that exists
> >      back from a command thatspecified CHOOSE.  It implies that
> >      you ignore the ContextId until you parse the command (and
> >      discover an error).Brian
> >
> >           From: Tom-PT Taylor
> >           [mailto:[email-masked]]
> >           Sent: Friday, March 30, 2001 11:17 AM
> >           To: 'Rosen, Brian'; [email-masked]'
> >           Subject: RE: ContextId for an error
> >