Subject: RE: A question about digitmap

From: Dave Sclarsky <[email-masked]>
Date: Mon, 26 Mar 2001 10:26:01 -0500

Tom,
I agree that '2' would be the best choice.  Do you think we could come up
with a recommended method of enabling individual digit reporting?  Using
dd/* is convenient syntax for the events descriptor, but given the number of
events that it generates, it probably shouldn't be used.
DaveS.

-----Original Message-----
From: Tom-PT Taylor [mailto:[email-masked]]
Sent: Monday, March 26, 2001 9:25 AM
To: 'P.S.K. Chakravarthi'
Cc: 'megaco'
Subject: RE: A question about digitmap

I can think of three possibilities: 
 (1) Least effective: EventBufferControl is OFF and the original events
descriptor contains dd/*, so digit events continue to be reported after the
digit map completion event.  The problem with this one is that until the
digit map completes every dialled digit is reported individually as well as
within the digit map.

 (2) Probably most effective: the original events descriptor contains an
embedded events descriptor which enables individual digit reporting.

 (3) EventBufferControl is set to LOCKSTEP, the event buffer descriptor
collects dialled digits, and a new events descriptor is loaded which allows
a digit event to be reported.

> -----Original Message----- 
> From: P.S.K. Chakravarthi [ mailto:[email-masked]
<mailto:[email-masked]> ] 
> Sent: Saturday, March 24, 2001 11:37 AM 

[snip] 

  If MG gives 
> digits as per 3, MGC has to send another command to MG to get 
> the extra 
> digit.  
> 
> thanks 
> Chak 
> 
> 
>   ALCATEL, USA Inc.                      Email: 
> [email-masked] 
>   1000 Coit Road Plano, Texas 75075 
>   ******** The opinions expressed are not those of Alcatel 
> USA, Inc.******** 
> 
> On Sat, 24 Mar 2001, Tom-PT Taylor wrote: 
> 
> > Number 3 is what would be reported.  The '9' would be recycled for 
> > processing by the whatever events descriptor was active 
> following the digit 
> > map completion event.  Our original digit map rules came 
> from MGCP, but we 
> > modified them considerably to fit within Megaco syntax.  In 
> the process, we 
> > got rid of the extra digit.  Some people wanted it, but the 
> consensus was 
> > not to report it.  
> > 
> > > -----Original Message----- 
> > > From: ?=@yahoo.com.cn [ mailto:?=@yahoo.com.cn
<mailto:?=@yahoo.com.cn> ] 
> > > Sent: Friday, March 23, 2001 7:46 PM 
> > > To: Taylor, Tom-PT [NORSE:B881:EXCH] 
> > > Subject: A question about digitmap 
> > > 
> > > 
> > > Hi,Tom!  
> > >   I have a question when considering the scenario of 
> > > collecting digits on MG. 
> > >   If there is a digitmap like this '458'. After 
> > > collecting '45', there comes '9'. The possible notify 
> > > to MGC maybe the following: 
> > > 
> > >   1.Move the '9' out, report '45' to MGC with causing 
> > > partial match dtmf event '9'. That is: 
> > >     ... 
> > >     Notify=A8888{ObservedEvents=1234{ 
> > >       20010323T17300001:dd/ce{ds="45"}:Meth=PM},dd/d9} 
> > >     ... 
> > >   2.Report the whole string with partial match. 
> > >     ... 
> > >     Notify=A8888{ObservedEvents=1234{ 
> > >       20010323T17300001:dd/ce{ds="459"}:Meth=PM}} 
> > >     ... 
> > >   3.Move the '9' out ,report '45' to MGC with partial 
> > > match. 
> > >     ... 
> > >     Notify=A8888{ObservedEvents=1234{ 
> > >       20010323T17300001:dd/ce{ds="45"}:Meth=PM}} 
> > >     ... 
> > > 
> > >    According to RFC3015 page39 procedure(5). I bet the 
> > > first. But this seems different from MGCP(Rfc2705). In 
> > > this case, the MGCP would report '459' with fail. 
> > >    Thanks sincerely. 
> > >    
> > >    Zhou Zichun 
> > > 
> > >    And more, when writing to the [email-masked], mail 
> > > delivering tells me there are too many unprocessing 
> > > mail in that mail box as the fail delivering reason. 
> > > 
> > > 
> > > _________________________________________________________ 
> > > Do You Yahoo!? ????????! http://mail.yahoo.com.cn
<http://mail.yahoo.com.cn>  
> > > ???????????????? http://cn.clubs.yahoo.com <http://cn.clubs.yahoo.com>

> > > 
> > 
> > Tom Taylor 
> > Multimedia Control and Applications Standards 
> > Ph.  +1 613 736 0961 
> > Cell +1 613 290 0844 
> > [email-masked] 
> > 
> 
>

---

From: "P.S.K. Chakravarthi" <[email-masked]>
Date: Mon, 26 Mar 2001 09:45:52 -0600 (CST)

Individual digits reporting will start only after the completion of digit
collection for the first digit map.  So there should be many events, if
the first digit map is constructed properly.

thanks
Chak

  ALCATEL, USA Inc.                      Email: [email-masked]
  1000 Coit Road Plano, Texas 75075
  ******** The opinions expressed are not those of Alcatel USA, Inc.********