Subject: RE: Reply to an action with only Context properties

From: Dave Sclarsky <[email-masked]>
Date: Thu, 8 Mar 2001 14:18:24 -0500

Christian,

I think that Dan points out a real problem, in that the syntax doesn't allow
a reply like:

MEGACO/1 127.127.127.127 Reply=10006 {Context=1}
or like:
MEGACO/1 127.127.127.127 Reply=10006 {Context=1{}}

A commandReply requires either contextProperties or a commandReplyList,
neither of which can be empty.

This is similar to the issue of how to build a 'contextID list' to reply to
an audit with context=all, termination=root, as required by 7.2.5 (see the
thread "ContextId List" back around Feb. 20).

The two issues are similar, because the protocol calls for messages which
have no encoding defined (at least in the ABNF, I haven't checked the
asn.1).  Is this something we can (should?) fix in the IG?

Dave Sclarsky

-----Original Message-----
From: Christian Groves [mailto:[email-masked]]
Sent: Saturday, March 03, 2001 8:30 PM
To: Dan Elbert
Cc: megaco ietf
Subject: Re: Reply to an action with only Context properties

G'Day Dan,

Why have the Topology in the reply at all?

Cheers, Christian

Dan Elbert wrote:
> 
> Hi All
> 
> Suppose that we have a action like
> 
> MEGACO/1 <dev1.iol.unh.edu>:2944
> Transaction = 10006 {
>   Context = 1 {
>         Topology { term1,line/1, Oneway }
>   }
> }
> 
> What should be the reply to this action ?
> The reply should include the context id, and the syntax requires either
> properties or commands or both. So we can reply:
> 
> MEGACO/1 127.127.127.127
> Reply = 10006 {
>   Context = 1 {
>         Topology
>   }
> }
> 
> But the syntax doesn't allows to have an empty topology descriptor, so I
> need to put something there, for example echo the input:
> 
> MEGACO/1 127.127.127.127
> Reply = 10006 {
>   Context = 1 {
>         Topology { term1,line/1, Oneway }
> 
>   }
> }
> 
> It looks pretty ugly.
> Does anybody has another idea ?
> 
> Dan Elbert
> RADVISION

---

From: Christian Groves <[email-masked]>
Date: Tue, 13 Mar 2001 15:24:21 +1100

G'Day Dave,

I think you are pointing out a seperate issue.
Topology does not need to be replied. In the ASN1 the topologyReq is
optional so there's no problem with this.

You pointed out an issue with "all" context properties. The ASN1 might
give you a way out by having a 0 sequence length in "commandReply
SEQUENCE OF CommandReply". Returning of context properties are optional.
The ABNF production "commandReply       = (( contextProperties [COMMA
commandReplyList] ) / commandReplyList ) looks like the cause for this
problem. Do you have a suggested fix?

Cheers, Christian