Subject: RE: Local and Remote on PSTN termination

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 7 Mar 2001 08:27:56 -0500

There is a thread on this subject that started only a couple of
weeks ago.  Tom Taylor promised a draft proposing
an SDP registration of an appropriate network type for
these terminations, so you wouldn't see any of the IP or RTP
stuff.

Generally, pushing properties into LocalControl has proved
to be problematic in MGCP because every time you add something
to SDP for remote, you end up definining an equivalent localControl
equivalent.  See the work on ATM support for how bad this is.

Brian

> -----Original Message-----
> From: Christer Holmberg [mailto:[email-masked]]
> Sent: Wednesday, March 07, 2001 8:18 AM
> To: [email-masked]
> Subject: Re: Local and Remote on PSTN termination
> 
> 
> 
> 
> Personally I don't even think we would need Local and Remote 
> descriptors
> for PSTN terminations, because the only information needed for the
> termination is the encoding (no addresses, ports, media types etc are
> needed). Instead, I think it maybe should be possible to specify the
> encoding in the LocalControl descriptor. That is the way it works in
> MGCP, so...
> 
> Comments?
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> Christer Holmberg wrote:
> > 
> > Hi,
> > 
> > I have one question about the Local- and Remote parameters 
> on PSTN (eg.
> > a E1 timeslot) terminations.
> > 
> > In the RFC examples (Appendix A) the following Local 
> parameter is used
> > on the PSTN (in this case, an analog line) termination.
> > 
> > 3. The MGC programs a Termination in the NULL context. The 
> terminationId
> > is A444, the stream...
> > 
> > MGC to MG1:
> > MEGACO/1 [123.123.123.4]:55555
> > Transaction = 9999 {
> > ...
> >        Local {
> > v=0
> > c=IN IP4 $
> > m=audio $ RTP/AVP 0
> > a=fmtp:PCMU VAD=X-NNVAD
> >        }
> > 
> > My questions:
> > 
> > 1. Why is "IN" and "IP4" used in the c line?
> > 
> > 2. Why is a Remote parameter not needed on this termination?
> > 
> > I appologise if these questions have been answered before, 
> but I haven't
> > been following the list for a while.
> > 
> > Regards,
> > 
> > Christer Holmberg
> > Ericsson Finland
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 07 Mar 2001 15:45:03 +0200

Hi,

>equivalent.  See the work on ATM support for how bad this is.

I don't think we have the same issue in H.248, because we have separate
terminations for the PSTN link and the RTP connection. For the
terminations where we use the Remote and Local descriptors (eg. RTP
terminations) we would not define the encoding in the LocalControl. 

Also, if we use the Local descriptor we will also have to define a
Remote descriptor - which in this case will be a copy of the Local
descriptor...

One solution is that the encoding is a property in a package related to
the terminations where separate remote and local descriptors are not
needed. For example, there could be a "encoding" property in the TDM
circuit package.

The Add would then look like:

MEGACO/1 [email-masked]
Transaction = 1 {
 Context = $ {
  Add = ts01 {
   LocalControl {
    Mode = SendReceive,
    tdmc/encoding = 0	// the encoding property
   }
  }
 }
}

If we use Local and Remote descriptors it would look like:

MEGACO/1 [email-masked]
Transaction = 1 {
 Context = $ {
  Add = ts01 {
   LocalControl {
    Mode = SendReceive,
   },
   Local {
v=0
c=<whatever>
m=audio $ RTP/AVP 0
   },
   Remote {
v=0
c=<whatever>
m=audio $ RTP/AVP 0
   }
  }
 }
}

Regards,

Christer Holmberg
Ericsson Finland