Subject: RE: Failure in Subtract

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 12 Mar 2001 09:34:01 -0500

If the command fails, then the termination remains in the
context it was in before the command was executed.

Brian

> -----Original Message-----
> From: Madhu Babu Brahmanapally [mailto:[email-masked]]
> Sent: Saturday, March 10, 2001 5:25 PM
> To: [email-masked]
> Subject: Failure in Subtract
> 
> 
> HI all,
> If the MG fails to process Subtract message and returns an 
> error message, is
> there any way where the Termination can be brought back to 
> NULL context for
> further usage. Or does the MGC needs to generate servicechange to that
> termination and then restart the same???
> Best Regards
> Madhubabu
>

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 12 Mar 2001 10:22:10 -0500

Hi Brian,list,
This Means the termination cannot be added to any other new context. (Leave
that the call will not be charged since the stats are not received by MGC ).
How about reusing the termination for other calls?? The MGC probably need to
move the termination if any new call is received for that termination. If
the MG is a residential gateway and the user needs to initiate a call I
think again the MGC cannot add this termination in any new context? I think
there should be some guidelines for the MGC in such scenarios to invoke
ServiceChange for removal of the termination from service and then another
ServiceChange to bring it back to service.

Best Regards
Madhubabu

-----Original Message-----
From: Rosen, Brian [mailto:[email-masked]]
Sent: Monday, March 12, 2001 9:34 AM
To: 'Madhu Babu Brahmanapally'; [email-masked]
Subject: RE: Failure in Subtract

Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Mon, 12 Mar 2001 09:57:37 -0600

Interesting problem.

But Madhubabu, you keep referring to using ServiceChange to take the
termination in/out of
service to correct the problem.

Unless I missed another change in the Standard, ServiceChange can't be used to
implicitly
subtract a termination from a context and put it back in the NULL context.
So taking the termination out/in service does not fix whatever was the problem
in the
subtract.

Can you be more specific in how a subtract would fail?

Thanks
Chuong

--
  Alcatel USA, Inc             Internet: [email-masked]
  1000 Coit Road Plano, Texas 75075           Phone:    (972) 519-4613
  **** The opinions expressed are not those of Alcatel USA, Inc ****

---

From: "Madhu Babu Brahmanapally" <[email-masked]>
Date: Mon, 12 Mar 2001 11:55:55 -0500

Hi Choung,list.
We are testing the MG and MGC using UDP and with very high data traffics.
Its only a coincidence that Subtract message was lost couple of times ...
and the termination become useless. ServiceChange may not be the solution
but definitely one of way to get out from any such problems.

Best Regards
Madhubabu
  -----Original Message-----
  From: [email-masked]
[mailto:[email-masked]]On Behalf Of Chuong Nguyen
  Sent: Monday, March 12, 2001 10:58 AM
  To: megaco
  Subject: Re: Failure in Subtract

  Interesting problem.

  Unless I missed another change in the Standard, ServiceChange can't be
used to implicitly
  subtract a termination from a context and put it back in the NULL context.
  So taking the termination out/in service does not fix whatever was the
problem in the
  subtract.

  Thanks
  Chuong

    Hi Brian,list,
    This Means the termination cannot be added to any other new context.
(Leave
    that the call will not be charged since the stats are not received by
MGC ).
    How about reusing the termination for other calls?? The MGC probably
need to
    move the termination if any new call is received for that termination.
If
    the MG is a residential gateway and the user needs to initiate a call I
    think again the MGC cannot add this termination in any new context? I
think
    there should be some guidelines for the MGC in such scenarios to invoke
    ServiceChange for removal of the termination from service and then
another
    ServiceChange to bring it back to service.
    Best Regards
    Madhubabu

    -----Original Message-----
    From: Rosen, Brian [mailto:[email-masked]]
    Sent: Monday, March 12, 2001 9:34 AM
    To: 'Madhu Babu Brahmanapally'; [email-masked]
    Subject: RE: Failure in Subtract

    Brian

---

From: Chuong Nguyen <[email-masked]>
Date: Mon, 12 Mar 2001 11:02:34 -0600

Ok.
It seems like an implementation issue.  Therefore I can't go into
details how you can
prevent from this kind of Subtract failure and get out of this Subtract
problem.
But we do handle this particular kind of Subtract failure as part of our
MGC implementation.

Chuong

Madhu Babu Brahmanapally wrote:

> Hi Choung,list.We are testing the MG and MGC using UDP and with very
> high data traffics. Its only a coincidence that Subtract message was
> lost couple of times ... and the termination become useless.
> ServiceChange may not be the solution but definitely one of way to get
> out from any such problems. Best RegardsMadhubabu
>
>      But Madhubabu, you keep referring to using ServiceChange to
>      take the termination in/out of
>      Unless I missed another change in the Standard,
>      ServiceChange can't be used to implicitly
>      So taking the termination out/in service does not fix
>      whatever was the problem in the
>      subtract.
>